RED更新记录

RED引擎更新日志

官方网站: www.redm2.com

交流QQ群: 317076826

【2026/04/01更新】

1.修正APP稳如泰山问题
2.优化闪退问题
3.增加APP平滑开关
4.优化APP一些操作细节问题
5.修正APP宝宝名字过长不显示问题

本版修改手机端UI文件 Bottom，Bottom_right, SetUi, Depot 内挂拾取过滤需在控制台重新生成

【2026/03/20更新】

1.修正上一版遗留错误
2.优化微端速度
3.优化APP移动平滑
4.优化APP操作细节
5.优化APP闪退问题
6.优化PC端PK操作细节
6.修正假怪问题
7.还有其它细节问题

本版修改手机端UI文件 Login，Bottom_right 内挂拾取过滤需在控制台重新生成

【2026/03/13更新】

1.优化英雄目标为空时优先攻击主人的目标
2.增加APP点屏关窗选项
3.增加APP屏幕跟随重力旋转
4.修正挂机偶尔发呆问题
5.PC端内挂换皮,修正物品拾取过滤抽风问题
6.修正切割功能已知问题
7.优化称号AniCount 字段大于0时不佩戴属性也能生效
8.M2增加小退等待开关 客户端设置->快捷按钮
9.引擎控制台增加内挂物品过滤功能
10.优化魔血石功能
11.修正交易操作一处bug
12.修正某些时候退出游戏重进黑屏必须重启M2才行的问题
13.修正行会战和攻城时候名字变色问题
14.修改自动拾取命令 AUTOPICKUPITEM 拾取范围 模式 是否触发
15.修改自动拾取物品同步玩家内挂过滤，玩家需开启自动拾取功能
16.修正APP切换人物行会界面显示问题
17.修复PC登陆器配置器更换图标功能
18.增加APP滑动切换目标
19.修正无极真气释放间隔无效问题
20.修正物品掉落提示坐标问题
21.开放pak使用权限

本版修改SetUI文件，内挂过滤文件需在引擎控制台生成 放到网站Config文件夹中

【2026/01/31更新】

1.优化NPC读写商店物品数据规则
2.优化怪物显示问题
3.调整流星火雨伤害逻辑
4.修正APP装备信息诅咒显示异常问题

【2026/01/09更新】

1.修正PC端角色杀死玩家后不能立刻进行走步
2.将刺杀剑法, 逐日剑法, 开天斩忽视防御和忽视魔法盾分开来控制
3.增加调整流星火雨攻击范围选项
4.修正APP在行会攻击模式下切换目标选择同行会为目标得问题
5.修正二次刷怪显示不同步以及切换地图部分怪物不显示问题

【2025/09/21更新】

1.修正盾牌和时装元素属性无效问题
2.修正某些情况下假人不显示的问题
3.完善PC端启动背景图设置,data目录读取图片名 logo_1024_768.png, 分辨率可改会根据玩家游戏窗口自动读取
4.优化挂机假怪和发呆问题
5.优化网关封挂功能
6.修正苹果端运行游戏期间屏幕常亮
7.修正其他一些小问题

【2025/09/09更新】

1.APP主界面增加电池电量,网络状态,时间,HPMP值,背包重量组件
2.APP内挂增加持久警告,自动修理,换装提示,自动关组 开关选项, Config.txt文件内增加对应默认参数
3.修正APP掷骰子功能
4.修正打到的装备卖到商店再买出物品来源重置问题
5.修正自动拾取某些时候会爆异常提示
6.修正APP上SendDelayMsg倒计时信息无效问题
7.修正PC端读取PAK补丁部分格式图片有花边问题
8.PC内挂增加卷轴保护选项
9.修正SCREENEFFECT命令在PC无效问题
10.增加引擎与客户端版本验证, 不是同一更新日期的客户端无法登陆游戏
11.修正其他一些小问题

【2025/08/23更新】

1.优化APP部分组件切换效果
2.修正PC英雄背包最后6格不能显示物品问题
3.修正与玩家交易或与英雄交换叠加物品时会多个残影物品问题
4.修改PC挂机寻路逻辑,内挂挂机小地图取消挂机点间距限制,也可直接开启挂机自动生成挂机点
5.扩展KILLSLAVENAME增加参数2 杀死宝宝数量
6.增加获取宝宝名字和等级命令GETSLAVEBASEDATA 宝宝序号 名字保存变量 等级保存变量
7.修改流星火雨为两段伤害
8.修正挂机不打人形怪的问题
9.增加火龙之心填充物物品类型StdMode = 96
10.修正装备攻击速度为负数时出刀很快的问题
11.扩展changeexp命令支持第三参数 是否同步增加聚灵珠经验
12.优化APP飘血显示
13.修正寄售行购买持久为0的物品只扣钱不给东西的问题
14.修正APP英雄释放技能卡动作问题
15.增加APP英雄技能开关功能
16.修改道士召唤技能不受M2设置叛变时间限制, 叛变时间选项仅作用于诱惑之光技能
17.增加一键回收命令支持参数9 极品是否回收
18.修改套装特殊属性吸血的效果为伤害的10%
19.删除M2客户端设置移动端NPC对话框文字缩放选项, APP内挂增加NPC对话框缩放选项
20.修正宝宝叠加人物属性百分比问题
21.修改聚灵珠释放条件限制和限制参数字段,详情点击
22.修正法师英雄怪物近身无限撑盾的问题
23.增加脚本释放技能命令有动作RELEASEMAGIC和无动作RELEASEMAGICEX
24.修正一些其它细节问题

APP里Config.txt内增加默认NPC对话框缩放比例参数CLICKTYPE_NPC_SCALE,务必更新替换

本次移动端UI更新 SetUp.csd , SetUp,udf

【2025/08/08更新】

1.修正连续释放技能特效跟不上问题
2.同步怪物类型至狐月山
3.同步NPC外观编码至227
4.同步技能特效,连击技能除外
4.PC和APP内挂增加显示NPC血条选项
5.优化PC挂机打怪逻辑和保护设置,增加挂机单法和群法选项
6.修改APP装备内观支持纯特效点击
7.优化APP保护逻辑和解包逻辑
8.修正0716一些遗留问题

本次移动端UI更新 SetUp.csd , SetUp,udf 和部分技能图标文件

【2025/07/16更新】

1.增加ReadCacheConfigFileItem, WriteCacheConfigFileItem, DelCacheConfigFileItem, DelCacheConfigFileSection命令
2.增加AddCacheTextList, DelCacheTextList, CheckCacheStringList, ClearCacheNameList命令
3.修正app合击技能显示异常和内挂自动合击无效的问题
4.修正APP装备信息不显示鉴定属性问题
5.修正APP在网关加速情况下施法效果显示不出来问题
6.修正APP使用随机会导致挂机停止问题
7.增加宝宝攻击触发相关
8.扩展等级经验控制到100个
9.修正寄售行已知问题
10.修正客户端假物品问题(已经被捡走了,留个假象在地上)
11.修正客户端假怪问题(怪物实际已经嘎了,留个假象在原地)
12.修正APP因速度不匹配导致对象移动闪现问题
13.M2客户端设置页面增加 启用极品掉落特效 选项
14.修正PC端不穿怪时候跑步撞怪
15.修正APP挂机切换地图停止挂机不触发的问题
16.增加限时物品,非叠加物品Need字段可设置101,102,103,104四种限时类型
17.修正APP在NPC对话框不能打开网站的问题

本次移动端UI更新 SetUp.csd , SetUp,udf 文件

由于角色数据结构变动, 开区中请勿更新引擎

【2025/06/11更新】

1.修正MySQL数据库已知问题
2.增加复活触发@Revival 复活剩余时间变量：<$RevivalTime>
3.修正APP读取13周年及以后的N开头地图花屏问题
4.PC登陆器配置器增加列表刷新间隔选项
5.修正BONUSABIL不刷新分配属性点问题
6.修正APP行会掌门人无法转让行会
7.修正APP附近的人发起联盟会闪退
8.修正APP删除快捷栏物品有残影
9.修正CheckStringlength命令检测某些字母开头长度计算错误问题
10.修正PC端宝宝传送走会有残影问题
11.修正上架寄售行物品不受物品规则影响的问题
12.增加M2查看 监听附近信息 选项
13.修改KILLSLAVE参数
14.修正APP内挂物品过滤问题
15.增加两种新爆率格式,详情点击

【2025/05/10更新】

1.修正APP部分技能音效播放两次的问题
2.修改@MagSelfFuncX为释放技能前触发,@MagSelfFuncExX为释放技能后触发
3.修改CHANGESLAVELEVEL宝宝名字参数支持*为所有宝宝
4.修正APP小地图绘制问题
5.修正APP未加入行会时点开行会页面自动关闭问题
6.修正日志服务器货币记录无效问题
7.修正APP不能同步PC货币名字问题
8.修正APP快速注册点击无反应问题
9.修正APP某些情况下技能CD无线刷新问题
10.优化APP选区时卡顿问题
11.修正<$KILLMONX> <$KILLMONY>无效的问题
12.修正GIVE命令给予叠加物品时不能和背包已有的同物品叠加问题
13.修正自动拾取捡起叠加物品会延迟拾取问题
14.增加寄售行功能,详情点击
15.其他修了啥不记得了...

【2025/04/10更新】

1.修正APP商城物品介绍问题
2.修正APP特殊情况下注册账号没有反应问题
3.修正APP小地图边缘花问题
4.修正MySQL不读取人物神佑盒标识问题
5.修正PC端查看他人装备不显示装备信息问题
6.修正召唤宝宝命令不写时间参数导致招出就死的问题
7.扩展假人和人形怪支持神佑首饰盒(假人配置 和人形怪配置)
8.修正宝宝攻击锁定目标不掉血问题
9.修正APP勾选自动双防无限打防问题
10.修正APP行会界面显示异常问题
11.修改APP快捷栏物品图标刷新频率
12.修改释放技能自身触发: @MagSelfFuncX逻辑为释放后触发
13.修正APP因32位图片闪退问题
14.修改套装信息支持区分男女
15.增加PC端内挂挂机页面物品过滤按钮
16.增加APP快速注册功能
17.增加APP人物简装和怪物简装选项
18.增加检测指定位置装备所有附加属性之和命令 CheckItemAddValueEx
19.增加APP装备对比功能
20.增加PC挂机道法不躲避选项
21.增加APP内挂默认配置,读取config.txt

99.修改移动端UI工程中Login, SetUp,Bag,Depot,HeroBag,Shop,Team,Rank文件

【2025/03/31更新】

1.修正不使用微端情况下无法读取pak补丁问题
2.缩短PC端劈砍动作到走动操作中间的停顿时间
3.修改PC必备补丁支持data和pak两种格式
4.修正微端开启状态黑夜模式不显示光源问题
5.修正自定义输入 @@InputString 和@@InputInteger 分别保存的变量为S和N
6.修正pc 端看不到斗笠外观
7.修正生肖存入仓库和取出，左键来回拖动会出现假象
8.修正MySQL数据库不能保存物品特效设置问题
9.修正MySQL数据库不能存仓问题
10.修正app 扩展预留的按钮位，按下去不会回弹
11.修正app 宝宝残影问题
12.修正app 技能释放完按钮上依然有倒计时
13.修改生肖和首饰盒装备双击直接进装备栏
14.修正APP组队勾子不刷新
15.修正附近的人和组队成员所属行会显示问题
16.修正PC身上部分装备拿起后右键消失问题
17.增加APP商城物品点击图标显示物品介绍
18.修正APP神佑和首饰盒特效偏移问题
19.修正APP撞墙反弹后照明无效问题
20.修正APP修复资源不能清理补丁问题
21.修改newopui.pak默认密码为REDM2, 不使用自定义补丁情况下PC和APP均默认支持newopui.pak为必备补丁
22.修正资源编辑器批量导出时卡死问题
23.修正APP小地图雷达偏移

24.修改APP公告文件从php改为html

【2025/03/11更新】

1.扩展支持pak补丁
2.修改PC端补丁集成方式
3.修正上一版部分问题
4.套装功能增加技能威力属性
5.增加CHANGESPEED 调整攻击速度命令
6.扩展THROWITEM参数支持修改来源信息
7.修正几个物品穿戴条件
8.重构物品特效逻辑,掉落特效合并到特效列表里
9.增加设置物品特效命令 SETITEMEFFECT 位置 特效编号
10.优化PC端微端更新速度
11.修正PC身上部分装备拿起后右键消失问题

【2025/02/22更新】

1.修正道士隐身术隐身时长问题
2.M2增加施毒术和隐身术效果时长倍率选项
3.修正PC内挂特殊药品使用逻辑
4.修改快捷栏物品位置不受整理背包和小退影响
5.修改护身符和红绿毒道具不受M2零持久不消失控制
6.修正M2内核数据页面全局变量大于99双击修改无效问题
7.增加引擎支持MySQL数据库
8.修正装备位置G细节问题
9.增加检测装备名字颜色代码CHECKITEMNAMECOLOR 位置 颜色代码
10.增加RangeHarm 附加伤害效果命令
11.修正上一版苹果端没有音效问题
12.增加SCREENEFFECT 屏幕播放动画命令
13.增加MAPEFFECT地图播放动画命令
14.增加聚灵珠使用等级限制
15.修正套装不计算神佑首饰盒等装备,扩展套装数量为2000套
16.APP内挂增加挂机群法, 自动施法, 自动施毒选项
17.修正极品属性超出设定值1点的问题
18.修改CHECKRANGEMONCOUNTEX命令参数, 用到此命令请注意修改脚本
19.增加两个变量,经验倍数<$KILLMONEXPRATE> 倍数时长<$KILLMONEXPRATETIME>

本次移动端UI工程文件修改了 SetUp页面, Top页面和 ..\cocosstudio\res\public\btn_checkbox.png文件

【2025/01/25更新】

1.取消APP内补丁包500M大小限制, 改为常规目录存放补丁(苹果端稍有不同苹果ipa补丁集成说明 )
2.APP增加游戏修复按钮
3.修正APP部分地图花屏问题
4.修正APP刀魂功能
5.扩展自定义属性支持PLAYIMG和IMG, PIC标签(与备注功能同步)
6.同步APP备注支持PLAYIMG和IMG, PIC标签
7.扩展装备支持星星功能装备星星功能
8.修正扩展装备造成的套装, APP神佑和首饰盒, APP流星火雨特效等问题
9.修正自定义OK框放入和取出触发在特定条件下无效和0号OK框不隐藏的问题
10.修改盾牌外观读取为600张一组,不分男女
11.修正默认OK框功能,增加返回默认OK框物品命令 RECLAIMITEM
12.修正PC端编辑行会封号时提示字符过长问题
13.修正聚灵珠使用失败提示
14.扩展KILLMONEXPRATE命令支持下线是否保存经验倍数参数
15.增加物品位置G, 绑定GIVE命令最后一次给予的物品
16.增加修改宝宝属性命令ChangeSlaveAbilityEx和刷新宝宝属性命令RecalcSlaveAbility

【2025/01/15更新】

1.修正假人使用GOTONOW无效问题
2.取消APP装备界面拖动操作
3.修正M2参数设置麻痹状态允许动作选项无效的问题
4.修复烟花效果
5.修正群雷 飓风破
6.扩展Mongen.txt支持 集中刷怪率 名字颜色 是否内功怪
7.扩展MongenEx命令支持参数7(名字颜色)和参数8(是否内功怪)
8.增加盾牌和时装单件装备,M2客户端设置可控制时装外显是否显示盾牌及发型选项
9.同步更新UI编辑器和配置文件支持新增装备
10.修改时装衣服类型从12,13修改为66,67,其它时装单件类型查看说明书
11.扩展装备位置( 装备位置 )
12.修正APP切换地图后英雄加血不刷新问题
13.APP增加解包文件BindItem.txt, 内挂增加自定义解包编辑选项
14.增加APP锁定目标光圈
15.修正APP对SENDSCROLLMSG和SENDMSG命令中各参数支持
16.增加升级前触发 @PlayBeginLevelUp @HeroBeginLevelUp和停止升级命令 STOPLEVELUP
17.增加武器被诅咒前触发@BeginCurse @HeroBeginCurse和取消本次诅咒命令 STOPCURSE
18.删除M2客户端背包格子全局数量设置
19.增加CHANGEBAGCOUNT 修改玩家背包格子命令,相关变量<$BAGMAXCOUNT>玩家背包格子数量,双击未解锁图标触发@UnLockBag
20.增加SETSTORAGEOPEN修改玩家仓库页数命令, 相关变量<$STORAGEPAGE> 已开启页数,点击未开启分页触发@StorageOpenFail编号
21.修正PC挂机不开自动拾取状态下还是会惦记地上物品
22.修正APP小退组队信息不清除问题
23.修正PC同时执行开盾和使用快捷栏物品会卡顿问题
24.M2选项-性能参数页面增加 怪物刷新从死亡开始计算 选项
25.修正APP自定义按钮支持X Y坐标偏移
26.增加10个预留按钮, 聊天框(0-4), 人物背包(5-9),通过UI编辑显示或隐藏,触发QF @DefButtonClick序号 触发
!!!程序务必全套更新, 如出现问题先删除M2文件夹下的!setup.txt文件以及清理玩家数据

【2025/01/01更新】

1.修正隐身戒指时效被隐身术重置问题
2.M2功能设置-全局设置里增加掉持久倍率选项
3.修正APP路灯和技能光照偏移问题
4.修正APP锁定技能点屏跑偏问题
5.优化APP读取32位bmp图片效果
6.增加倒计时转换命令COUNTDOWN
7.修正App灵符显示错误问题
8.修正ipa使用超级签无效问题
9.修正道士英雄某些时候会造成引擎AV报错
10.合并PC和APP的游戏列表,分区支持独立微端地址,(需更新列表文件)
11.优化PC挂机,恢复挂机点功能
12.修正PC寻路状态不能使用部分快捷键问题
13.修正叠加物品操作逻辑,增加APP拆分,合并按钮(需更新Tips.csb)
14.修正APP因账号长度问题登录无反应问题(账号莫名多出字符)
15.修正APP自定义对话框受是否可移动参数控制
16.修改APP内挂界面不可移动
17.修正APP部分机型点不出装备属性问题
18.扩展CHECKPC命令支持参数1位客户端类型(0电脑端, 1安卓端, 2苹果端),M2同步区分显示

【2024/12/16更新】

1.优化APP大地图相关操作
2.优化APP挂机寻路逻辑
3.修复APP升级SDK导致使用魔法闪退问题
4.优化自定义属性7个固定属性的计算逻辑
5.修正PC英雄锁定快捷键无效问题
6.修正自动拾取物品支持P位置
7.修正PC掉线后人物不卡(攻击间隔小于500ms时无效,其实就是及时雨上的超级不卡功能)
8.修正APP勾选自动魔防无限打防问题
9.增加APP点击目标头像将目标名字添加到挂机不攻击列表
10.优化APP双摇杆操作
11修正APP支持挂机命令和触发
12.删除APP内挂名字偏移和技能偏移滑动条
13.增加APP内挂保护支持瞬蓝和修正卷轴保护功能
14.修改APP寻路或挂机状态可被摇杆或点屏中断
15.修正data文件中位图错位问题
16.修正套装物品左右不分和APP部分装备不显示套装信息问题
17.修正时装外显时男女不分问题
18.优化APP摇杆延迟问题
19.修正部分怪物攻击音效播放两次的问题
20.增加组队经验获取和英雄经验获取方式
21.修正APP自定义按钮初次加载显示细节以及隐藏后仍然能点击问题
22.增加StatusRate, CHANGEMODEEX, ADDHUMNEWVALUE, CHANGEHUMABILITY命令支持英雄操作
23.修正APP部分老地图显示错乱问题
24.修改PC端NPC对话关闭按钮默认和按下按钮为必备补丁的46,47
25.M2在线人数信息增加显示电脑和手机状态

【2024/12/03更新】

1.命令CHECKCURRTARGETRACE 第二个参数增加类型10 为NPC
2.恢复双摇杆切换,APP工程文件需更新
3.自定义属性增加装备属性百分比计算模式(在自定义属性页面设置)
4.增加M2功能设置-全局设置里 复活间隔选项, 修正小退可以重置复活CD的问题
5.增加引擎可以使用域名做为IP地址
6.同步humeffect.wzl文件读取, 扩展humeffect6.wzl~ humeffect9.wzl
7.升级APP支持安卓14系统
8.修正APP顶戴花翎取消不刷新问题
9.修正APP商铺不能翻页问题
10.修正无法获取英雄私人变量的问题
11.修正PC技能图标显示细节问题
12.修正PC读取盛大武器特效默认使用混合模式(去黑边)
13.修正APP读取部分8位bmp图片错位问题
14.修正PC配置器一些细节问题
15.优化APP补丁读取方式
16.优化APP挂机逻辑

【2024/11/25更新】

1.修正商店物品卖价超过65535显示异常问题
2.修正APP特效播放数量多1问题
3.调整锁定目标功能支持英雄的BB,调整宝宝锁定目标的时长
4.修正上一版刷新血值造成魔法盾乱入问题
5.修正APP首饰特效偏移问题
6.修正APP的NPC对话框内提示框跟随对话框移动
7.修正APP自定义OK框物品偏移问题
8.调整PC端NPC名字支持换行
9.修正APP月灵显示问题
10.修正APP一些技能特效与PC同步
11.修正APP英雄死亡血值不归零
12.优化M2与客户端之间的通讯
13.修正96僵尸不会复活的问题
14.删除CHECKTITLE命令的参数2和参数3
15.修正TEXTSPLIT字符串分割命令最后一个分割项无效的问题
16.扩展S变量和N变量支持0~999, 优化变量写入和读取逻辑
17.调整脚本执行逻辑,#IF支持空检测
18.优化PC和APP之间的攻击速度差和移动速度差
19.同步PC和APP的斗笠外观显示
20.优化APP物品秀ITEMSHOW标签信息的显示细节
21.修正APP升级无特效问题
22.修复PC登陆器窗口化组件
23.删除PC端列表生成工具
24.重写PC登陆器配置器, 修改列表格式
25.修正APP文本解析IMG标签点击范围过大问题
26.修正角色死亡时有负面状态进行复活后状态不会消失的问题
27.修正QUERYVALUE无返回值时APP弹出错误的提示框
28.修正PC部分按钮不显示默认图片问题
29.修正PC小退开始按钮等待时间过长问题
30.取消APP快捷栏可放置31类物品
31.修正PC端已知UI细节问题
32.修改UI.xml文件存放位置为列表网站Config目录下,名字可以随便改

【2024/11/09更新】

1.修正宝石镶嵌相关命令不支持自定义OK框问题
2.修正上一版更换字体造成的装备数据错乱和特效失效问题
3.增加APP全局字体缩放,自适应缩放后的间隔
4.修正APP角色复活屏幕还是灰色
5.修正APP打开网页命令无效
6.修正上一版漏掉的仓库细节问题
7.APP增加装备备注, 修改获取物品备注路径为列表目录下..\Config\ItemDescList.txt (PC和APP相同)
8.修正一些怪物不攻击英雄的问题
9.修正创建行会一些细节问题
10.修正APP宝宝偶尔走路打飘的问题
11.删除APP内挂中一些无用选项
12.修改APP商城界面
13.APP列表增加充值链接, 商城界面充值按钮点击跳转
14.修正APP雪球绘制问题
15.修正HumanMP命令刷新问题
16.修正SendMsg命令中%s显示怪物名字带数字问题
17.增加PK血值实时刷新效果
18.优化PC背包刷新逻辑
19.修正APP非法师职业不能使用自动开盾问题

【2024/10/28更新】

1.修复宝石镶嵌功能
2.修正APP移动会解除锁定目标问题
3.修正APP增删技能刷新问题
4.修正人物装备界面细节问题
5.修正APP摆摊相关操作和细节问题
6.修正APP快捷栏操作和叠加物品不显示数量问题
7.修正APP交易操作细节问题
8.修复APP拾取按钮功能
9.修正APP仓库操作和细节问题
10.优化NPC和任务栏黄色可点击字体
11.增加APP对话框字体缩放功能NPC对话框文字缩放
12.修正APP倒计时消息显示问题
13.修正APP攻速过高时APP怪物死亡延迟
14.增加APP英雄状态切换和锁定按钮
15.增加APP左上角玩家主属性显示, 删除信号和时间组件
16.修正伤害飘血问题(需更新NewopUi.data文件)
17.修正使用可锁定技能时点屏移动不能停止的问题
18.修正宝石内观没有特效
19.修正PC端自定义OK框切换NPC不删除问题
!!!暂时屏蔽套装提示

【2024/10/21更新】

1.修正数据库DuraMax字段值为0时商店无法购买问题
2.修正APP角色死亡血球细节问题
3.修正神兽趴下显示不正常问题
4.调整APP金币掉落颜色
5.修正APP合击能量条和技能显示问题
6.修正APP装备界面头盔斗笠偏移问题
7.修改APP穿戴提示框显示逻辑
8.补充APP部分技能图标
9.优化内挂过滤获取方式,删除M2下发内挂过滤功能
10.取消M2可视化仓库开关,使用OPENSTORAGEVIEW为打开可视化仓库
11.修正PC界面细节问题
12.修正APP文本解析部分细节问题
13.优化APP移动刺杀寻路逻辑
14.修正PC装备信息框显示问题
15.修正PC攻速问题

【2024/10/15更新】

1.修复APP点击挂机键闪退
2.调整APP单击锁定目标,双击攻击目标
3.调整强攻按着不放一直攻击
4.修改点屏移动执行方式 和PC鼠标左键效果相同
5.修正松开摇杆偶尔不会归位的问题
6.M2参数设置增加人物死亡掉落装备最大数量设置
7.修正PC碰到障碍物反弹回来照明失效的问题
8.扩展APP端bmp图片支持24和32位,和PC同步
9.修正部分补丁显示错位的问题
10.修改APP自定义按钮显示逻辑
11.修正APP补丁items5.wzl读取错误问题
12.修改APP微端逻辑,优化更新速度
13.修复闪退问题

【2024/09/27更新】

1.修复攻速属性无效的问题
2.同步APP和PC游戏速度
3.扩展mon255.wzl Npc5.wzl Tiles255.wzl Smtiles255.wzl
4.M2增加移动刺杀开关
5.修复APP移动刺杀功能
6.更换摇杆控制方式
7.修正PC戴斗笠切换地图延迟过大的问题
8.调整APP界面UI,增加信号强度和时间显示
9.增加点击屏幕移动及内挂部分功能开关按钮

【2024/09/16更新】

1.调整叠加物品上限为物品DuraMax字段控制
2.修复APP小退切换角色会出现装备乱入问题
3.修复APP切换地图对象残影
4.调整APP部分UI字体
5.修复APP修改密码功能
6.增加APP登陆窗口"记住密码"选项
7.修正APP切图闪退问题
8.修正APP怪物随机变成裸奔男或者女
9.修正APP背包数据刷新细节
10.修正APP挂机状态背包满及其它已知造成闪退的问题
11.修正APP小退或切换地图出现部分黑屏问题
12.调整APP提示框显示位置, 原位置会影响双击
13.增大APP对话框装备图标点击范围
14.修正武器编号1不显示外观及声音问题
15.扩展补丁支持,详情点击补丁支持说明
16.修正PC端开启微端模式启动报错或者不启动问题
17.修正PC端UI显示细节
18.修复资源编辑器批量导出异常中断问题,优化批量导入导出速度

!!!由于修改了物品掉落特效规则造成APP进游戏闪退, 重新编辑物品掉落特效即可解决

【2024/09/09更新】

1.修正APP左上角任务栏显示细节及组队功能
2.APP游戏UI整体缩放
3.修正UI一些细节问题
4.修正同一台PC上运行两个登录器关闭时提示内存冲突问题
5.修正机器人使用特定命令造成死循环问题
6.修正沙巴克攻城AV报错
7.修正切换UI细节问题
8.修正自定义OK框刷新物品会返回背包及一些操作细节问题
9.增加绿毒飘血显示
10.扩展武器和衣服补丁到 hum19和weapon19

【2024/05/11更新】

1.修正因自定义UI造成的部分UI显示异常问题
2.修正APP英雄信息显示问题
3.修改APP小地图编号小于9300时读取mmap文件9301~9999读取/data/mmap/内的png图片
4.修复套装功能已知问题
5.修正GETITEMFIELDVALUE命令获取武器极品属性不正确的问题
6.引擎包加入PC端UI编辑器及UI配置文件

【2024/05/06更新】

1.修改判断死循环逻辑, 最大限制连续200次GOTO
2.修正一些触发无效的问题
3.修正自定义属性一处错误
4.修正Wzl已知问题
5.修正APP备注读取同步PC
6.修正APP装备特效问题
7.修正自定义OK框属性问题
8.修正一些命令不支持P D位置的问题
9.修复英雄拾取触发物品的相关变量
10.修正RunGate网关设置导致APP进不去游戏的问题
11.修正APP自定义属性显示问题
12.修正连击界面技能图标显示问题
13.删除M2客户端设置控制背包相关组件
14.增加PC端UI编辑工具
15.列表生成器客户端控制页面增加开启自定义UI选项

【2024/04/23更新】

1.修正假人拾取触发及ISDUMMY无效的问题
2.修正PC端武器特效不受男女通用控制的问题
3.修正APP因上一版扩展人物名字长度造成的排行榜数据错误问题
4.优化wzl编辑器
5.增加获取进度条指定属性值GETCUSTOMITEMPROGRESSBARVALUE 装备位置 进度条编号 属性类型 保存变量
6.修正PC时装不显示特效问题
7.修正RECALLSELF 命令的时间参数无效问题
8.修正武器和勋章开启0持久不消失功能时仍然消失的问题
9.修正@开始提问 命令对假人无效的问题

【2024/04/16更新】

由于本次更新扩展了数据结构, 更新后需清除所有人物数据及网关配置文件和!Setup.txt ,开区状态请勿更新!

1.增加召唤分身命令RECALLSELF 有效时间(秒)
2.扩展人物U, T 变量支持 0~255
3.增加获取地图角色数量命令GetMapHumCount 地图代码 类型(0所有角色, 1玩家, 2假人) 变量
4.扩展检测角色数量命令CheckMapHumanCount 支持第四个参数(0或空为所有角色, 1玩家, 2假人)
5.修正道士英雄只有施毒术时站街不打怪也不施毒的问题
6.修复假人相关功能及命令, 假人功能完成
7.优化PC内挂物品过滤细节
8.M2功能设置- 宝宝升级页面增加新的宝宝升级属性计算规则以及人物属性叠加给宝宝选项
9.M2物品规则增加拾取触发规则, 选中后物品捡起会触发@PickUpItem字段
10.扩展PC打开网站命令WEBBROWSER 第二参数不为0或空时打开系统默认浏览器

【2024/04/10更新】

由于本次更新扩展了数据结构, 更新后需清除所有人物数据及网关配置文件和!Setup.txt ,开区状态请勿更新!

1.修复PlayEffect播放人物动画命令绘制模式为1的情况下不显示的问题
2.修复APP切换时装内观不能刷新的问题
3.修正GETHUMCUSTOMITEMVALUEEX 位置为-2时无效的问题
4.扩展CHANGEMODEEX命令支持模式10...15
5.修复人形怪宝宝不受SLAVELOCK控制以及道士人形怪宝宝不能给玩家加状态的问题
6.修复DBServer网关控制可创建职业重启失效问题
7.修复CHECKITEMADDVALUE不支持P D位置的问题
8.修改M2最高等级限制逻辑
9.扩展地图文件名,NPC脚本名字, 怪物名字,玩家名字,物品名字 最大长度支持22个字符

【2024/04/03更新】

1.扩展自定义属性支持45个
2.修复PC端擒龙手抓取玩家位置不能及时刷新的问题
3.修复CHANGEHUMABILITY 命令存在的问题
4.优化攻击触发,被攻击触发,魔法攻击触发,被魔法攻击触发逻辑及相关变量取值逻辑
5.增加设置技能威力和防御命令 SETSKILLPOWER
6.扩展英雄锁定目标快捷键同步控制玩家宝宝(支持自定义快捷键)
7.增加开启宝宝锁定目标命令 SLAVELOCK (0关1开) (此命令效果不保存小退重置)
8.修复挖人形怪挖到自己身上的装备的问题
9.增加内挂手动控制群法选项
10.增加M2选项 - 物品装备 - 元素相关 设置暴击伤害倍率选项
11.修正机器人脚本调用THROWITEM 导致M2异常的问题
12.修正因添加物品未及时更新内挂过滤导致客户端闪退的问题
13.扩展套装功能支持所有身上装备位置0-34,支持增加属性值和套装属性计算顺序选项

【2024/03/28更新】

1.优化PC整理背包逻辑
2.修改ITEMSHOW显示细节,支持非叠加物品显示数量
3.修复EXTRACTSTRING 无效和TEXTSPLIT异常问题
4.修复部分M2内存泄漏
5.优化PC内挂物品过滤逻辑和挂机打怪过滤逻辑(删除挂机需要勾选打怪过滤的操作)
6.增加必备补丁NewopUi.data里18和19号图片
7.修复PC端可视化仓库存取操作问题
8.修复使用个人定时器造成GOTO死循环的问题
9.修复M2英雄设置里战士英雄基本技能设置
10.修复带宝宝过图时有概率宝宝死亡引起M2异常报错
11.修复PC龙影剑气不显示问题
12.修复设置英雄捡物重启服务器失效的问题
13.修复日志服务器查询功能

【2024/03/21更新】

1.修正顶戴取消逻辑
2.调整押镖提交任务时同时删除镖车
3.增加获取自定义属性命令GETCUSTOMITEMABIL 装备位置(支持所有位置) 属性位置(0-9) 获取类型(0-2) 保存变量
4.修正GETHUMCUSTOMITEMVALUE命令一处问题
5.修正镜像地图功能人物退出地图M2出现AV报错及相关命令无效问题
6.增加获取指定位置装备名字命令GETUSERITEMNAME 装备位置 保存变量 是否改名(0改名 1数据库名字)
7.增加获取装备附加属性命令GETITEMFIELDVALUE 装备位置 属性名字 保存变量
8.增加刷机人物属性命令RECALCABILITYS
9.调整人物宝宝自动继承人物暴率
10.扩展修改怪物属性命令,属性编号增加14,为怪物当前血量
11.修正一些AV异常报错

【2024/03/10更新】

1.优化EQUAL LARGE SMALL 比较逻辑
2.修正PC端自定义NPC对话框X和Y参数无效以及其他显示细节问题
3.修复PC端挂机使用回城卷不会停止挂机的问题(不区分是否切换地图,回城必停)
4.扩展GOTONOW支持范围参数 GOTONOW X坐标 Y坐标 范围
5.修正商城购买物品货币名字不对问题
6.优化百分比计算命令CALCPERCENT的计算精度
7.修正PC端在微端模式下首次登录选择角色界面过度偏移问题
8.调整PC端在系统缩放下自适应显示游戏窗口
9.扩展所有有关操作或检测装备属性的命令全部支持自定义OK框位置 BOXITEM0~BOXITEM11
10.扩展怪物掉落触发支持所有检测或操作装备属性的命令
11.修复M2报错(待验证)
12.修正叠加物品数量大于1时在地面显示名字不正确的问题
13.删除SetUpgradeItem , UpDateBoxItem 命令
14.增加命令LINKITEM 装备位置 UPITEMDATE 装备位置 用于优化修改装备效率,详情 LINKITEM和UPITEMDATE
15.增加装备位置 P 和D P为捡起的装备位置, D为怪物爆出的装备位置 详情查看 装备位置
16.增加拾取触发支持装备属性修改
17.修正玩家拾取装备和怪物爆出装备触发的装备信息绑定逻辑
18.修正经验吸收元素属性无效的问题
19.扩展TakeW命令支持 装备位置, 如: TakeW 1 取走身上的武器
20.调整列表信息二中的内挂过滤,支持分类编辑
21.扩展GIVE命令单次最大给予数量为999

【2024/03/04更新】

1.优化NPC对话框文本解析逻辑, APP对话框标签不再区分大小写以及备注无需加颜色代码
2.修正登录器配置器重复加载必备补丁的问题,(无需手动添加,自动隐藏加载)
3.修正APP自定义按钮标题不能识别颜色代码的问题
4.修正GETBAGITEMCOUNT命令的问题
5.去掉一些命令中的越界提示
6.调整APP头盔和斗笠在身上的点击位置
7.修正PC端在加速情况下无技能强行重击加速不生效的问题
8.增加NPC解析标签 EQUIPSHOW 显示人物身上穿戴的装备
9.增加走和跑步触发 @walk @run
10.增加人物坐标和方向变量 <$X> <$Y> <$DIR>

【2024/02/28更新】

1.修改命令MAKEPOISON 改为MAKEPOSION 同步GEE GOM引擎
2.修正ChangeHumAbility 值为0时无效的问题
4.调整挂机时道法蓝量过低自动使用近身肉搏
5.修正道法挂机对着石化中的怪物死磕(不去引活)
6.修复TEXT标签不随NPC对话框移动的问题
7.扩展变量嵌套支持<$STR(<$STR(s$扩展变量)>)>格式,原本仅支持<$STR(S<$STR(s$扩展变量)>)>
8.修复SetStringBlank, MonGenEx, AFFILIATEGUILD命令的小问题
9.增加PC端移动刺杀选项,快捷键Ctrl+F
10.修复战士内挂自动使用烈火剑法,逐日剑法,开天斩,破空斩,雷霆剑法 互相冲突的问题
11.修复删除英雄背包物品不能实时刷新的问题
12. M2人物在线列表增加刷新按钮
13.M2控制选项里修改可多次加载离线脱机人物
14.修改登录器配置器默认增加NewopUi.data 和 NewopUi2.data 两个必备文件
15.优化商城界面

【2024/02/23更新】

1.修复MapEvent地图触发事件范围参数无效的问题
2.修复IP查询插件无效的问题
3.优化同步APP和PC的游戏速度
4.增加检测人物幸运命令CheckLuckpoint 检测符 点数
5.删除ABILITYADD 修改人物属性命令
6.增加修改人物属性命令 ChangeHumAbility 属性 操作符 点数 时效 是否百分比
7.扩展修改怪物属性命令 CHANGEMONABILITY
8.兼容GEE和Blue引擎里MapEvent.txt配置
9.增加攻击相关变量

【2024/02/16更新】

1.修正PC端切换地图停止挂机
2.增加切换地图触发@EnterMap
3.修正PC端自定义按钮位置参数为1时不能移动的问题
4.增加调整人物隐藏元素属性命令AddHumNewValue 类型 操作符 数值 时长
5.增加客户端角色属性界面元素属性同步显示
6.增加元素属性常量
7.M2功能设置-宝宝升级页面增加宝宝叛变时间
8.修复攻城相关检测命令ISATTACKGUILD, ISDEFENSEGUILD, ISATTACKALLYGUILD, ISDEFENSEALLYGUILD
9.修正鞭尸命令OPENITEMBOX 在杀怪触发下会造成M2崩溃的问题
10.修正物品掉落触发偶尔会造成M2报错的问题
11.修正PC挂机不打石化怪问题
12.修正PC挂机打城门问题
13.扩展NPC脚本点击触发带参数, 参数支持变量,格式为 [$STR(T0)]
14.修复APP播放人物特效偏移问题

【2024/02/02更新】

1.M2参数设置--升级经验分页 增加 可连续提升指定数量等级选项
2.增加获取一组不同的随机数命令 GETMULTIRANDOMNUMBER 开始数值 结束数值 获取数量 保存变量 实际获取数量保存变量
3.增加获取一组不同的文本命令 GETMULTIRANDOMTEXT 文本路径 获取数量 保存变量 实际获取数量保存变量
4.扩展NPC命令参数支持变量嵌套, 如 <$STR(S<$STR(S5)>)>
5.修改自定义属性下发规则, 修正手机端接收自定义属性文本规则
6.优化自定义OK框一些细节
7.修正blue模式下显示对比信息间距过大
8.增加获取文本内容行数命令 GetTextLineCount 路径 保存变量
9.装备极品控制里增加防御魔御属性以及增加靴子,腰带,宝石,照明物等分类
10.修改物品规则逻辑, 增加物品规则列表支持选择物品类型
11.增加挂机命令及触发StartAutoPlayGame 停止挂机StopAutoPlayGame

【2024/01/28更新】

1.增加创建和删除临时NPC命令 CreateNPC DelNPC
2.修复挂机背包满在两个物品上来回跑的问题
3.修复自定义进度条
4.修正修改怪物属性命令CHANGEMONABILITY 的执行逻辑
5.修正M变量切换地图不清0的bug
6.增加修改装备名字命令ChangeItemName 位置 名字 及相关改名装备变量
7.增加修改装备名字颜色命令ChangItemNameColor 位置 颜色

【2024/01/18更新】

1.增加镜像地图功能及相关命令
2.增加检测物品幸运命令CheckItemLuck 位置 比较符 数值
3.增加检测地图是否存在CheckMap 地图代码
4.调整元素属性显示位置
5.修复上一版手机端挂机不打怪的问题

【2024/01/13更新】

1.大幅优化物品数据下发速度
2.调整客户端UI设置为1.85或1.80时,手机端时装分页也同步隐藏
3.修复PLAYIMG在点开NPC对话框一瞬间播放图片错误的问题
4.调整地图参数CHECKQUEST进图执行任务脚本支持传送触发
5.修正SENDDELAYMSG参数切换地图消失为1时在当前地图随机也会消失的问题
6.修正PC端内挂勾选职业等级后,其他角色职业等级显示为0的问题
7.彩色字体设置里均支持变量为参数<[$STR(S8)]/FCOLOR=[$STR(S9)]>
8.增加自动出师触发@UnMasterEnd
9.增加所有行会攻城命令ADDATTACKSABUKALL

年前最后一更

【2024/01/10更新】

1.扩展ADDLINELIST和ADDTEXTLIST写入命令支持第三参数 写入指定行(0-65535)
2.扩展物品名字最大支持22个字符(11个汉字)
3.修复列表信息套装列表里套装数量为0时不能保存的问题
4.列表信息增加挂机不攻击怪物列表
5.增加占领沙城,加入行会,退出行会,加入小组,退出小组触发
6.修复仿GOM样式下,技能和称号信息框显示问题及1.80界面中称号激活显示问题
7.修复SENDDELAYMSG命令支持手机端
8.修改脚本执行逻辑,和GEE翎风一致
9.扩展文本解析所有成员支持变量参数, <ITEMSHOW:[$STR(S5)]:1:30:[$STR(S6)]:0:0>
10.修复PC端自定义OK框GOM模式下悬浮框不显示物品looks问题

【2024/01/05更新】

1.修复APP自定义对话框在自定义按钮之间切换的显示问题
2.修复部分文本解析显示不正常的问题
3.修复上一版顶戴花翎实时更新遗留的问题
4.修正变量加减乘除计算逻辑
5.修复自定义属性的一些细节问题
6.修改给字符串增加空格命令SETSTRINGBLANK判断字符串长度逻辑,1汉字等于2长度

【2024/01/02更新】

1.修复记忆石不保存数据问题
2.修复APP端顶戴花翎不能实时更新问题
3.修复APP挂机干自己和英雄的宝宝的陋习
4.修复GM命令及调试命令编辑后不能保存的问题
5.M2功能设置-基本设置增加仅允许安全区摆摊选项
6.修复人形怪由于时装外显引起的武器衣服显示不正常的问题
7.调整任务和摆摊按钮的显示位置
8.修复二次刷新人形怪显示不正常的问题
9.修复物品备注调用动画或图片功能,详情见- 功能相关- 物品备注解析
10.修改物品规则支持批量增加和批量删除操作
11.修改所有文本文件操作命令支持相对和绝对命令,无需外加参数,引擎自动解析
12.增加变量传递命令SetHumVar和GetHumVar
13.增加获取物品原始各项数据库字段值参数命令GetDBItemFieldValue 物品名称 字段名 变量 和GetDBIdxItemFieldValue idx 字段名 变量
14.修复角色通过多种方式升级不刷新属性问题
15.修复角色通过多种方式获得或被收走物品背包负重不刷新问题
16.修复APP由于切换装备信息显示模式引起的部分自定义功能显示异常
17.修复装备字段Reserved值为8时人物死亡装备不消失的问题

【2023/12/26更新】

1.增加自动加载离线人物命令 RELOADOFFLINE
2.增加检测纯度命令 CHECKMINE 物品名字 数量 比较符(<>=) 纯度
3.修复游戏网关里封机器码文件路径错误问题
4.扩展MAPMOVE 支持范围参数, MAPMOVE 地图 X Y 范围
5.增加回城石DB,Reserved为回城范围,详情查询 数据库相关-- 示例DB--物品数据DB
6.修改PC端帐号登陆背景
7.修复登录器配置器皮肤编辑中的分辨率设置
8.增加检测技能熟练度命令CHECKTRANPOINT 技能名字 比较符(><=?) 点数
9.修复检测装备升级次数 CHECKITEMUPGRADECOUNT 装备位置 比较符(><=?) 次数
10.修复主界面一些提示细节, 屏蔽内挂英雄界面
11.增加修改怪物属性命令CHANGEMONABILITY 地图 怪物名(ALL或*为不判断名字) 属性类别 操作符 数值 是否百分比 时效(秒) 坐标X|坐标Y|范围
12.同步增加刷新怪物属性命令 RECALCMONABILITY 地图 怪物名字 坐标X 坐标Y 范围
13.同步APP的NPC对话框字体颜色<测试文本/FCOLOR=253> <TEXT:测试内容:X坐标:Y坐标 {FCOLOR=253}/@LABLE >
14.修复二次刷怪怪物不主动攻击玩家的问题
15.修复手机端PLAYEFFECT播放人物动画命令
16.增加打开可视化仓库命令OPENSTORAGEVIEW
17.同步PC和手机端的攻击速度,移动速度
18.调整挂机状态随机不停止,取消PC端点选挂机点

【2023/12/16更新】

1.同步自定义NPC对话框的一些按钮 图片 OK框 物品秀等
2.同步APP支持播放角色动画命令 PLAYEFFECT 资源序号 开始图片 播放数量 播放次数 播放间隔 X Y 绘制模式(0特效,1普通)
3.调整所有变量解析支持小写, 原来只支持<$USERNAME>这种大写,现在不分大小写
4.修复游戏中切换1.85和1.80布局时军鼓和马牌装备位置不隐藏的问题
5.修复升级经验不即时刷新问题,同步修复APP
6.修复61英雄类人形怪导致的暴率乱套问题
7.修复英雄时装外显不屏蔽发型和武器的问题
8.修复APP打开网站乱码问题
9.修复部分因为神佑盒和大背包造成的显示bug问题
10.扩展MapEvent.txt地图触发事件支持坐标范围参数

【2023/12/01更新】

1.增加1.80角色装备界面
2.M2上增加内挂过滤选项, 查看-列表信息二 以后内挂过滤由M2控制下发
3.添加神佑盒及相关命令
4.增加大地图自动寻路导航线
5.增加APP端开启自定义对话框命令SETMERCHANTDLGIMGNAME 图片名字 缩放比例 字体大小
6.取消M2全局控制中的攻击触发和被攻击触发开关,(实际没什么用)

【2023/11/16更新】

1.修改KILLMONEXPRATE 杀怪经验倍数 和POWERRATE 攻击力倍数 时间参数为0时在线一直有效
2.增加首饰盒显示命令 SETSNDACASKET (0隐藏/1显示)
3.增加随机命令 RANDOMEX 1 100 为100分之一的概率
4.整合四格和六格配置器,改成M2控制四格六格切换
5.修改APP自定义按钮标题颜色同步PC颜色
6.增加百区装备提示模式
7.修复微端不更新PC端data补丁问题
8.增加英雄支持首饰盒
9.增加装备提示框边框保留选项

【2023/11/11更新】

1.修复四级魔法盾的问题
2.修改APP可视化仓库和PC同步
3.增加首饰盒
4.优化大幅度降低引擎内存使用率
5.增加客户端游戏窗口宽高变量<$SCREENWIDTH> <$SCREENHEIGHT>
6.增加检测是否为PC客户端玩家命令 CheckPC
7.增加怪物掉落触发[@M2DROPITEM] 相关变量<$DROPITEMINDEX> <$DROPITEMNAME> <$DROPITEMSTDMODE> <$DROPITEMMAKEINDEX>
8.扩展CHECKITEMADDVALUE CHANGEITEMADDVALUE两个命令支持检测和修改怪物掉落触发的装备属性,其他命令暂不考虑
9.增加获得杀怪经验时触发[@GETEXP] 相关变量<$GETEXP>

【2023/11/04更新】

1.增加移动怪物命令 MoveMapMonToPos 怪物名(all或*为所有怪物) 老地图 老X 老Y 老范围 新地图 新X 新Y 新范围
2.修改APP挂机按钮是否显示受M2控制
3.修复偶尔小退进不去游戏的问题
4.取消限制人数
5.背包最大格子从120提高为200格
6.修复PC端挂机傻逼的问题

【2023/10/28更新】

1.增加脱下装备命令 TAKEOFF 装备位置
2.增加倒计时触发命令 SENDDELAYMSG 消息内容 时间 字颜色 QF触发段 换地图是否显示
3.修复英雄技能不保存的BUG
4.修复变量判断逻辑问题
5.添加假人(未完成)
6.增加假人相关命令
7.修复因客户端缺少地面特效资源文件引起的多开闪屏问题
8.修复APP套装显示重复的问题
9.增加GOTOLABEL 成员或范围触发命令
10.增加HCALL 让指定玩家触发指定标签命令
11.修复APP自定义按钮点击无反应的bug
12.增加调整宝宝等级命令 ChangeSlaveLevel 名字 操作符(+ = -) 等级(1-7)

【2023/10/21更新】

1.控制台增加自动设置服务端目录按钮
2.增加时间戳<$UTCNOW>
3.增加UTC时间到北京时间命令 UnixToStr UTC时间 保存变量
4.增加更改游戏窗口标题命令 SendClientTitleMsg 变量
5.增加数学表达式命令 FORMULATION 计算公式 保存变量
6.控制台配置向导页面增加数据库字段补全按钮,一键补全数据库缺少的字段
7.M2客户端设置增加调整其他货币上下间隔

【2023/10/19更新】

1.去掉客户端测试提示 修复GOM显示模式下武器不显示重量的问题
2.修改app大地图传送戒指命令逻辑
3.扩展背包数量,目前最大支持120格,相关设置在M2客户端设置
4.增加可视化仓库

【2023/08/28更新】

1.修正PC不能丢弃快捷物品栏物品
2.修正PC骰子绘制错误
3.修正在交易进行时不允许撤回物品
4.修复英雄穿戴不刷新需要小腿问题
5.修复挂机时刷新怪物不显示怪物名字和不攻击怪物的问题
6.修改APP和PC端称号功能共同调用UI1.wzl
7.修改APP和PC端顶戴花翎可以同步自定义补丁
8.修正APP端和PC端顶戴花翎位置不统一的问题
9.调整APP上物品来源受M2控制
10.修复游戏里删除角色出现错误的问题
11.修复GM命令删除玩家全部技能面板不及时刷新的问题

【2022/08/09更新】

1.增加获取文本命令GETLISTSTRING 路径 行号 变量1 变量2 是否绝对路径
2.增加分隔字符串命令 EXTRACTSTRING 分隔符 字符串 变量1~变量8
3.增加分割字符串命令 TEXTSPLIT 分隔符 字符串 变量
4.增加获取字符串所在文本的行数GETSTRINGPOS 路径 字符串 是否绝对路径
5.修复列表生成器保存时候报错问题

【2022/08/07更新】

1.调整微端构建程序和微端网关布局
2.修改登录界面调用补丁的文件为必备补丁NewopUI.data,以配合微端
3.修复开启微端状态下,F12内挂界面打开无补丁的问题
4.修复服务器上不能打开微端构建器的问题

【2022/07/25更新】

1.增加调整称号有效时长命令CHANGEFENGHAOTIME 称号名字 符号(+-) 时间(小时1~65535)
2.增加删除配置文件 关键字和节点命令DELCONFIGFILEITEM ， DELCONFIGFILESECTION
3.登录器启用反外挂检测代码（测试版）

【2022/07/23更新】

1.增加SetVars批量变量赋值命令 格式: SetVars 开始变量 赋值数量 值
4.修改DBServer删除人物等级限制的逻辑
5.修复灭天火,飓风破无伤害及动画错误
6.增加N和S扩展变量 格式举例: 整数型 N$测试 <$STR(N$测试)> 字符型 S$测试 <$STR(S$测试)>
7.增加获取背包指定物品数量命令 GETBAGITEMCOUNT 物品名字(或IDX) 保存变量 是否区分改名(0否/1是)
8.增加百分比计算命令 CalcPercent 数值 百分比 结果 模式(0或空为百分比,1为千分比,2为万分比)
9.增加循环跳转命令 LOOPGOTO 字段 循环次数, 支持变量

【2022/07/15更新】

1.M2在线人物信息里增加U,T变量查询修改功能
2.修复自定义按钮无法在QM上线触发中使用的问题
3.修复#OR检测问题
4.增加读写配置命令ReadConfigFileItem和WriteConfigFileItem,支持绝对路径
5.增加变量 J0~J49(数字型) 和 Z0~Z49(字符型) 每日定点清空, 清空时间在M2 参数设置~时间控制 调整!

【2022/07/07更新】

1.增加大地图功能,并支持大地图自动寻路和右键传送功能,大地图背景图片在NewopUI.data 文件中77号图片
2.增加自动寻路命令GOTONOW X坐标 Y坐标
3.增加M2查询修改全局G和A变量窗口

【2022/06/29更新】

1.控制台增加""一键初始化""按钮,转引擎必须点击执行初始化,可避免莫名其妙的错误
2.登录器配置器集成默认皮肤文件
3.增加生成登录器时检测目录下是否有必备补丁NewopUI.data,生成登录器时自动集成无需设置

4.增加捡起物品相关常量<$CURRTEMNAME>物品名,<$CURRTEMNAME_G>修改后的名字,<$CURRTEMINDEX>数据库IDX,<$CURRTEMMAKEINDEX>制造ID,<$CURRTEMSTDMODE>类型

【2022/06/21更新】
1.增加道士技能免毒符选项 在技能魔法页面设置
2.扩展灵符和金刚石的携带上限为21E
3.增加幸运值常量<$LUCK>,年月日时分秒常量<$YEAR><$MONTH><$DAY><$HOUR><$MIN><$SEC>

【2022/06/16更新】

1.优化变量执行逻辑.
2.扩展MUL DIV支持第三参数.
3.重做INC DEC命令,支持字符串操作
4.增加一些常量
5.修复控制台查询修改账号信息功能

【2022/05/25更新】

1.修改引擎!Setup.txt文件里称号ShowRankLevelName默认为开启状态.
2.修改控制台清理数据界面取消选择路径控件,点击开始清理将自动清理控制台程序所在的版本目录
3.修复商城功能,增加上架物品支持多种货币
4.APP背包增加灵符显示
5.增加M2重载机器人脚本选项
6.增加自定义按钮
7.增加自定义属性及相关操作命令

【2022/05/03更新】

1.修复APP上线血量显示错误问题
2.修改数据库连接方式为Sqlite方式
3.控制台集成libmySQL_x64.dll文件
4.增加合区工具Sqlite版并支持合并行会数据

【2022/04/25更新】

1.增加攻击触发，被攻击触发，魔法攻击触发，被魔法攻击触发 举例：[@Attack]，[@Struck]，[@MagicAttack]，[@MagicStruck]
2.增加调整人物杀怪爆率命令 MONDROPRATE 举例：MonDropRate 操作符(+,-,=) 数值，例子：如果数值写100，原来爆率是1/500的话，经过命令加成就是1/250；该命令真实有效取值1~21亿
3.增加P变量至99个
4.修复金刚石,灵符退出不保存问题
5.增加U,T变量0~49.
6.增加NOT反向检测命令

【2022/04/01更新】

1.增加CHECKMAPSAMEMONCOUNT命令,检测指定地图指定怪物的数量 举例：CHECKMAPSAMEMONCOUNT 地图 怪物名字 比较符 数量
2.扩展MOVR命令支持第三个参数, 举例：MOVR M5 1 4 ,随机取值范围为: 1,2,3
3.PC端说话文字拉高至血值上面(以前和血条重叠,看着很蛋疼)
4.增加文本比较CheckContainsText命令 举例：CheckContainsText 母变量或值 子变量或值
5.提高give命令给予物品的数量为255
6.增加@PickUpItemEX拾取触发命令
7.增加GETRANDOMNAME 随机或指定获取行文本保存到指定变量， 举例：GETRANDOMNAME 路径 变量 行数(0或空为随机获取)
8.增加脚本回城命令GOHOME
9.修改CheckItemAddValue检测装备附加属性值支持变量操作 举例：CheckItemAddValue 位置(-1为OK框) 属性 比较符 值
10.增加获取装备极品属性命令GETITEMADDVALUE 举例：GETITEMADDVALUE 位置(-1为OK框) 属性(支持元素属性) 保存变量
11.增加一键回收命令TAKEBAGITEMS 举例：TAKEBAGITEMS 物品名字 计数变量 （支持除叠加物品以外的任何类型物品）


颜色对照表

Help >
颜色对照表

0 | 1 | 2 | 3 | 4 | 5
6 | 7 | 8 | 9 | 10 | 11
12 | 13 | 14 | 15 | 16 | 17
18 | 19 | 20 | 21 | 22 | 23
24 | 25 | 26 | 27 | 28 | 29
30 | 31 | 33 | 34 | 35 | 36
37 | 38 | 39 | 40 | 41 | 42
43 | 44 | 45 | 46 | 47 | 48
49 | 50 | 51 | 52 | 53 | 54
55 | 56 | 57 | 58 | 59 | 60
61 | 62 | 63 | 64 | 65 | 66
67 | 68 | 69 | 70 | 71 | 72
73 | 74 | 75 | 76 | 77 | 78
79 | 80 | 81 | 82 | 83 | 84
85 | 86 | 87 | 88 | 89 | 90
91 | 92 | 93 | 94 | 95 | 96
97 | 98 | 99 | 100 | 101 | 102
103 | 104 | 105 | 106 | 107 | 108
109 | 110 | 111 | 112 | 113 | 114
115 | 116 | 117 | 118 | 119 | 120
121 | 122 | 123 | 124 | 125 | 126
127 | 128 | 129 | 130 | 131 | 132
133 | 134 | 135 | 136 | 137 | 138
139 | 140 | 141 | 142 | 143 | 144
145 | 146 | 147 | 148 | 149 | 150
151 | 152 | 153 | 154 | 155 | 156
157 | 158 | 159 | 160 | 161 | 162
163 | 164 | 165 | 166 | 167 | 168
169 | 170 | 171 | 172 | 173 | 174
175 | 176 | 177 | 178 | 179 | 180
181 | 182 | 183 | 184 | 185 | 186
187 | 188 | 189 | 190 | 191 | 192
193 | 194 | 195 | 196 | 197 | 198
199 | 200 | 201 | 202 | 203 | 204
205 | 206 | 207 | 208 | 209 | 210
211 | 212 | 213 | 214 | 215 | 216
217 | 218 | 219 | 220 | 221 | 222
223 | 224 | 225 | 226 | 227 | 228
229 | 230 | 231 | 232 | 233 | 234
235 | 236 | 237 | 238 | 239 | 240
241 | 242 | 243 | 244 | 245 | 246
247 | 248 | 249 | 250 | 251 | 252
253 | 254 | 255 |  |  |

This file is decompiled from a .CHM file
by an UNREGISTERED version of Easy CHM.
You can download Easy CHM at : http://www.eTextWizard.com

Copyright © 2019. All rights reserved. (To change the copyright info, just edit it in template.)


NPC对照表

Help >
NPC对照表

 | 代码：0
 | 代码：1
 | 代码：2
 | 代码：3
 | 代码：4
 | 代码：5
 | 代码：6
 | 代码：7
 | 代码：8
 | 代码：9
 | 代码：10
 | 代码：11
 | 代码：12
 | 代码：13
 | 代码：14
 | 代码：15
 | 代码：16
 | 代码：17
 | 代码：18
 | 代码：19
 | 代码：20
 | 代码：21
 | 代码：22
 | 代码：23
 | 代码：24
 | 代码：25
 | 代码：26
 | 代码：27
 | 代码：28
 | 代码：29
 | 代码：30
 | 代码：31
 | 代码：32
 | 代码：33
 | 代码：34
 | 代码：35
 | 代码：36
 | 代码：37
 | 代码：38
 | 代码：39
 | 代码：40
 | 代码：41
 | 代码：42
 | 代码：43
 | 代码：48
 | 代码：49
 | 代码：50
 | 代码：51
 | 代码：52
 | 代码：54 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：55 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：56 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：57 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：58 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：59
 | 代码：60
 | 代码：61
 | 代码：62
 | 代码：63
 | 代码：64
 | 代码：65
 | 代码：66
 | 代码：67
 | 代码：68
 | 代码：70
 | 代码：71
 | 代码：72
 | 代码：73
 | 代码：74
 | 代码：75
 | 代码：76
 | 代码：77
 | 代码：78
 | 代码：79
 | 代码：80
 | 代码：81
 | 代码：82
 | 代码：83
 | 代码：84
 | 代码：90
 | 代码：91
 | 代码：92
 | 代码：94 传送门，可以点击。
 | 代码：95 传送门，可以点击。
 | 代码：96 传送门，可以点击。
 | 代码：97 传送门，可以点击。
 | 代码：98 传送门，可以点击。
0 | 代码：99
1 | 代码：100
1 | 代码：101
1 | 代码：102
1 | 代码：200
1 | 代码：201
1 | 代码：202
1 | 代码：203
1 | 代码：204
1 | 代码：205
1 | 代码：206
1 | 代码：207
1 | 代码：208
 | 代码：209
 | 代码：210
 | 代码：211
 | 代码：212
 | 代码：213
 | 代码：214
 | 代码：215
 | 代码：216
 | 代码：217
 | 代码：218
 | 代码：219
 | 代码：220
 | 代码：221
 | 代码：222
 | 代码：223
 | 代码：224
 | 代码：225
 | 代码：226
 | 代码：227

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


程序变量操作说明

Help > 基本设置 >
程序变量操作说明

变量解析

更新变量参数

P0-P99 (私人变量，数字型) 打开对话框重置为0。
D0-D99 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M99 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N999 (私人变量，数字型) 下线不保存.小退归0.
S0-S999 (私人变量，字符型) 下线不保存.小退清空.
I0-I99 (全局变量，数字型) 下线不保存.小退归0.
G0-G499 (全局变量，数字型) 可保存。（存放在Mir200/!Setup.txt文件里面）
A0-A499 (全局变量，字符型) 可保存。（存放在Mir200/!Setup.txt 文件里面）
U0-U255 (私人变量，数字型) 可保存。（存放在人物数据库MIR.db里面）
T0-T255 (私人变量，字符型) 可保存。（存放在人物数据库MIR.db里面）
J0-J49(私人变量，数字型) 可保存，定时清空。（存放在人物数据库MIR.db里面）
Z0-Z49(私人变量，字符型) 可保存，定时清空。（存放在人物数据库MIR.db里面）

一.标识

[001]-[499](各引擎不同标识的上限值不能。正常的是499个)，这不是变量，这是标识
标识的初始值是关闭的，它不会因为人物下线或服务器重启而重置
相关命令格式:
Check [001] 0 的意思是检测你的标识[001]是否关闭
SET [001] 1 的意思是设置你的标识[001]为开的状态

1.关于reset命令的详解：
reset [XXX] 7 意思是将从XXX开始的7个变量回复到原始值0
比如：reset [100] 7 就是把100 101 102 103 104 105 106 107这7个变量赋值为0。
它等同与：set [100] 0
set [101] 0
set [102] 0
set [103] 0
set [104] 0
set [105] 0
set [106] 0

二.变量

P0-P99 (私人变量，数字型) 关闭对话框重置为0。
D0-D99 (私人变量，数字型) 不可保存。
M0-M99 (私人变量，数字型) 不可保存。
N0-N999 (私人变量，数字型) 不可保存。
S0-S999 (私人变量，字符型) 不可保存。
I0-I99 (全局变量，数字型) 不可保存，服务器重启自动重置为0。
G0-G99 (全局变量，数字型) 可保存。
A0-A99 (全局变量，字符型) 可保存。

变量与数字之间的常用格式:

small G88 5 ;检测变量G88，是否小于5
large G88 5 ;检测变量G88，是否大于5
equal G88 5 ;检测变量G88，是否等于5
mov G88 5 ;设置G88=5
INC G88 5 ;设置变量G88=G88+5
DEC G88 5 ;设置变量G88=G88-5
MUL G88 5 ;设置变量G88=G88*5
DIV G88 5 ;设置变量G88=G88/5< br>

变量与变量之间的常用格式:

small M88 <$STR(G88)> ;检测私人变量M88，是否小于全局变量G88
large M88 <$STR(G88)> ;检测私人变量M88，是否大于全局变量G88
EQUAL M88 <$STR(G88)> ;检测私人变量M88，是否等于全局变量G88
mov G88 <$STR(M88)> ;设置全局变量G88=M88
inc G88 <$STR(M88)> ;设置全局变量G88=G88+M88
DEC G88 <$STR(M88)> ;设置全局变量G88=G88-M88
MUL M88 $STR(M89) ;设置私人变量M88=M88*M89
DIV M88 $STR(M89) ;设置私人变量M88=M88/M89< br>

Small、Large、Equal、mov、INC、DEC、MUL、DIV、PERCENT 支持第3参数，例：
#IF
LARGE N1 <$STR(P0)> <$STR(M5)> //检测表达式为： N1 > ( $STR(P0) * $STR(M5) ) ，即检测N1是否大于( $STR(P0) 乘以 $STR(M5) )
用法类似：GameGold - <$STR(P0)> <$STR(M5)>

其他变量命令：
1.关于SUM命令的详解：
首先有MOV (变量X) 0 ;(变量X)清0
sum (变量A) (变量B) ;X=A+B
sum (变量C) ;X=X+C
2.关于movr命令的详解：
movr (变量) (数值) ;随机把指定数值以下的数(正数)给变量
3.DEC特殊用法
支持A，S变量的DEC操作，格式：DEC A0 X Y
其中X，Y表示位置，操作的结果：删除A0字符串中从X开始到Y结束之间的字符
以下操作去掉“ABCDEFGHIJK”
MOV S0 屠龙ABCDEFGHIJK刀
DEC S0 5 15

三.自定义变量
注意： 自定义变量不要以P、G、M、I、D、N、S、A开头

说明

数据类型

Integer 整型

String 字符串

变量类型

HUMAN 个人变量

GUILD 行会变量

GLOBAL 公共变量

$HUMAN() //个人自定义变量显示方式
$GUILD() //行会自定义变量显示方式
$GLOBAL()
//全局自定义变量显示方式

配套NPC命令：
VAR //定义变量
LOADVAR //读取
SAVEVAR //存储
CALCVAR //对变量进行运算(+、-、*、/)

CHECKVAR HUMAN 自定义变量 > 5 ;检测[自定义变量]是否大于5
CHECKVAR HUMAN 自定义变量 = 5 ;检测[自定义变量]是否等于5
CHECKVAR HUMAN 自定义变量 < 5 ;检测[自定义变量]是否大于5
CALCVAR HUMAN 自定义变量 = 5 ;设置[自定义变量]=5
CALCVAR HUMAN 自定义变量 + 5 ;设置[自定义变量]=[自定义变量]+5
CALCVAR HUMAN 自定义变量 - 5 ;设置[自定义变量]=[自定义变量]-5

自定义变量与变量之间的常用格式:

MOV M88 <$HUMAN(自定义变量)> ;设置变量M88=[自定义变量]
CALCVAR HUMAN 自定义变量 = <$STR(M88)> ;设置[自定义变量]=变量M88
CALCVAR HUMAN 自定义变量 + <$STR(M88)> ;设置[自定义变量]=[自定义变量]+变量M88
CALCVAR HUMAN 自定义变量 - <$STR(M88)> ;设置[自定义变量]=[自定义变量]-变量M88

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


脚本变量大全

Help > 基本设置 >
脚本变量大全

变量名 | 注释说明
<$SERVERNAME> | 服务器名称
<$SERVERIP> | 服务器IP
<$WEBSITE> | 网站在String.ini设置
<$BBSSITE> | 论坛在String.ini设置
<$CLIENTDOWNLOAD> | 下载地址在String.ini设置
<$QQ> | 客服QQ在String.ini设置
<$PHONE> | 客服电话在String.ini设置
<$BANKACCOUNT0> | 银行信息在String.ini设置
$BANKACCOUNT1....9 | 银行信息1...9在String.ini设置
<$GAMEGOLDNAME> | 游戏币名称
<$GAMEPOINTNAME> | 游戏点名称
<$USERCOUNT> | 在线人数
<$MACRUNTIME> | 服务器运行天数
;指向物品的相关常量 | 意思就是在某些脚本执行或脚本段触发时返回的物品相关信息；
目前支持指向物品的触发段：
 [@PickUpItemEx]
[@PickUpItemX]
[@PickUpItem]
目前支持指向物品的脚本命令： 检测命令(#IF/GIVEOK)
执行命令(#ACT)
GIVE
GIVEEX
<$CURRTEMNAME> | 当前操作指向物品名称
<$CURRTEMMAKEINDEX> | 当前操作指向物品唯一生产编号
<$G_CURRTEMNAME> | 当前操作指向物品改名名称
<$CURRTEMSTDMODE> | 当前操作指向物品DB字段StdMode值
<$CURRTEMSHAPE> | 当前操作指向物品DB字段Shape值
<$CURRTEMANICOUNT> | 当前操作指向物品DB字段AniCount值
<$CURRTEMDURA> | 当前操作指向物品剩余持久值
<$CURRTEMINDEX> | 当前操作指向物品DB字段Idx值
<$CURRTEMDURAMAX> | 当前操作指向物品DB库中持久最大字段值
<$CURRTEMLOOKS> | 当前操作指向物品DB库中Looks值字段值
<$CURRRTARGETNAME> | 当前指向攻击对象的名称
<$CURRRTARGETMAXHP> | 当前攻击(被攻击)对象(受)攻击时的最大血量
<$CURRRTARGETDELHP> | 当前被攻击对象受攻击被减少的血量
<$CURRRTARGETHP> | 当前攻击(被攻击)对象(受)攻击时的剩余血量
<$CURRRUSEMAGICID> | 攻击对象使用的魔法ID
<$PKPOWER> | 对目标造成的伤害值
<$STRUCKHP> | 被攻击受到的伤害值
<$CURRRTARGETX> | 当前目标的X坐标
<$CURRRTARGETY> | 当前目标的Y坐标
<$LOCKTARGETNAME> | 当前锁定目标的名字
<$LOCKTARGETX> | 当前锁定目标的X坐标
<$LOCKTARGETY> | 当前锁定目标的Y坐标
<$CURHUMANHPTARGETPOWER> | HumanHP - 数值 减掉的血
<$GETEXP> | 最后一次杀怪经验值
<$DATETIME> | 服务器时间
<$YEAR> | 年
<$MONTH> | 月
<$DAY> | 日
<$HOUR> | 小时
<$MINUTE> | 分钟
<$SECOND> | 秒数
<$WEEK> | 星期 注意：国外是星期天才是一周的第一天，所以用此常量的时候注意这一点
<$SCREENWIDTH> | 角色当前登录游戏使用的分辨率宽度
<$SCREENHEIGHT> | 角色当前登录游戏使用的分辨率高度
<$RevivalTime> | 复活剩余时间
<$MONKILLER> | 把人物击杀的怪物名称
<$KILLMONNAME> | 被人物击杀的怪物名称(带数字)
<$KILLMONNAMEEX> | 被人物击杀的怪物名称(不带数字)
<$KILLMONX> | 被人物击杀的怪物X坐标
<$KILLMONY> | 被人物击杀的怪物Y坐标
<$DECEDENT> | 被杀者名称
<$KILLER> | 杀人者名称
<$KILLEREX> | 杀人者名称(不区分杀人者类型)
<$HIGHLEVELINFO> | 最高级别信息
<$HIGHPKINFO> | 最高PK值
<$HIGHDCINFO> | 最高攻击
<$HIGHMCINFO> | 最高魔法
<$HIGHSCINFO> | 最高道术
<$HIGHONLINEINFO> | 在线最长时间玩家的信息
<$CURRENTMAPDESC> | 人物当前地图名称信息如：盟重省
<$CURRENTMAP> | 人物当前地图名称编号如：3
<$CURRENTX> 或者 <$X> | 人物当前坐标X
<$CURRENTY> 或者 <$Y> | 人物当前坐标Y
<$DIR> | 人物朝向(0-7) 英雄的加H
<$KILLMONEXPRATE> | 杀怪经验倍数
<$KILLMONEXPRATETIME> | 杀怪经验倍数时长
<$GENDER> | 人物性别
<$JOB> | 人物职业
英雄类的变量在人物变量前面加H.即可，如下：就不再单独赘述
<$H.JOB> | 英雄职业
<$H.GENDER> | 英雄性别
<$USERNAME> | 人物名称
<$HWID> | 人物机器码
<$USERID> | 人物登陆账号
<$DLGITEMNAME> | 点击后可得到的物品名
<$RANDOMNO> | 随机值变量
<$DEALGOLDPLAY> | 元宝交易对象
<$RELEVEL> | 转生级别
<$H.RELEVEL> | 英雄转生级别
<$GUILDNAME> | 行会名称
<$RANKNAME> | 行会职位名称
<$LEVEL> | 级别
<$HP> | 当前生命值
<$MAXHP> | 最高生命值
<$MP> | 魔法值
<$MAXMP> | 最高魔法值
<$AC> | 防御
<$MAXAC> | 最高防御
<$MAC> | 魔御
<$MAXMAC> | 最高魔御
<$DC> | 攻击
<$MAXDC> | 最高攻击
<$MC> | 魔法
<$MAXMC> | 最高魔法
<$SC> | 道术
<$MAXSC> | 最高道术
<$HIT> | 准确
<$SPD> | 躲避率
<$HITSPD> | 攻击速度
<$EXP> | 当前经验
<$MAXEXP> | 升级经验值
<$PKPOINT> | PK点数
<$CREDITPOINT> | 声望点数
<$HW> | 腕力
<$MAXHW> | 最高腕力
<$BW> | 背包重量
<$MAXBW> | 最高背包重量
<$WW> | 负重力
<$MAXWW> | 最高负重
<$GOLDCOUNT> | 金币
<$GAMEGOLD> | 元宝
<$NIMBUS> | 灵气值
<$GAMEPOINT> | 游戏点
<$GAMEDIAMOND> | 金刚石数
<$GAMEGIRD> | 灵符
<$HUNGER> | 饥饿程度
<$LOGINTIME> | 登录时间
<$LOGINLONG> | 登录时长
<$DRESS> | 身上衣服名称
<$WEAPON> | 身上武器名称
<$RIGHTHAND> | 蜡烛
<$HELMET> | 头盔
<$HELMETEX> | 斗笠
<$NECKLACE> | 项链
<$ARMRING_R> | 手镯右
<$ARMRING_L> | 手镯左
<$RING_R> | 戒指右
<$RING_L> | 戒指左
<$BELT> | 腰带
<$BOOTS> | 鞋子
<$CHARM> | 宝石
<$BUJUK> | 符
<$DRUM> | 军鼓
<$HORSE> | 马牌
<$FASHION> | 时装
<$G_DRESS> | 身上衣服改名后的名称
<$G_WEAPON> | 身上武器改名后的名称
<$G_RIGHTHAND> | 蜡烛改名后的名称
<$G_HELMET> | 头盔改名后的名称
<$G_HELMETEX> | 斗笠改名后的名称
<$G_NECKLACE> | 项链改名后的名称
<$G_ARMRING_R> | 手镯右改名后的名称
<$G_ARMRING_L> | 手镯左改名后的名称
<$G_RING_R> | 戒指右改名后的名称
<$G_RING_L> | 戒指左改名后的名称
<$G_BELT> | 腰带改名后的名称
<$G_BOOTS> | 鞋子改名后的名称
<$G_CHARM> | 宝石改名后的名称
<$G_BUJUK> | 符改名后的名称
<$G_DRUM> | 军鼓改名后的名称
<$G_HORSE> | 马牌改名后的名称
<$G_FASHION> | 时装改名后的名称
<$IPADDR> | IP地址
<$IPLOCAL> | IP地区信息如：来自于[<$IPLOCAL>]的玩家[<$USERNAME>]先生进入了游戏..
<$HUMANSHOWNAME> | 人物名字全称（可包含行会封号，结婚对象，师徒名……等等）
<$MEMBRETYPE> | 会员类型
<$MEMBRELEVEL> | 会员等级
;可显示的玩家命令对应Command.ini里面相关的值
<$CMD_DATE> | 此变量对应Command.ini里面的DATE=服务器时间，这里DATE值为服务器时间变量显示为，服务器时间
<$CMD_ALLOWMSG> | 同上
<$CMD_LETSHOUT>
<$CMD_LETTRADE>
<$CMD_LETGUILD>
<$CMD_ENDGUILD>
<$CMD_BANGUILDCHAT>
<$CMD_AUTHALLY>
<$CMD_AUTH>
<$CMD_AUTHCANCEL>
<$CMD_USERMOVE>
<$CMD_SEARCHING>
<$CMD_ALLOWGROUPCALL>
<$CMD_GROUPRECALLL>
<$CMD_ATTACKMODE>
<$CMD_REST>
<$CMD_STORAGESETPASSWORD>
<$CMD_STORAGECHGPASSWORD>
<$CMD_STORAGELOCK>
<$CMD_STORAGEUNLOCK>
<$CMD_UNLOCK>
;记路标识所配套的变量
<$TAGMAPNAME0~<$TAGMAPNAME06> | 0~6目标地图名
<$TAGX0~<$TAGX6> | 0~6目标坐标X
<$TAGY0~<$TAGY6> | 0~6目标坐标Y
例：MAPMOVE <TAGMAPNAME3> <$TAGX3> <$TAGY3>
;城堡相关
<$CASTLEGOLD> | 城堡金币数
<$TODAYINCOME> | 每天的收入
<$CASTLEDOORSTATE> | 城门状态
<$REPAIRDOORGOLD> | 修理城门的费用
<$REPAIRWALLGOLD> | 修理皇宫城墙的费用
<$GUARDFEE> | 雇佣守卫费用
<$ARCHERFEE> | 雇佣弓箭手费用
<$REQUESTCASTLELIST> | 攻城列表
;商人NPC
<$PRICERATE> | 价格倍数
<$UPGRADEWEAPONFEE> | 升级武器的价格
<$USERWEAPON> | 手上拿的武器的名称
<$QUERYYBDEALLOG> | 元宝寄售交易记录（寄售人不在线，交易成功后，使用此变量回收已交易的元宝）
;属性附加相关配套变量
<$ABILITYADDPOINT0> | HP附加点数
<$ABILITYADDPOINT1> | MP附加点数
<$ABILITYADDPOINT2> | 防御附加点数
<$ABILITYADDPOINT3> | 魔御附加点数
<$ABILITYADDPOINT4> | 攻击附加点数
<$ABILITYADDPOINT5> | 魔法附加点数
<$ABILITYADDPOINT6> | 道术附加点数
<$ABILITYADDTIME0> | HP附加点数时间
<$ABILITYADDTIME1> | MP附加点数时间
<$ABILITYADDTIME2> | 防御附加点数时间
<$ABILITYADDTIME3> | 魔御附加点数时间
<$ABILITYADDTIME4>
 攻击附加点数时间
<$ABILITYADDTIME5> | 魔法附加点数时间
<$ABILITYADDTIME6> | 道术附加点数时间
;行会相关
<$GUILDHUMCOUNT> | 行会人数
<$GUILDBUILDPOINT> | 行会建筑度
<$GUILDAURAEPOINT> | 行会人气度
<$GUILDSTABILITYPOINT>
 行会安定度
<$GUILDFLOURISHPOINT>
 行会繁荣度
<$REQUESTCASTLEWARITEM> | 攻城需要的物品（祖玛头像）
<$REQUESTCASTLEWARDAY> | 多少天后攻城
<$REQUESTBUILDGUILDITEM> | 允许建立行会的物品（号角）
<$OWNERGUILD> | 城堡所属行会
<$CASTLENAME> | 城堡名称
<$LORD>
 城堡所属行会的老大
<$GUILDWARFEE> | 申请行会战需要金币数
<$BUILDGUILDFEE> | 建立行会所需的金币数
<$CASTLEWARDATE> | 攻城的日期
<$LISTOFWAR> | 攻城的时间表
<$CASTLECHANGEDATE> | 占领日期
<$CASTLEWARLASTDATE> | 最后一次攻城战的日期
<$CASTLEGETDAYS> | 占领天数
;天地结晶
<$GCEPAYMENT> | 天地结晶开启元宝
<$COLLECTEXP> | 天地结晶当前经验
<$COLLECTIPEXP> | 天地结晶当前内功经验
<$GAINCOLLECTEXP> | 天地结晶当前能提取的经验
<$GAINCOLLECTIPEXP> | 天地结晶当前能提取的内功经验
;自由属性加点
<$BONUSPOINT> | 剩余点数
<$BONUSABIL_AC> | 已+防御点数
<$BONUSABIL_MAC> | 已+魔御点数
<$BONUSABIL_DC> | 已+攻击点数
<$BONUSABIL_MC> | 已+魔法点数
<$BONUSABIL_SC> | 已+道术点数
<$BONUSABIL_HP> | 已+HP点数
<$BONUSABIL_MP> | 已+MC点数
<$BONUSABIL_HIT> | 已+准确点数
<$BONUSABIL_SPD> | 已+躲避点数
<$BONUSTICK_AC> | 增加1点AC所需要的自由点数，如X/17，表示需要17自由点才+1点AC值，AC上下限自动分配，下同
<$BONUSTICK_MAC>
<$BONUSTICK_MC>
<$BONUSTICK_DC>
<$BONUSTICK_SC>
<$BONUSTICK_HP>
<$BONUSTICK_MP>
<$BONUSTICK_HIT>
<$BONUSTICK_SPD>
;改名后的装备变量信息
<$CHANGEDRESS> | 人物身上穿着的衣服改名后名称
<$CHANGEWEAPON>
<$CHANGEHELMET>
<$CHANGEHELMETEX>
<$CHANGERIGHTHAND>
<$CHANGENECKLACE>
<$CHANGERING_R>
<$CHANGERING_L>
<$CHANGEARMRING_R>
<$CHANGEARMRING_L>
<$CHANGEBUJUK>
<$CHANGEBELT>
<$CHANGEBOOTS>
<$CHANGECHARM>
<$CHANGEDRUM>
<$CHANGEFASHION>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


装备位置

Help > 基本设置 >
装备位置

所有修改或者检测装备属性的命令均支持以下所有位置

-1 为OK框位置 , 自定义OK框位置 BOXITEM0 ---BOXITEM11

P 为捡起的物品位置

D 为怪物爆出的装备位置

G 为GIVE命令最后一次给与的物品位置

  • 0.衣服
    1.武器
    2.勋章
    3.项链
    4.头盔
    5.左手镯
    6.右手镯
    7.左戒指
    8.右戒指
    9.毒符
    10.腰带
    11.靴子
    12.宝石
    13.斗笠
    14.军鼓
    15.马牌
    16.盾牌
    17.时装
    18.时装武器
    19.时装项链
    20.时装头盔
    21.时装左手
    22.时装右手
    23.时装左戒
    24.时装右戒
    25.时装勋章
    26.时装腰带
    27.时装靴子
    28.时装宝石
    29.首饰盒1
    30.首饰盒2
    31.首饰盒3
    32.首饰盒4
    33.首饰盒5
    34.首饰盒6
    35.神佑盒1
    36.神佑盒2
    37.神佑盒3
    38.神佑盒4
    39.神佑盒5
    40.神佑盒6
    41.神佑盒7
    42.神佑盒8
    43.神佑盒9
    44.神佑盒10
    45.神佑盒11
    46.神佑盒12

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


属性位置

Help > 基本设置 >
属性位置

引擎属性位置：

衣服：

  • 0 防御
    1 魔御
    2 攻击
    3 魔法
    4 道术
    5 衣服翅膀 （Anicount值）
    6 未知
    7 强度无效
    8 暴击
    9 PK目标爆率
    10 未知
    11-13 暂不知道
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

武器：

  • 0 攻击
    1 魔法
    2 道术
    3 幸运
    4 诅咒
    5 准确
    6 攻击速度
    7 强度
    8 暴击
    9 PK目标爆率
    10 需要开封
    11-13 暂不知道
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

勋章：

  • 0 防御
    1 魔御
    2 攻击
    3 魔法
    4 道术
    5 佩带需求
    6 佩带级别
    7 无效果
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

项链

  • 0 AC2
    1 MAC2
    2 DC2
    3 MC2
    4 SC2
    6 佩带需求
    7 佩带级别
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

头盔

  • 0 防御
    1 魔御
    2 攻击
    3 魔法
    4 道术
    5 佩带需求
    6 佩带级别
    7 随便设置数字，头盔将无法取下
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

手镯

  • 0 AC2
    1 MAC2
    2 DC2
    3 MC2
    4 SC2
    5 佩带需求
    6 佩带级别
    7 随便设置数字，手镯将无法取下
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

戒指

  • 0 AC2
    1 MAC2
    2 DC2
    3 MC2
    4 SC2
    5 佩带需求
    6 佩带级别
    7 随便设置数字，戒指将无法取下
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

腰带

  • 0 AC2
    1 MAC2
    2 DC2
    3 MC2
    4 SC2
    5 佩带需求
    6 佩带级别
    7 未知
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光

靴子

  • 0 AC2
    1 MAC2
    2 DC2
    3 MC2
    4 SC2
    5 佩带需求
    6 佩带级别
    7 未知
    8 暴击
    9 PK目标爆率
    10-13 无效果
    14 持久下限
    15 持久上限
    16 防爆
    17 忽视目标防御
    18 增加伤害
    19 伤害反射
    20 物理伤害减少
    21 魔法伤害减少
    22 经验吸收增加
    23 发光


离线挂机设置

Help > 基本设置 >
离线挂机设置

自动挂离线人物功能步骤：
1、游戏路径配置正确后
2、使用Dbserver->管理->数据工具->自动登陆数据 导出数据
3、M2启动，DBS已连接M2，控制->加载自动挂机人物
为防止出错，注意加载挂机人物过程，没有玩家正常登陆游戏 已脱机登陆的人物， 在再次正常登陆时，最好T下线，防止数据显示不正常
4、不建议挂太多，只会消耗资源！

增加开关：功能设置->离线人物配置->挂机人物自动走动

相关NPC命令：

加载离线挂机人物: RELOADOFFLINE

2、新增：几个离线人物的命令：
1>检测命令：是否为假人或者离线挂机人物
[@main]
#If
IsDummy
#act
sendmsg 0 我是给老板撑人气的假人
break

2>操作命令：离线挂机人物或假人开始\停止挂机活动； //原来的命令OFFLINEPLAYEX可以不需要了；
[@main]
#If
IsDummy
#act
DummyStart
break

[@main]
#If
IsDummy
InSafeZone
#act
DummyStop
break

老的离线挂机自动打怪，可不用了！
 功能：离线挂机，自动打怪
格式：OFFLINEPLAYEX 时间(分) //不建议挂太多，只会消耗资源！挂机的人物必须学习了主动技能，否则不会进行攻击怪物
[@OFFLINEPLAYEX]
#If
CheckLevelEx > 0
#Act
OFFLINEPLAYEX 5000


安全区光环设置

Help > 基本设置 >
安全区光环设置

功能：
      安全区光环(注：!Setup.txt中设置SafeZoneAureole=1开启功能.参数设置为0则为关闭)

格式：
      ;地图号 座标X 座标Y 禁止说话 大小范围 光环类型 PKZONE PKFIRE
         0 　　411 　611　　 0 　　　20　　　　 4　　　 0 　　0


地图参数详解

Help > 基本设置 >
地图参数详解

地图参数标志 | 说明
CHECKQUEST | 进入本地图执行任务脚本 格式：CHECKQUEST(Q001) 说明： Q001 代表脚本名。
NEEDSET_ON | 进入本地图需要人物指定标志为打开状态格式：NEEDSET_ON(001) 说明：001 代表人物标志
NEEDSET_OFF | 进入本地图需要人物指定标志为关闭状态格式：NEEDSET_OFF(001) 说明：001 代表人物标志
MUSIC | 进入入本地图播放音乐 格式：MUSIC(..\Wav\bg.mp3) 或者 MUSIC(.\Wav\sellect-loop2.wav)代表客户端Wav文件下的sellect-loop2.wav文件
EXPRATE | 进入本地图后杀怪经验倍数 格式：EXPRATE(100) 说明：100代表经验倍数，除以100后为实际倍数。
PKWINLEVEL | 进入本地图后可以PK升级 格式：PKWINLEVEL(1) 说明：1代表升多少级；
PKWINEXP | 进入本地图后可以PK得经验 格式：PKWINEXP(1000) 说明：1000代表得多少经验；
PKLOSTLEVEL | 进入本地图后可以PK死亡掉等级 格式：PKLOSTLEVEL(1) 说明：1代表掉多少等级；
PKLOSTEXP | 进入本地图后可以PK死亡掉经验 格式：PKLOSTEXPP(1000) 说明：1000代表掉多少经验；
DECHP | 进入本地图后自动减HP 格式：DECHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCHP | 进入本地图后自动加HP 格式：INCHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次加多少点；
DECGAMEGOLD | 进入本地图后自动减游戏币 格式：DECGAMEGOLD(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCGAMEGOLD | 进入本地图后自动加游戏币 格式：INCGAMEGOLD(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；
INCGAMEPOINT | 进入本地图后自动加游戏点 格式：INCGAMEPOINT(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；(用于游戏泡点功能)
DECGAMEPOINT | 进入本地图后自动减游戏点 格式：DECGAMEPOINT(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；(用于游戏泡点功能)
RUNMON | 允许穿怪
RUNHUMAN | 允许穿人
KILLFUNC | 杀怪杀人触发 KILLFUNC(X) X和QMapEvent-0.txt触发中X对应 [@KillPlayMonX ] [@KillPlayX]
NEEDHOLE | 进入需要洞
NORECALL | 禁止记忆召唤
NOGUILDRECALL | 禁止行会召唤
NODEARRECALL | 禁止夫妻召唤
NOMasterRECALL | 禁止师徒传送
NORANDOMMOVE | 禁止随机传送;瞬息移动
NODRUG | 禁止使用任何药品
MINE | 可以挖矿
NOPOSITIONMOVE | 禁止定座标移动、传送戒指、坐标传送
NORECONNECT | 进游戏时退出本地图 格式:NORECONNECT(3) 说明：3 代表地图号盟重
QUIZ | 禁止喊话
FIGHT2 | 杀人不犯法.但是会爆装备.适合用来做一些战争PK的地图
FIGHT3(是否掉装备) | 行会战地图进入该地图名字颜色会变色，杀人不加PK。格式:FIGHT3(0) 死亡不掉装备 格式:FIGHT3(1) 死亡掉装备
NOTALLOWUSEITEMS | 禁止使用物品 说明：NOTALLOWUSEITEMS(回城卷|强效金创药)
NOTALLOWUSEMAGIC | 禁止使用技能 说明：NOTALLOWUSEMAGIC(火墙|彻地钉)
THUNDER | 例:THUNDER(10) 此地图有闪电效果,击中减hp为10
LAVA | 例:LAVA(10) 此地图地上冒岩浆,击中减HP为10
Safe | 此地图为安全地图，不可PK类似安全区
FIGHT | 此参数地图不犯法，不爆装备
NOMANNOMON | 智能刷怪，当地图无人时清理怪物，有人时重新刷怪，此功能需在M2怪物设置开启
NORECALLHERO | 禁止召唤英雄，已召唤英雄不受影响
DARK | 黑暗效果 如果同时存在 DAY以DAY参数效果为准
DAY | 白天效果 如果同时存在DARK以DAY参数效果为准
NOSWITCHATTACKMODE | 地图中禁止切换攻击模式
NOTHROWITEM | 禁止丢物品(连金币都不可以)!
COLLECTEXP | 天地结晶(AA/BB/CC/DD/EE/F1~F4/G1~G4) 详细请参考:天地结晶
NoDeal | 禁止交易
CANRIDE | 可以骑马???(未测试)
CANBAT | 可以踢球???(微测试)
NOTAGMAPINFO | 禁止记录地图坐标信息(记忆石)
STALL | 允许摆摊地图
GREATTHUNDER | GREATTHUNDER(100) //大雷电，群体攻击
SPURT | SPURT(100) //喷气，群体攻击
DIGITEM | 允许挖宝 DIGITEM(X), X为宝藏密度,取值范围1-200, 0为不加宝藏
SECRET | 浑水摸鱼模式, SECRET(第一参数值|固定名字|衣服的统一外观shape|武器的统一外观shape )
FB | 副本地图, FB(A|B|C) A=创建副本数量(2-99), B=副本名字, C=限制职业?(0或1) 相关链接: 副本功能

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


元素相关

Help > 基本设置 >
元素相关

元素字段:

Smite 暴击几率增加(范围0-15) 属性位置 8 <$SMITE>

DropRate 目标爆率增加(范围0-15) 属性位置 9 <$DROPRATE>

ItemType 防爆几率增加(范围0-15) 属性位置 16 <$ITEMTYPE>

IgnDef 忽视目标防御(范围0-15) 属性位置 17 <$IGNDEF>

DamAdd 增加攻击伤害(范围0-15) 属性位置 18 <$DAMADD>

DamReb 伤害反射增加(范围0-15) 属性位置 19 <$DAMREB>

DcRedu 物理伤害减少(范围0-15) 属性位置 20 <$DCREDU>

McRedu 魔法伤害减少(范围0-15) 属性位置 21 <$MCREDU>

ExpAdd 经验吸收增加(范围0-15) 属性位置 22 <$EXPADD>

可用 CHECKITEMADDVALUE 命令检测元素属性

可用 CHANGEITEMADDVALUE 命令修改装备元素属性

可用 GETITEMADDVALUE 命令获取装备元素属性


补丁支持说明

武器得外观算法:

  • Weapon.wzl Shape 1~49
    Weapon2.wzl Shape 100~149
    Weapon3.wzl Shape 150~199
    Weapon4.wzl Shape 200~249
    Weapon5.wzl Shape 250~299
    Weapon6.wzl Shape 300~349
    Weapon7.wzl Shape 350~399
    Weapon8.wzl Shape 400~449
    Weapon9.wzl Shape 450~499
    Weapon10.wzl Shape 500~549
    Weapon11.wzl Shape 550-599
    Weapon12.wzl Shape 600-649
    Weapon13.wzl Shape 650-699
    Weapon14.wzl Shape 700-749
    Weapon15.wzl Shape 750-799
    Weapon16.wzl Shape 800-849
    Weapon17.wzl Shape 850-899
    Weapon18.wzl Shape 900-949
    Weapon19.wz Shape 950-999

衣服得外观算法:

  • Hum.wzl Shape 1~49
    Hum2.wzl Shape 100~149
    Hum3.wzl Shape 150~199
    Hum4.wzl Shape 200~249
    Hum5.wzl Shape 250~299
    Hum6.wzl Shape 300~349
    Hum7.wzl Shape 350~399
    Hum8.wzl Shape 400~449
    Hum9.wzl Shape 450~499
    Hum10.wzl Shape 500~549
    Hum11.wzl Shape 550~599
    Hum12.wzl Shape 600~649
    Hum13.wzl Shape 650~699
    Hum14.wzl Shape 700~749
    Hum15.wzl Shape 750~799
    Hum16.wzl Shape 800~849
    Hum17.wzl Shape 850~899
    Hum18.wzl Shape 900~949
    Hum19.wzl Shape 950~999

装备内观 背包 地上显示算法:

  • Items.wzl DnItems.wzl StateItem.wzl 数据库Looks起始编号0~9999
    增加Items2.wzl DnItems2.wzl StateItem2.wzl 数据库Looks起始编号10000~19999
    增加Items3.wzl DnItems3.wzl StateItem3.wzl 数据库Looks起始编号20000~29999
    增加Items4.wzl DnItems4.wzl StateItem4.wzl 数据库Looks起始编号30000~39999
    增加Items5.wzl DnItems5.wzl StateItem5.wzl 数据库Looks起始编号40000~49999

小地图:

  • mmap.wzl 读取为1-9999
    mmap2.wzl 10000-19999
    mmap3.wzl 20000-29999
    mmap4.wzl 30000-39999
    mmap5.wzl 40000-49999

NPC补丁:

  • Npc3.wzl 1000-1499
    Npc4.wzl 1500-1999
    Npc5.wzl 2000-2499

地图补丁:

  • Objects.wzl , Objects2.wzl ..... Objects254.wzl
  • Tiles.wzl, Tiles2.wzl ..... Tiles254.wzl
  • SmTiles.wzl, SmTiles2.wzl ..... SmTiles254.wzl

怪物补丁:

  • Mon1.wzl, Mon2.wzl ..... Mon254.wzl
  • 提示: 自定义怪物补丁可以用 40-69, 以及100以后的Mon文件,
  • 计算规则 文件编号 - 1 * 10, 例如 Mon123.wzl 第一个怪物的代码就是1220, 第二个 1221....

衣服特效:

  • HumEffect.wzl, HumEffect2.wzl ..... HumEffect9.wzl
  • 提示: HumEffect.wzl ...HumEffect5.wzl中包含部分武器特效,使用时注意区分
  • 衣服字段Anicount字段,HumEffect.wzl ...HumEffect5.wzl编号从1开始递增, HumEffect6.wzl ...HumEffect9.wzl为扩展,每个文件放10组特效编号从101开始

盾牌:

  • Shield.wzl 读取为1-49 600张图片为一组,不分男女
    Shield2.wzl 50-99
    Shield3.wzl 100-149
    Shield4.wzl 150-199
    Shield5.wzl 200-249


苹果ipa补丁集成说明

由于平台差异,苹果ipa集成补丁后须在对应文件中写入文件名,

data文件夹内的 datalist.txt

map文件夹中的maplist.txt

wav文件夹中的wavlist.txt

例如:

data目录中有 newopui.data, hair.wzl, hair.wzx , hum.wzl, humwzx 这五个文件

那么就需要在data目录中的 datalist.txt文件中写入以上补丁文件名,一行一个

newopui.data

hair.wzl

hair.wzx

hum.wzl

humwzx


爆率格式说明

爆率格式:

格式一: 基础爆率格式 不过多解释

1/10 金币 2000

1/20 炼狱

1/15 凝霜

格式二: 有十分之一的概率 随机爆出 木剑|炼狱|裁决之杖|魔杖 其中一件物品

1/10 木剑|炼狱|裁决之杖|魔杖

格式三: 有十分之的概率触发QF中[@触发脚本]段落, 如检测条件通过则随机爆出 木剑|炼狱|裁决之杖|魔杖 其中一件,

否则可用StopDropItem命令停止此次爆出

1/10 木剑|炼狱|裁决之杖|魔杖|@触发脚本

QF中内容如下:

[@触发脚本]

#if

LARGE U45 6

#ACT

DEC U45 1

#ELSEACT

StopDropItem

格式四: 有十分之一的概率进行检测N1>N2N4>=N3 N5=1000这三个条件符合其中一个就可以触发本//和爆率,

去掉|OR为检测三个条件全部符合才能进入触发和爆率,条件数量自行定义,触发段落写在QF中

#CHILD 1/10 [N1>N2;N4>=N3;N5=1000]OR,@触发脚本]
(
1/5 铁剑
1/3 木剑
1/10 屠龙|凝霜|无极棍|骨玉权杖
1/3 金币 2000
)

#CHILD 1/10 [N1>N2;N4>=N3;N5=1000|OR]
(
1/5 铁剑
1/3 木剑
1/10 屠龙|凝霜|无极棍|骨玉权杖
1/3 金币 2000
)

#CHILD 1/10 [N1>N2;N4>=N3;N5=1000,@触发脚本]
(
1/5 铁剑
1/3 木剑
1/10 屠龙|凝霜|无极棍|骨玉权杖
1/3 金币 2000
)

#CHILD 1/10 [N1>N2;N4>=N3;N5=1000]
(
1/5 铁剑
1/3 木剑
1/10 屠龙|凝霜|无极棍|骨玉权杖
1/3 金币 2000
)

#CHILD 1/10
(
1/5 铁剑
1/3 木剑
1/10 屠龙|凝霜|无极棍|骨玉权杖
1/3 金币 2000
)


自定义变量

Help > 功能相关 >
自定义变量

功能：
      自定义变量功能，不再受固定几个变量限制

使用方法：
三个步骤：
1、首先要声明变量
2、读取变量
3、保存变量
该变量支持增加、减少、脚本查看、检查大小等功能.该功能的开发突破了变量使用受限制.利用该变量可制作出超强功能脚本.

脚本示例：

[@varcontrol]
<声明变量/@声明变量> \
<查看变量/@查看变量>\
<读取变量/@读取变量> \
<保存变量/@保存变量> \
<增加变量/@增加变量>\
<减少变量/@减少变量>\
<检查变量是否大于5/@检查变量是否大于5>\
<检查变量是否小于5/@检查变量是否小于5>\
<检查变量是否等于5/@检查变量是否等于5>

[@增加变量]
#If
#Act
Calcvar HUMAN QQQQ + 5
Goto @varcontrol

[@减少变量]
#If
#Act
Calcvar HUMAN QQQQ - 5
Goto @varcontrol

[@检查变量是否等于5]
#If
CHECKVAR HUMAN QQQQ = 5
#Act
SendMSG 7 等于5
Goto @varcontrol
#ElseAct
SendMSG 7 不等于5
Goto @varcontrol

[@检查变量是否大于5]
#If
CHECKVAR HUMAN QQQQ > 5
#Act
SendMSG 7 大于5
Goto @varcontrol
#ElseAct
SendMSG 7 小于5
Goto @varcontrol

[@检查变量是否小于5]
#If
CHECKVAR HUMAN QQQQ < 5
#Act
SendMSG 7 小于5
Goto @varcontrol
#ElseAct
SendMSG 7 大于5
Goto @varcontrol

[@读取变量]
#If
#Act
LOADVAR HUMAN QQQQ VarSave.txt
SendMSG 7 OK
Goto @varcontrol

[@保存变量]
#If
#Act
SAVEVAR HUMAN QQQQ VarSave.txt
SendMSG 7 OK
Goto @varcontrol

[@声明变量]
#If
#Act
VAR Integer HUMAN QQQQ
SendMSG 7 OK
Goto @varcontrol
[@查看变量]
<$HUMAN(QQQS)>


淬炼装备功能

Help > 功能相关 >
淬炼装备功能

功能：
增加淬炼功能

增加打开淬炼窗口NPC命令：QUERYREFINEITEM

示例：

#IF
CHECKLEVELEX > 0
#ACT

QUERYREFINEITEM
MESSAGEBOX 你已经打开淬炼窗口
BREAK

淬炼配置文件在：D:\MirServer\Mir200\Envir\RefineItem.txt 编辑后可以在M2重新加载
格式如下：
==============================================================================================================
;例子（可以自由组合3个物品）：
[火云石+黑铁头盔+雷霆战戒]
;淬炼后的物品 淬炼成功几率 失败还原几率 火云石是否消失 淬炼极品属性几率 淬炼极品属性设置
;淬炼后的物品 表示30%成功率 30%还原成功率0=减少1持久,1=消失 表示1%成功率 淬炼物品的14个属性，用法类似于SuerMake命令，4-5表示：最高限制升4点，淬炼难度5(数字越大越难淬炼到高点属性)
星王魔戒 30 30 0 1 0-5,0-5,0-5,4-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,

[火云石+火云石+星王魔戒]
星王魔戒 30 100 0 60 0-5,0-5,0-5,6-4,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,

[火云石碎片+魔龙冰晶+弩牌]
;当淬炼原料下列表有多个物品，将随机抽取列表任一物品进行计算
光芒项链 60 0 0 1 2-6,2-6,0-5,0-5,4-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
烈焰魔戒 60 0 0 1 0-5,0-5,0-5,4-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
雷霆护腕 60 0 0 1 4-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,

部分物品DB设置：
==============================================================================================================
魔龙冰晶;41;0;1;0;0;0;1167;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;
火云晶石;41;1;1;0;0;0;1112;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;
火云石;25;10;1;0;0;0;1178;3000;0;0;0;0;0;0;0;0;0;0;0;0;50000;;
火云石碎片;25;11;1;0;0;0;1176;500;0;0;0;0;0;0;0;0;0;0;0;0;50000;;
说明：火云石佩带在毒符位置，再将火云晶石或火云石拖放到毒符位置的火云石上，可恢复火云石5点持久，火云石低于5持久不可以恢复。

淬炼配置文件在：D:\MirServer\Mir200\Envir\RefineItem.txt 编辑后可以在M2重新加载

举几个我测试区的列子如下：
1。没有属性的就写0-0比如战士戒指只加攻击防御魔淤 其他的都是 0-0
2。改好他的成功失败几率即可 还有控制点数的几率即可
3。以下举列需要的详细材料我没写。自己可以参考淬炼说明里加自己需要的材料

;淬炼装备，55%淬炼成功，60%失败属性还原

[火云石+原质晶石+战意项链]
战意项链 100 55 0 60 3-3,3-10,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+魔意项链]
魔意项链 100 55 0 60 3-3,3-10,0-0,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+勾魂链坠]
勾魂链坠 100 55 0 60 3-3,3-10,0-0,0-0,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破魔战意项链]
破魔战意项链 100 55 0 60 3-3,3-10,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破咒魔意项链]
破咒魔意项链 100 55 0 60 3-3,3-10,0-0,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+迷心勾魂链坠]
迷心勾魂链坠 100 55 0 60 3-3,3-10,0-0,0-0,10-5,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+战意戒指]
战意戒指 100 55 0 60 5-10,5-10,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+魔意戒指]
魔意戒指 100 55 0 60 5-10,5-10,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+勾魂戒指]
勾魂戒指 100 55 0 60 5-10,5-10,0-0,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+坚硬战意戒指]
坚硬战意戒指 100 55 0 60 5-10,5-10,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+坚硬魔意戒指]
坚硬魔意戒指 100 55 0 60 5-10,5-10,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+坚硬勾魂戒指]
坚硬勾魂戒指 100 55 0 60 5-10,5-10,0-0,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破魔战意戒指]
破魔战意戒指 100 55 0 60 5-10,5-10,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破咒魔意戒指]
破咒魔意戒指 100 55 0 60 5-10,5-10,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+迷心勾魂戒指]
迷心勾魂戒指 100 55 0 60 5-10,5-10,0-0,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+战意手镯]
战意手镯 100 55 0 60 5-10,5-10,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+魔意护手]
魔意护手 100 55 0 60 5-10,5-10,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+勾魂手镯]
勾魂手镯 100 55 0 60 5-10,5-10,0-0,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破魔战意手镯]
破魔战意手镯 100 55 0 60 5-10,5-10,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+破咒魔意护手]
破咒魔意护手 100 55 0 60 5-10,5-10,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+迷心勾魂手镯]
迷心勾魂手镯 100 55 0 60 5-10,5-10,0-0,0-0,8-4,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

;淬炼武器，95%淬炼成功，80%失败属性还原

[火云石+原质晶石+天赐天之逍遥扇]
天赐天之逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀天之逍遥扇]
闪耀天之逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉天之逍遥扇]
凌厉天之逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良天之逍遥扇]
精良天之逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天赐逍遥扇]
天赐逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀逍遥扇]
闪耀逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉逍遥扇]
凌厉逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良逍遥扇]
精良逍遥扇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天赐天之龙纹剑]
天赐天之龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀天之龙纹剑]
闪耀天之龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉天之龙纹剑]
凌厉天之龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良天之龙纹剑]
精良天之龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天赐龙纹剑]
天赐龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀龙纹剑]
闪耀龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉龙纹剑]
凌厉龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良龙纹剑]
精良龙纹剑 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天赐咒术银蛇]
天赐咒术银蛇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀咒术银蛇]
闪耀咒术银蛇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉咒术银蛇]
凌厉咒术银蛇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良咒术银蛇]
精良咒术银蛇 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天赐符纹无极棍]
天赐符纹无极棍 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+闪耀符纹无极棍]
闪耀符纹无极棍 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+凌厉符纹无极棍]
凌厉符纹无极棍 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精良符纹无极棍]
精良符纹无极棍 100 95 0 80 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀天之龙牙]
神雀天之龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作天之龙牙]
天作天之龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐天之龙牙]
敏锐天之龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵天之龙牙]
附灵天之龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀龙牙]
神雀龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作龙牙]
天作龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐龙牙]
敏锐龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵龙牙]
附灵龙牙 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀天之血饮]
神雀天之血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作天之血饮]
天作天之血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐天之血饮]
敏锐天之血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵天之血饮]
附灵天之血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀血饮]
神雀血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作血饮]
天作血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐血饮]
敏锐血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵血饮]
附灵血饮 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀天之嗜魂]
神雀天之嗜魂 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作天之嗜魂]
天作天之嗜魂 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐天之嗜魂]
敏锐天之嗜魂 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵天之嗜魂]
附灵天之嗜魂 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀嗜魂法杖]
神雀嗜魂法杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作嗜魂法杖]
天作嗜魂法杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐嗜魂法杖]
敏锐嗜魂法杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵嗜魂法杖]
附灵嗜魂法杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀魔光骨玉]
神雀魔光骨玉 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作魔光骨玉]
天作魔光骨玉 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐魔光骨玉]
敏锐魔光骨玉 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵魔光骨玉]
附灵魔光骨玉 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神雀聚法魔杖]
神雀聚法魔杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天作聚法魔杖]
天作聚法魔杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+敏锐聚法魔杖]
敏锐聚法魔杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+附灵聚法魔杖]
附灵聚法魔杖 100 95 0 80 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威天之怒斩]
天威天之怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力天之怒斩]
神力天之怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气天之怒斩]
霸气天之怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸天之怒斩]
精铸天之怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威怒斩]
天威怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力怒斩]
神力怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气怒斩]
霸气怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸怒斩]
精铸怒斩 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威天之屠龙]
天威天之屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力天之屠龙]
神力天之屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气天之屠龙]
霸气天之屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸天之屠龙]
精铸天之屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威屠龙]
天威屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力屠龙]
神力屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气屠龙]
霸气屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸屠龙]
精铸屠龙 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威天之裁决]
天威天之裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力天之裁决]
神力天之裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气天之裁决]
霸气天之裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸天之裁决]
精铸天之裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威重钢裁决]
天威重钢裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力重钢裁决]
神力重钢裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气重钢裁决]
霸气重钢裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸重钢裁决]
精铸重钢裁决 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+天威裁决之杖]
天威裁决之杖 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+神力裁决之杖]
神力裁决之杖 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+霸气裁决之杖]
霸气裁决之杖 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[火云石+原质晶石+精铸裁决之杖]
精铸裁决之杖 100 95 0 80 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

;升级武器，100%升级成功，随机增加附加属性

[天工护符+天赐晶石+闪耀天之逍遥扇]
天赐天之逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉天之逍遥扇]
闪耀天之逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良天之逍遥扇]
凌厉天之逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+天之逍遥扇]
精良天之逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天赐晶石+闪耀逍遥扇]
天赐逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉逍遥扇]
闪耀逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良逍遥扇]
凌厉逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+逍遥扇]
精良逍遥扇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天赐晶石+闪耀天之龙纹剑]
天赐天之龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉天之龙纹剑]
闪耀天之龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良天之龙纹剑]
凌厉天之龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+天之龙纹剑]
精良天之龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天赐晶石+闪耀龙纹剑]
天赐龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉龙纹剑]
闪耀龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良龙纹剑]
凌厉龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+龙纹剑]
精良龙纹剑 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天赐晶石+闪耀咒术银蛇]
天赐咒术银蛇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉咒术银蛇]
闪耀咒术银蛇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良咒术银蛇]
凌厉咒术银蛇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+咒术银蛇]
精良咒术银蛇 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天赐晶石+闪耀符纹无极棍]
天赐符纹无极棍 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+闪耀晶石+凌厉符纹无极棍]
闪耀符纹无极棍 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+凌厉晶石+精良符纹无极棍]
凌厉符纹无极棍 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精良晶石+符纹无极棍]
精良符纹无极棍 100 100 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀天之龙牙]
天作天之龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐天之龙牙]
神雀天之龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵天之龙牙]
敏锐天之龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+天之龙牙]
附灵天之龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀龙牙]
天作龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐龙牙]
神雀龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵龙牙]
敏锐龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+龙牙]
附灵龙牙 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀天之血饮]
天作天之血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐天之血饮]
神雀天之血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵天之血饮]
敏锐天之血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+天之血饮]
附灵天之血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀血饮]
天作血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐血饮]
神雀血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵血饮]
敏锐血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+血饮]
附灵血饮 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀天之嗜魂]
天作天之嗜魂 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐天之嗜魂]
神雀天之嗜魂 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵天之嗜魂]
敏锐天之嗜魂 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+天之嗜魂法杖]
附灵天之嗜魂 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀嗜魂法杖]
天作嗜魂法杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐嗜魂法杖]
神雀嗜魂法杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵嗜魂法杖]
敏锐嗜魂法杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+嗜魂法杖]
附灵嗜魂法杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀魔光骨玉]
天作魔光骨玉 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐魔光骨玉]
神雀魔光骨玉 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵魔光骨玉]
敏锐魔光骨玉 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+魔光骨玉]
附灵魔光骨玉 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天作晶石+神雀聚法魔杖]
天作聚法魔杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神雀晶石+敏锐聚法魔杖]
神雀聚法魔杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+敏锐晶石+附灵聚法魔杖]
敏锐聚法魔杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+附灵晶石+聚法魔杖]
附灵聚法魔杖 100 100 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力天之怒斩]
天威天之怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气天之怒斩]
神力天之怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸天之怒斩]
霸气天之怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+天之怒斩]
精铸天之怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力怒斩]
天威怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气怒斩]
神力怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸怒斩]
霸气怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+怒斩]
精铸怒斩 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力天之屠龙]
天威天之屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气天之屠龙]
神力天之屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸天之屠龙]
霸气天之屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+天之屠龙]
精铸天之屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力屠龙]
天威屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气屠龙]
神力屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸屠龙]
霸气屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+屠龙]
精铸屠龙 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力天之裁决]
天威天之裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气天之裁决]
神力天之裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸天之裁决]
霸气天之裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+天之裁决]
精铸天之裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力裁决之杖]
天威裁决之杖 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气裁决之杖]
神力裁决之杖 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸裁决之杖]
霸气裁决之杖 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+裁决之杖]
精铸裁决之杖 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+天威晶石+神力重钢裁决]
天威重钢裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+神力晶石+霸气重钢裁决]
神力重钢裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+霸气晶石+精铸重钢裁决]
霸气重钢裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工护符+精铸晶石+重钢裁决]
精铸重钢裁决 100 100 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;升级武器，20-30%升级成功，随机增加附加属性

[天赐晶石+天赐晶石+闪耀天之逍遥扇]
天赐天之逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉天之逍遥扇]
闪耀天之逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良天之逍遥扇]
凌厉天之逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+天之逍遥扇]
精良天之逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天赐晶石+天赐晶石+闪耀逍遥扇]
天赐逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉逍遥扇]
闪耀逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良逍遥扇]
凌厉逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+逍遥扇]
精良逍遥扇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天赐晶石+天赐晶石+闪耀天之龙纹剑]
天赐天之龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉天之龙纹剑]
闪耀天之龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良天之龙纹剑]
凌厉天之龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+天之龙纹剑]
精良天之龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天赐晶石+天赐晶石+闪耀龙纹剑]
天赐龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉龙纹剑]
闪耀龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良龙纹剑]
凌厉龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+龙纹剑]
精良龙纹剑 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天赐晶石+天赐晶石+闪耀咒术银蛇]
天赐咒术银蛇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉咒术银蛇]
闪耀咒术银蛇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良咒术银蛇]
凌厉咒术银蛇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+咒术银蛇]
精良咒术银蛇 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天赐晶石+天赐晶石+闪耀符纹无极棍]
天赐符纹无极棍 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+凌厉符纹无极棍]
闪耀符纹无极棍 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+精良符纹无极棍]
凌厉符纹无极棍 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+符纹无极棍]
精良符纹无极棍 30 30 0 50 0-0,0-0,10-4,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀天之龙牙]
天作天之龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐天之龙牙]
神雀天之龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵天之龙牙]
敏锐天之龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+天之龙牙]
附灵天之龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀龙牙]
天作龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐龙牙]
神雀龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵龙牙]
敏锐龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+龙牙]
附灵龙牙 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀天之血饮]
天作天之血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐天之血饮]
神雀天之血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵天之血饮]
敏锐天之血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+天之血饮]
附灵天之血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+天之血饮]
附灵天之血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀血饮]
天作血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐血饮]
神雀血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵血饮]
敏锐血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+血饮]
附灵血饮 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀天之嗜魂]
天作天之嗜魂 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐天之嗜魂]
神雀天之嗜魂 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵天之嗜魂]
敏锐天之嗜魂 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+天之嗜魂法杖]
附灵天之嗜魂 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀嗜魂法杖]
天作嗜魂法杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐嗜魂法杖]
神雀嗜魂法杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵嗜魂法杖]
敏锐嗜魂法杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+嗜魂法杖]
附灵嗜魂法杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀魔光骨玉]
天作魔光骨玉 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐魔光骨玉]
神雀魔光骨玉 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵魔光骨玉]
敏锐魔光骨玉 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+魔光骨玉]
附灵魔光骨玉 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天作晶石+天作晶石+神雀聚法魔杖]
天作聚法魔杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+敏锐聚法魔杖]
神雀聚法魔杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+附灵聚法魔杖]
敏锐聚法魔杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+聚法魔杖]
附灵聚法魔杖 30 30 0 50 0-0,10-4,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力天之怒斩]
天威天之怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气天之怒斩]
神力天之怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸天之怒斩]
霸气天之怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+天之怒斩]
精铸天之怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力怒斩]
天威怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气怒斩]
神力怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸怒斩]
霸气怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+怒斩]
精铸怒斩 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力天之屠龙]
天威天之屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气天之屠龙]
神力天之屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸天之屠龙]
霸气天之屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+天之屠龙]
精铸天之屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力屠龙]
天威屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气屠龙]
神力屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸屠龙]
霸气屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+屠龙]
精铸屠龙 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力天之裁决]
天威天之裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气天之裁决]
神力天之裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸天之裁决]
霸气天之裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+天之裁决之杖]
精铸天之裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力裁决之杖]
天威裁决之杖 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气裁决之杖]
神力裁决之杖 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸裁决之杖]
霸气裁决之杖 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+裁决之杖]
精铸裁决之杖 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天威晶石+天威晶石+神力重钢裁决]
天威重钢裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+霸气重钢裁决]
神力重钢裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+精铸重钢裁决]
霸气重钢裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+重钢裁决]
精铸重钢裁决 30 30 0 50 10-4,0-0,0-0,7-3,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;淬炼合成，20%合成成功

[水晶+原质矿石+火云石碎片]
原质晶石 10 10 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[天工之锤+天工神石+火云石碎片]
天工护符 10 10 1 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[闪耀晶石+闪耀晶石+火云石碎片]
天赐晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[凌厉晶石+凌厉晶石+火云石碎片]
闪耀晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良晶石+精良晶石+火云石碎片]
凌厉晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精良石（碎片）+精良石（碎片）+火云石碎片]
精良晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神雀晶石+神雀晶石+火云石碎片]
天作晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[敏锐晶石+敏锐晶石+火云石碎片]
神雀晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵晶石+附灵晶石+火云石碎片]
敏锐晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[附灵石（碎片）+附灵石（碎片）+火云石碎片]
附灵晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[神力晶石+神力晶石+火云石碎片]
天威晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[霸气晶石+霸气晶石+火云石碎片]
神力晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸晶石+精铸晶石+火云石碎片]
霸气晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

[精铸石（碎片）+精铸石（碎片）+火云石碎片]
精铸晶石 100 100 0 50 0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,0-0,

;当淬炼原料下列表有多个物品，将随机抽取列表任一物品，再按照淬炼成功几率计算是否淬炼成功
[火云石碎片+魔龙冰晶+弩牌]
;淬炼后的物品 淬炼成功几率 失败还原几率 火云石是否消失 淬炼极品属性几率 淬炼极品属性设置
;淬炼后的物品 表示70%成功率 8%还原成功率0=减少1持久,1=消失 表示1%成功率 淬炼物品的14个属性，用法类似于SuerMake命令，4-5表示：最高限制升4点，淬炼难度5(数字越大越难淬炼到高点属性)
光芒项链 70 100 0 70 1-5,1-5,0-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
光芒护腕 70 100 0 70 1-5,1-5,0-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
光芒道戒 70 100 0 70 1-5,1-5,0-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
烈焰项链 70 100 0 70 1-5,1-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
烈焰护腕 70 100 0 70 1-5,1-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
烈焰魔戒 70 100 0 70 1-5,1-5,0-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
雷霆项链 70 100 0 70 1-5,1-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
雷霆护腕 70 100 0 70 1-5,1-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,
雷霆战戒 70 100 0 70 1-5,1-5,1-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,0-5,


庄园寄卖系统

Help > 功能相关 >
庄园寄卖系统

功能：
1、GAMEDIAMOND +/-/= 数字 //金刚石(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
2、GAMEGIRD +/-/= 数字 //灵符(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
3、OPENYBDEAL 数字 //开通元宝交易，数字表示需要的元宝数量
4、QUERYYBSELL //查询正在出售的物品
5、QUERYYBDEAL //购买物品
6、<$GAMEDIAMOND> <$GAMEGIRD> //金刚石,灵符变量
7、<$QUERYYBDEALLOG> //显示交易记录
8、CHECKGAMEDIAMOND >/=/< 数字 //检测金刚石，数字支持变量
9、CHECKGAMEGIRD >/=/< 数字 //检测灵符，数字支持变量

示例：

(@ybdeal)
[@main]
您好，有什么可以效劳的？我可以为您提供关于元宝的各类服务 \
现在已经开通了金刚石的元宝交易功能，\
点击交易栏的第十格可以放置金刚石进行交易，\
如果不更新客户端，<交易栏的第十格将不能使用>。\
<查询元宝交易协议/@rule1> <开通元宝交易/@rule>\
<查询元宝数/@askybnum> <出售物品/@@dealybme>\
<查询正在出售的物品/@askybsell> <购买物品/@askybdeal>\
<查询交易信息/@askybdeallog>\
<去周围看看/@randomga0> <关闭对话/@exit> \

[@randomga0]
#act
mapmove GA0

[@askybsell]
我只能保证在我这里出售的物品3天内是不会有差池\
如果超过3天交易还没有成功，我可不能保证物品不会丢失\
并且就算不丢失，取回时也需要另外交给我1个元宝\
要知道，我做这行是很辛苦的，如果不想找麻烦\
那就在3天之内保证交易成功\
<返回/@main>
#ACT
QUERYYBSELL

[@askybdeal]
我只能保证在我这里出售的物品3天内是不会有差池\
如果超过3天交易还没有成功，我可不能保证物品不会丢失\
并且就算不丢失，取回时也需要另外交给我1个元宝\
要知道，我做这行是很辛苦的，如果不想找麻烦\
那就在3天之内保证交易成功\
<返回/@main>
#ACT
QUERYYBDEAL

[@askybdeallog]
<$QUERYYBDEALLOG>

[@askybnum]
你的帐号里元宝的总数是：<$GAMEGOLD>颗。\ \ \
<返回/@main>

[@rule]
人人都知道，我是玛法大陆最公正的人\
您要开通以元宝出售道具，必须向我支付1个元宝\
我将为您提供永久、公正的服务\ \
<我已阅读并同意元宝交易协议，支付一个元宝开通元宝交易/@openybsell>\
<不同意/@exit>

[@openybsell]
#ACT
//参数1 表示开通需要元宝
OPENYBDEAL 1

[@rule1]
您确定已仔细阅读了《元宝交易协议》并接受协议内的所有条款\
1、第一次使用元宝交易，必须开通元宝交易功能并向NPC支付1个元宝\
2、充值元宝是针对帐号进行的，\
该帐号下相同服务器的角色均可以使用这些元宝\
3、如果物品放在NPC处出售超过3天，交易将被终止，\
同时卖方取回物品时需额外再支付1个元宝。\
4、卖方在输入买方角色和元宝数量时，请注意输入正确的角色名\
因自己本身操作失误造成的损失系统将不进行补偿。\
<下一页/@rule2>

[@rule2]
5、在一笔交易未完成的情况下，交易双方均不可以再次进行元宝交易\
6、帐号在单组服务器携带元宝上限:9999个，\
元宝单次交易额最高不超过9999个，\
交易成功如果角色携带元宝数量超过上限，\
超过上限的元宝数量将被自动转换成游戏时间（天卡）\
7、交易成功，卖方将自动获得相应元宝\
8、玩家可在我这里查询最近一次的元宝交易记录\
在取消交易或接受交易物品时,若包裹栏无足够空间，则物品将不能取回\
<返回/@main>

[@AskYBSellFail]
没有查询到指定的记录
[@AskYBDealFail]
没有查询到指定的记录
[@YBDealOK]
收购物品成功


结婚功能

Help > 功能相关 >
结婚功能

功能：
      设置及更改结婚显示的名称
格式：
      配置文件：String.ini

以下为相关配置内容：
;==========================================
ManDearName=%s的老公

WoManDearName=%s的老婆

;==========================================

[@Main]
<我想结婚/@Marry>\
<我想离婚/@unmarry>\ \
<离开/@exit>

[@Marry]
<$USERNAME>,你和你的心上人一起来了吗.?\
结婚可是双方自愿的,如果你们准备好了.\
请面对面站好.!再向对方<求婚/@Agree>..!\
不管你的求婚有没有成功.都需要给我一个求婚戒指..!\ \
<还没准备好/@Exit>

[@Agree]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚.想犯重婚罪呀.!
Goto @Main
Break
#If
CheckPoseMarry
#Act
Messagebox 对方已经结过婚了.是不是想犯重婚罪呀.!
Goto @Main
Break

#If
Gender Man
#ElseAct
Messagebox 只有男的向女的求婚.还没见过大姑娘向小伙子求婚的.!
Goto @Main
Break
#If
CheckPoseGender Man
#Act
Messagebox 你变态呀.想搞同性恋.!
Goto @Main
Break

#If
CheckPoseDir 2
#ElseAct
Messagebox 你们二个面对面站好呀.不要乱动.!
Goto @Main
Break

#If
CheckLevel 40
#ElseAct
Messagebox 结婚要求你的等级必须40级或以上.小伙子努力练好级再来找我.!
Goto @Main
Break

#If
CheckPoseLevel > 34
#ElseAct
Messagebox 你的对象还没成年.等她长大点再来吧.小伙子不要心急嘛.!
Goto @Main
Break

#If
CheckItemw 求婚戒指 1
#ElseAct
Messagebox 你没求婚戒指.弄到求婚戒指再来找我吧.!
Goto @Main
Break

#If
#Act
Takew 求婚戒指 1
Marry

[@StartMarry]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚.想犯重婚罪呀.!
Goto @Main
Break

#If
Gender Man
#Act
Break
#Say
婚礼现在正式开始.\ \
你愿意娶对方为妻.并照顾她一生一世吗.?\ \
<我愿意/@RequestMarry>

#If
Gender WoMan
#Act
Break
#Say
婚礼现在正式开始.\ \
请耐心等待你心爱的人向你求婚\ \

[@RequestMarry]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚，想犯重婚罪呀.!
Goto @Main
Break

#If
#Act
Marry RequestMarry

[@WateMarry]
你已向对方求婚.请耐心等待对方的答复.!

[@RevMarry]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚.想犯重婚罪呀.!
Goto @Main
Break

#If
#Say
对方向你求婚.你是否答应嫁给他.?\ \
<我愿意/@ResposeMarry> \
<我不愿意/@ResposeMarryFail>

[@ResposeMarry]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚.想犯重婚罪呀.!
Goto @Main
Break

#If
#Act
Marry ResponseMarry ok

[@ResposeMarryFail]
#If
CheckMarry
#Act
Messagebox 你都结过婚了.还来注册结婚.想犯重婚罪呀.!
Goto @Main
Break

#If
#Act
Marry Responsemarry Fail

[@EndMarry]
#Act
Messagebox 你们二个已经成为了一对全法夫妻了.
Close

[@EndMarryFail]
#Act
Messagebox 结婚失败.
Close

[@MarryDirErr]
#Act
Messagebox 对方没站好位置.
Close

[@MarryCheckDir]
#Act
Messagebox 请站好位置.
Close

[@HumanTypeErr]
#Act
Messagebox 你变态呀.既然选择一个非人类作为结婚对象.
Close

[@MarrySexErr]
#Act
Messagebox 你变态呀.既然同性恋.
Close

;===================================离婚开始
[@unmarry]
#If
Checkmarry
#Act
Unmarry
#ElseAct
Messagebox 你都没结婚离什么婚.?
Close

;===========双方离婚时没面对面站好显示的信息
[@UnMarryCheckDir]
要离婚是吧.?离婚是二个人的事.必须二个人对面对站好位置.\
如果人来不了你只能选择强行离婚姻了.!\ \
<我要强行离婚/@FUnMarry>\
<返回/@main>

;===========================对面位置不是人物时显示的信息
[@UnMarryTypeErr]
你对面站了个什么东西.怎么不太象人来的.!\ \
<返回/@main>

;=========================开始离婚程序后，双方显示的信息
[@StartUnMarry]
#If
Gender Man
#Act
Break
#Say
是否确定真的要与你共事多年的妻子离婚吗.?\ \
<确定/@RequestUnMarry>

#If
Gender WoMan
#say
你的老公现在向我请求离婚.是不是愿意协议离婚.? \ \
<确定/@RequestUnMarry>
#Act
Break

;===========================================发出离婚请求
[@RequestUnMarry]
#If
CheckMarry
#Act
UnMarry RequestUnmarry
;===========================================回应离婚请求
[@ResposeUnMarry]
#If
Checkmarry
#Act
Unmarry Responseunmarry

;===============================================
;请求离婚后显示的信息
[@WateUnMarry]
你已向对方发出离婚请求.请耐心等待对方的答复.!

;===============================================
;请求离婚后对方显示的信息
[@RevUnMarry]
对方向你离婚请求,你是否答应离婚.? \ \
<我愿意/@RequestUnMarry>
<返回/@main>

;===============================================
;没结过婚的人点离婚后出的提示信息
[@ExeMarryFail]
你都没结过婚.跑来做什么.? \ \
[返回/@main]

;==============================================
;强行离婚
[@fUnMarry]
#If
Checkitem 金砖 1
Checkmarry
#Act
Take 金砖 1
Unmarry Requestunmarry Force
#ElseAct
Messagebox 要收一根金条的手续费.你没有金条.我不能让你离婚.!
Close
;==============================================
;离婚完成后的提示信息
[@UnMarryEnd]
#If
#Act
Messagebox 呵呵.你已经脱离苦海了..
[@Asktime]
你调查结婚时间的请求已发出.请稍后\
<确定/@Exit>


拜师收徒功能

Help > 功能相关 >
拜师收徒功能

功能：
      设置及更改拜师显示的名称
格式：
      配置文件： String.ini

以下为相关配置内容：
;==========================================
MasterName=%s的师父

NoMasterName=%s的徒弟

;==========================================

[@main]
<我想拜师/@master>\
<我想出师/@unmaster>\ \
<离开/@exit>

[@master]
想拜师呀，你要拜的师父来了没有？\
与你师父面对面站好，开始拜师。\ \
<准备好了/@agree>\
<我知道了/@exit>\ \
<返回/@main>

[@agree]
;检查是不是已经是别人的师父
#if
checkismaster
#act
break
#say
没事别来这玩！！！\ \
<返回/@main>

;检查是不是已经拜师了
#if
checkmaster
#act
break
#say
你都都已经拜了别人为师，怎么还拜师！！！ \ \
<返回/@main>

;检查对面的人物是不是别人的徒弟
#if
checkposemaster
#say
你找了个什么人做师父，怎么现在还是别人的徒弟？\ \
<返回/@main>
#act
break

;检查二个有没站好位置
#if
checkposedir
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#say
你都40多级了还要找师父？\ \
<返回/@main>
#act
break

;检查对方等级
#if
checkposelevel > 50
#elsesay
你找个什么师父呀，等级这么低？\ \
<返回/@main>
#elseact
break
#act
master

[@StartGetMaster]
拜师仪式正式开始。\ \
你是否确认拜师？\ \
<确认/@RequestMaster>

[@StartMaster]
拜师仪式正式开始。\ \
对方已经向你提出拜师请求。\ \

[@RequestMaster]

;检查所需物品
#if
checkitemw 力量戒指 1
#elsesay
你都没信物，怎么拜呀！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 力量戒指 1
master requestmaster

[@WateMaster]
你已向对方请求拜师，请耐心等待对方的答复。

[@RevMaster]
对方想拜你为师，你是否想收此人为徒？ \ \
<同意/@ResposeMaster> \
<不同意/@ResposeMasterFail>

[@ResposeMaster]
#if
#act
master responsemaster ok

[@ResposeMasterFail]
#if
#act
master responsemaster fail
[@EndMaster]
你们二个已经是师徒关系了。\ \
<关闭/@exit>
[@EndMasterFail]
拜师失败！\ \
<关闭/@exit>
[@MasterDirErr]
对方没站好位置

[@MasterCheckDir]
请站好位置\\

[@HumanTypeErr]
此人不可以做你的师父。

;==========================================
开始
[@unmaster]
#if
havemaster
#act
unmaster
#elsesay
你都没师父，跑来做什么？？\ \
<返回/@main>

;=======================================================

[@UnMasterCheckDir]
按正常出师步骤，必须二个人对面对站好位置，\
如果人来不了你只能选择强行出师了。\ \
<我要强行出师/@fUnMaster>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMasterTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>
[@UnIsMaster]
必须由徒弟发出请求！！！\ \
<返回/@main>
[@UnMasterError]
不要来捣乱！！！\ \
<返回/@main>
;=======================================================
;开始程序后，双方显示的信息
[@StartUnMaster]
出师仪式现在开始！！！\ \
是否确定真的要脱离师徒关系？\ \
<确定/@RequestUnMaster>
[@WateUnMaster]
出师仪式现在开始！！！\ \

;=======================================================
;发出请求
[@RequestUnMaster]
#if
havemaster
#act
unmaster requestunmaster
;=======================================================
;回应请求
[@ResposeUnMaster]
#if
havemaster
#act
unmaster responseunmaster

;===============================================
;请求后显示的信息
[@WateUnMaster]
你已向对方发出请求，请耐心等待对方的答复。

;===============================================
;请求后对方显示的信息
[@RevUnMaster]
对方向你请求，你是否答应？ \ \
<我愿意/@RequestUnMaster>
<返回/@main>

;===============================================

[@ExeMasterFail]
你都没师父，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行
[@fUnMaster]
#if
checkitem 金条 1
havemaster
#act
take 金条 1
unmaster requestunmaster force
#elsesay
要收一根金条的手续费，你没有金条，\
<确定/@exit>
;==============================================
;完成后的提示信息
[@UnMasterEnd]
呵呵，你已经和对方脱离师徒关系了


装备名字自定义功能

Help > 功能相关 >
装备名字自定义功能

功能：
      装备名称自定义系统

示例脚本：

(@@useitemname)
[@Main]
请选择要改名的装备：(将要改名的装备戴身上)\ \
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
<盔　甲/@@useitemname0><武　器/@@useitemname1><勋 章/@@useitemname2>\
<项　链/@@useitemname3><头　盔/@@useitemname4><右手镯/@@useitemname5>\
<左手镯/@@useitemname6><右戒指/@@useitemname7><左戒指/@@useitemname8>\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\ \
［<返回/@main>］ ［<关闭/@exit>］

[@@useitemname0]
#ACT
goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName

[@ChangeName]
#If
CheckGameGold > 0
#Act
GameGold - 1
SETSCRIPTFLAG 1 1
Sendmsg 7 改名成功.
Close
#Elseact
Sendmsg 7 没钱跑来做什么.?

This file is decompiled from a .CHM file
by an UNREGISTERED version of Easy CHM.
You can download Easy CHM at : http://www.eTextWizard.com


元宝转账功能脚本

Help > 功能相关 >
元宝转账功能脚本

功能：
元宝转帐功能脚本演示

对于一些写版本的来说这个脚本不需要参考！对于一些新手也许可以帮上忙！我在这里列出来了！

示例：

(@@dealgold)
[@main]
<进行元宝转帐/@dealgamegold>\
<关闭/@exit>

[@dealgamegold]
#IF
#ACT

STARTTAKEGOLD

[@startdealgold]
#IF
#SAY
<$DEALGOLDPLAY>与你交易，请<输入转帐/@@dealgold>数量\
<返回/@main>

[@dealgoldpost]
对不起,需要交易的人没站好位置！\
<返回/@main>

[@dealgoldFail]
对不起，你的元宝数量没有这么多！\
<返回/@exit>

[@dealgoldInputFail]
非法操作，交易失败！

[@dealgoldPlayError]
转帐失败！


创建英雄功能脚本

Help > 功能相关 >
创建英雄功能脚本

脚本：

(@@BuHero)
[@main]
创建英雄：<英雄取名/@@buHero>\ \
删除英雄：<删除英雄/@DelMyHero>\ \
<退出/@exit>

[@@buHero]
#ACT
DELAYCALL 10 ~$CREATEHERO

[~$CREATEHERO]
//CREATEHERO 职业 性别
请创建英雄：\ \
<男战士/@CREATEHERO_WARR_MAN> <女战士/@CREATEHERO_WARR_WOM>\
<男法师/@CREATEHERO_WIZA_MAN> <女法师/@CREATEHERO_WIZA_WOM>\
<男道士/@CREATEHERO_TAOS_MAN> <女道士/@CREATEHERO_TAOS_WOM>\ \
<关闭/@exit>
[@CREATEHERO_WARR_MAN]
#ACT
CREATEHERO 0 0
[@CREATEHERO_WARR_WOM]
#ACT
CREATEHERO 0 1
[@CREATEHERO_WIZA_MAN]
#ACT
CREATEHERO 1 0
[@CREATEHERO_WIZA_WOM]
#ACT
CREATEHERO 1 1
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 2 0
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 2 1

//返回消息
[@CreateingHero]
系统正在接受申请，请稍候……\ \
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>

[@SetHeroName]
请先给您的英雄取名字。\ \
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>

[@DelMyHero]
#ACT
DELETEHERO
//返回消息
[@NotHaveHero]
你没有英雄。\ \
<关闭/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！\ \
<关闭/@exit>
[@DeleteHeroOK]
删除英雄成功。\ \
<关闭/@exit

注意：QFunction 添加如下设置

[@@RECALLPLAYER]
#IF
CHECKHEROONLINE
#ACT
CLOSE
MESSAGEBOX 请先设置您的英雄下线！
#ELSEACT
CLOSE
RECALLPLAYER

[@HERONAMEFILTER]
英雄名字中包含禁用字符\<关闭/@EXIT>

[@CREATEHEROOK]
#IF
#ACT
GIVE 火龙之心 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功带领英雄。
#SAY
创建英雄成功\<关闭/@EXIT>
[@HERONAMEEXISTS]
英雄名字已经存在\<关闭/@EXIT>
[@HEROOVERCHRCOUNT]
你的帐号角色过多\<关闭/@EXIT>
[@CREATEHEROFAIL]
创建英雄失败\<关闭/@EXIT>
[@CREATEHEROFAILEX]
创建英雄失败，请稍候重试\<关闭/@EXIT>


记忆石功能脚本

Help > 功能相关 >
记忆石功能脚本

功能：

可以让玩家回到自己设定的坐标，可以做次数限制

示例：

物品DB库DB：

949;记忆石;2;0;1;123;0;0;1025;50000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;

QFunction-0.txt段如下：

[@StdModeFunc123]
当前记录地图信息：\
一： <记录当前坐标/@TAGMAPINFO1> <移动到/@PMOVE1> -> <$TAGMAPNAME1> <$TAGX1> <$TAGY1>\
二： <记录当前坐标/@TAGMAPINFO2> <移动到/@PMOVE2> -> <$TAGMAPNAME2> <$TAGX2> <$TAGY2>\
三： <记录当前坐标/@TAGMAPINFO3> <移动到/@PMOVE3> -> <$TAGMAPNAME3> <$TAGX3> <$TAGY3>\
四： <记录当前坐标/@TAGMAPINFO4> <移动到/@PMOVE4> -> <$TAGMAPNAME4> <$TAGX4> <$TAGY4>\
五： <记录当前坐标/@TAGMAPINFO5> <移动到/@PMOVE5> -> <$TAGMAPNAME5> <$TAGX5> <$TAGY5>\
六： <记录当前坐标/@TAGMAPINFO6> <移动到/@PMOVE6> -> <$TAGMAPNAME6> <$TAGX6> <$TAGY6>\
 <关闭/@exit>
[@PMOVE1]
#ACT
TAGMAPMOVE 1
[@PMOVE2]
#ACT
TAGMAPMOVE 2
[@PMOVE3]
#ACT
TAGMAPMOVE 3
[@PMOVE4]
#ACT
TAGMAPMOVE 4
[@PMOVE5]
#ACT
TAGMAPMOVE 5
[@PMOVE6]
#ACT
TAGMAPMOVE 6
[@TAGMAPINFO1]
#ACT
TAGMAPINFO 1
DELAYGOTO 100 @StdModeFunc123
[@TAGMAPINFO2]
#ACT
TAGMAPINFO 2
DELAYGOTO 100 @StdModeFunc123
[@TAGMAPINFO3]
#ACT
TAGMAPINFO 3
DELAYGOTO 100 @StdModeFunc123
[@TAGMAPINFO4]
#ACT
TAGMAPINFO 4
DELAYGOTO 100 @StdModeFunc123
[@TAGMAPINFO5]
#ACT
TAGMAPINFO 5
DELAYGOTO 100 @StdModeFunc123
[@TAGMAPINFO6]
#ACT
TAGMAPINFO 6
DELAYGOTO 100 @StdModeFunc123


装备绑定帐号功能

Help > 功能相关 >
装备绑定帐号功能

功能：
绑定装备的控制在 功能设置->全局设置

使用方法：
[!] Envir目录下的AllowBindNameList.txt为允许绑定的装备列表，每行一个装备名字，编辑后可在M2菜单重新加载
[!] 绑定装备的控制在 功能设置->全局设置
QUERYBINDITEM 0 //弹出绑定窗口
QUERYBINDITEM 1 //弹出解绑窗口
RESUMEBINDITEM //允许继续执行绑定
RESUMEUNBINDITEM //允许继续执行解绑

[@ItemBinding] //进行绑定之前，做检测用
[@ItemUnBinding] //进行解绑之前，做检测用
[@ItemBinded] //绑定成功后
[@ItemUnBinded] //解绑成功后

示意脚本：
--------------------------------------------------------------------------------------
[@main]
<绑定物品/@Bind> <解绑物品/@UnBind>\ \<退出/@exit>

[@Bind]
#ACT
QUERYBINDITEM 0

[@UnBind]
#ACT
QUERYBINDITEM 1

[@ItemBinding]
#IF
CHECKGAMEGOLD ? 10
#ACT
RESUMEBINDITEM
#ELSESAY
你元宝不够！\ \<退出/@exit>

[@ItemUnBinding]
#IF
CHECKGAMEGOLD ? 10
#ACT
RESUMEUNBINDITEM
#ELSESAY
你元宝不够！\ \<退出/@exit>

[@ItemBinded]
物品绑定到帐号成功！\ \<退出/@exit>

[@ItemUnBinded]
物品解除绑定成功！\ \<退出/@exit>


创建英雄副将功能脚本

Help > 功能相关 >
创建英雄副将功能脚本

增加英雄副将系统

例：
====================================================

(@@BuHero)
[@main]
<建立主英雄/@@buHero> -> 建立后设置为主英雄\
<申请多英雄/@@buHeroEx> -> 申请后可按F12英雄页面切换英雄\
<退出/@exit>\

[@@buHero]
#ACT
DELAYCALL 10 ~$CREATEHERO
[~$CREATEHERO]
//CREATEHERO 职业 性别
请创建英雄：\ \
<男战士/@CREATEHERO_WARR_MAN> <女战士/@CREATEHERO_WARR_WOM>\
<男法师/@CREATEHERO_WIZA_MAN> <女法师/@CREATEHERO_WIZA_WOM>\
<男道士/@CREATEHERO_TAOS_MAN> <女道士/@CREATEHERO_TAOS_WOM>\ \
<关闭/@exit>
[@CREATEHERO_WARR_MAN]
#ACT
CREATEHERO 0 0
[@CREATEHERO_WARR_WOM]
#ACT
CREATEHERO 0 1
[@CREATEHERO_WIZA_MAN]
#ACT
CREATEHERO 1 0
[@CREATEHERO_WIZA_WOM]
#ACT
CREATEHERO 1 1
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 2 0
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 2 1

[@@buHeroEx]
#ACT
DELAYCALL 10 ~$CREATEHEROEX
[~$CREATEHEROEX]
选择英雄职业：\ \
<男战士/@CREATEHERO_WARR_MAN1> <女战士/@CREATEHERO_WARR_WOM1>\
<男法师/@CREATEHERO_WIZA_MAN1> <女法师/@CREATEHERO_WIZA_WOM1>\
<男道士/@CREATEHERO_TAOS_MAN1> <女道士/@CREATEHERO_TAOS_WOM1>\ \
<关闭/@exit>
[@CREATEHERO_WARR_MAN1]
#ACT
CREATEHEROEX 0 0
[@CREATEHERO_WARR_WOM1]
#ACT
CREATEHEROEX 0 1
[@CREATEHERO_WIZA_MAN1]
#ACT
CREATEHEROEX 1 0
[@CREATEHERO_WIZA_WOM1]
#ACT
CREATEHEROEX 1 1
[@CREATEHERO_TAOS_MAN1]
#ACT
CREATEHEROEX 2 0
[@CREATEHERO_TAOS_WOM1]
#ACT
CREATEHEROEX 2 1

//返回消息
[@CreateingHero]
系统正在接受申请，请稍候……\ \
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>

[@SetHeroName]
请先给您的英雄取名字。\ \
<关闭/@exit>


自定义按钮功能

Help > 功能相关 >
自定义按钮功能

命令格式:

如果添加自定义按钮命令放在QM里的话,一定要写在DELAYGOTO跳转字段里

ADDBUTTON WIL序号 按钮编号(1-20) 默认图片 经过图片 按下图片 偏移X 偏移Y 显示位置 显示标题 悬浮提示

DELBUTTON 按钮编号 对象(0或空为个人, 1为全服)

自定义按钮功能

ADDBUTTON命令参数八 九 十 APP暂时无效

WIL序号调用的是M2里 选项 --> 客户端管理 --> 物品自定义相关 --> 特效文件

点击按钮触发QF中的[@ButtonClickX], X为按钮编号 最大支持20个自定义按钮

显示标题和悬浮提示 均支持设置颜色和换行, "/"为颜色符号, "\"为换行符号

显示位置:

0 主窗口不能移动 1主窗口可以移动 2人物装备界面 3人物背包界面 4英雄装备界面 5英雄背包

6 底部左边 7底部右边 8底部中间 9商城界面 20行会界面

示例:

[@login]

#if

#act

DELAYGOTO 500 @自定义按钮 ;DelayGoto 这个命令必须要有 必须延迟跳转

[@自定义按钮]

#if

#act

ADDBUTTON 0 1 625 626 627 0 0 2 253/这是标题 249/这是提示\250/这是提示2

#if

#act

DELBUTTON 1 1

sendsmg 6 删除全服玩家编号为1的自定义按钮

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


顶戴花翎

Help > 功能相关 >
顶戴花翎

命令格式:

SETICON 位置(0-9) WIL序号 开始图片 偏移X 偏移Y 播放数量 模式(0普通,1混合) 播放间隔(毫秒)

设置人物顶戴花翎 WIL序号为-1时 关闭该位置的顶戴花翎

WIL序号调用的是M2里 选项 --> 客户端管理 --> 物品自定义相关 --> 特效文件

示例:

[@main]

#if

#act

SETICON 1 0 120 0 0 12 1 100

sendmsg 6 设置一个顶戴花翎

#if

#act

SETICON 1 -1

sendmsg 6 关闭1号位置顶戴花翎


自定义NPC对话框

Help > 功能相关 >
自定义NPC对话框

命令格式:

OPENMERCHANTBIGDLG WIL编号 背景图片 是否可移动 显示位置 坐标X 坐标Y

是否显示关闭按钮(0关1开) 关闭按钮X 关闭按钮Y

打开NPC自定义对话框

WIL序号调用的是M2里 选项 --> 客户端管理 --> 物品自定义相关 --> 特效文件

显示位置: 0左上角 1右上角 2左下角 3右下角 4居中

CLOSEMERCHANTBIGDLG

关闭自定义NPC对话框命令, 用CLOSE或者关闭按钮关闭也行

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


在线改名功能

Help > 功能相关 >
在线改名功能

( @@InPutString @@InPutInteger)

[@main]
    \\\\
          <COLOR=clRed 改人物名费用为500金币,改名前请先退出行会,英雄下线.>\\\
            【<更换我的角色名/@@InputString35>】　　　【<更换英雄的名字/@@InputString36>】\\

[@@InPutString35]
#if
#act
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
DelayCall 1000 @InPutString35

[@InPutString35]
#IF
CHECKGOLD 500
#ACT
#ELSEACT
MESSAGEBOX 你没有500金币,无法为你服务！
BREAK

#if
haveGuild
#say

失败，行会成员不能变更角色名！\ \
<关闭/@exit>
#act
SENDMSG 5 行会成员不能变更角色名！
break

#if
haveHero
checkHeroOnline
#say

失败，英雄需下线才能更名！\ \
<关闭/@exit>
#act
SENDMSG 5 英雄需下线才能更名！
break

#if
#act
changeCharName <$STR(S35)>
BREAK

[@@InPutString36]
#if
#act
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
SENDMSG 7 正在为检测.请勿关闭对话框......请稍后.....
DelayCall 1000 @InPutString36

[@InPutString36]
#IF
CHECKGOLD 500
#ACT
#ELSEACT
MESSAGEBOX 你没有500金币,无法为你服务！
BREAK

#if
!haveHero
#act
SENDMSG 5 你还没有英雄！
break

#if
!checkHeroOnline
#act
SENDMSG 5 失败，英雄在线才能更名！
break

#if
#act
h.changeCharName <$STR(S36)>
break


切割命令

Help > 功能相关 >
切割命令

命令格式:

CUTTINGOBJECT 切割数值 切割类型(0固定值, 1当前气血的百分比, 2总气血的百分比) 切割对象(0所有, 1怪物,2玩家 3,英雄)

切割功能

RED_Def\AntiCuttingObject.txt 文本内的怪物，免疫切割

新增变量返回自己的<$RACE>值，主体返回1，英雄为2.

新增变量<$TARGETRACE>返回攻击目标的的RACE值，主体返回1，英雄为2,怪物返回自己的race值

命令格式:

ANTICUTTINGOBJECT 减免切割百分比(1-100) 持续时间(1-65535秒)

减免切割百分比命令

示例:

[@attack]

#if

#act

CUTTINGOBJECT 10 2 0

sendmsg 6 攻击触发切割扣除目标最大血量的10%的气血

[@struck]

#if

#act

ANTICUTTINGOBJECT 50 100

sendmsg 6 受到切割伤害减少50%,持续100秒钟


自动拾取物品命令

Help > 功能相关 >
自动拾取物品命令

命令格式:

AUTOPICKUPITEM 拾取范围(0-12) 模式(0拾取所有,1拾取怪物掉落) 是否触发[@PickUpItem] 标签(0或空不触发,1触发)

开启玩家自动拾取功能

当第一个参数为 CLOSE 时关闭自动捡取功能

本功能给指定玩家开启后，自动拾取物品完全和该玩家内挂过滤同步，无需GM设置

示例:

[@main]

#if

#act

AUTOPICKUPITEM 10 0 1

sendsmg 6 开启自动捡取功能

#if

#ACT

AUTOPICKUPITEM CLOSE

sendmsg 6 关闭自动拾取功能

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


物品来源功能

Help > 功能相关 >
物品来源功能

命令格式:

获取来源信息: GETITEMFROM 装备位置(0-34) 来源类型(0-4) 保存变量(例如:S1)

设置来源信息: SETITEMFROM 装备位置(0-34) 来源类型(0-4) 值1 值2(来源类型为4时可用)

给予一个带自定来源信息的物品:

GIVEITEMFROM 物品名字 来源类型 地图名字 怪物或NPC名字 经手人名字(留空为当前角色) 来源时间(留空为当前时间)

来源类型:

0 物品来源类型

1 来源地图

2 来源怪物或NPC

3 经手人

4 来源时间

当参数2为0时,来参数3取值范围如下:

(0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：挖肉获取；9：捕捉获取)

示例:

[@main]

#if

#act

GETITEMFROM 1 1 S2

sendmsg 6 你手中拿的物品,它的来源地图是<$STR(S2)>

#if

#act

SETITEMFROM 0 1 盟重土城

sendmsg 6 已经把你的衣服的来源地图修改为盟重土城了

#if

#act

GIVEITEMFROM 屠龙 杀怪掉落 三王殿 战王 <$USERNAME>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


首饰盒

Help > 功能相关 >
首饰盒

命令格式:

SETSNDACASKET (0隐藏/1显示)

[@main]

#IF

#ACT

SETSNDACASKET 1

SENDMSG 6 你的首饰盒功能已开启,你现在可以使用首饰盒了!

[@main]

#IF

#ACT

SETSNDACASKET 0

SENDMSG 6 你的首饰盒功能已关闭,

可以放入首饰盒的物品类型有 15, 19, 20, 21, 22, 23, 24, 26

物品的Overlap字段为 4 时,只能放进首饰盒

物品的Overlap字段为 5 时,只能放进首饰盒和穿在身上

物品的Overlap字段为 8 时,可以放在身上,首饰盒以及神佑盒

首饰盒的物品位置为 29~34 变量名字 <$JEWELRYITEM1>....<$JEWELRYITEM6>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


神佑盒(十二生肖)

Help > 功能相关 >
神佑盒(十二生肖)

命令格式:

SHOWGODBLESS (0/1)

[@main]

#act

SHOWGODBLESS 1

sendmsg 6 神佑盒已开启!

[@main]

#act

SHOWGODBLESS 0

sendmsg 6 神佑盒已关闭!

可以放入神佑盒的物品类型有 15, 19, 20, 21, 22, 23, 24, 26

物品的Overlap字段为 6 时,只能放进神佑盒

物品的Overlap字段为 7 时,只能放进神佑盒和穿在身上

物品的Overlap字段为 8 时,可以放在身上,首饰盒以及神佑盒

物品的Source 字段为0时不限制放入位置 为1时只能放入第一个位置 后面以此类推

神佑盒的物品位置 35~46 变量名字 <$GODBLESSITEM1> ...<$GODBLESSITEM12>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


自定义OK框功能

Help > 功能相关 >
自定义OK框功能

自定义OK框

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~11)
F=OK框的背景的WIL序号

M=OK框的背景的图片序号
X Y =
微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

<$BOXITEM[X].INDEX> DB里的IDX字段值加1，例如DB里的IDX值是1，这个变量获取到的值就是2
<$BOXITEM[X].NAME> 当前自定义OK框中的物品名称
<$BOXITEM[X].NAME_G> 当前自定义OK框中的物品改名名称
<$BOXITEM[X].DURA> 当前自定义OK框中的物品持久
<$BOXITEM[X].DURAMAX> 当前自定义OK框中的物品最大持久
<$BOXITEM[X].MAKEINDEX> 当前自定义OK框中的物品序列号
<$BOXITEM[X].STDMODE> 当前自定义OK框中的物品StdMode字段值
<$BOXITEM[X].SHAPE> 当前自定义OK框中的物品Shape字段值
<$BOXITEM[X].LOOKS> 当前自定义OK框中的物品Looks字段值
<$BOXITEM[X].COLOR> 当前自定义OK框中的物品Color字段值
<$BOXITEM[X].HP> 当前自定义OK框中的物品HP字段值
<$BOXITEM[X].MP> 当前自定义OK框中的物品MP字段值
<$BOXITEM[X].LAC> 当前自定义OK框中的物品的防御下限
<$BOXITEM[X].HAC> 当前自定义OK框中的物品的防御上限
<$BOXITEM[X].LMAC> 当前自定义OK框中的物品的魔防下限
<$BOXITEM[X].HMAC> 当前自定义OK框中的物品的魔防上限
<$BOXITEM[X].LDC> 当前自定义OK框中的物品的攻击下限
<$BOXITEM[X].HDC> 当前自定义OK框中的物品的攻击上限
<$BOXITEM[X].LMC> 当前自定义OK框中的物品的魔法下限
<$BOXITEM[X].HMC> 当前自定义OK框中的物品的魔法上限
<$BOXITEM[X].LSC> 当前自定义OK框中的物品的道术下限
<$BOXITEM[X].HSC> 当前自定义OK框中的物品的道术上限

<$BOXITEM[X].DRILL1> 当前自定义OK框中的物品 镶嵌宝石的 第一个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL2> 当前自定义OK框中的物品 镶嵌宝石的 第二个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL3> 当前自定义OK框中的物品 镶嵌宝石的 第三个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL4> 当前自定义OK框中的物品 镶嵌宝石的 第四个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL5> 当前自定义OK框中的物品 镶嵌宝石的 第五个孔是否已经打孔(0=没有打孔 1=已打孔)

<$BOXITEM[X].GINDEX1> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX2> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX3> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX4> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX5> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)

<$BOXITEM[X].GNAME1> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME2> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME3> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME4> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME5> 当前自定义OK框中的物品 镶嵌宝石的名称

元素属性值暂时支持1-7 //1暴击 //2伤害增加 //3物理伤害减少 //4魔法伤害减少 //5忽视目标防御 //6伤害反射 //7PK目标爆率

<$BOXITEM[X].VALUE1> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE2> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE3> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE4> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE5> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE6> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE7> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE8> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE9> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE10> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE11> 当前自定义OK框中的物品 元素属性值

<$BOXITEM[X].CUSTOMTEXT> 当前自定义OK框中的物品 自定义文本内容
<$BOXITEM[X].CUSTOMTEXTCOLOR> 当前自定义OK框中的物品 自定义文本显示的颜色

<$BOXITEM[X].CUSTOMVALUE.VALUE1> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE2> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE3> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE4> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE5> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE6> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE7> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE8> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE9> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE10> 当前自定义OK框中的物品 自定义属性值

<$BOXITEM[X].CUSTOMVALUE.COLOR1> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR2> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR3> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR4> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR5> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR6> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR7> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR8> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR9> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR10> 当前自定义OK框中的物品 自定义属性值显示的颜色

<$BOXITEM[X].CUSTOMVALUE.TYPE1> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE2> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE3> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE4> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE5> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE6> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE7> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE8> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE9> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE10> 当前自定义OK框中的物品 自定义属性类型

<$BOXITEM[X].CUSTOMVALUE.POS1> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS2> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS3> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS4> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS5> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS6> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS7> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS8> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS9> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS10> 当前自定义OK框中的物品 自定义属性显示位置

<$BOXITEM[X].CUSTOMVALUE.RATE1> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE2> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE3> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE4> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE5> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE6> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE7> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE8> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE9> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE10> 当前自定义OK框中的物品 自定义属性是否是百分比类型

<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR1.NAME> 当前自定义OK框中的物品 第一个进度条的名称
<$BOXITEM[X].PROGRESSBAR1.COLOR> 当前自定义OK框中的物品 第一个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR1.RATE> 当前自定义OK框中的物品 第一个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR1.MAXRATE> 当前自定义OK框中的物品 第一个进度条的最大值
<$BOXITEM[X].PROGRESSBAR1.IMAGEINDEX> 当前自定义OK框中的物品 第一个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR1.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第一个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR1.LEVEL> 当前自定义OK框中的物品 第一个进度条等级

<$BOXITEM[X].PROGRESSBAR2.OPEN> 当前自定义OK框中的物品 第二个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR2.NAME> 当前自定义OK框中的物品 第二个进度条的名称
<$BOXITEM[X].PROGRESSBAR2.COLOR> 当前自定义OK框中的物品 第二个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR2.RATE> 当前自定义OK框中的物品 第二个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR2.MAXRATE> 当前自定义OK框中的物品 第二个进度条的最大值
<$BOXITEM[X].PROGRESSBAR2.IMAGEINDEX> 当前自定义OK框中的物品 第二个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR2.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第二个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR2.LEVEL> 当前自定义OK框中的物品 第二个进度条等级

X范围=0~11

[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.gameofmir.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.gameofmir.com>\

BAGITEMINTOBOX 物品名称 OK框编号(0~11)
把包裹中的物品放入OK框中

CHECKBAGTEMCOUNTEX 物品名称 数量
检测包裹中物品的数量(排除已经放入自定义OK框的物品)

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

CheckBoxItemCount OK框编号(0~11) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

ReturnBoxItem OK框编号(0~11)
OK框物品返回到包裹

DELBOXITEM OK框编号(0~11) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpDateBoxItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，都全部删除)
删除OK框物品

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~11
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

把自定义OK框中的物品放入包裹后，在当前NPC脚本中触发，X值为0~7
[@ItemOutBoxX]

例:
[@main]
请放入需要升级的装备\ \
<把包裹物品自动放OK框/@自动放物品>\ \
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \
<ITEMBOX:1:2:117:20:10:76:76>\ \ \ \

<开始升级/@开始升级>\

[@自动放物品]
#IF
CHECKBAGTEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 0
;放到0号OK框

#IF
CHECKBAGTEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 1
;放到1号OK框

[@开始升级]
#IF
#ACT

#IF
;检测OK框中是否有物品
CheckBoxItemCount 0 1
#ACT

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备


OK框功能

Help > 功能相关 >
OK框功能

命令格式:

打开OK框命令: QUERYITEMDLG 提示文字 跳转标签 是否删除OK框物品(0=忽略,1=删除)

参数二：是在玩家点击了OK按钮之后，跳转的标签

参数三：一般等于0，忽略不写也可以。执行完[跳转标签]之后，由TAKEDLGITEM来取走OK框内的物品。

等于1的话，当玩家点击OK按钮时直接取走物品，不再往下执行：CHECKDLGITEMADDVALUE、

CHECKDLGITEMNAME、CHECKDLGITEMTYPE、GETDLGITEMVALUE、UPGRADEDLGITEM

检测OK框物品属性: CHECKDLGITEMADDVALUE 属性位置(0-30) 比较符(><=?) 数值

检测OK框物品类型: CHECKDLGITEMTYPE 类型(详细分类在下面)

检测OK框物品名字: CHECKDLGITEMNAME 物品名字

检测OK框物品特征: CHECKPOSDLGITEMNAME 特征字符(检测OK框物品名字包含的关键词)

升级OK框物品属性: UPGRADEDLGITEM 属性位置(0-30) 成功几率(0-100,值越大几率越大) 点数几率(0-255) 失败处理(0不变1破碎2还原) 提示信息(非空时不显示提示信息)

取走OK框里的物品: TAKEDLGITEM

返回OK框的物品到背包 RECLAIMITEM

类型: DRESS //检测是否衣服
WEAPON //检测是否武器
MEDAL //勋章
NECKLACE //项链
HELMET //头盔
HELMETEX //斗笠
ARMRING //手镯
RING //戒指
BOOTS //靴子
BELT //腰带
BUJUK //物品
CHARM //宝石
DRUM //军鼓
HORSE //马牌
FASHION //时装

示例:

[@打开OK框]
#IF
TRUE
#ACT
QUERYITEMDLG 请放入物品： @OK框标签

[@OK框标签]
#IF
CHECKDLGITEMNAME 物品名字
CHECKDLGITEMTYPE DRESS
CHECKDLGITEMADDVALUE 属性位置(0..30) (检测符 < > = ?) 检测数值
#ACT
GETBOXITEMVALUE 私人变量M 属性位置(0..30)< BR>UPGRADEDLGITEM属性位置(0-14)成功机率(0-100)点数机率(0-255)失败处理(0=失败不做处理,1=没收物品,2=还原属性)
TAKEDLGITEM

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


称号系统

Help > 功能相关 >
称号系统

新称号系统

命令格式:

检测人物称号: CHECKTITLE 称号

授予人物称号: CONFERTITLE 称号 操作(可留空, 值为1时直接激活称号)

删除人物称号: DEPRIVETITLE 称号(为ALL时删除玩家所有称号)

调整称号时长: CHANGEFENGHAOTIME 称号 操作符(+-=) 时长(小时 1-65535)

[@CHECKTITLE]

#IF

CHECKTITLE 传奇之星

#ACT

CONFERTITLE 传奇之星 1 //授予称号

#ELSEACT

DEPRIVETITLE 传奇之星

数据库DB:

增加减少称号物品DB时，请注意Shape的连续性（递增），
Shape 编号
AniCount 字段大于0时不佩戴属性也能生效

weight = 1，图片和名字分为上下显示
Source颜色，0~5（0=白色、1=绿色、2=蓝色、3=紫色、4=红色、5=金色）
Reserved 显示DB中的名字（有部分图自带了名字，所以可以写上1）
Looks 图片在 ui1.wzl 中的开始位置
DuraMax 可使用时间，单位小时
其他就等同于装备属性。

玩家改变使用称号或刚上线有使用到称号，触发：QFunction 的
人物：[@TitleChanged_XX]
英雄：[@HeroTitleChanged_XX]
XX代表物品DB中的Shape

1285;沙巴克城主;51;1;0;0;0;0;690;7;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1286;兵贵神速;51;2;0;0;0;0;700;1;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1287;战神;51;3;0;0;0;0;710;7;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1288;法圣;51;4;0;0;0;0;705;7;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1289;道尊;51;5;0;0;0;0;695;7;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1290;玛法主宰者;51;6;0;0;0;0;715;4320;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1291;传奇之星;51;7;0;0;1;1;1275;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1292;玛法之星;51;8;0;0;1;1;1265;288;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1293;一星主宰者;51;9;0;0;0;0;720;288;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1294;二星主宰者;51;10;0;0;1;0;720;288;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1295;三星主宰者;51;11;0;0;2;0;720;288;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1296;君临天下;51;12;0;0;5;0;1260;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1297;倾国倾城;51;13;0;0;4;0;725;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1298;主宰者知己;51;14;0;0;4;0;725;288;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1299;行会之星;51;15;0;0;4;0;700;48;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1300;国士无双;51;16;0;0;3;0;1270;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1301;绝代佳人;51;17;0;0;3;0;725;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1302;不动如山;51;18;0;0;2;0;1250;24;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1303;勇者无敌;51;19;0;0;1;0;710;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1304;国色天香;51;20;0;0;3;0;725;720;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1305;巅峰战神;51;21;0;0;4;0;710;24;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1306;巅峰勇士;51;22;0;0;4;0;710;24;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1307;永恒沙巴克城主;51;23;0;0;5;0;690;60000;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;
1308;屠龙勇士;51;24;0;0;2;0;730;24;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;

======================================================================

功能：
旧称号系统
注：必须在!Setup.txt里把该功能打开：ShowRankLevelName= 1

格式：
 SETRANKLEVELNAME %s称号
想人物名字与称号分行显示，只需在%s后面加上\，如：%s\称号

[@NAME]
#IF
#ACT
SETRANKLEVELNAME %s[称号]
#SAY
你的名字后面已经加上[称号]了
英雄为H.SETRANKLEVELNAME

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


任务系统

Help > 功能相关 >
任务系统

命令格式:

检测任务进度: CHECKMISSION 任务ID 比较符(><=) 步骤

CHECKMISSION 任务ID = 0 //任务不存在

CHECKMISSION 任务ID > 2 //任务执行到步骤2以上，否则任务不存在或未执行到步骤2以上

设置任务进度: SETMISSION 操作符( + - ^ ) 任务ID 步骤

SETMISSION + 12 2 //增加ID=12的任务 //若当前人物还没有接ID=12的任务，则相当于SETMISSION + 12 1

//若当前人物已经接了ID=12的任务，则相当SETMISSION ^ 12 2

SETMISSION - 23 //删除ID=23的任务，触发QFunction的 @CancelMission< /FONT>

SETMISSION ^ 12 //更新ID=12任务到当前步骤+1

SETMISSION^345//更新ID=34任务到指定步骤5，//ID=34的任务存在//必要条件：ID=34任务步骤>=5

清理所有任务: CLEARMISSION

相关文件：
建立 X:\MirServer\Mir200\Envir\Missions.txt，编辑如下：
========================================================================
;[类型(1=成长任务,2=日常任务,3=每日活动,4=节日活动)-任务ID(1~65535,不可重复)] 任务标题
[1-1] 成长任务1
;任务步骤详情描述：1~65535行，任务描述第1行就是第1个步骤,第2行就是第2个步骤,依次类推...
;步骤XXX可不写，但是注意行的顺序...
步骤1:\<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
步骤2:\<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
步骤3:\<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

[1-2] 成长任务2
<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

[1-3] 成长任务3
<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

[2-4] 日常任务1
<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

[2-5] 日常任务2
<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

[2-6] 日常任务3
<$USERNAME>\<COLOR=clSkyBlue 自动移动到：><盟重333:335/@_automove 333:335>
<$USERNAME>\<COLOR=clLime 自动移动到：><盟重333:335/@_automove 332:332>
<$USERNAME>\<COLOR=clBlue 自动移动到：><盟重333:335/@_automove 331:331>

=================================================================

示例:

[@main]

#IF

CHECKMISSION 5 > 2

#ACT

SETMISSION ^ 34 5

#SAY

干的不错, 我把你的任务更新到了第34步第5小节的任务上了。

#ELSEACT

CLEARMISSION

SENDSMG 你都还没达到指定任务进度,我看还是把你的任务取消了吧。\


押镖系统

Help > 功能相关 >
押镖系统

命令格式:

检测镖车是否在身边: CHECKESCORTINNEAR

放弃押运任务: GIVEUPESCORT

开始押镖任务: STARTESCORT 镖车名字

提交押镖任务: FINISHESCORT

检测押镖是否进行中: ISESCORTING

Monster.DB：

普通镖车;54;19;290;40;0;100;6000;150;45;45;45;45;45;45;10;20;1200;1;0;1000;0;0;0;0;
紫色镖车;54;19;290;40;0;100;6000;150;45;45;45;45;45;45;10;20;1200;1;0;1000;0;0;0;0;
超级镖车;54;19;291;50;0;100;8000;100;45;45;45;45;45;45;10;20;1100;1;0;1000;0;0;0;0;
无敌镖车;54;19;292;60;0;100;10000;1;45;45;45;45;45;45;10;20;1000;1;0;1000;0;0;0;0;

说明:

接任务后，45分钟内完成押运，否则镖车消失，任务失败

杀死镖车触发：QMapEvent-0.txt [@Plunder_镖车名] 此节下的触发支持：<$ROBBER> - 被抢劫人的名称

镖车正受攻击：QMapEvent-0.txt [@EscortUnderFire]

相关下载: 点击下载拉镖脚本.rar


行会建设相关

Help > 功能相关 >
行会建设相关

命令格式:

检测行会建筑度: CHECKGUILDBUILDPOINT 比较符(><=?) 数值< /FONT>

检测行会人气度: CHECKGUILDAURAEPOINT 比较符(><=?) 数值

检测行会安定度: CHECKGUILDSTABILITYPOINT 比较符(><=?) 数值

检测行会繁荣度: CHECKGUILDFLOURISHPOINT 比较符(><=?) 数值

检测行会领取装备数量: CHECKGUILDCHIEFITEMCOUNT 比较符(><=?) 数值

修改行会建筑度: GUILDBUILDPOINT 控制符（+ - = ）数字

修改行会人气度: GUILDAURAEPOINT 控制符（+ - = ）数字

修改行会安定度: GUILDSTABILITYPOINT 控制符（+ - = ）数字

修改行会繁荣度: GUILDFLOURISHPOINT 控制符（+ - = ）数字

修改行会领取装备数量: GUILDCHIEFITEMCOUNT 控制符（+ - = ）数字

变量：
<$GUILDHUMCOUNT> 行会人数

<$GUILDBUILDPOINT> 行会建筑度

<$GUILDAURAEPOINT> 行会人气度

<$GUILDSTABILITYPOINT> 行会安定度

<$GUILDFLOURISHPOINT> 行会繁荣度

<$GUILDCHIEFITEMCOUNT> 行会领取装备数量


自定义进度条(刀魂系统)

Help > 功能相关 >
自定义进度条(刀魂系统)

自定义装备进度条 类似于刀魂技能

功能说明：可以给装备自定义进度条，支持2个进度条。显示在装备名称的下面一行

必备补丁 NewopUI.data 490 是第一个进度条的背景图片 491~499 为静态的进度条图 500~509 为动态的进度条图

必备补丁 NewopUI.data 510 是第二个进度条的背景图片 511~519 为静态的进度条图 520~529 为动态的进度条图

检测进度条是否开启：
CHECKCUSTOMITEMPROGRESSBAR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条)

[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

检测进度条值：
CHECKCUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测类型(0当前进度值,1进度条最大值,2进度条等级(0~65535)) 检测符(<,>,=) 检测值

检测进度条百分比：
CHECKCUSTOMITEMPROGRESSBARPERCENT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测符(<,>,=) 检测值(0~100)

修改自定义装备进度条属性：
CHANGECUSTOMITEMPROGRESSBAR 参数1 参数2 参数3 参数4

参数1:装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)
参数2:进度条序号。参数范围(0,1)0=表示第一个进度条 1表示第二个进度条
参数3:修改类型，参数范围(0~4) 0显示或关闭进度条 1进度条名称(会显示在进度条左边) 2进度条名称颜色(0~255) 3进度条图片张数(1~9) 4显示进度的数值(0~2)

参数4:
参数3=0时，范围(0关闭进度条,1显示进度条)
参数3=1时，进度条名称(15个字符)支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
参数3=2时，进度条名称颜色(0~255)
参数3=3时，进度条图片张数(1~191~9表示绘制单张的，如果是第一个进度条，如果参数4=1就会绘制491，如果参数4=2就会绘制492。如果参数4在10~19之间，表示循环绘制，如果参数4=10 表示绘制500，如果参数4=11 表示在500~501之间循环绘制，如果参数4=12 表示在500~502之间循环绘制)
参数3=4时，显示进度的数值(0不显示,1百分比显示方式 2数值显示方式)

修改自定义装备进度条属性值：
CHANGECUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条 1表示第二个进度条) 类型(0表示当前进度 1表示进度条最大值,2表示进度条等级(0~65535)) 操作符(+,-,=) 值

获取进度条指定属性值:

GETCUSTOMITEMPROGRESSBARVALUE 装备位置(所有装备位置) 进度条编号(0-1) 属性类型(0-3) 保存变量

属性类型:

0：进度条最大值
1：进度当前值
2：进度条当前百分比
3：进度条等级

例：
[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

[@检测衣服的第一个进度条最大值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 1 > 99
#ACT
SENDMSG 6 衣服的第一个进度条最大值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条最大值不大于99

[@检测衣服的第一个进度条当前值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条当前值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条当前值不大于99

[@检测衣服的第一个进度条等级]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 2 > 99
#ACT
SENDMSG 6 衣服的第一个进度条等级大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条等级不大于99

[@检测衣服的第一个进度条百分比]
#IF
CHECKCUSTOMITEMPROGRESSBARPERCENT 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条百分比为100%

[@显示衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 1

[@显示衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 1

[@关闭衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 0

[@关闭衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 0

[@修改衣服的第一个进度条的名称]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂
;支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
;例如:
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %l
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %r
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %p-%m

[@修改衣服的第一个进度条的名称颜色]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 2 254

[@修改衣服的第一个进度条静态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1
SENDMSG 6 衣服的第一个进度条静态图片素材,使用NewopUI.PAK第491号

[@修改衣服的第一个进度条动态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 19
SENDMSG 6 衣服的第一个进度条动态图片素材,使用NewopUI.PAK第500~509号之间循环播放

[@修改衣服的第一个进度条图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1

[@修改衣服的第一个进度条百分比显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 1

[@修改衣服的第一个进度条数值显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 2

[@修改衣服的第一个进度条的最大值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 1 = 100
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。这里最大值设置为100

[@修改衣服的第一个进度条的当前进度值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 0 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

[@修改衣服的第一个进度条的等级]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 2 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


副本功能

Help > 功能相关 >
副本功能

副本功能

检测副本是否创建成功: CANMOVEECTYPE 副本名字

传送到副本命令: MOVEECTYPE 副本名字 x坐标 y坐标

脚本刷怪指令: MOBECTYPEMON 地图类型(1：NPCMAP NPC所在地图 2：FBMAP 玩家所创建的副本地图 3：SELF 玩家所在地图) X坐标 Y坐标 怪物名字 刷怪数量 刷新范围

清除副本怪物: CLEARECTYPEMON 地图类型(1：NPCMAP NPC所在地图 2：FBMAP 玩家所创建的副本地图 3：SELF 玩家所在地图)

给地图添加触发事件: MOBMACHINERYEVENT 地图类型(1：NPCMAP NPC所在地图 2：FBMAP 玩家所创建的副本地图 3：SELF 玩家所在地图) X坐标 Y坐标 持续时间 事件名字

删除某个事件: CLEARMACHINERYEVENT 地图类型(1：NPCMAP NPC所在地图 2：FBMAP 玩家所创建的副本地图 3：SELF 玩家所在地图) 事件名字

MapInfo.txt

[grly 火龙怪副本]
FB(10|测试副本|1)
[GA1 变异火龙副本]  FB(10|变异火龙副本|1)
[GA0 白野猪副本]
FB(10|白野猪副本|1)

mapquest.txt

$FB_GA1_1 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_2 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_3 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_4 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_5 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_6 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_7 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_8 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_9 [0] 0 变异火龙王 * 变异火龙王
$FB_GA1_10 [0] 0 变异火龙王 * 变异火龙王

脚本案例：

[@白野猪副本] //创建副本并且进入
#IF
CHECKVAR HUMAN fuben1 < 5
#ACT
CREATEECTYPE 白野猪副本 3
MOVEECTYPE 白野猪副本 15 25
CLEARMAPITEM <$FBMAP> 15 25 30
CLEARECTYPEMON FBMAP
CLEARMACHINERYEVENT FBMAP
CLEARMAPMON <$FBMAP> 白野猪
MonGenEx <$FBMAP> 15 25 白野猪 1 1
SENDMSG 5 你已传送至白野猪副本的(40:41)坐标，挑战白野猪副本！
#ELSESAY
不好意思，只能挑战5次，挑战成功记一次，失败不计。

[@CreateFB] //创建副本
#IF
#ACT
CREATEECTYPE 变异火龙副本 1
SENDMSG 5 你已创建了一个测试副本，有效时间为10分钟。

[@CheckFB] //检测副本是否创建成功
#IF
CANMOVEECTYPE 变异火龙副本
#SAY
你已经创建了一个测试副本
#ELSESAY
没有找到相关副本

[@MoveFB] //检测传送进入副本
#IF
CANMOVEECTYPE 变异火龙副本
#ACT
MOVEECTYPE 变异火龙副本 20 20
SENDMSG 5 你已传送至测试副本的(40:41)坐标<$FBMAP>
CLEARECTYPEMON FBMAP
CLEARMACHINERYEVENT FBMAP
CLEARMAPMON <$FBMAP> 鸡
MonGenEx <$FBMAP> 15 25 鸡 1 1
#ELSEACT
SENDMSG 5 您没有创建副本

[@CREATEECTYPE_IN] //创建副本后返回 副本已经存在可以直接传送
#IF
#ACT
CLEARECTYPEMON FBMAP
CLEARMACHINERYEVENT FBMAP
CLEARMAPMON <$FBMAP> 鸡
MonGenEx <$FBMAP> 15 25 鸡 1 1

[@CREATEECTYPE_OK] //创建副本后返回 副本创建成功
#IF
#ACT
CLEARECTYPEMON FBMAP
CLEARMACHINERYEVENT FBMAP
CLEARMAPMON <$FBMAP> 鸡
MonGenEx <$FBMAP> 15 25 鸡 1 1
MESSAGEBOX 副本创建成功！

[@CREATEECTYPE_FAIL] //创建副本后返回 副本创建失败
#IF
#ACT
MESSAGEBOX 创建副本失败，副本人数已满，请稍候再试！


宝石镶嵌功能

Help > 功能相关 >
宝石镶嵌功能

命令格式:

检测装备是否打孔: CHECKDRILLHOLE 装备位置(-1-34) 孔位(0-4)

检测装备打孔数量: CHECKDRILLHOLECOUNT 装备位置(-1-34) 比较符(><=) 数量

检测是否镶嵌宝石: CHECKSOCKETABLEITEM 装备位置(-1-34) 宝石位置(0-4) 变量1(如果镶嵌,该宝石IDX会保存到此变量) 变量2(如果镶嵌,该宝石名字保存到此变量)

检测装备镶嵌宝石数量: CHECKSOCKETABLEITEMCOUNT 装备位置(-1-34) 比较符(><=) 数量

装备打孔命令: DRILLHOLE 装备位置(-1-34) 空位置(0-4) 状态(1打开,0关闭)

镶嵌宝石命令: SOCKETABLEITEM 装备位置(-1-34) 孔位置(0-4) 宝石IDX(数据库的IDX+1, 为0时删除宝石)

宝石DB说明:

宝石的Shape值不等于255时显示必备补丁NewopUI.PAK的300和301

宝石的Shape值如果设置为255，镶嵌后会显示宝石DB的Looks的。也就是DnItems里面的素材

宝石DB库的字段Reserved=0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值是增加的对应的7个基本属性的值

[@例子]

#IF

CHECKSOCKETABLEITEM 0 0 N1 S1

#act

SENDMSG 6 衣服第一个位置镶嵌了宝石。宝石名称：<$STR(S1)>,宝石IDX字段：<$STR(N1)>

#elseact

SENDMSG 6 衣服第一个位置没有镶嵌宝石

[@镶嵌衣服的第一个宝石，宝石IDX为831]

#ACT

;先要打孔

DRILLHOLE 0 0 1

;然后镶嵌

SOCKETABLEITEM 0 0 832

相关链接: 装备位置

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


自定义属性功能

Help > 功能相关 >
自定义属性功能

自定义属性功能

提示: 自定义属性（防御，魔御，攻击，魔法，道术，HP，MP）的百分比模式是以自身基础属性来计算加成，其他引擎是以该装备的属性来计算加成，注意区分！

自定义装备属性 该数据保存在人物Mir.DB里

功能说明：可以自定义装备的属性值，支持10个属性

自定义装备属性的名称控制(M2-选项-客户端设置-自定义属性)

功能说明：可以给装备自定义一行文字，文字长度20个字符，也就是10个汉字。

修改自定义装备文字内容：
CHANGECUSTOMITEMTEXT 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备)文字内容

获取自定义装备文字内容：
GETCUSTOMITEMTEXT 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 保存变量

修改自定义装备文字内容显示的颜色：
CHANGECUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 文字颜色(0~255)

获取自定义装备文字内容显示的颜色：
GETCUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 保存变量

检测自定义装备文字内容显示的颜色：
CHECKCUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 色号(0~255)

检测自定义装备属性值：
CHECKCUSTOMITEMVALUE 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值

检测自定义装备属性绑定类型：
CHECKCUSTOMITEMVALUETYPE 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值(1~30 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~30为23个无属性的)

修改自定义装备属性值：
CHANGECUSTOMITEMVALUE 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (控制符+，-，=) 值

获取人物装备指定属性位置的自定义属性值：
GETHUMCUSTOMITEMVALUE 装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备) 属性位置(0~9) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量)变量2可留空

获取人物装备的所有自定义属性值：
GETHUMCUSTOMITEMVALUEEX 装备位置(-2为全身,-1为OK框,大于-1为身上位置) 绑定的属性类型(1~45 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~45为38个无属性的) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量) 变量2可留空

获取自定义属性:

GETCUSTOMITEMABIL 装备位置(所有位置) 属性位置(0-9) 属性类型(0-2) 保存变量

属性类型: 0 属性颜色 1绑定M2里属性编号 2是否百分比显示属性

------------------------------------------------------------------------------------------------------------------------

修改自定义装备属性：
CHANGECUSTOMITEMABIL 装备位置 属性位置 属性颜色 绑定属性 是否百分比

参数1:
装备位置(-1时是OK框中的装备, 0~34时是穿在身上的装备)

参数2:
属性位置(0~9）每个装备可以自定义10个属性

参数3:
 属性颜色(0~255)

参数4:
绑定属性(1~30 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~30为23个无属性的)

参数5:
是否为百分比计算显示(0否/1是)

提示: 参数3~参数6 值为-1时表示不修改原有属性

自定义属性标题和属性描述均支持PLAYIMG和PIC标签, 具体格式参考备注功能,

使用标签会造成标题描述文字颜色失效, 用<T:文字内容:颜色>, 例如:

CHANGECUSTOMITEMTEXT 1 <T:武器自定义属性:249><PLAYIMG:1:2:3:4:5:6:7>

相关链接: 装备位置

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


五行阵法功能

Help > 功能相关 >
五行阵法功能

功能：
增加“五行阵法奇效”功能：

形成五行阵法的三个前提是：组队状态下、双方一定范围内、人物拥有五行属性。
五行阵法不同于游戏中的其他阵法，无需学习，无需由队长发动。只要玩家组队，
并且队伍中的玩家角色具备与自己相生或相克五行属性，则阵法自动生效。
五行阵法奇效
下表列举了每个属性的玩家与其他属性的相生、相克情况，以及由此可以获得的增益效果：
自身属性 队友属性（相生） 效果 队友属性（相克） 效果
金 土 增加自身生命值和魔法值上限 火 增加自身物理和魔法攻击力
木 水 金
水 金 土
火 木 水
土 火 木
五行属性的获得：
在游戏中，可以通过任务去完成，完成后找NPC选择一个自己中意的五行属性即可。

----------------------------------------------------
使用 SETATTRIBUTE 数字(0-5) NPC命令完成属性赋予，0清除属性，1-5代表：金/木/水/火土
因为有5个属性，所以组对人数最好控制在6个，比较平衡。

示例：

[@GroupAttrib]
五行阵法形成，前提：\
1、人物在组队状态下\
2、双方在九屏范围内\
3、人物拥有五行属性\
请点下面各个属性进行了解，之后谨慎选择你的属性：\ \
<金/@GroupAttrib1> <木/@GroupAttrib2> <水/@GroupAttrib3> <火/@GroupAttrib4> <土/@GroupAttrib5>\ \
<退出/@exit>
[@GroupAttrib1]
你选择的是<金>属性：\ \
当队伍中有<土/@GroupAttrib5>属性的队友时，你将增加自身生命值和魔法值上限。\
当队伍中有<火/@GroupAttrib4>属性的队友时，你将会提升自身物理和魔法攻击力。\ \
<确定选择/@Sel1>\ \
<返回/@GroupAttrib>
[@GroupAttrib2]
你选择的是<木>属性：\ \
当队伍中有<水/@GroupAttrib3>属性的队友时，你将增加自身生命值和魔法值上限。\
当队伍中有<金/@GroupAttrib1>属性的队友时，你将会提升自身物理和魔法攻击力。\ \
<确定选择/@Sel2>\ \
<返回/@GroupAttrib>
[@GroupAttrib3]
你选择的是<水>属性：\ \
当队伍中有<金/@GroupAttrib1>属性的队友时，你将增加自身生命值和魔法值上限。\
当队伍中有<土/@GroupAttrib5>属性的队友时，你将会提升自身物理和魔法攻击力。\ \
<确定选择/@Sel3>\ \
<返回/@GroupAttrib>
[@GroupAttrib4]
你选择的是<火>属性：\ \
当队伍中有<木/@GroupAttrib2>属性的队友时，你将增加自身生命值和魔法值上限。\
当队伍中有<水/@GroupAttrib3>属性的队友时，你将会提升自身物理和魔法攻击力。\ \
<确定选择/@Sel4>\ \
<返回/@GroupAttrib>
[@GroupAttrib5]
你选择的是<土>属性：\ \
当队伍中有<火/@GroupAttrib4>属性的队友时，你将增加自身生命值和魔法值上限。\
当队伍中有<木/@GroupAttrib2>属性的队友时，你将会提升自身物理和魔法攻击力。\ \
<确定选择/@Sel5>\ \
<返回/@GroupAttrib>
[@Sel1]
#IF
CHECK [415] 0
#ACT
SETATTRIBUTE 1
SET [415] 1
CLOSE
#ELSEACT
CLOSE
MESSAGEBOX 目前只能选择一次五行属性！
[@Sel2]
#IF
CHECK [415] 0
#ACT
SETATTRIBUTE 2
SET [415] 1
CLOSE
#ELSEACT
CLOSE
MESSAGEBOX 目前只能选择一次五行属性！
[@Sel3]
#IF
CHECK [415] 0
#ACT
SETATTRIBUTE 3
SET [415] 1
CLOSE
#ELSEACT
CLOSE
MESSAGEBOX 目前只能选择一次五行属性！
[@Sel4]
#IF
CHECK [415] 0
#ACT
SETATTRIBUTE 4
SET [415] 1
CLOSE
#ELSEACT
CLOSE
MESSAGEBOX 目前只能选择一次五行属性！
[@Sel5]
#IF
CHECK [415] 0
#ACT
SETATTRIBUTE 5
SET [415] 1
CLOSE
#ELSEACT
CLOSE
MESSAGEBOX 目前只能选择一次五行属性！


天地结晶

Help > 功能相关 >
天地结晶

参数：
      地图参数 COLLECTEXP (AA/BB/CC/DD/EE/F1~F4/G1~G4)

说明：

AA //增加的经验
BB //增加的内功经验
CC //打怪吸收经验比率，100则收集打怪的100%经验
DD //释放需要元宝比率 注：释放需要元宝 = 释放需要元宝比率 * 经验结晶阶段
EE //增加经验时间间隔(秒)
F1~F4 //1~4阶段的最高经验，中间用“|”号分开
G1~G4 //1~4阶段的最高内功经验

示例：
-------------------------------------------------------------------------------------
[0122 皇宫] COLLECTEXP(8000/3200/100/3/10/600000|1200000|2400000|4800000/240000|480000|960000|1280000)

释放触发：QFunction-0.txt：
[@ReleaseCollectExp]
#ACT
QUERYVALUE 2 2 10 @ReleaseCollectExpNow 你的天地结晶已经储存了<$COLLECTEXP>经验和<$COLLECTIPEXP>内功经验，你可以支付<$GCEPAYMENT>元宝\提取其中的<$GAINCOLLECTEXP>经验和<$GAINCOLLECTIPEXP>内功经验 QF

[@ReleaseCollectExpNow]
#IF
CHECKGAMEGOLD ? <$GCEPAYMENT>
#ACT
GAMEGOLD - <$GCEPAYMENT>
CHANGEEXP + <$GAINCOLLECTEXP>
CHANGEIPEXP + <$GAINCOLLECTIPEXP>
RESETCOLLECTEXPSTATE //恢复天地结晶到初始状态


假人功能相关

Help > 功能相关 >
假人功能相关(待完善)

假人配置

功能：假人配置
格式：无
说明：假人是和人物一样的，所有人物的命令假人都可以使用，比如可以使用加入行会的命令，把假人加入某个行会

相关命令

登陆假人 DUMMYLOGON 地图 X Y 范围 数量

会自动登陆 MirServer\Mir200\Envir\AICharNameList.txt 列表内的假人

假人配置目录在 MirServer\Mir200\Envir\Dummys 文件夹内

(引擎包M2文件夹里已经放入基本假人配置)

检测是否为假人 ISDUMMY

假人自动打怪 DUMMYSTART

假人停止打怪 DUMMYSTOP

假人配置文件:

[info]
;职业 (0战士，1法师，2道士)
Job=0

;性别 (0男，1女)
Gender=0

;发型
Hair=1

;初始等级
Level=35

;是否可挖
Butch=0

;身体坚韧度
BodyLeathery=200

;是否掉落物品
DropUseItem=0

;掉落物品概率
DropUseItemRate=500

;使用所有职业技能
UseAllSkillByJob=0

;使用技能
UseSkill=基本剑术,攻杀剑术,刺杀剑术,半月弯刀,野蛮冲撞,烈火剑法

;背包物品
InitItems=木剑,回城石

;拾取模式（0=不拾取，1=拾取全部物品，2=只拾取极品装备，3=只拾取金币，4=拾取极品装备和金币）
PickUpItemMode=1

;拾取间隔（毫秒）
PickUpItemTick=1000

;攻击模式
AttatckMode=2

;攻击类型（0=只走路，1=只攻击怪物，2=只攻击人物，3=攻击人和怪）
AIAttatckMode=3

;优先攻击主体目标
TargetCretHum=1

;优先还击
AILastHiter=1

;无目标随机等待时间（秒）
AILastAttackTick=20

;开启首饰盒
UseJewelry=1

;开启神佑盒
UseGod=1

;英雄开启首饰盒
UseJewelry=1

;英雄开启神佑盒
UseGod=1

身上装备
[USEITEMS]
;衣服
USEITEMS0=龙神宝甲
;武器
USEITEMS1=屠龙剑
;照明物
USEITEMS2=武士之星
;项链
USEITEMS3=龙神项链
;头盔
USEITEMS4=龙神战盔
;左手镯
USEITEMS5=龙神手镯
;右手镯
USEITEMS6=龙神手镯
;左戒指
USEITEMS7=龙神战戒
;右戒指
USEITEMS8=龙神战戒
;毒符
USEITEMS9=
;腰带
USEITEMS10=
;鞋子
USEITEMS11=
;宝石
USEITEMS12=
;斗笠
USEITEMS13=
;军鼓
USEITEMS14=
;马牌
USEITEMS15=
;盾牌
USEITEMS16=
;时装衣服
USEITEMS17=
;时装武器
USEITEMS18=
;时装项链
USEITEMS19=
;时装头盔
USEITEMS20=
;时装左手
USEITEMS21=
;时装右手
USEITEMS22=
;时装左戒
USEITEMS23=
;时装右戒
USEITEMS24=
;时装勋章
USEITEMS25=
;时装腰带
USEITEMS26=
;时装靴子
USEITEMS27=
;时装宝石
USEITEMS28=
;首饰1
USEITEMS29=
;首饰2
USEITEMS30=
;首饰3
USEITEMS31=
;首饰4
USEITEMS32=
;首饰5
USEITEMS33=
;首饰6
USEITEMS34=
;神佑1
USEITEMS35=子鼠
;神佑2
USEITEMS36=
;神佑3
USEITEMS37=
;神佑4
USEITEMS38=
;神佑5
USEITEMS39=
;神佑6
USEITEMS40=
;神佑7
USEITEMS41=
;神佑8
USEITEMS42=
;神佑9
USEITEMS43=
;神佑10
USEITEMS44=
;神佑11
USEITEMS45=
;神佑12
USEITEMS46=

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


ini读写命令

Help > 功能相关 >
ini读写命令

命令格式:

读取配置文件命令: READCONFIGFILEITEM 文本路径 节点 关键字 保存变量

写入配置文件命令: WRITECONFIGFILEITEM 文本路径 节点 关键字 写入值

删除关键字命令: DELCONFIGFILEITEM 文本路径 节点 关键字

删除节点命令: DELCONFIGFILESECTION 文本路径 节点

读取配置文件命令: READCACHECONFIGFILEITEM 文本路径 节点 关键字 保存变量

写入配置文件命令: WRITECACHECONFIGFILEITEM 文本路径 节点 关键字 写入值

删除关键字命令: DELCACHECONFIGFILEITEM 文本路径 节点 关键字

删除节点命令: DELCACHECONFIGFILESECTION 文本路径 节点

带有CACHE的命令操作速度会比不带cache的快很多，问题就是，在M2运行过程中，只能用脚本操作，手动操作的无效。如果ini文件不存在手动操作的情况下，就用Cache
Cache的特点是，对ini的操作只打开一次，然后一直在内存缓存，所以只命令操作才有效，手动操作无效。关闭引擎时候才会保存到INI文件内，引擎运行期间一直内存中运行，所以启动引擎后手动修改INI文件信息是无效的
在没有手动操作ini的情况下，推荐用带cache的。不带cache的比较耗时。

示例:

测试文本.txt ,内容如下:

[张三]

性别=男

年龄=19

[李四]

性别=女

年龄=18

读取配置命令 : READCONFIGFILEITEM ..\QuestDiary\测试文本.txt 张三 年龄 N88

N88的读取结果为 19

写入配置命令: WRITECONFIGFILEITEM ..\QuestDiary\测试文本.txt 王五 性别 男

写入后文本内容如下:

[张三]

性别=男

年龄=19

[李四]

性别=女

年龄=18

[王五]

性别=男 此段为刚刚写入的内容

删除关键字命令: DELCONFIGFILEITEM ..\QuestDiary\测试文本.txt 张三 性别

删除后 [张三]节点下的 性别=男 将被删除

删除节点命令: DELCONFIGFILESECTION ..\QuestDiary\测试文本.txt 张三

删除后文本中就没有[张三]这个节点,以及节点内的关键字内容

文本中的内容:

[李四]

性别=女

年龄=18

[王五]

性别=男 此段为刚刚写入的内容

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


灵气功能

Help > 功能相关 >
灵气功能

功能：

增加灵气功能

[!] 增加人物/英雄变量：<$NIMBUS> <$H.NIMBUS> 灵气值，下线保存数据

[!] 增加NPC命令： //人物站在灵气附近，一定间隔时间可以吸收一定的灵气值，吸收多少取决于周围灵气大小和数量

检测人物灵气值: CHECKNIMBUS 比较符(><=) 数值

调整人物灵气值: NIMBUS 操作符(+-=) 数值

创建灵气地图: CreateMapNimbus 地图 密集度(1~255) 持久(秒) //创建地图灵气，密集度数字越小，产生的灵气越多

检测地图灵气数量: CheckMapNimbusCount 地图 >/</= 数量 //检测地图灵气数量

举列：

[@main]
文字提示请自己写!\? \
<我要强化主体技能/@WOW>
<我要强化英雄技能/@HERO>
[@WOW]
<$USERNAME>，欢迎！\
请选择你要强化技能的职业！\? \
<我要强化战士主体技能/@Warrior>\
<我要强化法师主体技能/@Wizard>\
<我要强化道士主体技能/@Taoist>\
[@Warrior]
你的灵气值为:<$NIMBUS>点，请选择你要强化的技能!? \ \
<强化攻杀剑法/@Warrior1> <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化半月弯刀/@Warrior2> <COLOR=clSkyBlue 需求等级40级,灵气值最低1000>\
<强化刺杀剑术/@Warrior3> <COLOR=clSkyBlue 需求等级55级,灵气值最低1000>\
<强化基本剑术/@Warrior4> <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化烈火剑法/@Warrior5> <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>?????? <返回/@MAIN>
[@Warrior1]
#ACT
MOV S1 攻杀剑法
//技能名称变量S1
MOV M1 <$NIMBUS>
//灵气值变量 M1
MOV S3 Warrior
//职业变量S3
MOV M2 35
//等级变量M2
DelayGoto 5 ~QIANGHUA
[@Warrior2]
#ACT
MOV S1 半月弯刀
MOV M1 <$NIMBUS>
MOV S3 Warrior
MOV M2 40
DelayGoto 5 ~QIANGHUA
[@Warrior3]
#ACT
MOV S1 刺杀剑术
MOV M1 <$NIMBUS>
MOV S3 Warrior
MOV M2 55
DelayGoto 5 ~QIANGHUA
[@Warrior4]
#ACT
MOV S1 基本剑术
MOV M1 <$NIMBUS>
MOV S3 Warrior
MOV M2 75
DelayGoto 5 ~QIANGHUA
[@Warrior5]
#ACT
MOV S1 烈火剑法
MOV M1 <$NIMBUS>
MOV S3 Warrior
MOV M2 95
DelayGoto 5 ~QIANGHUA
[@Wizard]
你的灵气值为:<$NIMBUS>点，请选择你要强化的技能! \ \
<强化爆裂火焰/@Wizard1> <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化雷电术/@Wizard2>?? <COLOR=clSkyBlue 需求等级55级,灵气值最低1000>\
<强化疾光电影/@Wizard3> <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化火墙/@Wizard4>???? <COLOR=clSkyBlue 需求等级75级,灵气值最低1000>\
<强化冰咆哮/@Wizard5>?? <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>?????? <返回/@MAIN>
[@Wizard1]
#ACT
MOV S1 爆裂火焰
MOV M1 <$NIMBUS>
MOV S3 Wizard
MOV M2 35
DelayGoto 5 ~QIANGHUA
[@Wizard2]
#ACT
MOV S1 雷电术
MOV M1 <$NIMBUS>
MOV S3 Wizard
MOV M2 55
DelayGoto 5 ~QIANGHUA
[@Wizard3]
#ACT
MOV S1 疾光电影
MOV M1 <$NIMBUS>
MOV S3 Wizard
MOV M2 75
DelayGoto 5 ~QIANGHUA
[@Wizard4]
#ACT
MOV S1 火墙
MOV M1 <$NIMBUS>
MOV S3 Wizard
MOV M2 75
DelayGoto 5 ~QIANGHUA
[@Wizard5]
#ACT
MOV S1 冰咆哮
MOV M1 <$NIMBUS>
MOV S3 Wizard
MOV M2 95
DelayGoto 5 ~QIANGHUA
[@Taoist]
你的灵气值为:<$NIMBUS>点，请选择你要强化的技能!? \ \
<强化施毒术/@Taoist1>???? <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化神圣战甲术/@Taoist2> <COLOR=clSkyBlue 需求等级50级,灵气值最低1000>\
<强化幽灵盾/@Taoist3>???? <COLOR=clSkyBlue 需求等级60级,灵气值最低1000>\
<强化召唤骷髅/@Taoist4>?? <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化灵魂火符/@Taoist5>?? <COLOR=clSkyBlue 需求等级90级,灵气值最低1000>\
<强化召唤神兽/@Taoist6>?? <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>????? <返回/@MAIN>
[@Taoist1]
#ACT
MOV S1 施毒术
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 35
DelayGoto 5 ~QIANGHUA
[@Taoist2]
#ACT
MOV S1 神圣战甲术
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 50
DelayGoto 5 ~QIANGHUA
[@Taoist3]
#ACT
MOV S1 幽灵盾
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 60
DelayGoto 5 ~QIANGHUA
[@Taoist4]
#ACT
MOV S1 召唤骷髅
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 70
DelayGoto 5 ~QIANGHUA
[@Taoist5]
#ACT
MOV S1 灵魂火符
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 90
DelayGoto 5 ~QIANGHUA
[@Taoist6]
#ACT
MOV S1 召唤神兽
MOV M1 <$NIMBUS>
MOV S3 Taoist
MOV M2 95
DelayGoto 5 ~QIANGHUA

[~QIANGHUA]
#IF
CHECKJOB <$STR(S3)>
#ACT
QUERYVALUE 2 2 10 @NowQIANGHUA 你确定提升【<$STR(S1)>】【<$STR(M1)>】点熟练度？ LEGENDM2
#ELSEACT
MESSAGEBOX 错误！你正在试图提升其它职业技能!
[@NowQIANGHUA]
#IF
CHECKLEVELEX < <$STR(M2)>
#ACT
MESSAGEBOX <$STR(M2)>级以上才可以提升<$STR(S1)>熟练度!
BREAK
#IF
CHECKMAGICNAME <$STR(S1)>
CHECKNIMBUS ? 1000
#ACT
NIMBUS - <$STR(M1)>
ChangeTranPoint <$STR(S1)> + <$STR(M1)>
SENDMSG 7 恭喜您的<$STR(S1)>技能点数提升了<$STR(M1)>点熟练度!
SENDMSG 0 恭喜【%S】成功提升<$STR(S1)>熟练度<$STR(M1)>点！技能再次飞跃！
break
#ELSEACT
MESSAGEBOX 你的灵气不足1000点，或者你没有学习<$STR(S1)>！
[@HERO]
<$USERNAME>，欢迎！\
请选择你要强化英雄技能的职业！\? \
<我要强化战士英雄技能/@HEROWarrior>\
<我要强化法师英雄技能/@HEROWizard>\
<我要强化道士英雄技能/@HEROTaoist>\
[@HEROWarrior]
你英雄的灵气值为:<$H.NIMBUS>点，请选择你英雄要强化的技能!\ \
<强化英雄攻杀剑法/@HEROWarrior1> <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化英雄半月弯刀/@HEROWarrior2> <COLOR=clSkyBlue 需求等级40级,灵气值最低1000>\
<强化英雄刺杀剑术/@HEROWarrior3> <COLOR=clSkyBlue 需求等级55级,灵气值最低1000>\
<强化英雄基本剑术/@HEROWarrior4> <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化英雄烈火剑法/@HEROWarrior5> <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>?? <返回/@MAIN>
[@HEROWarrior1]
#ACT
MOV S1 英雄攻杀剑法
MOV M1 <$H.NIMBUS>
MOV S3 Warrior
MOV M2 35
DelayGoto 5 ~HEROQIANGHUA
[@HEROWarrior2]
#ACT
MOV S1 英雄半月弯刀
MOV M1 <$H.NIMBUS>
MOV S3 Warrior
MOV M2 40
DelayGoto 5 ~HEROQIANGHUA
[@HEROWarrior3]
#ACT
MOV S1 英雄刺杀剑术
MOV M1 <$H.NIMBUS>
MOV S3 Warrior
MOV M2 55
DelayGoto 5 ~HEROQIANGHUA
[@HEROWarrior4]
#ACT
MOV S1 英雄基本剑术
MOV M1 <$H.NIMBUS>
MOV S3 Warrior
MOV M2 70
DelayGoto 5 ~HEROQIANGHUA
[@HEROWarrior5]
#ACT
MOV S1 英雄烈火剑法
MOV M1 <$H.NIMBUS>
MOV S3 Warrior
MOV M2 95
DelayGoto 5 ~HEROQIANGHUA
[@HEROWizard]
你英雄的灵气值为:<$H.NIMBUS>点，请选择你英雄要强化的技能!? \ \
<强化英雄爆裂火焰/@HEROWizard1> <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化英雄雷电术/@HEROWizard2>?? <COLOR=clSkyBlue 需求等级55级,灵气值最低1000>\
<强化英雄疾光电影/@HEROWizard3> <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化英雄火墙/@HEROWizard4>???? <COLOR=clSkyBlue 需求等级75级,灵气值最低1000>\
<强化英雄冰咆哮/@HEROWizard5>?? <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>?? <返回/@MAIN>
[@HEROWizard1]
#ACT
MOV S1 英雄爆裂火焰
MOV M1 <$H.NIMBUS>
MOV S3 Wizard
MOV M2 35
DelayGoto 5 ~HEROQIANGHUA
[@HEROWizard2]
#ACT
MOV S1 英雄雷电术
MOV M1 <$H.NIMBUS>
MOV S3 Wizard
MOV M2 55
DelayGoto 5 ~HEROQIANGHUA
[@HEROWizard3]
#ACT
MOV S1 英雄疾光电影
MOV M1 <$H.NIMBUS>
MOV S3 Wizard
MOV M2 70
DelayGoto 5 ~HEROQIANGHUA
[@HEROWizard4]
#ACT
MOV S1 英雄火墙
MOV M1 <$H.NIMBUS>
MOV S3 Wizard
MOV M2 75
DelayGoto 5 ~HEROQIANGHUA
[@HEROWizard5]
#ACT
MOV S1 英雄冰咆哮
MOV M1 <$H.NIMBUS>
MOV S3 Wizard
MOV M2 95
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist]
你英雄的灵气值为:<$H.NIMBUS>点，请选择你英雄要强化的技能!? \ \
<强化英雄施毒术/@HEROTaoist1>???? <COLOR=clSkyBlue 需求等级35级,灵气值最低1000>\
<强化英雄神圣战甲术/@HEROTaoist2> <COLOR=clSkyBlue 需求等级50级,灵气值最低1000>\
<强化英雄幽灵盾/@HEROTaoist3>???? <COLOR=clSkyBlue 需求等级60级,灵气值最低1000>\
<强化英雄召唤骷髅/@HEROTaoist4>?? <COLOR=clSkyBlue 需求等级70级,灵气值最低1000>\
<强化英雄灵魂火符/@HEROTaoist5>?? <COLOR=clSkyBlue 需求等级90级,灵气值最低1000>\
<强化英雄召唤神兽/@HEROTaoist6>?? <COLOR=clSkyBlue 需求等级95级,灵气值最低1000>\ \
<COLOR=clBlue 强化技能时该技能你必须学习！>?? <返回/@MAIN>
[@HEROTaoist1]
#ACT
MOV S1 英雄施毒术
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 35
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist2]
#ACT
MOV S1 英雄神圣战甲
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 50
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist3]
#ACT
MOV S1 英雄幽灵盾
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 60
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist4]
#ACT
MOV S1 英雄召唤骷髅
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 70
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist5]
#ACT
MOV S1 英雄灵魂火符
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 90
DelayGoto 5 ~HEROQIANGHUA
[@HEROTaoist6]
#ACT
MOV S1 英雄召唤神兽
MOV M1 <$H.NIMBUS>
MOV S3 Taoist
MOV M2 95
DelayGoto 5 ~HEROQIANGHUA

[~HEROQIANGHUA]
#IF
H.CHECKJOB <$STR(S3)>
#ACT
QUERYVALUE 2 2 10 @HERONowQIANGHUA 你确定提升【<$STR(S1)>】【<$STR(M1)>】点熟练度？ LEGENDM2
#ELSEACT
MESSAGEBOX 错误！你正在试图提升其它职业技能熟练度!
[@HERONowQIANGHUA]
#IF
H.CHECKLEVELEX < <$STR(M2)>
#ACT
MESSAGEBOX 你的英雄<$STR(M2)>级以上才可以提升<$STR(S1)>熟练度!
BREAK
#IF
H.CHECKMAGICNAME <$STR(S1)>
H.CHECKNIMBUS ? 1000
#ACT
H.NIMBUS - <$STR(M1)>
H.ChangeTranPoint <$STR(S1)> + <$STR(M1)>
SENDMSG 7 恭喜您英雄的<$STR(S1)>技能点数提升了<$STR(M1)>点熟练度!
SENDMSG 0 恭喜【%S】的英雄成功提升<$STR(S1)>熟练度<$STR(M1)>点！技能再次飞跃！
break
#ELSEACT
MESSAGEBOX 你英雄的灵气不足1000点，或者你英雄没有学习<$STR(S1)>！


挖宝功能

Help > 功能相关 >
挖宝功能

[+] 挖宝： //挖出的装备必出神秘属性
//神秘属性：主要优势是可以解读比较好的神秘属性，如复活属性，五岳独尊技能等

相关脚本: 寻宝人.txt
增加地图标志 DIGITEM(X)
X=0不加宝藏
X的密集度范围建议1~200，数字越大，密集度越小，每个地图加载了多少宝藏可以在M2加载时看到，
X取值多少请根据地图大小和个人意愿自行确定
宝藏一定时间内会被挖完，间隔数分钟后会自动适量补充
挖到物品后触发QFunction的[@DigItem]

部分物品DB

7;新手铲;5;77;5;0;0;0;2381;10000;0;0;0;0;0;10;0;0;0;0;0;10;1500;50;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
//一般概率，挖一般物品
8;铁铲;5;77;5;1;0;0;2381;16000;0;0;0;0;0;30;0;0;0;0;0;10;1500;50;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
//一般概率，挖一般物品
9;金刚铲;5;76;5;2;0;0;2382;16000;0;0;0;0;0;30;0;0;0;0;0;10;1500;50;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
//中等概率，挖中等物品
10;乌金铲;5;75;5;3;0;0;2383;16000;0;0;0;0;0;30;0;0;0;0;0;10;1500;50;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
//较好概率，挖较好物品
11;除魔灵媒;56;10;1;0;0;0;2380;1;200;250;0;0;0;0;0;0;0;0;0;1;8000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
//ac=品质
ac2=灵气值
12;灵气神水;2;3;1;0;0;0;17;10000;0;0;0;0;0;0;0;0;0;0;0;1;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;

[+] 挖宝物品配置文件：\Envir\DigItemList.txt，修改后，在M2菜单-重新加载-地图挖宝配置 生效
挖到的宝物是否提示，请在\Envir\HintItemList.txt 添加，可以包括 声望，经验，元宝 等等。
文件内容如下：
-----------------------------------------------------------------------------
;[地图名] 例如：[3] 表示是盟重的挖宝配置
;难度分类 0=灵媒品质(1-50) 1=灵媒品质(51-100) 2=灵媒品质(101-150) 3=灵媒品质(151-250) 4=灵媒品质(250-255)
;物品名称 难度分类 数量 几率

[3]
声望 0 50000 30
经验 1 50000 40
金刚石 2 5000 50
内功 3 5000 60
灵符 2 100 70

炎龙战盔 0 1 50
雷龙魔盔 0 1 50
青龙道盔 0 1 50
炎龙项链 0 1 50
雷龙项链 0 1 50
青龙项链 0 1 50
炎龙护腕 0 1 50
雷龙护腕 0 1 50
青龙护腕 1 1 50
炎龙战戒 0 1 50
雷龙魔戒 0 1 50
青龙道戒 1 1 50
炎龙腰带 0 1 50
雷龙腰带 1 1 50
青龙腰带 0 1 50
炎龙战靴 0 1 50
雷龙魔靴 0 1 50
青龙道靴 0 1 50

内功 3 1000000 100
何首凝神酒 3 1 65535
虎威战盔 3 1 65535
虎威魔盔 3 1 65535
虎威道盔 3 1 65535
虎威项链(战) 3 1 65535
虎威项链(法) 3 1 65535
虎威项链(道) 3 1 65535
虎威战靴 3 1 65535
-----------------------------------------------------------------------------

[@main]
宝物之间有一定的灵犀存在，鉴宝师可以帮你分辨你的宝物到底是\
不是灵媒，如果是灵媒，你可以把它放在灵媒探索位，对，就是界\
面左下角那个框，用快截键<COLOR=clRed CTRL+X>就可以探寻宝物的存在。\
<购买铲子/@购买铲子> <如何寻宝/@如何寻宝>\
<如何挖宝/@如何挖宝> <关于灵媒/@关于灵媒>\
<回收除魔灵媒/@回收除魔灵媒>\

[@回收除魔灵媒]
你要是除魔灵媒太多，可以交给我，我免费回收。\
<COLOR=clRed 点击下面的按钮将回收包裹中所有的除魔灵媒，请确认。>\
<回收包裹中的所有除魔灵媒/@回收>\

[@回收]
你确定要回收掉<COLOR=clRed 包裹中所有的除魔灵媒吗？>\ \
<确定/@确定>\

[@确定]
#IF
CHECKITEM 除魔灵媒 1
#ACT
TAKE 除魔灵媒 999
close
#ELSESAY
您的背包中没有除魔灵媒啊！\ \

[@关于灵媒]
通过鉴宝师的鉴定，任何宝物都有可能成为灵媒。每个灵媒都有自\
己的品质，品质越高的灵媒，越有可能寻找到好的宝物，使用最好\
的灵媒甚至可以挖到天龙装备和神戒！不过每次挖到一件宝物，灵\
媒的品质都会有所降低。每次使用灵媒会扣除灵媒一定的灵气值，\
灵媒的灵气值可以使用灵气神水来补充，灵气神水可以在商城购买\
得到。\
<返回/@MAIN>\

[@如何挖宝]
只有用我特制的新手铲、铁铲、金刚铲、乌金铲才能挖掘到宝物，\
用的铲子越好，挖掘范围则越大，挖掘速度也越快。\ \
<购买铲子/@购买铲子>\
<返回/@MAIN>\

[@如何寻宝]
     要想寻找宝物，首先你必须有一个宝物灵媒，任何可鉴定的物\
品都可能是宝物灵媒，你要去鉴定师那里进行鉴定，如果你的某件\
装备被鉴定为宝物灵媒，你可以把它放在灵媒探索位，放好之后，\
按下<COLOR=clRed CTRL+X>快截键就可以使用灵媒了。\
     在某些地图，例如<COLOR=clRed 祖玛七层大厅、雷炎二层、宫殿迷宫、霸者>\
<COLOR=clRed 大厅、连接通道、石墓七层、尸魔洞三层、骨魔洞五层、沃玛寺庙>\
<COLOR=clRed 、行会遗迹地图>等都有大量宝物的存在，在这些地图中，灵媒更容\
易感应到宝物的存在。在以上地图中，当你使用灵媒的时候，灵媒\
<下一页/@下一页> <返回/@MAIN>\

[@下一页]
会给你指示宝物所在的方位，当你离很近的时候，灵媒会给你指示\
宝物所在的范围，你离宝物越近，灵媒给你的提示也会不同，你需\
要<COLOR=clRed 细心琢磨>，快速掌握挖宝的诀窍哦！\
<上一页/@如何寻宝> <返回/@MAIN>\

[@购买铲子]
只有用我特制的新手铲、铁铲、金刚铲、乌金铲才能挖掘到宝物，\
用的铲子越好，挖掘范围则越大，挖掘速度也越快。\
<使用5000金币购买新手铲/@新手铲>\
<使用1元宝购买铁铲/@铁铲>\
<使用10元宝购买金刚铲/@金刚铲>\
<使用50元宝购买乌金铲/@乌金铲>\
<返回/@MAIN>\

[@乌金铲]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
GIVE 乌金铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@金刚铲]
#IF
CHECKGAMEGOLD > 9
#ACT
GAMEGOLD - 10
GIVE 金刚铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@铁铲]
#IF
CHECKGAMEGOLD > 0
#ACT
GAMEGOLD - 1
GIVE 铁铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@新手铲]
#IF
CHECKGOLD 5000
#ACT
TAKE 金币 5000
GIVE 新手铲 1
close
#ELSESAY
购买新手铲需要5000金币，你没有足够的金币。\ \
<返回/@购买铲子>


鉴定功能

Help > 功能相关 >
鉴定功能

功能：

[!] 鉴定：

神秘属性(未解读)，可以解出麻痹，护身等属性，也可以解读出特殊技能，请参考面版设置

相关脚本: 鉴定师.txt

示例：StdItem.DB

1;卷轴碎片;41;0;1;0;0;0;650;1;0;0;0;0;0;0;0;0;0;0;0;1;1000;1000;0;1;0;0;0;0;0;0;0;0;0;0;0;0;; //交换 鉴定卷轴
2;羊皮卷;41;50;1;0;0;0;2377;1;0;0;0;0;0;0;0;0;0;0;0;1;8000;5000;0;1;0;0;0;0;0;0;0;0;0;0;0;0;; //制作 神秘卷轴
3;神秘卷轴;56;0;1;0;0;0;2373;1;0;0;0;0;0;0;0;0;0;0;0;1;8000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
4;一级鉴定卷轴;56;1;1;0;0;0;2370;1;0;0;0;0;0;0;0;0;0;0;0;1;8000;5000;0;1;0;0;0;0;0;0;0;0;0;0;0;0;;
5;二级鉴定卷轴;56;2;1;0;0;0;2371;1;0;0;0;0;0;0;0;0;0;0;0;1;8000;5000;0;1;0;0;0;0;0;0;0;0;0;0;0;0;;
6;三级鉴定卷轴;56;3;1;0;0;0;2372;1;0;0;0;0;0;0;0;0;0;0;0;1;8000;5000;0;1;0;0;0;0;0;0;0;0;0;0;0;0;;

关于解读出的特殊技能：
服饰和武器都可以解读出来，但是必须佩带武器，才能拥有指定的技能，
服饰带的技能Lv+1属性，是在武器带了该技能的情况下，用来增加技能的等级。
解读出特殊技能时，触发QFunction的[@SecretProperty_Skill]
同时赋予S98=技能名，S99=装备名，目前支持技能：五岳独尊，召唤巨魔，神龙附体，倚天劈地
例：
[@SecretProperty_Skill]
#ACT
SendScrollMsg [神秘解读]：<$USERNAME>的<$STR(S99)>解读出<$STR(S98)>特技 253 16

高级鉴定功能：(可鉴定出主宰装备)

高级鉴定几率控制面版：

高级鉴定获得的主宰装备是否提示，请在\Envir\HintItemList.txt 添加主宰套装。


MapEvent.txt地图坐标触发事件

Help > 功能相关 >
MapEvent.txt地图坐标触发事件

功能：
       地图坐标触发,到达指定坐标按指定条件触发

说明：
       配置文件Mir200\Envir\MapEvent.txt

;触发标识
==================
; 标识:(-1 - 800) -1 代表不检查标识
; 值: (0 - 1)

;触发条件
==================
; 格式: 代码:物品:组队
; 代码: 0:无效 1:扔物品 2:捡物品 3:挖矿 4:走路(不支持物品条件) 5:跑步(不支持物品条件)
; 物品: (物品名称 - *) * 代表不需要物品
; 组队: (0 - 1) 0为不需要组队，1为必须组队才触发(支持)

;触发机率
==================
; 数字越大，机率越低
; 范围:(0 - 999999) 0 的机率为100%

;事件类型
==================
; 格式: 代码:内容
; 代码:(现在只支持脚本事件)
; 0:无效 1:调用脚本(调用QFunction-0.txt中的内容)

;注意事项
==================
;在相同地图座标，不支持相同触发标识及条件(触发条件中的物品名称除外)，如果有相同的设置，只有最后一个设置有效
;地图号 座标X 座标Y 范围 触发标识 触发条件 触发机率 事件类型
3 333 333 5 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 333 333 5 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
3 338 331 5 -1:1 3:*:0 2 1:@MapEventMine
3 330 330 5 -1:1 4:*:0 2 1:@MapEventWalk
3 331 335 5 -1:1 5:*:0 2 1:@MapEventRun

示例：

;==========================================
;Mir200\Envir\MapEvent.txt中内容
3 333 333 2 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 333 333 2 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
;==========================================
;QFunction-0.txt中的内容
[@MapEventDropItem]
#Act
SendMsg 1 <$USERNAME>在(%M,%X,%Y)丢掉物品：回城卷
[@MapEventPickUpItem]
#Act
SendMsg 1 <$USERNAME>在(%M,%X,%Y)拣到物品：回城卷
;==========================================

使用瞬间移动功能，并且 当前地图<>目标地图
瞬移之前，触发 QMapEvent-0.txt 的 [@ONMAPCHANGING]
瞬移之后，触发 QMapEvent-0.txt 的 [@ONMAPCHANGED]
例：
NPC1： //进MAP001地图，限时30分钟
--------------------------------------------
TimeRecall 30
MAP MAP001

QMapEvent： //在MAP001瞬移到其他地图，清理TimeRecall
--------------------------------------------
[@ONMAPCHANGING]
#IF
ISONMAP MAP001
#ACT
BreakTimeRecall


多级脚本的使用

Help > 功能相关 >
多级脚本的使用

功能：多级脚本使用

说明：本功能的实现突破执行脚本的唯一性，使脚本的使用更加灵活多变，使用方法为 任意人物名称. 任意脚本命令。以下所使用的RED引擎 名称等全部支持变量操作
格式：
H. 表示是英雄
O. 表示是主人
M. 表示是怪物(当前攻击目标)
P. 表示是对面的角色
L. 表示是当前攻击自己角色

例：

#if
RED引擎.CheckLevel 51
CheckLevel 51
#act
RED引擎.GameGold + 10
GameGold + 10
#say
RED引擎的等级在50级以上，给予10元宝奖励
你的等级也在50级以上，给予10元宝奖励
上面脚本，如果RED引擎不在线，M2会提示出错，但脚本会继续执行并跳过该句做为无效检测处理
当做为无效检测处理后，只要RED引擎等级和自己的等级在50级以上，既执行#say和#act段，
并且，RED引擎.GameGold + 10 该句也无法执行，被跳过，继续执行下面的
所以在使用多级的时候请注意脚本的使用

#if
H.CheckLevelEx > 1
#say
你的英雄大于1级
#if
P.CheckLevelEx > 1
#say
你的对面的角色大于1级
;怪物操作，一般用在攻击触发里
#if
#act
M.HumanHP + 100

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


浑水摸鱼模式

Help > 功能相关 >
浑水摸鱼模式
浑水摸鱼地图参数计算器

是否禁止说话 | 1为是，0为否
是否禁止名字变色 | 2为是，0为否
是否禁看目标装备 | 4为是，0为否
是否统一角色名字 | 8为是，0为否
是否统一装备外观 | 16为是，0为否
第一参数值计算结果 |

参数格式：
   SECRET(第一参数值|固定名字|衣服的统一外观shape|武器的统一外观shape )

参数说明：
  //第1参数非0，则本地图的人物、英雄 HP将以百分比显
  //第2参数：固定显示所有地图内玩家名字
  //第3参数：衣服的统一外观shape；
  //第4参数：武器的统一外观shape；

范例：
[3 盟重省] SECRET(31|神秘人|2|21)


文本解析大全

Help > 功能相关 >
文本解析大全

所有参数均支持变量, 注意书写格式 <ITEMSHOW:[$STR(S5)]:1:30:[$STR(S6)]:0:0>

物品秀:

<ITEMSHOW:A:B:C:D:E:F/@LABLE>

A=物品IDX

B=显示数量(0为不显示数量)

C=X坐标

D=Y坐标

E=物品框编号, PC端读取是必备补丁NewopUi中的图片, APP是读取res/private/tip/bg_icon_NPC.png

F=是否显示特效(0否1是)

@LABLE(可省略)= 跳转字段

个人装备秀:

<EQUIPSHOW:A:B:C:D:E:F/@LABLE>

A=对象(0自己,1英雄)

B=装备位置(0~34)

C=X坐标

D=Y坐标

E=物品框编号, PC端读取是必备补丁NewopUi中的图片, APP是读取res/private/tip/bg_icon_NPC.png

F=是否显示特效(0否1是)

@LABLE(可省略)= 跳转字段

图片:

<IMGS:A:B:C:D:E:提示/@LABLE>

A=WIL序号

B=图片编号

C=X坐标

D=Y坐标

E=绘制模式(0普通1混合)

提示(可省略)=备注提示

@LABLE(可省略)=跳转字段

按钮:

<IMGEX:A:B:C:D:E:F:G:提示/@LABLE>

A=WIL序号

B=正常图片

C=经过图片

D=按下图片

E=X坐标

F=Y坐标

G=绘制模式(0普通1混合)

提示(可省略)=备注提示

@LABLE=跳转字段

动画效果:

<PLAYIMG:A:B:C:D:E:F:G:H:提示/@LABLE>

A=WIL序号

B=开始图片

C=播放数量

D=播放间隔(毫秒)

E=X坐标

F=Y坐标

G=绘制模式(0普通1混合)

H=播放次数(0为无限)

提示(可省略)=备注提示

@LABLE(可省略)=跳转字段

OK框:

<ITEMBOX:A:B:C:D:E:F:G:H:提示>

A=OK框编号(0-12)

B=WIL序号

C=背景框

D=X坐标

E=Y坐标

F=OK框宽

G=OK框高

H=可放入的类型, 多种类型用英文","隔开, *为不限制

提示=备注提示

TEXT:

<TEXT:A:B:C{FCOLOR=253}/@LABLE>

A=文字内容

B=X坐标

C=Y坐标

{}(可省略)=颜色值

@LABLE(可省略)=跳转字段

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


NPC对话框彩色文字

Help > 功能相关 >
NPC对话框彩色文字

彩色字体:

彩色字体所有参数均支持变量, 格式如: <[$STR(S8)]/FCOLOR=[$STR(S9)]>

功能：
格式一: <COLOR=clSkyBlue 你好！>\<关闭/@exit>

格式二: <哈喽,你好!/FCOLOR=253> 颜色值参考: 颜色对照表

格式三: <哈喽,你好!/SCOLOR= 253> 颜色值参考: 颜色对照表

格式：

例：<COLOR=clSkyBlue 你好！>\<关闭/@exit>
clBlack, clMaroon, clGreen, clOlive, clNavy, clPurple, clTeal, clGray,
clSilver, clRed, clLime, clYellow, clBlue, clFuchsia, clAqua, clLtGray,
clDkGray, clWhite, clMoneyGreen, clSkyBlue, clCream, clMedGray

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


物品备注解析

Help > 功能相关 >
物品备注解析

物品备注解析说明:

此功能仅支持GOM装备信息显示模式

"\" 换行符

"253/" 颜色符号

"-" 分割线

特别说明:

备注内容中, 第一段文字前面不带颜色符号的为顶部备注, 如不需要顶部备注就添加上颜色符号

例如: 屠龙=我是副标题\-\243/我是底部备注\70/[物品类型]：/253/武器\-\251/武器详情：/249/[单件激活]\-\<IMG:1:751:10:0:0>

效果如下:

播放动画:

<PLAYIMG:A:B:C:D:E:F:G>

A=WIL资源编号

B=开始图片

C=播放数量

D=播放间隔

E=X坐标

F=Y坐标

G=绘制模式(0普通,1混合)

展示图片:

<IMG:A:B:C:D:E> 或 <PIC:A:B:C:D:E>

A=WIL编号

B=开始图片

C=X坐标

D=Y坐标

E=绘制模式(0普通,1混合)

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


镜像地图功能

Help > 功能相关 >
镜像地图功能

镜像地图功能:

创建镜像地图: ADDMIRRORMAP 原地图代码 镜像地图代码 镜像地图名字 有效时间(秒) 返回地图代码

删除镜像地图: DELMIRRORMAP 镜像地图代码 返回地图代码 延迟删除时间(秒, 为空或者0时立即删除镜像地图)

设置镜像地图有效时间: SETMIRRORMAPTIME 镜像地图代码 操作符(+-=) 时间(秒)

获取镜像地图剩余时间: GETMIRRORMAPTIME 镜像地图代码 保存变量

可以用 CHECKMAP命令来检测镜像地图是否创建成功! 相关链接: 检测地图是否存在

不举例了, 老手不用举例, 新手举例也没用


扩展NPC脚本点击触发带参数

Help > 功能相关 >
扩展NPC脚本点击触发带参数

功能说明:

NPC点击传递参数

示例:

[@main]
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\

[@购物]

#if

checkgold <$SCRIPTPARAM(0)>

#act

take 金币 <$SCRIPTPARAM(0)>

give <$SCRIPTPARAM(1)> 1

sendmsg 6 成功购买<$SCRIPTPARAM(1)>,消耗金币<$SCRIPTPARAM(0)>个

这里<$SCRIPTPARAM(0)>就等于是括号里第一个参数 20 , <$SCRIPTPARAM(1)>等于括号里第二个参数

四个选项点击哪个就等于哪个.

最多支持6个参数, 所有参数均支持变量, 例如: <麻痹戒指/@购物(20,麻痹戒指, [$STR(T0)],[$STR(T1)],[$STR(T2)])>

SENDMSG 6 <$SCRIPTPARAM(0)>,<$SCRIPTPARAM(1)>,<$SCRIPTPARAM(2)>


LINKITEM和UPITEMDATE

Help > 功能相关 >
LINKITEM和UPITEMDATE

命令格式:

LINKITEM 装备位置

UPITEMDATE 装备位置

锁定与解锁装备位置

引擎中 每个修改装备属性的命令在每次修改完成后都会向客户端发送刷新该装备的属性,

写脚本时如果对一件装备有大量的修改属性命令,就会导致短时间内向客户端发送多次装备刷新数据,从而增加引擎负担,

如果使用LINKITEM命令 ,锁定该装备数据, 中间进行任意次数的属性修改, 直到命令执行到UPITEMDATE 对装备数据解锁

才会发送一次该装备刷新数据, 极大减轻了服务器负担.

该命令只是优化数据处理,所有修改装备属性的脚本,

GM可自行选择使用该命令,对脚本实际效果没有影响,

示例:

[@main]

#if

#act

LINKITEM 1 // 锁定位置1 为 武器位置

CHANGEITEMNAME 1 超级屠龙

CHANGEITEMNAMECOLOR 1 253

UPITEMDATE 1 //解锁位置 1 要和锁定位置相同

sendmsg 6 你的武器已经更名为超级屠龙


NPC对话框文字缩放

示例:

[@main]

150&&&

这是一个测试NPC对话框内容!\

<这里是测试按钮/@测试按钮> <关闭/@exit>

[@测试按钮]

#if

#act

sendmsg 6 测试内容!

以上内容中 150&&& 是调整当前页面文字缩放比例 150为缩放比 &&&为分隔符 后面不需要带换行符!

切记一定要写到NPC对话内容的第一行 如不填写则默认为 55 缩放比


预留按钮

增加一些预留按钮, 可以在UI编辑中修改按钮的可见性属性来控制显示或隐藏

编号0-4 主界面

编号5-9 人物背包

触发字段QF文件中 @DefButtonClick序号

按钮的组件名字为 DefButton0 ....DefButton9 ,最后的编号就是触发QF字段的序号

例如:

[@DefButton6]

#act

sendmsg 6 点击触发编号6按钮


装备星星功能

检测装备星星数量: CHECKUPGRADECOUNT 物品位置 比较符(><=) 数量

修改装备星星数量: CHANGEITEMUPGRADECOUNT 物品位置 操作符(+-=) 数量(1-255)

获取星星数量: GETUPGRADECOUNT 位置(ALL或者*为全身) 保存变量

相关变量: <$UPGRADECOUNT> 角色全身星星数量 英雄为: <$H.UPGRADECOUNT>

示例:

不想举例了


寄售行功能

须在脚本头部写上 (@Consignment), 脚本点击字段 @Consignment

示例:

(@Consignment)

[@main]

你好,这里是寄售行,请问有什么需求?\ \ \ \

<打开寄售行/@Consignment>\ \

<关闭/@exit>


文本缓存操作命令

写入字符串到文本 AddCacheTextList 文本路径 字符串

删除文本指定字符串 DelCacheTextList 文本路径 字符串

检查字符串是否在文本中 CheckCacheStringList 文本路径 字符串

清空指定文本 ClearCacheNameList 文本路径

注：这4个是 Cache(缓存)，操作速度会比不带cache的快很多，问题就是，在M2运行过程中，只能用脚本操作，手动操作的无效。如果ini文件不存在手动操作的情况下，就用Cache
Cache的特点是，对ini的操作只打开一次，然后一直在内存缓存，所以只命令操作才有效，手动操作无效。关闭引擎时候才会保存到INI文件内，引擎运行期间一直内存中运行，所以启动引擎后手动修改INI文件信息是无效的
在没有手动操作ini的情况下，推荐用带cache的。不带cache的比较耗时。

提示: 如果某个文件.txt 已经用Cache命令操作过,就不要再使用不带Cache的命令进行操作,以免引擎关闭时数据被覆盖


限时物品说明

计时物品 | 限时物品带到身上开始计时,放在背包不计算时间.(每分钟检测一次) 物品Need=101时限时物品,NeedLevel=时间(分钟)
计时物品 | 计时物品增加物品Need=102时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 穿戴即刻计算时间，就是丢背包也计算时间！
计时物品 | 计时物品增加物品Need=103时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 给予(物品刷或者爆出开始计算)时即刻计算时间，无论是穿戴或放在背包（在线就计算时间）！
计时物品 | 计时物品增加物品Need=104时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 给予(物品刷或者爆出开始计算)时即刻计算时间，无论角色是否在线，物品正常计算时间（无论是否使用，是否在线都计算时间）！

提示: 叠加物品不支持限时


概率执行命令

Help > 检测命令 >
概率执行命令

命令格式:

Random 数值

例如数值为 10 ,从1~10之间取值, 如果取到1就执行,否则就不执行!

RandomEx 分子 分母

例如分子为5, 分母为8, 就是有8分之5的概率执行,否则就不执行!

示例一:

[@main]

#if

random 5

#act

sendmsg 6 你的运气不错!

#elseact

sendmsg 5 运气有点差啊 !

示例二:

[@main]

#if

RandomEx 5 8

#act

sendmsg 6 你的运气不错!

#elseact

sendmsg 5 运气有点差啊 !


检测性别命令

Help > 检测命令 >
检测性别命令

命令格式:

GENDER (MAN男/WOMAN女)

[@main]

#if

GENDER MAN

#act

sendmsg 6 你是个男娃!

#elseact

sendmsg 5 你是个女娃!

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测游戏时段

Help > 检测命令 >
检测游戏时段

命令格式:

DAYTIME 数值(0,1,2,3)

0代表黎明,1代表白天,2代表黄昏,3代表夜晚

[@main]

#if

DAYTIME 0

#act

sendmsg 6 现在游戏里的时段是黎明

#if

DAYTIME 1

#act

sendmsg 6 现在游戏里的时段是白天


检测角色等级

Help > 检测命令 >
检测角色等级

命令格式:

CHECKLEVEL 数值

人物当前等级大于或者等于数值则执行

CHECKLEVELEX (>,<,=) 数值

根据比较符号来判断玩家的等级

示例一:

[@main]

#if

CHECKLEVEL 50

#act

sendmsg 6 你当前的等级大于49级

#elseact

sendmsg 5 你的等级还不足50级,还需多多努力

示例二:

[@main]

#if

checklevelex > 50

#act

sendmsg 6 你当前等级大于50


检测角色职业

Help > 检测命令 >
检测角色职业

命令格式:

CHECKJOB (warrior, wizard, taoist)

warrior 为战士, wizard 为法师, taoist 为道士

示例:

[@main]

#if

CHECKJOB wizard

#act

sendmsg 6 你是法师职业


检测宝宝数量

Help > 检测命令 >
检测宝宝数量

命令格式:

CHECKBBCOUNT 数值

检测宝宝数量是否大于或等于数值

CHECKSLAVECOUNT 比较符(><=) 数值

示例一:

[@main]

#if

CHECKBBCOUNT 5

#act

sendmsg 6 你已经有5只宝宝了

示例二:

[@main]

#if

CHECKSLAVECOUNT < 4

#act

sendmsg 6 你的宝宝不足4只


检测物品数量

Help > 检测命令 >
检测物品数量

命令格式:

CHECKITEM 物品名字 物品数量

检测背包里是否有指定数量的物品

CHECKITEMW 装备名字 装备数量

检测角色身上是否装备了指定数量的装备

示例一:

[@main]

#if

checkitem 圣战戒指 1

#act

sendmsg 6 你背包里有圣战戒指

示例二:

[@main]

#if

checkitemw 圣战手镯 2

#act

sendmsg 6 你身上装备了2个圣战手镯


检测金币数量

Help > 检测命令 >
检测金币数量

命令格式:

CHECKGOLD 数值

检测角色当前拥有的金币值是否大于或等于数值

示例:

[@main]

#if

CHECKGOLD 998

#act

sendmsg 6 花998来做一次足疗吧

#elseact

sendmsg 6 穷比滚


检测物品持久(纯度)

Help > 检测命令 >
检测物品持久(纯度)

命令格式:

CHECKDURA 物品名字 持久(纯度) ←该持久为除以1000后的数值

检测背包里该物品中有没有大于或者等于这个持久的物品

CHECKDURAEVA 物品名字 持久(纯度)

检测背包中的所有该物品持久总和的平均值是否大于或等于该持久值

示例一:

[@main]

#if

CHECKDURA 黑铁矿石 8

#act

sendmsg 6 你背包中有纯度8及以上的黑铁矿石

示例二:

[@main]

#if

CHECKDURAEVA 金矿 10

#act

sendmsg 6 你背包里所有的金矿,它们的平均纯度大于或等于10


检测今天是星期几

Help > 检测命令 >
检测今天是星期几

命令格式:

DAYOFWEEK (SUN,MON,TUE,WED,THU,FRI,SAT) 代表周日~周六

示例:

[@main]

#if

DAYOFWEEK SUN

#ACT

sendmsg 6 今天是周日,出来浪啊


检测时间

Help > 检测命令 >
检测时间

命令格式:

HOUR 时间1(0~23) 时间2(0~23) 参数二可省略

MIN 时间1(0~59) 时间2(0~59) 参数二可省略

示例一:

[@main]

#if

HOUR 13 15

#act

sendmsg 6 现在是下午1点到3点之间

#if

HOUR 16

#act

sendmsg 6 现在是下午4点多

MIN逻辑同上


检测PK点

Help > 检测命令 >
检测PK点

命令格式:

CHECKPKPOINT 点数

检测角色的PK点是否大于或者等于指定点数

参数1写1时为检测PK点是否大于100, 写2时检测PK点是否大于200,以此类推

示例:

[@main]

#if

CHECKPKPOINT 2

#act

sendmsg 6 你小子杀人了吧,都红名了

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测幸运值

Help > 检测命令 >
检测幸运值

命令格式:

CHECKLUCKPOINT 比较符(><= ?)点数

检测角色的幸运值是否大于或者等于指定点数

示例:

[@main]

#if

CHECKLUCKPOINT = 9

#act

sendmsg 6 天啊,你都运9了,这可是刀刀上限攻击伤害啊


检测地图怪物数量

Help > 检测命令 >
检测地图怪物数量

命令格式:

CHECKMONMAP 地图代码 数量

检测地图怪物的总数是否大于或者等于指定数量, 不包括宝宝

CHECKMAPMONCOUNT 地图代码 比较符(><=?) 数量 是否区分宝宝(0或空不区分,大于0为区分)

示例一:

[@main]

#if

CHECKMONMAP 3 100

#act

sendmsg 6 盟重省的怪物总数达到了100只, 这其中不包括玩家的宝宝

[@main]

#if

CHECKMAPMONCOUNT D401 > 100

#act

sendmsg 6 现在比奇矿区的怪物大于100个,不包括玩家的宝宝

#if

CHECKMAPMONCOUNT D401 > 100 1

#act

sendmsg 6 现在比奇矿区的怪物大于100个, 也包括玩家的宝宝在内


检测地图玩家数量

Help > 检测命令 >
检测地图玩家数量

命令格式:

CHECKHUM 地图代码 数量 类型(0或空为所有角色, 1玩家, 2假人)

检测指定地图的玩家数量是否大于或者等于指定数量

CHECKMAPHUMANCOUNT 地图代码 比较符(><=?) 数量 类型(0或空为所有角色,1玩家, 2假人)

示例一:

[@main]

#if

CHECKHUM 3 100

#act

sendmsg 6 现在盟重土城的玩家数量达到了100个, 这群服开的可以啊

示例二:

[@main]

#if

CHECKMAPHUMANCOUNT 3 > 200

#act

sendmsg 6 现在盟重土城地图上有超过200名的玩家,兄弟你是要发达了

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测角色获得物品后是否超重

Help > 检测命令 >
检测角色获得物品后是否超重

命令格式:

CHECKBAGGAGE 物品名字

检测玩家如果获得该物品后是否会超重

示例:

[@main]

#if

CHECKBAGGAGE 屠龙

#act

sendmsg 6 本来想给你一把屠龙呢,可是给你的话你就超重了..所以等下次再给你吧


检测角色名字是否在指定文本

Help > 检测命令 >
检测角色名字是否在指定文本

命令格式:

CHECKNAMELIST 文件名

检测玩家的名字是否在指定文本内

示例:

[@main]

#if

CHECKNAMELIST ..\QuestDiary\名单.txt

#act

sendmsg 6 你的名字在名单.txt 内


检测是否为行会老大

Help > 检测命令 >
检测是否为行会老大

命令格式:

ISGUILDMASTER

检测角色是否为行会老大

示例:

[@main]

#if

ISGUILDMASTER

#act

sendmsg 6 哇塞,你是行会老大也,人家好piapia呀


检测是否正在攻城

Help > 检测命令 >
检测是否正在攻城

命令格式:

ISONCASTLEWAR 或 CHECKCASTLEWAR 或 CHECKUNDERWAR

检测当前是否处于攻城期间

示例一:

[@main]

#if

ISONCASTLEWAR

#act

sendmsg 6 现在是攻城期间,你还在这乱跑!

示例二:

[@main]

#if

CHECKCASTLEWAR

#act

sendmsg 6 现在是攻城期间,你还在这乱跑!

示例三:

[@main]

#if

CHECKUNDERWAR

#act

sendmsg 6 现在是攻城期间,你还在这乱跑!


检测是否为沙城行会

Help > 检测命令 >
检测是否为沙城行会

命令格式:

ISCASTLEGUILD

检测角色所属行会是否是沙巴克管理行会

示例:

[@main]

#if

ISCASTLEGUILD

#act

sendmsg 6 原来是沙巴克行会成员,失敬失敬


检测是否为攻城进攻方

Help > 检测命令 >
检测是否为攻城进攻方

命令格式:

ISATTACKGUILD

检测角色行会是否为沙城进攻方

示例:

[@main]

#if

ISATTACKGUILD

#act

sendmsg 6 你的行会正在进攻沙巴克


检测是否为攻城防守方

Help > 检测命令 >
检测是否为攻城防守方

命令格式:

ISDEFENSEGUILD

检测角色所属行会是否为攻城防守方

示例:

[@main]

#if

ISDEFENSEGUILD

#act

sendmsg 6 你的行会现在正在防守沙巴克


检测是否加入行会

Help > 检测命令 >
检测是否加入行会

命令格式:

HAVEGUILD

检测玩家是否加入行会

示例:

[@main]

#if

HAVEGUILD

#act

sendmsg 6 你已经加入行会


检测城门状态

Help > 检测命令 >
检测城门状态

命令格式:

CHECKCASTLEDOOR (损坏,开启,关闭)

检测当前沙巴克大门状态

示例:

[@main]

#if

CHECKCASTLEDOOR 开启

#act

sendmsg 6 当前沙巴克城门是开启状态


检测是否为攻城方同盟行会

Help > 检测命令 >
检测是否为攻城方同盟行会

命令格式:

ISATTACKALLYGUILD

检测角色行会是否与攻城方行会结盟

示例:

[@main]

#if

ISATTACKALLYGUILD

#act

sendmsg 6 你的行会和进攻方行会结盟


检测是否为守城方同盟行会

Help > 检测命令 >
检测是否为守城方同盟行会

命令格式:

ISDEFENSEALLYGUILD

检测角色的行会是否与守城方结盟

示例:

[@main]

#if

ISDEFENSEALLYGUILD

#act

sendmsg 6 你的行会与守城方结盟了


检测是否为管理员(区分权限)

Help > 检测命令 >
检测是否为管理员(区分权限)

命令格式:

ISSYSOP

检测角色权限等级是否大于等于4

ISADMIN

检测角色权限等级是否大于等于6

示例:

[@main]

#if

ISSYSOP

#act

sendmsg 6 你的管理权限大于等于4

#if

ISADMIN

#act

sendmsg 6 你的管理权限大于等于6


检测角色是否有死亡地点

Help > 检测命令 >
检测角色是否有死亡地点

命令格式:

CHECKSIGNMAP 地图代码(可忽略)

检测玩家是否有死亡地点,或者死亡地点是否为指定地图

示例:

[@main]

#if

CHECKSIGNMAP 3

#act

sendsmg 6 你上次的死亡地点是盟重土城


检测指定坐标怪物数量

Help > 检测命令 >
检测指定坐标怪物数量

命令格式:

CHECKRANGEMONCOUNTEX 地图代码 怪物名字 X坐标 Y坐标 范围 比较符(><= ) 数量 是否计算宝宝(0或空不算)

检测指定地图 指定坐标 指定的怪物数量是否大于或小于或等于指定数量

[@main]

#if

CHECKRANGEMONCOUNTEX 3 白野猪 330 330 5 = 5 1

#act

sendmsg 6 盟重土城的330 330 5格范围内有5头白野猪....

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测字符串是否在指定文本

Help > 检测命令 >
检测字符串是否在指定文本

命令格式:

CHECKSTRINGLIST 路径 字符串

检测字符串是否存在指定路径的文本中

示例:

[@main]

#if

CHECKSTRINGLIST ..\QuestDiary\测试文本.txt 屠龙

#act

sendmsg 6 测试文本里有屠龙这个装备名字


检测并获取组队成员数

Help > 检测命令 >
检测并获取组队成员数

命令格式:

CHECKGROUPCOUNT 比较符(><=) 数值 变量

检测小队成员数量并且将成员数量保存到指定变量

示例:

[@main]

#if

CHECKGROUPCOUNT > 2 N8

#act

sendmsg 6 你的小队成员数大于2人,具体人数为<$STR(N8)>人


检测金刚石数量

Help > 检测命令 >
检测金刚石数量

命令格式:

CHECKGAMEDIAMOND 比较符(><=) 数值 倍数(可忽略)

检测角色拥有的金刚石数量是否大于等于或者小于指定数值

示例:

[@main]

#if

CHECKGAMEDIAMOND > 100

#act

sendmsg 6 你的金刚石大于100个

#if

CHECKGAMEDIAMOND > 100 3

#act

sendmsg 6 你的金刚石大于300个


检测灵符数量

Help > 检测命令 >
检测灵符数量

命令格式:

CHECKGAMEGIRD 比较符(><=) 数值 倍数(可忽略)

检测角色拥有的灵符数量是否大于小于等于指定数值

示例:

[@main]

#if

CHECKGAMEGIRD > 100

#act

sendmsg 6 你的灵符数量大于100个

#if

CHECKGAMEGIRD > 100 3

#act

sendmsg 6 你的灵符数量大于300个


检测师徒另一方是否在线

Help > 检测命令 >
检测师徒另一方是否在线

命令格式:

CHECKMASTERONLINE

检测师徒关系的另一方是否在线, 你是师父就检测的是徒弟, 你是徒弟就检测的是师父 共用一个命令

示例:

[@main]

#if

CHECKMASTERONLINE

#act

sendmsg 6 你的徒弟(师父)现在在线


检测夫妻另一方是否在线

Help > 检测命令 >
检测夫妻另一方是否在线

命令格式:

CHECKDEARONLINE

检测夫妻关系的另一方是否在线, 你是丈夫就检测你媳妇是否在线, 你是媳妇就检测你丈夫是否在线

示例:

[@main]

#if

CHECKDEARONLINE

#act

sendmsg 6 你的媳妇(丈夫)现在在线


检测师徒是否在同一地图

Help > 检测命令 >
检测师徒是否在同一地图

命令格式:

CHECKMASTERONMAP 地图代码或者SELF

检测你和师父(徒弟)是否在都在指定地图 SELF代表当前地图

[@main]

#if

CHECKMASTERONMAP SELF

#act

sendmsg 6 你的师父(徒弟)也在当前地图


检测夫妻是否在同一地图

Help > 检测命令 >
检测夫妻是否在同一地图

命令格式:

CHECKDEARONMAP 地图代码或者SELF

检测夫妻二人是否在同一个地图上

示例:

[@main]

#if

CHECKDEARONMAP SELF

#act

sendmsg 6 你的丈夫(媳妇)也在当前地图,快去找他吧


检测对面角色和自己是否为师徒关系

Help > 检测命令 >
检测对面角色和自己是否为师徒关系

命令格式:

CHECKPOSEISPRENTICE

检测对面的角色是否和自己是师徒关系

示例:

[@main]

#if

CHECKPOSEISPRENTICE

#act

sendmsg 6 你对面站的是你的师父(徒弟)


检测英雄的声望点

Help > 检测命令 >
检测英雄的声望点

命令格式:

CHECKHEROCREDITPOINT 比较符(><=) 数值

检测英雄的声望点

示例:

[@main]

#if

CHECKHEROCREDITPOINT > 100

#act

sendmsg 6 你英雄的声望点大于100点,好牛啊


检测指定坐标范围玩家数量

Help > 检测命令 >
检测指定坐标范围玩家数量

命令格式:

CHECKMAPRANGEHUMANCOUNT 地图代码 坐标X 坐标Y 范围 比较符(><=) 数量

检测指定坐标范围内的玩家数量

示例:

[@main]

#if

CHECKMAPRANGEHUMANCOUNT 3 330 330 100 = 100

#act

sendmsg 6 盟重省330 330 100格范围内有100个玩家


检测当前攻击模式

Help > 检测命令 >
检测当前攻击模式

命令格式:

CHECKATTACKMODE 编号(0..6)

检测玩家当前的攻击模式

0 全体模式
1 和平模式
2 夫妻模式
3 师徒模式
4 编组模式
5 行会模式
6 善恶模式

示例:

[@main]

#if

CHECKATTACKMODE 0

#act

sendmsg 6 你当前的攻击模式为全体攻击模式


检测角色帐号是否在指定文本

Help > 检测命令 >
检测角色帐号是否在指定文本

命令格式:

CHECKACCOUNTLIST 文本

检测角色的帐号是否存在于指定文本中

示例:

[@main]

#if

CHECKACCOUNTLIST ..\QuestDiary\帐号文本.txt

#act

sendmsg 6 你的帐号在帐号文本里


检测角色IP是否在指定文本

Help > 检测命令 >
检测角色IP是否在指定文本

命令格式:

CHECKIPLIST 文本

检测玩家当前登录的IP地址是否在指定文本

示例:

[@main]

#if

CHECKIPLIST ..\QuestDiary\IP文本.txt

#act

sendmsg 6 你的IP地址已经记录在IP文本内


检测对面角色状态

Help > 检测命令 >
检测对面角色状态

命令格式:

CHECKPOSEDIR 1或2(可忽略)

检测对面角色是否和你面对面站立, 有参数时1为检测你俩是否为同性别, 2为是否为异性

示例:

[@main]

#if

CHECKPOSEDIR

#act

sendmsg 6 很好,你俩现在是面对面站立

#if

CHECKPOSEDIR 2

#act

sendmsg 6 和你面对面的是你的爱人吗?


检测对面等级

Help > 检测命令 >
检测对面等级

命令格式:

CHECKPOSELEVEL 比较符(><=?) 数值(1-65535)

检测你对面角色的等级, 比较符为?时是检测对面等级是否大于等于指定数值

示例:

[@main]

#if

CHECKPOSELEVEL ? 50

#act

sendmsg 6 你对面的哥们他现在等级在49以上


检测对面性别

Help > 检测命令 >
检测对面性别

命令格式:

CHECKPOSEGENDER (MAN,男 或 WOMAN,女)

检测对面角色性别,参数写男或女, MAN或WOMAN都行

示例:

[@main]

#if

CHECKPOSEGENDER 男

#act

sendmsg 6 你对面站着一个大老爷们

#if

CHECKPOSEGENDER WOMAN

#act

sendmsg 6 你对面站着一个大老娘们


检测角色属性点

Help > 检测命令 >
检测角色属性点

命令格式:

CHECKBONUSPOINT 比较符(><=) 数值

检测角色已用和未用的总属性点

示例:

[@main]

#if

CHECKBONUSPOINT > 100

#act

sendmsg 6 你现在拥有的已用和未用的属性点总和已经超过了100点


检测角色是否已结婚

Help > 检测命令 >
检测角色是否已结婚

命令格式:

CHECKMARRY

检测角色是否已婚

示例:

[@main]

#if

CHECKMARRY

#act

sendmsg 6 你都结婚了,该干点正事了,别整天在这玩传奇


检测对面角色是否已婚

Help > 检测命令 >
检测对面角色是否已婚

命令格式:

CHECKPOSEMARRY

检测对面角色是否已婚

示例:

[@main]

#if

CHECKPOSEMARRY

#act

sendmsg 6 你对面的是个有家室的人了,别没事去勾搭人家


检测角色结婚次数

Help > 检测命令 >
检测角色结婚次数

命令格式:

CHECKMARRYCOUNT 比较符(><=) 数值

检测角色已经离过几次婚, 结婚不计数,离婚才开始计数

示例:

[@main]

#if

CHECKMARRYCOUNT > 10

#act

sendmsg 6 诶唷我去,你都离婚10次以上了......


检测角色是否是徒弟

Help > 检测命令 >
检测角色是否是徒弟

命令格式:

CHECKMASTER

检测角色是否是别人的徒弟

示例:

[@main]

#if

CHECKMASTER

#act

sendmsg 6 你是别人的徒弟


检测角色是否已建立师徒关系

Help > 检测命令 >
检测角色是否已建立师徒关系

命令格式:

HAVEMASTER

检测角色是否为别人的师父或者徒弟

示例:

[@main]

#if

HAVEMASTER

#act

sendmsg 6 你已经和别人建立师徒关系了


检测对面角色是否为徒弟身份

Help > 检测命令 >
检测对面角色是否为徒弟身份

命令格式:

CHECKPOSEMASTER

检测对面的角色是否为徒弟身份, 这里不区分是自己的徒弟还是别人的徒弟

示例:

[@main]

#if

CHECKPOSEMASTER

#act

sendmsg 6 你是徒弟


检测对面角色是否已经建立师徒关系

Help > 检测命令 >
检测对面角色是否已经建立师徒关系

命令格式:

POSEHAVEMASTER

检测对面的角色是否已经建立师徒关系,这里不区分和自己建立还是和别人建立

示例:

[@main]

#if

POSEHAVEMASTER

#act

sendmsg 6 对面的哥们已经建立过师徒关系了


检测角色是否是别人的师父

Help > 检测命令 >
检测角色是否是别人的师父

命令格式:

CHECKISMASTER

检测角色是否为别人的师父

示例:

[@main]

#if

CHECKISMASTER

#act

sendmsg 6 你已经是别人的师父了,要以身作则哦


检测对面是否为别人的师父

Help > 检测命令 >
检测对面是否为别人的师父

命令格式:

CHECKPOSEISMASTER

检测对面角色是否为别人的师父,这里不区分是自己的还是别人的师父

示例:

[@main]

#if

CHECKPOSEISMASTER

#act

sendmsg 6 你对面的人已经收了徒弟了


检测角色名字和IP是否在指定文本

Help > 检测命令 >
检测角色名字和IP是否在指定文本

命令格式:

CHECKNAMEIPLIST 文本名字

检测角色的名字和IP信息是否在指定文本内 ,文本格式如下:

张三 127.0.0.1

李四 192.168.1.1

名字和IP中间可以用空格, / 或者 Tab键

示例:

[@main]

#if

CHECKNAMEIPLIST ..\QuestDiary\信息文本.txt

#act

sendmsg 6 你的名字和IP存在于信息文本中


检测角色帐号和IP是否在指定文本

Help > 检测命令 >
检测角色帐号和IP是否在指定文本

命令格式:

CHECKACCOUNTIPLIST 文本.txt

检测角色的帐号和IP信息是否在指定文本内 ,文本格式如下:

66666 127.0.0.1

88888 192.168.1.1

帐号和IP中间可以用空格, / 或者 Tab键

示例:

[@main]

#if

CHECKNAMEIPLIST ..\QuestDiary\信息文本.txt

#act

sendmsg 6 你的帐号和IP存在于信息文本中


检测是否为沙巴克老大

Help > 检测命令 >
检测是否为沙巴克老大

命令格式:

ISCASTLEMASTER

检测角色是否为沙巴克老大

示例:

[@main]

#if

ISCASTLEMASTER

#act

sendmsg 6 原来是沙巴克老大啊,失敬失敬!


检测角色是否为新人

Help > 检测命令 >
检测角色是否为新人

命令格式:

ISNEWHUMAN

检测角色是否为新人, 就是刚创建角色进入游戏还没有退出过游戏就算新人

示例:

[@main]

#if

ISNEWHUMAN

#act

sendmsg 6 原来是新人啊,那我可要多多照顾了


检测角色会员类型

Help > 检测命令 >
检测角色会员类型

命令格式:

CHECKMEMBERTYPE 比较符(><=?) 数值(1-65535)

检测角色的会员类型

示例:

[@main]

#if

CHECKMEMBERTYPE = 2

#act

sendmsg 6 你是2阶会员


检测角色会员等级

Help > 检测命令 >
检测角色会员等级

命令格式:

CHECKMEMBERLEVEL 比较符(><=?) 数值(1-65535)

检测角色的会员等级

示例:

[@main]

#if

CHECKMEMBERLEVEL > 500

#act

sendmsg 6 你的会员等级已经超过500级了


检测角色元宝数量

Help > 检测命令 >
检测角色元宝数量

命令格式:

CHECKGAMEGOLD 比较符(><=?) 数值 倍数(可忽略)

检测角色当前拥有的元宝数量

示例:

[@main]

#if

CHECKGAMEGOLD > 100

#act

sendsmg 6 你有100以上的元宝

#if

CHECKGAMEGOLD > 100 3

#act

sendsmg 6 你有300以上的元宝


检测角色游戏点数量

Help > 检测命令 >
检测角色游戏点数量

命令格式:

CHECKGAMEPOINT 比较符(><=?) 数值 倍数

检测角色拥有的游戏点数量

示例:

[@main]

#if

CHECKGAMEPOINT > 100

#act

sendsmg 6 你有大于100的游戏点

#if

CHECKGAMEPOINT > 100 5

#act

sendmsg 6 你有大于500的游戏点


检测角色名字在文本中的位置

Help > 检测命令 >
检测角色名字在文本中的位置

命令格式:

CHECKNAMELISTPOSITION 文本 比较符(><=?) 数值

检测角色的名字在文本中的行数(类似于排名之类的), ? 代表大于等于

示例:

[@main]

#if

CHECKNAMELISTPOSITION ..\QuestDiary\排名名单.txt ? 10

#act

sendmsg 6 你的排名在前十名,很牛逼啊


检测行会名字是否在指定列表

Help > 检测命令 >
检测行会名字是否在指定列表

命令格式:

CHECKGUILDLIST 列表文本.txt

检测玩家所在行会的行会名字是否存在于指定文本中

示例:

[@main]

#if

CHECKGUILDLIST ..\QuestDiary\行会列表.txt

#act

sendmsg 6 你所在的行会的行会名字在行会列表中


检测角色转生等级

Help > 检测命令 >
检测角色转生等级

命令格式:

CHECKRENEWLEVEL 比较符(><=?) 数值

检测角色当前转生等级, ?代表大于等于

示例:

[@main]

#if

CHECKRENEWLEVEL > 2

#act

sendmsg 6 你已经2转以上了


检测宝宝等级

Help > 检测命令 >
检测宝宝等级

命令格式:

CHECKSLAVELEVEL 比较符(><=?) 数值

检测角色所有宝宝中最高的宝宝等级

示例:

[@main]

#if

CHECKSLAVELEVEL ? 5

#act

sendmsg 6 你的所有宝宝中最高的等级已经大于等于5级了


检测宝宝名字

Help > 检测命令 >
检测宝宝名字

命令格式:

CHECKSLAVENAME 宝宝名字

检测角色的所有宝宝中是否有指定名字的宝宝

示例:

[@main]

#if

CHECKSLAVENAME 骷髅

#act

sendmsg 6 你已经召唤了骷髅宝宝


检测角色的声望值

Help > 检测命令 >
检测角色的声望值

命令格式:

CHECKCREDITPOINT 比较符(><=?) 数值

检测角色的声望值

示例:

[@main]

#if

CHECKCREDITPOINT > 100

#act

sendmsg 6 你的声望值已经大于100 ,看来没少干好事


检测角色行会名字

Help > 检测命令 >
检测角色行会名字

命令格式:

CHECKOFGUILD 行会名字

检测角色的行会名字是否为指定名字

示例:

[@main]

#if

CHECKOFGUILD 君临天下

#act

sendmsg 6 原来是君临天下的成员啊


检测角色指定位置是否佩戴装备

Help > 检测命令 >
检测角色指定位置是否佩戴装备

命令格式:

CHECKUSEITEM 位置(0-34)

检测角色指定位置是否佩戴装备

示例:

[@main]

#if

CHECKUSEITEM 1

#act

sendmsg 6 你佩戴了武器


检测角色剩余背包格子

Help > 检测命令 >
检测角色剩余背包格子

命令格式:

CHECKBAGSIZE 数值

检测角色剩余背包格子数

示例:

[@main]

#if

CHECKBAGSIZE 5

#act

sendmsg 6 你的背包至少还有5个空格


检测角色攻击力

Help > 检测命令 >
检测角色攻击力

命令格式:

CHECKDC 比较符(><=?) 数值1 比较符(><=?) 数值2

检测角色攻击力的最小值和最大值, 数值1是最小值 数值2是最大值

示例:

[@main]

#if

CHECKDC > 10 < 50

#act

sendmsg 你攻击力的最小值大于10 , 最大值小于50


检测角色魔法力

Help > 检测命令 >
检测角色魔法力

命令格式:

CHECKMC 比较符(><=?) 数值1 比较符(><=?) 数值2

检测角色魔法力的最小值和最大值, 数值1是最小值 数值2是最大值

示例:

[@main]

#if

CHECKMC > 10 < 50

#act

sendmsg 你魔法力的最小值大于10 , 最大值小于50


检测角色道术

Help > 检测命令 >
检测角色道术

命令格式:

CHECKSC 比较符(><=?) 数值1 比较符(><=?) 数值2

检测角色道术的最小值和最大值, 数值1是最小值 数值2是最大值

示例:

[@main]

#if

CHECKSC > 10 < 50

#act

sendmsg 你道术的最小值大于10 , 最大值小于50


检测角色HP

Help > 检测命令 >
检测角色HP

命令格式:

CHECKHP 比较符(><=?) 数值1 比较符(><=?) 数值2

检测角色HP的当前值和最大值, 数值1是当前值 数值2是最大值

示例:

[@main]

#if

CHECKHP > 100 < 500

#act

sendmsg 你HP的当前值大于100 , 最大值小于500


检测角色MP

Help > 检测命令 >
检测角色MP

命令格式:

CHECKMP 比较符(><=?) 数值1 比较符(><=?) 数值2

检测角色MP的当前值和最大值, 数值1是当前值 数值2是最大值

示例:

[@main]

#if

CHECKMP > 100 < 500

#act

sendmsg 你MP的当前值大于100 , 最大值小于500


检测当前在线最高各项属性玩家

Help > 检测命令 >
检测当前在线最高各项属性玩家

命令格式:

ISHIGH 标识(L, P, D, M, S)

检测玩家是否为 在线玩家中指定属性最高的玩家

L 等级

P PK值

D 攻击力

M 魔法力

S 道术力

示例:

[@main]

#if

ISHIGH L

#act

sendmsg 6 你是当前在线玩家中等级最高的


检测角色是否与其他角色重叠

Help > 检测命令 >
检测角色是否与其他角色重叠

命令格式:

ISDUPMODE

检测角色是否和其他角色重叠站立

示例:

[@main]

#if

ISDUPMODE

#act

sendmsg 6 你怎么和别人站在一个坐标上


检测指定位置装备类型

Help > 检测命令 >
检测指定位置装备类型

命令格式:

CHECKITEMTYPE 装备位置(0-34) 数值

检测角色指定位置的装备类型

示例:

[@main]

#if

CHECKITEMTYPE 0 11

#act

sendmsg 6 你身上穿的衣服只有女性才能穿哦


检测角色当前经验值

Help > 检测命令 >
检测角色当前经验值

命令格式:

CHECKEXP 比较符(><=?) 数值

检测角色当前经验值

示例:

[@main]

#if

CHECKEXP ? 10000

#act

sendmsg 6 你当前的经验值大于等于10000点


检测沙巴克资金

Help > 检测命令 >
检测沙巴克资金

命令格式:

CHECKCASTLEGOLD 比较符(><=?) 数值

检测沙巴克的资金

示例:

[@main]

#if

CHECKCASTLEGOLD ? 1000000

#act

sendmsg 6 沙巴克的资金大于等于1000000


检测仓库密码输入错误次数

Help > 检测命令 >
检测仓库密码输入错误次数

命令格式:

PASSWORDERRORCOUNT 比较符(><=?) 数值(1-255)

检测角色输入仓库密码错误次数, ? 代表大于等于

示例:

[@main]

#if

PASSWORDERRORCOUNT > 2

#act

sendmsg 6 你仓库密码已经输错2次以上了


检测仓库是否锁定

Help > 检测命令 >
检测仓库是否锁定

命令格式:

ISLOCKPASSWORD

检测角色仓库是否处于锁定状态

示例:

[@main]

#if

ISLOCKPASSWORD

#act

sendmsg 6 你的仓库现在处于锁定中


检测仓库是否禁止取出

Help > 检测命令 >
检测仓库是否禁止取出

命令格式:

ISLOCKSTORAGE

检测角色仓库是否处于禁止取出状态

示例:

[@main]

#if

ISLOCKSTORAGE

#act

sendmsg 6 你的仓库处于禁止取出状态


检测指定地图范围怪物的数量

Help > 检测命令 >
检测指定地图范围怪物的数量

命令格式:

CHECKRANGEMONCOUNT 地图代码 X坐标 Y坐标 范围 比较符(><=?) 数量

检测指定地图指定坐标指定范围内的怪物数量 SELF为当前地图 ?代表大于等于

示例:

[@main]

#if

CHECKRANGEMONCOUNT SELF 330 330 100 ? 500

#act

sendmsg 6 当前地图以330 330 为中心方圆100格范围内的怪物数量大于等于500只


检查人物是否在指定的[地图XY坐标]范围内

Help > 检测命令 >
检查人物是否在指定的[地图XY坐标]范围内

命令格式:

CHECKINMAPRANGE 地图代码(SELF为当前地图) X坐标 Y坐标 范围

检测角色是否在指定地图 指定坐标 指定范围

示例:

[@main]

#if

CHECKINMAPRANGE 3 330 330 10

#act

sendmsg 6 你当前在土城330 330 方圆10格范围内


检测城堡占领天数

Help > 检测命令 >
检测城堡占领天数

命令格式:

CASTLECHANGEDAY 比较符(><=?) 数值

检测占领沙巴克天数, ?代表大于等于

示例:

[@main]

#if

CASTLECHANGEDAY > 3

#act

sendmsg 6 已经占领沙城3天以上


检查城堡战争天数

Help > 检测命令 >
检查城堡战争天数

命令格式:

CASTLEWARAY 比较符(><=?) 数值

检测距离上一次攻城间隔了多少天, ?代表大于等于

示例:

[@main]

#if

CASTLEWARAY > 3

#act

sendmsg 6 距离上次攻城已经过去3天了


检测角色在线时长

Help > 检测命令 >
检测角色在线时长

命令格式:

ONLINELONGMIN 比较符(><=?) 数值(分钟)

检测玩家在线时长, ?代表大于等于

示例:

[@main]

#if

ONLINELONGMIN > 180

#act

sendmsg 6 你已经在线180分钟了,该休息下了


检测角色会员时间

Help > 检测命令 >
检测角色会员时间

命令格式:

CHECKNAMEDATELIST 会员文本.txt 比较符(><=?) 天数 使用天数P0 剩余天数P1 是否区分角色名(0或空为忽略, 1为区分)

CHECKUSERDATE 参数同上

这个命令中.

参数一为存储名单的文件路径.

参数二为控制符(现改进支持>、<、=).

参数三为检测的天数.

参数四为赋予的变量标志.用于读取当前人物在名单中已经存在的天数(可用<$STR(p0)>读取显示在脚本中,表示使用天数).

参数五同为赋予的变量标志.用于读取当前人物在参数三的检测天数减去名单中已经存在的天数所得的剩余天数(可用<$STR(p1)>读取显示在脚本中,表示剩余天数).

参数四,五,六都是可省略参数

示例:

[@main]

#If
CHECKNAMEDATELIST ..\QuestDiary\会员.txt < 30 p0 p1
#Act
SendMsg 6 您的30天会员使用权限已经使用了<$STR(p0)>天.还剩下<$STR(p1)>天使用权限.


检测当前服务器名字

Help > 检测命令 >
检测当前服务器名字

命令格式:

CHECKSERVERNAME 服务器名字

检测当前角色所在的服务器名字

示例:

[@main]

#if

CHECKSERVERNAME 盛世华夏

#act

sendmsg 6 你所在的服务器名字为盛世华夏


检测角色是被谁杀死的

Help > 检测命令 >
检测角色是被谁杀死的

命令格式:

CHECKDIEMON 名字

检测角色是被谁杀死的, 不区分怪物和玩家

示例:

[@main]

#if

CHECKDIEMON 触龙神

#act

sendmsg 6 你是被触龙神杀死的


检测攻击目标的名字

Help > 检测命令 >
检测攻击目标的名字

命令格式:

CHECKKILLPLAYMON 名字

检测角色当前攻击目标的名字, 不区分玩家还是怪物

示例:

[@main]

#if

CHECKKILLPLAYMON 触龙神

#act

sendmsg 6 你当前的攻击目标是触龙神


检测角色是否学习指定技能

Help > 检测命令 >
检测角色是否学习指定技能

命令格式:

CHECKMAGICNAME 技能名字

检测玩家是否学习了某个技能

示例:

[@main]

#if

CHECKMAGICNAME 雷电术

#act

sendmsg 6 你已经学习了雷电术


检测技能等级

Help > 检测命令 >
检测技能等级

命令格式:

CHECKMAGICLEVEL 技能名字 比较符(>, <, =, >=, <=, <>) 数值

检测角色指定技能等级

CHECKSKILL 技能名字 比较符(><=) 数值 是否为强化技能

示例:

[@main]

#if

CHECKMAGICLEVEL 雷电术 >= 2

#act

sendmsg 6 你的雷电术等级大于等于2级


检测角色是否为队长

Help > 检测命令 >
检测角色是否为队长

命令格式:

ISGROUPMASTER

检测角色是否为队长

示例:

[@main]

#if

ISGROUPMASTER

#act

sendmsg 6 你是你们小队的队长


检测是否在指定地图

Help > 检测命令 >
检测是否在指定地图

命令格式:

ISONMAP 地图代码

检测玩家是否在指定地图

示例:

[@main]

#if

ISONMAP 3

#act

sendmsg 6 你在盟重土城


检测输入的验证码是否正确

Help > 检测命令 >
检测输入的验证码是否正确

命令格式:

CHECKRANDOMNO 字符串

检测玩家输入的验证码是否正确, 需配合 SETRANDOMNO 命令给出的验证码

示例:

[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>：<$RANDOMNO>

[@@CheckNo]
#If
CHECKRANDOMNO
#Act
SendMsg 5 [提示]:验证码输入正确.
Close
#ElseAct
SendMsg 5 [提示]:验证码输入错误.
Close

相关链接:SETRANDOMNO


检测是否在安全区

Help > 检测命令 >
检测是否在安全区

命令格式 :

INSAFEZONE

检测角色是否在安全区

示例:

[@main]

#if

INSAFEZONE

#act

sendmsg 6 你在安全区发呆呢


检测是否被玩家杀害

Help > 检测命令 >
检测是否被玩家杀害

命令格式:

KILLBYHUM

检测角色是否被玩家杀害

示例:

[@main]

#if

KILLBYHUM

#act

sendmsg 6 你是被玩家<$KILLER>杀害的


检测是否被怪物杀害

Help > 检测命令 >
检测是否被怪物杀害

命令格式:

KILLBYMON

检测角色是否被怪物杀害

示例:

[@main]

#if

KILLBYMON

#act

sendmsg 6 你是被怪物<$MONKILLER>杀害的


检测玩家是否在线

Help > 检测命令 >
检测玩家是否在线

命令格式:

CHECKONLINE 玩家名字

检测指定玩家是否在线

示例:

[@main]

#if

CHECKONLINE RED大飞哥

#act

sendmsg 6 RED大飞哥现在在线


检测离线挂机人数

Help > 检测命令 >
检测离线挂机人数

命令格式:

OFFLINEPLAYERCOUNT 比较符(><=?) 数值

检测当前离线挂机的人数, ?代表大于等于

示例:

[@main]

#if

OFFLINEPLAYERCOUNT > 100

#act

sendmsg 6 当前离线挂机的人数已经100以上了


检测英雄是否在线

Help > 检测命令 >
检测英雄是否在线

命令格式:

CHECKHEROONLINE

检测角色是否召唤出英雄

示例:

[@main]

#if

CHECKHEROONLINE

#act

sendmsg 6 你的英雄现在守护在你的身边


检测是否创建了英雄

Help > 检测命令 >
检测是否创建了英雄

命令格式:

HAVEHERO

检测角色是否创建了英雄

示例:

[@main]

#if

HAVEHERO

#act

sendmsg 6 你已经成功创建了英雄


检测英雄的等级

Help > 检测命令 >
检测英雄的等级

命令格式:

CHECKHEROLEVEL 比较符(><=?) 数值

检测角色英雄的等级, ?代表大于等于

示例:

[@main]

#if

CHECKHEROLEVEL > 35

#act

sendmsg 6 你的英雄等级已经大于35级了


检测英雄职业

Help > 检测命令 >
检测英雄职业

命令格式:

CHECKHEROJOB 职业(Warrior, Wizard, Taoist)

检测角色的英雄职业, 0战士 1法师 2道士

示例:

[@main]

#if

CHECKHEROJOB Warrior

#act

sendmsg 6 你的英雄的职业是战士

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测英雄的PK值

Help > 检测命令 >
检测英雄的PK值

命令格式:

CHECKHEROPKPOINT 数值

检测角色英雄的PK值

示例:

[@main]

#if

CHECKHEROPKPOINT 2

#act

sendmsg 6 你英雄的PK值已经超过200了

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测地图玩家是否同属一个行会

Help > 检测命令 >
检测地图玩家是否同属一个行会

命令格式:

MapHumIsSameGuild 地图代码 是否排除无行会玩家(0或空为不排除,1为排除)

检测指定地图里的所有玩家是否属于同一个行会

示例:

[@main]

#if

MapHumIsSameGuild 0150 1

#act

sendmsg 6 排除掉无行会的玩家, 现在沙巴克皇宫里的所有玩家都属于同一个行会了


检测是否为真

Help > 检测命令 >
检测是否为真

命令格式:

TRUE

不检测任何条件, 任何时候都能检测通过

示例:

[@main]

#if

TRUE

#act

sendmsg 6 你说啥都对


检测字符串的长度

Help > 检测命令 >
检测字符串的长度

命令格式:

CHECKSTRINGLENGTH 字符串 比较符(><=?) 数值

检测指定字符串的长度, 一个汉字的长度为2, 阿拉伯数字和大小写字母均为1

中文模式的符号长度也为2, 英文模式的符号为1

示例:

[@main]

#if

CHECKSTRINGLENGTH 哈哈哈haha = 10

#act

sendmsg 6 "哈哈哈"长度为6, "haha"长度为4


检测文本中是否包含另一个文本

Help > 检测命令 >
检测文本中是否包含另一个文本

命令格式:

CHECKCONTAINSTEXT 文本1 文本2

检测文本1中是否包含文本2的所有字符

示例:

[@main]

#if

CHECKCONTAINSTEXT 神圣的屠龙 屠龙

#act

sendmsg 6 "神圣的屠龙"中包含字符串"屠龙"


检测文件中的内容是否包含指定文本

Help > 检测命令 >
检测文件中的内容是否包含指定文本

命令格式:

CHECKCONTAINSTEXTLIST 文本路径 文本

检测指定文件中的某段文本内容是否包含指定文本

这里不要求某段文本完全与检测的文本相同, 只要包含检测文本即可

CHECKCONTAINSTEXTLISTEX 文本路径 文本

检测指定文件中的某段文本内容完全被指定文本包含

示例一:

..\QuestDiary\测试文本.txt 内容如下:

今天是个好日子

今天天气真好

RED引擎真牛逼

[@main]

#if

CHECKCONTAINSTEXTLIST ..\QuestDiary\测试文本.txt RED

#act

sendmsg 6 你说的没错,RED引擎确实牛逼(第三行文本包含了RED)

示例二:

..\QuestDiary\测试文本.txt 内容如下:

今天是个好日子

今天天气真好

RED

[@main]

#if

CHECKCONTAINSTEXTLIST ..\QuestDiary\测试文本.txt RED引擎真牛逼

#act

sendmsg 6 你说的没错, RED引擎确实牛逼(第三行完全被指定文本包含)


检测背包指定物品数量(排除OK框)

Help > 检测命令 >
检测背包指定物品数量(排除OK框)

命令格式:

CHECKBAGITEMCOUNTEX 物品名字 数量

检测角色背包内指定物品数量, 不包括OK框中的物品

示例:

[@main]

#if

CHECKBAGITEMCOUNTEX 屠龙 5

#act

sendmsg 6 你背包里至少还有5把屠龙,不包括OK框里的


检测攻击(被攻击)目标类型

Help > 检测命令 >
检测攻击(被攻击)目标类型

命令格式:

CHECKCURRTARGETRACE 比较符(>, <, = , > =, <= ) 类型(0为玩家, 1为英雄, 10为NPC 99为怪物)

检测攻击目标或者被攻击的对象是什么类型

示例:

[@main]

#if

CHECKCURRTARGETRACE = 1

#act

sendmsg 6 你被别人的英雄揍了

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测角色杀怪暴率

Help > 检测命令 >
检测角色杀怪暴率

命令格式:

CHECKMONDROPRATE 比较符(><=?) 数值

检测角色的杀怪暴率, 100为正常倍数

示例:

[@main]

#if

CHECKMONDROPRATE = 200

#act

sendmsg 6 你现在的杀怪暴率是双倍


检测角色杀死的怪物名字

Help > 检测命令 >
检测角色杀死的怪物名字

命令格式:

CHECKKILLMONNAME 怪物名字

检测角色最后杀死的怪物名字

示例:

[@main]
#IF
CHECKKILLMONNAME 白野猪
#SAY
你把白野猪干掉了!


检测地图指定怪物数量

Help > 检测命令 >
检测地图指定怪物数量

命令格式:

CHECKMAPSAMEMONCOUNT 地图代码(SELF为当前地图) 怪物名字 比较符(><=) 数量 是否检测数字(0或空检测, 1为不检测)

检测地图指定怪物的数量有多少

示例:

[@main]

#if

CHECKMAPSAMEMONCOUNT SELF 白野猪11 = 10

#act

sendmsg 6 当前地图里白野猪11有10只

#if

CHECKMAPSAMEMONCOUNT SELF 白野猪 = 20 1

#act

sendmsg 6 当前地图的白野猪有20只, 包括白野猪11


检测客户端类型

Help > 检测命令 >
检测客户端类型

命令格式:

CHECKPC 类型(0电脑端, 1安卓端, 2苹果端,为空时默认检测是否为电脑端)

检测角色当前是否使用PC端登陆游戏

示例:

[@main]

#if

CHECKPC

#act

sendmsg 6 你当前使用的是PC端进行游戏

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测装备附加属性

Help > 检测命令 >
检测装备附加属性

命令格式:

CHECKITEMADDVALUE 装备位置(-1-34) 属性位置(0-30) 比较符(><=?) 数值

检测装备的附加属性值, ?代表大于等于

CheckItemAddValueEx 装备位置 (检测符 < > = ?) 检测数值 是否计算元素(1计算0不计算)

示例:

[@main]

#if

CHECKITEMADDVALUE 1 0 > 5

#act

sendsmg 6 你武器的攻击附加属性值大于5点

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


检测纯度(持久)命令

Help > 检测命令 >
检测纯度(持久)命令

命令格式:

CHECKMINE 物品名字 数量 比较符(><=) 数值(1-65)

检测背包知否有指定数量纯度(持久)物品

示例:

[@main]

#if

CHECKMINE 金矿石 3 = 20

#act

sendmsg 6 你有3块纯度20的金矿石


检测技能熟练度

Help > 检测命令 >
检测技能熟练度

命令格式:

CHECKTRANPOINT 技能名字 比较符(><=?) 点数

检测已经学习的技能的熟练度

示例:

[@main]

#if

CHECKTRANPOINT 烈火剑法 > 200

#act

sendmsg 6 你的烈火剑法的熟练度已经大于200点了


检测装备升级次数

Help > 检测命令 >
检测装备升级次数

命令格式:

CHECKITEMUPGRADECOUNT 装备位置 检测符(><=?) 点数(0-255)

检测装备升级次数,适合 UPGRADEITEM 和 UPGRADEITEMEX 命令升级过的装备

示例:

[@main]

#if

CHECKITEMUPGRADECOUNT 1 > 5

#act

sendmsg 6 你的武器升级次数已经大于5次


检测地图是否存在

Help > 检测命令 >
检测地图是否存在

命令格式:

CHECKMAP 地图代码

检测地图是都存在, 可用来检测镜像地图是否创建成功!

举例:

[@main]

#if

CHECKMAP 镜像神殿

#act

sendmsg 6 镜像神殿地图已经存在


检测物品幸运值

Help > 检测命令 >
检测物品幸运值

命令格式:

CheckItemLuck 装备位置 比较符(><=?) 数值

检测装备的幸运值

示例:

[@main]

#if

CheckItemLuck 1 > 8

#act

sendmsg 6 外日他对,你已经运9了?


检测物品名字颜色

命令格式

CHECKITEMNAMECOLOR 装备位置 颜色代码(0-255)

检测指定位置装备名字的颜色值

示例:

[@main]

#if

CHECKITEMNAMECOLOR 1 253

#ACT

SENDMSG 6 你武器的名字颜色时粉色,好装逼好耀眼!


收取玩家指定数量物品

Help > 执行命令 >
收取玩家指定数量物品

命令格式:

TAKE 物品名字 数量

收取玩家背包内指定数量的物品

TAKEW 装备名字(支持装备位置0~34) 数量

收取玩家身上穿戴的装备

示例:

[@main]

#if

#act

take 屠龙 1

sendmsg 6 从你背包里收取一把屠龙

#if

#act

takew 屠龙 1

sendmsg 6 把你手里拿的屠龙收走了


给予玩家指定数量物品

Help > 执行命令 >
给予玩家指定数量物品

命令格式:

GIVE 物品名字 数量(1-250)

给玩家指定数量的物品,单次最大250个

示例:

[@main]

#if

#act

GIVE 屠龙 1

sendmsg 6 系统赠与你一把屠龙

扩展GIVE命令，增加GiveEx命令

第1种:扩展GIVE命令：

物品名 数量 属性位置 属性值 （普通鉴定属性|神秘鉴定属性|特殊属性|神技|几鉴）注意：GIVE 给予鉴定属性， 必须在最后加入几鉴才可生效，1 2 3 //分别代表1鉴 2鉴 3鉴
GIVE屠龙 1 0 0 1=11,2=12,3=13,9=15|24=2,25=1,26=3,27=6|67|127|1
解释：
普通鉴定属性：最多4项属性(“,”号分隔)，每个属性：属性位置=属性值
神秘鉴定属性：最多4项属性(“,”号分隔)，每个属性：属性位置=属性值

属性值范围1~15，属性位置范围1~30，对应如下属性：
数字 类型 起作用的StdMode
----------------------------------------
1 攻击 通用
2 魔法 通用
3 道术 通用
4 物防 5, 6, 19, 20, 21, 23, 24
5 魔防 5, 6, 19, 20, 21, 23, 24
6 准确 5, 6, 20, 24
7 敏捷 20, 24
8 魔法躲避 19, 20, 21, 23, 24
9 幸运 5, 6, 19, 20, 21, 23, 24
10 诅咒 5, 6
11 攻击速度 5, 6
12 神圣 5, 6
13 魔法回复 21, 23
14 体力回复 21, 23
15 目标爆率 通用
16 防爆 通用
17 吸血上限 通用
18 内力恢复 通用
19 内力上限 通用
20 内功伤害 通用
21 内功减免 通用
22 内伤等级 通用
23 暴击威力 通用
24 合击威力 通用
25 麻痹抗性 通用
26 强身等级 通用
27 聚魔等级 通用
28 主属性 通用
29 毒物躲避 通用
30 中毒恢复 通用

------------------------------------------------------------------------------------------------------------------------------------------

第2种:增加NPC命令：GiveEx

解释：
普通鉴定属性：最多4项属性(“,”号分隔)，每个属性：属性位置=属性值
神秘鉴定属性：最多4项属性(“,”号分隔)，每个属性：属性位置=属性值

GIVEEX 物品名 数量 （附加属性） （普通鉴定属性|神秘鉴定属性|特殊属性|神技|几鉴）

格式：

0=11,1=12,2=13,3=15,4=11,5=12,6=13,8=15,9=15,16=15,17=15,18=15,19=15,20=15,21=15,22=15,23=1 代表附加普通属性

1=11,2=12,3=13,9=15|6=11,10=12,11=13,12=15|67|127|2 （普通鉴定属性|神秘鉴定属性|特殊属性|神技|几鉴）

#IF
#ACT
GIVEEX 炼狱 10=11,1=12,2=13,3=15,4=11,5=12,6=13,8=15,9=15,16=15,17=15,18=15,19=15,20=15,21=15,22=15,23=1 1=11,2=12,3=13,9=15|6=11,10=12,11=13,12=15|67|127|2

点击参考属性位置

神技能特殊属性参考

01 八卦护身神技
02 战意麻痹神技
04 重生神技
08 探测神技
16 传送神技
32 麻痹神技
64 魔道麻痹神技

比如我要特殊属性包含 战意麻痹和 探测属性那么就将 他们的代码相加 02+08= 10 那么特殊属性那一栏内写上10即可

在比如要特殊属性包含 八卦护身 战意麻痹 那么就将他们的代码相加 01+02= 3 那么特殊属性那一栏内写上3即可

关于神技:

固定神技代码为:

01 五岳独尊
02 召唤巨魔
04 神龙附体
08 倚天劈地

同样道理:代码相加

比如我要特殊属性包含 五岳独尊和 神龙附体技能那么就将 他们的代码相加 01+04= 5 那么神技那一栏内写上5即可

比如我要特殊属性包含 召唤巨魔和 倚天劈地技能那么就将 他们的代码相加 02+08= 10 那么神技那一栏内写上10即可


关闭NPC对话框

Help > 执行命令 >
关闭NPC对话框

命令格式:

CLOSE

关闭当前打开的NPC对话框

示例:

[@main]

#if

#act

CLOSE


停止命令

Help > 执行命令 >
停止命令

命令格式:

BREAK

停止执行脚本命令

示例:

[@main]

#if

#act

sendmsg 6 测试一字符串

sendmsg 6 测试二字符串

sendmsg 6 测试三字符串

BREAK

sendmsg 6 测试四字符串

测试结果只在游戏中打印前三个提示, "测试四字符串"将不会被打印出来


延时传送命令

Help > 执行命令 >
延时传送命令

命令格式:

TIMERECALL 时间(分钟)

延迟指定时间后传送到当前地图及坐标

示例:

[@main]

#if

#act

TIMERECALL 60

MAP D401

sendmsg 6 现在将你传送到比奇矿场,一个小时后会传送回来

使用 BREAKTIMERECALL 命令可以清除此延迟传送 BREAKTIMERECALL


用命令打开网站

Help > 执行命令 >
用命令打开网站

命令格式:

WEBBROWSER 网址 方式(0或空为自带浏览器, 1为用户默认浏览器)

使用登录器内置浏览器打开网页

示例:

[@main]

#if

#act

WEBBROWSER https://www.redm2.com

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


自动穿戴装备

Help > 执行命令 >
自动穿戴装备

命令格式:

TAKEON 装备名字 位置(0-34)

自动穿戴装备到指定位置,前提是背包里必须有此物品且穿戴位置无误

示例:

[@main]

#if

#act

TAKEON 天魔神甲 0

TAKEON 屠龙 1

具体位置请参考装备位置


传送到指定地图坐标

Help > 执行命令 >
传送到指定地图坐标

命令格式:

MAPMOVE 地图代码 X坐标 Y坐标 范围

将玩家传送到指定地图的指定坐标点上

示例:

[@main]

#if

#act

MAPMOVE 3 330 330 5

sendmsg 6 已经把你传送到土城的330 330坐标5范围内了


传送到指定地图的随机位置

Help > 执行命令 >
传送到指定地图的随机位置

命令格式:

MAP 地图代码

将玩家传送到指定地图的随机坐标点

示例:

[@main]

#if

#act

MAP d401

sendmsg 6 已经把你传送到比奇矿区的随机地点,祝你好运


收取刚检测过的物品

Help > 执行命令 >
收取刚检测过的物品

命令格式:

TAKECHECKITEM

收取刚被 CHECKDURA 命令检测过的物品,需要配合使用

示例:

[@免费]
#IF
checkitem 金矿 3
checkdura 金矿 15 //这里检测的是是否有纯度15的金矿
#SAY
啊？你真的把这些白给我？\
真没想到现如今还有你这样的人，看来还有人情啊。\
我不能白拿这么贵重的东西。\
你有没有听说过命运之刃？\
还有在北门街道小店修理武器之后，有没有仔细看过人？\ \
<返回/@kang>
#ACT
take 金矿 2
TAKECHECKITEM // 收取 checkdura 过的物品
BREAK

相关链接: CHECKDURA


设置NPC刷怪

Help > 执行命令 >
设置NPC刷怪

命令格式:

MONGEN 怪物名字 数量 范围

需要配合 PARAM1 ,PARAM2, PARAM3 参数使用

示例:

[@main]

#if

#act

PARAM1 3
PARAM2 330
PARAM3 330
MONGEN 白野猪 50 20

sendmsg 6 盟重土城330 330 刷新了50头白野猪


清除地图所有怪物

Help > 执行命令 >
清除地图所有怪物

命令格式:

MONCLEAR 地图代码

清除指定地图的所有怪物

CLEARMAPMON 地图代码

清除指定地图所有怪物, 不包括禁止清除怪物列表的怪物

示例:

[@main]

#if

#act

MONCLEAR D401

sendmsg 6 比奇矿区的所有怪物全部被清除掉了


清除延迟传送

Help > 执行命令 >
清除延迟传送

命令格式:

BREAKTIMERECALL

清除TIMERECALL 命令的延迟传送地图的效果

示例:

[@main]

#if

ISONMAP 3

#act

BREAKTIMERECALL

sendmsg 6 清除延迟传送成功

相关链接: TIMERECALL


发送消息命令

Help > 执行命令 >
发送消息命令

命令格式:

SENDMSG 信息类型(0-7) 信息内容 字体颜色(0-255) 背景颜色(0-255) 倒计时(1-65535秒) 触发@字段(可忽略)

发送指定类型消息给玩家, 参数三, 四, 五, 六省全部略掉为发送消息到聊天框

反之则发送消息到快捷物品栏上方位置

信息类型代码：

0、发送红色信息给所有在线玩家
 1、发送普通红色广播信息。
2、发送普通红色广播信息，并显示NPC名称。
3、发送普通红色广播信息，并显示人物名称。
4、在NPC头顶，显示普通说话信息。(假人可用此模拟玩家说话)
5、发送红色信息给人物
6、发送绿色信息给人物
7、发送蓝色信息给人物

信息内容中 %s 代表人物名称 %d 代表NPC名称 %t 代表倒计时剩余时间

示例:

[@main]

#if

#act

sendmsg 0 敌军还有%t秒到达战场,请做好准备! 249 0 30 @战斗

这里向全部在线玩家发送了一个持续时间为30秒红字黑边的信息

[@战斗]

#if

#act

sendmsg 6 开始战斗了!

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


脚本召唤宝宝

Help > 执行命令 >
脚本召唤宝宝

命令格式:

RECALLMOB 名字 等级(0-7) 最大召唤数量 叛变时长(分钟) 身体自动变色(1为变色,空或其他为不变) 固定颜色(1-7) 是否显示玩家名(留空为显示)

RECALLMOBEX 名字 X坐标 Y坐标 等级(0-7) 最大召唤数量 叛变时长(分钟) 身体自动变色(1为变色,空或其他为不变) 固定颜色(1-7) 是否显示玩家名(留空为显示)

脚本命令召唤宝宝, 最大召唤数量指玩家现有宝宝数量加上本次召唤数量必须小于最大召唤数量时才可以召唤出来

示例:

[@main]

#if

#act

RECALLMOBEX 稻草人 <$X> <$Y> 7 5 180 1 0 1

SENDMSG 6 你在坐标<$X> <$Y> 召唤了一只7级的稻草人宝宝, 身体会变色, 还不显示主人名字


踢掉在线玩家

Help > 执行命令 >
踢掉在线玩家

命令格式:

KICK 模式(0,1,2)可忽略

将指定玩家踢下线

参数1 =空或0，小退，退回角色选择界面
参数1 =1，大退，必须重新登陆帐号
参数1 =2，离线挂机

示例:

[@main]

#if

#act

sendmsg 6 你已被踢下线,请重新登录

KICK 1


个人定时器

Help > 执行命令 >
个人定时器

命令格式:

开启定时器

SETSCTIMER 定时器编号(0-255) 间隔时间(秒)

SETONTIMER 定时器编号(0-255) 间隔时间(秒)

关闭定时器

KILLSCTIMER 定时器编号(0-255)

SETOFFTIMER 定时器编号(0-255)

开启或关闭个人定时器, 每隔一段时间执行一次QManage.txt里[@OnTimerX]段

示例:

[@main]

#if

#act

SETONTIMER 5 20

sendmsg 6 已开启编号为5的定时器, 每隔20秒执行一次QManage.txt里[@OnTimer5]段落


概率获取文本内容

Help > 执行命令 >
概率获取文本内容

命令格式:

READRANDOMSTR 文本 保存变量

从指定文件内随机读取一行到变量中。

文本内容格式:

字符串1 11

字符串2 22

字符串3 55

11, 22, 55 代表的是读取概率, 数值越大概率越低

示例:

[@main]

#IF
#ACT
ReadRandomLine .\QuestDiary\变量\颜色.txt S15
#SAY
你所获得的颜色是：$STR(S15)


移动怪物到指定位置

Help > 执行命令 >
移动怪物到指定位置

命令格式:

CHANGERANGEMONPOS 怪物名字(*为不匹配怪名) 原地图(SELF为当前地图) 原X坐标 原Y坐标 原范围 新地图 新X坐标 新Y坐标 新范围

MOVEMAPMONTOPOS 怪物名字(*为不匹配怪名) 原地图(SELF为当前地图) 原X坐标 原Y坐标 原范围 新地图 新X坐标 新Y坐标 新范围

移动指定地图坐标的怪物到新的地图位置.

示例:

[@main]
#act
MOVEMAPMONTOPOS 白野猪 3 329 349 10 2 188 433 10
sendmsg 6 你已经将盟重地图(329,349)10格范围内的白野猪传到了毒蛇山谷(188,433) 范围10以内


NPC命令打开卧龙笔记

Help > 执行命令 >
NPC命令打开卧龙笔记

命令格式:

OPENBOOK 参数1 参数2 参数3

参数1：指定到客户端“.\Data\books\参数1\”目录
参数2：结合参数1，指定到客户端“\Data\books\参数1\”目录下的“参数2.uib”文件
参数3：跳转到NPC的节名
OPENBOOK 1 0 @GotoHill //打开客户端. \Data\books\1\ 目录下文件，翻页到最后，点“前往卧龙山庄”触发[@GotoHill]
OPENBOOK 5 1 //打开客户端 .\Data\books\5\1.uib 文件
(注：*.uib是16BitBmp文件，可以自己制作书页)

示例：

[@main]
#ACT
OPENBOOK 1 0 @gohill

;注意此写法，[@Label]+空格+TRUE，表示@gohill允许无条件跳转，如果添加TRUE，
;则只有在#SAY中存在<任意/@Label>才允许无条件跳转，或者任何时候使用goto命令
;此实例中，如果[@gohill]后不加TRUE，OPENBOOK 1 0 @gohill 执行并翻页到最后，将无法跳转到[@gohill]
[@gohill] TRUE
#ACT
MAPMOVE MAP X Y


NPC命令开启宝箱

Help > 执行命令 >
NPC命令开启宝箱

命令格式:

OPENBOX 宝箱名字

使用NPC命令打开背包里的宝箱

示例：

Merchant.txt配置(NPC外型在 60~67,90~92)：
;NPC 地图 X Y 名称 方向 外观 城堡 略...
黄金宝箱 3 335 335 黄金宝箱 0 67 1 0 0 0 1
例：
[@@InPutString0]
#ACT
OPENBOX 黄金宝箱

宝箱配置：

BoxItem.txt

;物品名称 数量 获取几率(1-255,数字越大几率越小),引擎将自动计算,按照几率安排中间一格的物品：获取几率设置 222 将无法获取，注：222 只能设置一个道具存在宝箱设置文件里！
金刚石 10 5
金针碎片 5 10
经验 200000 10
经验 350000 10
声望 10 10
书页 10 20
金刚石 30 40
经验 500000 50
经验 800000 80
声望 20 100
精元丹 1 101
经验 1000000 102
灵虚丹(小) 1 103
舒经活络丸 1 105
书页 20 150
乾坤白玉 1 151
500元宝 1 152
100元宝 1 153
200元宝 1 154
500元宝 1 155
经验 1200000 180
经验 2000000 200
经验 3000000 230
麻痹戒指 1 222


将玩家加入行会

Help > 执行命令 >
将玩家加入行会

命令格式:

AFFILIATEGUILD 行会名字

将指定玩家加入指定行会

示例:

[@main]

#if

#act

AFFILIATEGUILD 听雨阁

sendmsg 6 恭喜你成功加入听雨阁行会


移动所有玩家到另一张地图

Help > 执行命令 >
移动所有玩家到另一张地图

命令格式:

MAPMOVEHUMAN 原地图 目标地图

把原地图所有玩家移动到目标地图随机坐标

示例:

[@main]

#if

#act

MAPMOVEHUMAN 0150 3

sendmsg 6 把沙巴克皇宫的玩家全部移动到土城的随机地点


与指定地图的角色互换位置

Help > 执行命令 >
与指定地图的角色互换位置

命令格式:

EXCHANGEMAP 地图代码 类型(APPR为师徒, DEAR为夫妻, 留空为随机)

和指定地图的玩家互换位置, 可以师徒互换也可以夫妻互换

示例:

[@main]

#if

#act

EXCHANGEMAP 0150 APPR

sendmsg 6 你和在沙巴克皇宫与你有师徒关系的互换了位置


按地图列表移动

Help > 执行命令 >
按地图列表移动

命令格式:

ADDBATCH 地图代码 坐标X(可忽略) 坐标Y(可忽略)

BATCHDELAY 时间(秒)

BATCHMOVE

先用 BATCHDELAY 命令设定每一张地图停留的地间，再把地图列表添加一下，

然后用 BATCHMOVE 开始执行跳转,人物会从第一张地图开始一张一张移动到最后一张,中途人物死亡停止跳转

示例:

[@main]
#IF
#ACT
BATCHDELAY 1 ;(暂停时间)
ADDBATCH B102 ;步进地图名1
ADDBATCH B103 ;步进地图名2
ADDBATCH B104 ;步进地图名3
ADDBATCH B105 ;步进地图名4
ADDBATCH B106 ;步进地图名5
ADDBATCH B107 ;步进地图名6
BATCHMOVE ;开始从第一个步进地图移动到最后一个步进地图(这里是6)


掷骰子命令

Help > 执行命令 >
掷骰子命令

命令格式:

PLAYDICE 骰子数量(1-3) 跳转段落

投出指定数量的骰子,执行此命令之前先定义D0,D1,D2的值,分别代表三个骰子将要掷出的点数

示例:

[@main]

#if

#act

MOV D0 2

MOV D1 4

MOV D2 6

PLAYDICE 3 @测试

[@测试]

#act

sendmsg 6 你投了3个骰子,点数分别为<$STR(D0)>, <$STR(D1)>, <$STR(D2)>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


将玩家名字添加到指定文本

Help > 执行命令 >
将玩家名字添加到指定文本

命令格式:

ADDNAMELIST 文本.txt

将玩家的名字添加到指定文本中,如果名字已经存在就不再添加

[@main]

#if

#act

ADDNAMELIST ..\QusestDiary\测试名单.txt

sendmsg 6 已经把你的名字添加到测试名单中


将玩家名字从指定文本中删除

Help > 执行命令 >
将玩家名字从指定文本中删除

命令格式:

DELNAMELIST 文本.txt

将玩家的名字从指定文本中删除

示例:

[@main]

#if

#act

DELNAMELIST ..\QuestDiary\测试名单.txt

sendmsg 6 已经将你的名字从测试名单中删除


将行会名添加到指定文本

Help > 执行命令 >
将行会名添加到指定文本

命令格式:

ADDGUILDLIST 文本.txt

将玩家的行会名字添加到指定文本中,如果名字已经存在就不再添加

[@main]

#if

#act

ADDGUILDLIST ..\QusestDiary\测试行会名单.txt

sendmsg 6 已经把你的行会名字添加到测试行会名单中


将行会名从指定文本中删除

Help > 执行命令 >
将行会名从指定文本中删除

命令格式:

DELGUILDLIST 文本.txt

将玩家的行会名字从指定文本中删除

示例:

[@main]

#if

#act

DELGUILDLIST ..\QuestDiary\测试行会名单.txt

sendmsg 6 已经将你的行会名字从测试名单中删除


将玩家账号添加到指定文本

Help > 执行命令 >
将玩家账号添加到指定文本

命令格式:

ADDACCOUNTLIST 文本.txt

将玩家账号添加到指定文本中,已经存在将不会重复添加

示例:

[@main]

#if

#act

ADDACCOUNTLIST ..\QuestDiary\测试账号文本.txt

sendmsg 6 你的帐号已经添加进测试账号文本中了


将玩家帐号从指定文本删除

Help > 执行命令 >
将玩家帐号从指定文本删除

命令格式:

DELACCOUNTLIST 测试帐号文本.txt

将玩家帐号从指定文本中删除

示例:

[@main]

#if

#act

DELACCOUNTLIST ..\QuestDiary\测试帐号文本.txt

sendmsg 6 你的帐号已经从测试帐号文本中删除


将玩家IP添加到指定文本

Help > 执行命令 >
将玩家IP添加到指定文本

命令格式:

ADDIPLIST 测试文本.txt

将玩家当前的登陆IP添加到指定文本中,已经存在的IP不会重复添加

示例:

[@main]

#if

#act

ADDIPLIST ..\QuestDiary\测试IP文本.txt

sendmsg 6 你的IP已经添加进测试IP文本中了


将玩家IP从指定文本中删除

Help > 执行命令 >
将玩家IP从指定文本中删除

命令格式:

DELIPLIST 测试IP文本.txt

将玩家当前的IP从指定文本中删除

示例:

[@main]

#if

#act

DELIPLIST ..\QuestDiary\测试IP文本.txt

sendmsg 6 你的IP地址已经从测试IP文本中删除


刷新背包命令

Help > 执行命令 >
刷新背包命令

命令格式:

QUERYBAGITEMS 间隔时间(秒, 留空默认为是10秒检测)

刷新玩家背包命令, 和背包刷新按钮一样效果

示例:

[@main]

#if

#act

QUERYBAGITEMS

sendmsg 6 背包刷新成功


修改英雄的PK值

Help > 执行命令 >
修改英雄的PK值

命令格式:

CHANGEHEROPKPOINT 控制符(+-=) 点数

修改玩家英雄的PK点

示例:

[@main]

#if

#act

CHANGEHEROPKPOINT = 0

sendmsg 6 你英雄的PK点已经被清零了


修改英雄当前经验值

Help > 执行命令 >
修改英雄当前经验值

命令格式:

CHANGEHEROEXP 控制符(+-=) 数值

修改英雄当前已获得的经验值

示例:

[@main]

#if

#act

CHANGEHEROEXP + 10000

sendmsg 6 你英雄的经验值增加一万点


修改技能熟练度

Help > 执行命令 >
修改技能熟练度

命令格式:

CHANGETRANPOINT 技能名字 操作符(+-=) 点数

修改玩家已有技能的熟练度

示例:

[@main]

#if

#act

CHANGETRANPOINT 烈火剑法 + 100

sendmsg 6 你烈火剑法的熟练度增加100点


将字符串写到指定文本

Help > 执行命令 >
将字符串写到指定文本

命令格式:

ADDLINELIST 文本.txt 字符串(可以是变量)

ADDTEXTLIST 文本.txt 字符串(可以是变量)

将字符串写入到指定文本的最后一行

示例:

[@main]

#if

#act

MOV S66 测试内容

ADDLINELIST ..\QuestDiary\测试文本.txt <$str(s66)>

sendmsg 6 成功把 <$str(s66)>的值写入到测试文本中


删除指定文本的中的字符串

Help > 执行命令 >
删除指定文本的中的字符串

命令格式:

DELLINELIST 测试文本.txt 字符串(可以为变量)

将字符串从指定文本中删除

示例:

[@main]

#if

#act

MOV S5 测试内容

DELLINELIST ..\QuestDiary\测试文本.txt <$str(s5)>

sendmsg 6 成功把 <$str(s5)>的值从测试文本中删除


清除地图物品

Help > 执行命令 >
清除地图物品

命令格式:

CLEARMAPITEM 地图代码 X坐标 Y坐标 范围 物品名(留空则为全部)

清除指定地图范围内的掉落的物品, 不填写物品名则清除范围内全部物品

示例:

[@main]

#if

#act

CLEARMAPITEM 3 330 330 10 回城卷

sendmsg 6 已经把土城安全区地面掉落的回城卷全部删除了


动态添加地图连接点

Help > 执行命令 >
动态添加地图连接点

命令格式:

ADDMAPROUTE 原地图 原坐标X 原坐标Y 新地图 新坐标X 新坐标Y 是否互通(0或空不互通, 1为互通)

DELMAPROUTE 原地图 原坐标X 原坐标Y

增加一个地图连接点, 服务器重启失效, 也可以使用 DELMAPROUTE 命令删除该连接点

互通的意思就是也能从新地图的坐标连接到原地图的坐标, 有来有回

示例:

[@main]

#if

#act

ADDMAPROUTE 3 330 330 0150 12 12

sendmsg 6 创建一个新的连接点,从土城330 330 到沙巴克皇宫 12 12,有来无回

#if

#act

DELMAPROUTE 3 330 330

sendmsg 6 该连接点已被删除


自定义输入功能

Help > 执行命令 >
自定义输入功能

命令格式一:

QUERYVALUE 返回的变量编号 返回的变量类型(0字符型保存到S变量, 1整数型保存到M变量, 2无返回值) 限制输入长度 返回后跳转的字段 输入框提示内容 字段宿主NPC(QF, QM 或者空)

给玩家弹出一个输入框, 将玩家输入的内容返回到变量中,然后用于其他操作

字段宿主NPC指的是 将要跳转的字段所属哪个NPC , QF= QFunction，QM= QManage，空值为当前NPC

示例:

[@main]

#if

#act

QUERYVALUE 88 0 20 @测试 请输入字符串 QF

QFunction-0.txt 内容如下

[@测试]

#act

sendmsg 6 你所输入的内容为<$STR(S88)>..

命令格式二：

@@InputStringX 和@@InputIntegerX 分别保存的变量为S和N 使用这个格式需要在当前脚本头部标识里添加 （@@InPutString @@InPutInteger)

示例：

[@MAIN]

下面是自定义输入测试！\

<请输入文字/@@InPutString99> <请输入数字/@@InPutInteger88>

[@InPutString99]

#act

sendmsg 6 你输入的文字是<$STR(S99)>

[@InPutInteger88]

#act

sendmsg 6 你输入的数字是<$STR(N88)>

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


获取字符串长度

Help > 执行命令 >
获取字符串长度

命令格式:

GETSTRLENGTH 字符串 保存变量

获取字符串保存到指定变量中

示例:

[@main]

#if

#act

GETSTRLENGTH <$username> M1

sendmsg 6 你的角色名字长度为<$str(M1)>


技能互换功能

Help > 执行命令 >
技能互换功能

命令格式:

CONVERTSKILL 技能A 技能B

将人物指定技能替换成新的技能, 原技能的等级,熟练度都会保留

前提是自身已经学习了技能A

示例:

[@main]

#if

#act

CONVERTSKILL 烈火剑法 冰咆哮

sendmsg 6 已经成功把你的烈火剑法替换成冰咆哮了


杀死玩家宝宝

Help > 执行命令 >
杀死玩家宝宝

命令格式:

KILLSLAVENAME 宝宝名字(*为所有宝宝) 杀死数量(为空时不计数)

杀死玩家宝宝

示例:

[@main]

#if

#act

KILLSLAVENAME 神兽

sendmsg 6 你的神兽宝宝已经被清理掉了

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


随机获取文本内容

Help > 执行命令 >
随机获取文本内容

命令格式:

READRANDOMLINE 文本.txt 保存变量

GETRANDOMTEXT 文本.txt 保存变量 行数(0-65535, 留空时为随机获取)

随机获取指定文本的某一行内容 保存到指定变量

示例:

[@main]

#if

#act

READRANDOMLINE ..\QuestDiary\测试文本.txt S12

sendmsg 6 随机获取到的文本内容是<$STR(S12)>

#if

#act

GETRANDOMTEXT ..\QuestDiary\测试文本.txt S12 5

sendmsg 6 获取到的第5行文本内容是<$STR(S12)>


发送滚动消息

Help > 执行命令 >
发送滚动消息

命令格式:

SENDSCROLLMSG 模式(0全服,1个人) 消息内容 前景色(0-255) 背景色(0-255) Y坐标

发送一条屏幕滚动消息,

%s 为玩家名字

%d 为对象名字

%m 为玩家所处地图

%x 为玩家X坐标

%y 为玩家Y坐标

示例:

[@main]

#if

#act

SENDSCROLLMSG 0 这是一条全服滚动消息,发送人是%s,他当前所在地图%m,%x,%y处 249 0 50


自动召唤英雄

Help > 执行命令 >
自动召唤英雄

命令格式:

RECALLHERO 参数1(为空时召唤英雄, 不为空时收回英雄)

自动召唤/收回英雄

示例:

[@main]

#if

HAVEHERO

#act

RECALLHERO

sendmsg 6 成功召唤英雄

#if

#act

RECALLHERO 1

sendmsg 6 你已收回英雄


获取玩家对面的角色名字

Help > 执行命令 >
获取玩家对面的角色名字

命令格式:

GETPOSENAME 保存变量

获取对面的角色名字保存到指定变量

示例:

[@main]

#if

#act

GETPOSENAME S88

SENDMSG 6 你对面的角色名是<$STR(S88)>


播放背景音乐

Help > 执行命令 >
播放背景音乐

命令格式:

PLAYSOUND 文件名.wav 循环(0否/1是) 播放对象

播放背景音乐命令

播放对象:

all 为所有玩家

Guild 为所有行会成员

地图代码 为指定地图的玩家

为空时只有自己播放

示例：

PLAYSOUND .\wav\log-in-long2.wav 0 all 【所有在线的玩家播放客户端下的该音乐log-in-long2.wav】

PLAYSOUND .\wav\log-in-long2.wav 0 Guild 【执行该命令的行会玩家，同行会的全部播放，如无行会则不播放】

PLAYSOUND .\wav\log-in-long2.wav 0 3 【3，则盟重的所有人都播放】

PLAYSOUND .\wav\log-in-long2.wav 0 【参数为空 //自己播放】


更改玩家发型

Help > 执行命令 >
更改玩家发型

命令格式:

HAIRSTYLE 头发类型(1为长发型.当人物为男时.0为光头.当人物为女时.0为短发)

更改玩家发型

示例:

[@main]

#if

#act

HAIRSTYLE 0

sendmsg 6 你的头发已更改


组队传送命令

Help > 执行命令 >
组队传送命令

命令格式:

GROUPMAPTING 地图代码 X坐标(可留空) Y坐标(可留空)

GROUPMAPMOVE 地图代码 X坐标 Y坐标 最低等级 触发标签(QFunction内) 组长可用(空为不限制)

将小组成员集体传送到指定地图坐标, 如果坐标为空则为随机传送到指定地图

示例:

[@main]

#if

#act

GROUPMAPTING 0150

sendmsg 6 把你的小组成员集体传送到沙巴克皇宫


延迟跳转命令

Help > 执行命令 >
延迟跳转命令

命令格式:

DELAYGOTO 延迟时间(毫秒) 跳转@段落

DELAYCALL 延迟时间(毫秒) 跳转@段落

延迟跳转到当前脚本中的指定段落

CLEARDELAYGOTO

清除 DELAYGOTO 和 DELAYCALL 的延迟跳转效果

示例:

[@main]

#if

#act

DELAYGOTO 500 @测试

[@测试]

#act

sendmsg 6 延迟跳转成功


在地图上放置物品

Help > 执行命令 >
在地图上放置物品

命令格式:

THROWITEM 地图编号 坐标X 坐标Y 范围 物品名称 掉落数量 掉落捡取时间(秒) 是否掉落提示 是否可以立即捡取(0否/1是)

来源类型(0-9) 来源地图 来源怪物或NPC 经手人

在地图指定范围放置物品, 掉落拾取时间是指放置后多长时间后玩家才能捡起来

如果是否可以立即捡取参数为1时, 则所有玩家无需等待时间直接就能捡起来

来源信息要么全部为空,要么全部写上

来源类型: (0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：挖肉获取；9：捕捉获取)

示例:

[@main]

#if

#act

THROWITEM 3 330 330 10 回城卷 10 60 1 0

sendmsg 6 土城安全区内放置了10个回城卷,60秒后才可捡取

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


清空文本内容命令

Help > 执行命令 >
清空文本内容命令

命令格式:

CLEARNAMELIST 文本.txt

清空指定文本内容

示例:

[@main]

#if

#act

CLEARNAMELIST ..\QuestDiary\测试文本.txt

sendmsg 6 测试文本的内容已被清空


清除指定范围内的怪物

Help > 执行命令 >
清除指定范围内的怪物

命令格式:

KILLSLAVE 地图代码(SELF为当前地图) X坐标 Y坐标 范围 怪物名字(为*时为所有怪物) 数量 方式(0清除/1杀死) 是否计算宝宝(0否1是)

清除指定范围内的所有怪物

示例:

[@main]

#if

#act

KILLSLAVE 3 330 330 10 * 99 0

sendmsg 6 清除土城安全区内的所有怪物和宝宝,不留尸体

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


改变玩家性别命令

Help > 执行命令 >
改变玩家性别命令

命令格式:

CHANGEGENDER 性别(0男/1女)

改变玩家的性别

示例:

[@main]

#if

#act

CHANGEGENDER 0

sendmsg 6 你的性别已改变


设置玩家下线触发

Help > 执行命令 >
设置玩家下线触发

命令格式:

SETOFFLINEFUNC 触发@字段

设置玩家下线触发指定字段

触发字段为QFunction.txt文本中指定的脚本段落.设置后下线将触发[@Label]如参数一留空则为取消下线触发.

OFFLINE 间隔时间(秒) 经验值 离线挂机时长(分钟,留空为15天)

设置离线挂机时间和经验

示例:

[@main]

#if

#act

SETOFFLINEFUNC @测试触发

QFunction脚本中的

[@测试触发]

#if

#act

OFFLINE 60 3000000 1440

参数三 为空时，无限时间脱机挂着，否则为脱机的时间限制(分钟)，超过该时间踢下线


更改玩家金刚石数量

Help > 执行命令 >
更改玩家金刚石数量

命令格式:

GAMEDIAMOND 操作符(+-=) 数值 倍数(可忽略)

调整玩家金刚石数量

示例:

[@main]

#if

#act

GAMEDIAMOND + 100 2

sendmsg 6 金刚石增加200个


更改玩家灵符数量

Help > 执行命令 >
更改玩家灵符数量

命令格式:

GAMEGIRD 操作符(+-=) 数值 倍数(可忽略)

调整玩家灵符数量

示例:

[@main]

#if

#act

GAMEGIRD + 200 3

sendmsg 6 你的灵符增加600个


分配玩家属性点

Help > 执行命令 >
分配玩家属性点

命令格式:

BONUSABIL 属性类别 操作符(+-) 点数(1-1000)

使用脚本命令增加或者减少玩家属性点

增加时,未分配属性点必须大于等于增加的点数

属性类别:

DC 攻击

MC 魔法

SC 道术

AC 防御

MAC 魔御

HP 气血

MP 魔力

HIT 准确

SPD 敏捷

示例:

[@main]

#if

#act

BONUSABIL DC + 10

sendmsg 6 你的攻击属性点增加10点


调整英雄技能等级

Help > 执行命令 >
调整英雄技能等级

命令格式:

HEROSKILLLEVEL 技能名字 操作符(+-=) 数值

调整英雄技能等级

示例:

[@main]

#if

#act

HEROSKILLLEVEL 烈火剑法 = 3

sendmsg 6 你英雄的烈火剑法等级调整成3级


调整英雄声望点

Help > 执行命令 >
调整英雄声望点

命令格式:

HEROCREDITPOINT 操作符(+-=) 数值

调整英雄的声望点

示例:

[@main]

#if

#act

HEROCREDITPOINT + 10

sendmsg 6 你英雄的声望点增加10点


切换攻击模式

Help > 执行命令 >
切换攻击模式

命令格式:

CHANGEATTACKMODE 模式(0-6)

切换玩家的攻击模式

0 全体攻击

1 和平攻击

2 夫妻攻击

3 师徒攻击

4 编组攻击

5 行会攻击

6 善恶攻击

示例:

[@main]

#if

#act

CHANGEATTACKMODE 5

sendmsg 6 你的攻击模式已经被切换成行会攻击模式了


调整英雄的等级

Help > 执行命令 >
调整英雄的等级

命令格式:

CHANGEHEROLEVEL 操作符(+-=) 数值

调整玩家英雄的等级

示例:

[@main]

#if

#act

CHANGEHEROLEVEL + 5

sendmsg 6 你的英雄等级提升5级


调整玩家等级

Help > 执行命令 >
调整玩家等级

命令格式:

CHANGELEVEL 操作符(+-=) 数值

调整玩家的等级

示例:

[@main]

#if

#act

CHANGELEVEL + 5

sendmsg 6 你的等级提升5级


清除玩家所有技能

Help > 执行命令 >
清除玩家所有技能

命令格式:

CLEARSKILL

清除玩家所有技能

示例:

[@main]

#if

#act

CLEARSKILL

sendmsg 6 你的技能全部被清除


清除非本职业技能

Help > 执行命令 >
清除非本职业技能

命令格式:

DELNOJOBSKILL

清除非玩家当前职业的所有技能, 通用技能除外

示例:

[@main]

#if

#act

DELNOJOBSKILL

sendmsg 6 所有非你职业的技能已经被全部清理


删除玩家技能

Help > 执行命令 >
删除玩家技能

命令格式:

DELSKILL 技能名字

删除玩家指定技能

示例:

[@main]

#if

#act

DELSKILL 烈火剑法

sendmsg 6 你的烈火剑法已经被删除


学习技能

Help > 执行命令 >
学习技能

命令格式:

ADDSKILL 技能名字 技能等级(可忽略)

给玩家增加指定技能

示例:

[@main]

#if

#act

ADDSKILL 烈火剑法 3

sendmsg 6 成功学会3级烈火剑法


调整技能等级

Help > 执行命令 >
调整技能等级

命令格式:

SKILLLEVEL 技能名字 操作符(+-=) 等级

调整玩家指定技能等级,玩家必须已经学会此技能

示例:

[@main]

#if

#act

SKILLLEVEL 烈火剑法 + 1

sendmsg 6 你的烈火剑法提升1级


调整玩家PK点

Help > 执行命令 >
调整玩家PK点

命令格式:

CHANGEPKPOINT 操作符(+-=) 点数

调整玩家PK点数

示例:

[@main]

#if

#act

CHANGEPKPOINT + 100

sendmsg 6 你的PK点增加100点,快看看有没有红名


调整玩家经验值

Help > 执行命令 >
调整玩家经验值

命令格式:

CHANGEEXP 操作符(+-=) 数值 是否增加聚灵珠经验(0或空为不增加,1为增加)

调整玩家的当前经验值

示例:

[@main]

#if

#act

CHANGEEXP + 10000

sendmsg 6 你当前经验值增加10000点

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


调整玩家职业

Help > 执行命令 >
调整玩家职业

命令格式:

CHANGEJOB 职业(Warrior战士, Wizard法师 ,Taoist道士)

调整玩家职业

示例:

[@main]

#if

#act

CHANGEJOB Warrior

sendmsg 6 你的职业已经变成战士了


脚本控制怪物攻城

Help > 执行命令 >
脚本控制怪物攻城

功能：
      实现由脚本控制怪物攻城

介绍：

;怪物集中位置.怪物会自动向此位置集中
Mission 地图名 座标X 座标Y

;刷新怪物座标X
Param1 X

;刷新怪物座标Y
Param2 Y

;刷新怪物数量
Param3 数量

;刷新怪物范围
Param4 范围

;刷新怪物名称
MobPlace 怪物名称

;=======================================
[@MobMission]
#If
#Act
Mission 3 330 330
Param1 360
Param2 340
Param3 10
Param4 5
MobPlace 半兽勇士
;=======================================


调整玩家会员类型

Help > 执行命令 >
调整玩家会员类型

命令格式:

SETMEMBERTYPE 操作符(+-=) 数值

调整玩家的会员类型

示例:

[@main]

#if

#act

SETMEMBERTYPE + 1

sendmsg 6 你的会员类型又提升一级


调整玩家会员等级

Help > 执行命令 >
调整玩家会员等级

命令格式:

SETMEMBERLEVEL 操作符(+-=) 数值

调整玩家的会员等级

示例:

[@main]

#if

#act

SETMEMBERLEVEL + 1

sendmsg 6 你的会员等级提升1级


调整玩家元宝数量

Help > 执行命令 >
调整玩家元宝数量

命令格式:

GAMEGOLD 操作符(+-=) 数量 倍数(可忽略)

调整玩家的元宝数量

示例:

[@main]

#if

#act

GAMEGOLD + 100 2

sendmsg 6 你的元宝数量增加200个


设置自动增加元宝

Help > 执行命令 >
设置自动增加元宝

命令格式:

AUTOADDGAMEGOLD 开关(START/ STOP)

设置玩家自动增加元宝

示例:

[@main]

#if

#act

PARAM1 1 //增加元宝的数量

PARAM2 10 //间隔时间(秒)

AUTOADDGAMEGOLD START

sendmsg 你已进入自动增加元宝时间,每10秒钟获得1个元宝


设置自动减少元宝

Help > 执行命令 >
设置自动减少元宝

命令格式:

AUTOSUBGAMEGOLD 开关(START/ STOP)

设置玩家自动减少元宝

示例:

[@main]

#if

#act

PARAM1 1 //减少元宝的数量

PARAM2 10 //间隔时间(秒)

AUTOSUBGAMEGOLD START

sendmsg 你已进入自动减少元宝时间,每10秒钟扣除1个元宝


调整玩家名字颜色

Help > 执行命令 >
调整玩家名字颜色

命令格式:

CHANGENAMECOLOR 颜色(0-255)

修改玩家名字的颜色

示例:

[@main]

#if

#act

CHANGENAMECOLOR 250

sendmsg 6 你的名字已经变成绿油油的颜色


清除仓库密码

Help > 执行命令 >
清除仓库密码

命令格式:

CLEARPASSWORD

清除玩家仓库密码

示例:

[@main]

#if

#act

CLEARPASSWORD

sendmsg 6 你的仓库密码已被清除,请重新设置密码


人物转生

Help > 执行命令 >
人物转生

命令格式:

RENEWLEVEL 转生次数(1-255) 转生后人物等级(为0时保证不变) 人物增加属性点

人物转生控制

示例:

[@main]

#if

#act

RENEWLEVEL 5 0 100

sendmsg 6 恭喜你完成一次转生,人物等级保持不变,并获得100点属性点

功能：
      设置及更改转生人物显示的名称
格式：
      配置文件：String.ini

以下为相关配置内容：
;==========================================
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*

WarrReNewName 　武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 　道士转生后名称显示
;==========================================


调整玩家杀怪经验倍数

Help > 执行命令 >
调整玩家杀怪经验倍数

命令格式:

KILLMONEXPRATE 倍数 时间(秒,为0时在线一直有效) 下线是否保存(0否1是) 是否提示(0否1是)

调整玩家杀怪经验倍数, 人物初始倍数为100 ,也就是1倍

示例:

[@main]

#if

#act

KILLMONEXPRATE 200 0

sendmsg 6 你的杀怪经验倍数为2倍,在线一直有效

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


调整玩家攻击力倍数

Help > 执行命令 >
调整玩家攻击力倍数

命令格式:

POWERRATE 倍数 时长(秒,为0时在线一直有效) 是否提示(0否1是)

调整玩家攻击力倍数, 玩家初始倍数为100,也就是1倍

示例:

[@main]

#if

#act

POWERRATE 300 0

sendmsg 6 你的攻击力提升为原来的3倍,在线一直有效


设置玩家模式

Help > 执行命令 >
设置玩家模式

命令格式:

CHANGEMODE 模式(1管理模式, 2无敌模式, 3隐身模式)

CHANGEMODEEX 模式(0-9) 时间(秒,1-65535, 为0在线一直有效) 附加值(1-65535)

设置玩家当前模式

CHANGEMODEEX的模式:

0 无敌

1 隐身

2 HP

3 MP

4 攻击力

5 魔法力

6 道术力

7 攻击速度

8 禁止攻击

9 锁定

10 破护身

11 防麻痹

12 破复活

13 传送

14 防全毒

无敌,隐身,禁止攻击模式时附加值参数无效

示例:

[@main]

#if

#act

CHANGEMODE 2

sendmsg 6 你以进入无敌模式

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


调整玩家权限等级

Help > 执行命令 >
调整玩家权限等级

命令格式:

CHANGEPERMISSION 权限等级(1-10)

调整玩家的权限等级

示例:

[@main]

#if

#act

CHANGEPERMISSION 10

sendmsg 6 已经把你的管理权限调整到10,你现在是超级管理员了


杀死人物

Help > 执行命令 >
杀死人物

命令格式:

KILL 类型(0-3)

杀死人物

类型:
Kill 0 人物死亡.不显示凶手信息
Kill 1 人物死亡.不掉物品.不显示凶手信息
Kill 2 人物死亡.显示凶手信息为NPC
Kill 3 人物死亡.不掉物品.显示凶手信息为NPC

示例:

[@main]

#if

#act

KILL 0

sendmsg 6 你被杀死了,不知道是谁干的


调整玩家属性点(未分配)

Help > 执行命令 >
调整玩家属性点(未分配)

命令格式:

BONUSPOINT 操作符(+-=) 数值(1-10000)

调整玩家未分配的属性点

示例:

[@main]

#if

#act

BONUSPOINT + 100

sendmsg 6 你的未分配属性点增加100点


清除玩家转生等级

Help > 执行命令 >
清除玩家转生等级

命令格式:

RESTRENEWLEVEL

,清除玩家转生等级

示例:

[@main]

#if

#act

RESTRENEWLEVEL

sendmsg 6 你的转生等级已被清除


调整玩家声望

Help > 执行命令 >
调整玩家声望

命令格式:

CREDITPOINT 操作符(+-=) 点数(1-2100000000)

调整玩家声望点

示例:

[@main]

#if

#act

CREDITPOINT + 100

sendmsg 6 你的声望点增加100点


升级装备命令

Help > 执行命令 >
升级装备命令

命令格式:

UPGRADEITEM 装备位置(0-34) 成功几率(0-100, 0为必成) 点数几率(0-255)

随机给装备增加属性, 成功几率数值越大概率越小,为0时必定成功

UPGRADEITEMEX 装备位置 属性位置(0-22) 成功几率(0-100) 点数几率(0-255) 失败处理(0不做改变, 1收走物品, 2还原物品) 是否提示(为空时提示)

示例:

[@main]

#if

#act

UPGRADEITEMEX 1 1 50 5 2

sendmsg 6 给你的武器进行升级,失败将还原物品初始属性


脚本刷怪命令

Help > 执行命令 >
脚本刷怪命令

命令格式:

MONGENEX 地图代码 X坐标 Y坐标 怪物名字 范围 数量 名字颜色(可留空,0-255) 是否内功怪(0或空为否, 1是)

使用脚本命令在指定地图刷怪

M2里的MenGen.txt文件格式如下:

地图代码 X坐标 Y坐标 怪物名字 范围 数量 间隔时间 集中刷新概率(0~100,可空) 名字颜色(可空) 是否内功怪(可空)

示例:

[@main]

#if

#act

MONGENEX 3 330 330 白野猪 5 10

sendmsg 6 在土城安全区330 330范围5内刷新出10只白野猪

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


变更地图参数

Help > 执行命令 >
变更地图参数

命令格式:

SETMPAMODE 地图代码 地图参数 参数1 参数2

变更指定地图的参数设置, 一般情况下 参数1为空表示取消此参数, 不为空则为开启

在自动增减元宝或经验的这些参数中,参数1代表的是间隔时间, 参数2代表的是增减的数值

示例;

[@main]

#if

#act

SETMPAMODE 3 DECGAMEGOLD 5 1

sendmsg 6 修改盟重土城地图参数为每5秒钟扣除1元宝


调整玩家游戏点

Help > 执行命令 >
调整玩家游戏点

命令格式:

GAMEPOINT 操作符(+-=) 数值

调整玩家的游戏点

示例:

[@main]

#if

#act

GAMEPOINT + 100

sendmsg 6 你的游戏点增加100点


重置玩家属性点

Help > 执行命令 >
重置玩家属性点

命令格式:

RESTBONUSPOINT

重置玩家已经使用过的属性点

示例:

[@main]

#if

#act

RESTBONUSPOINT

sendmsg 6 你的属性点已重置,请重新分配


增加或减少玩家血和蓝

Help > 执行命令 >
增加或减少玩家血和蓝

命令格式:

HUMANHP 操作符(+-=) 数值 模式(0数值, 1总量百分比, 2当前量百分比)

HUMANMP 操作符(+-=) 数值 模式(0数值, 1总量百分比, 2当前量百分比)

增加或减少玩家的气血(魔力)值

示例:

[@main]

#if

#act

HUMANHP - 30 1

sendsmg 6 你的血量被扣除最大血量的30%


鞭尸命令

Help > 执行命令 >
鞭尸命令

命令格式:

OPENITEMBOX 怪物名字 设置归属(0所有人, 1执行者)

快速杀死怪物, 怪物死亡后会按爆率文件来爆出物品。

示例:

[@main]

#if

#act

OPENITEMBOX 赤月恶魔 1

sendmsg 6 赤月恶魔被鞭尸了,又爆了一遍东西


执行GM命令

Help > 执行命令 >
执行GM命令

命令格式:

GMEXECUTE 命令 参数1 参数2 参数3 参数4 参数5

用脚本命令来执行GM命令,参数1-5没有固定的格式

示例:

假如M2给玩家增加技能的命令为: 增加技能

[@main]

#if

#act

GMEXECUTE 增加技能 小小青年 烈火剑法 3

sendmsg 6 玩家小小青年增加了一个3级的烈火剑法


记录当前日期到指定文本

Help > 执行命令 >
记录当前日期到指定文本

命令格式:

ADDNAMEDATELIST 文本.txt

记录当前日期年月日到指定文本中

DELNAMEDATELIST 文本.txt

删除年月日记录

格式:

角色名 2023-12-11

示例:

[@main]

#if

#act

ADDNAMEDATELIST ..\QuestDiary\测试文本.txt

sendmsg 6 记录成功

#if

#act

DELNAMEDATELIST ..\QuestDiary\测试文本.txt

sendmsg 6 删除成功


设置地图光环效果

Help > 执行命令 >
设置地图光环效果

命令格式:

MOBFIREBURN 地图代码 X坐标 Y坐标 光环类型 时间(秒)

在地图指定坐标放置光圈特效

光环类型
1是僵尸钻的地洞
3是碎石块
4是困魔光
5是火墙
6是祖码教主裂开的石头
7是地刺
8是雷电
9-14是大雷电
15是流星火环
16是火龙泉
17是灵光
18是宝箱发光
19是光环门
20是光球
其他自己测试

示例:

[@main]

#if

#act

MOBFIREBURN 3 320 348 5 60
MOBFIREBURN 3 320 349 5 60
MOBFIREBURN 3 320 350 5 60
MOBFIREBURN 3 320 351 5 60
MOBFIREBURN 3 321 348 5 60
MOBFIREBURN 3 321 349 5 60
MOBFIREBURN 3 321 350 5 60
MOBFIREBURN 3 321 351 5 60
SendMsg 0 盟重开火墙，有效1分钟


发送弹窗消息

Help > 执行命令 >
发送弹窗消息

命令格式:

MESSAGEBOX 消息内容

发送一个弹窗消息

示例:

[@main]

#if

#act

MESSAGEBOX 测试成功!


在线泡经验

Help > 执行命令 >
在线泡经验

命令格式:

SETAUTOGETEXP 间隔时间 获得经验 是否为安全区(0为任何地方) 地图代码(留空为任何地图)

设置玩家在线增加经验(泡级)

示例:

[@main]

#if

#act

SETAUTOGETEXP 5 3000 1 3

sendmsg 6 每5秒钟获得3000经验,只在土城安全区有效


随机验证码命令

Help > 执行命令 >
随机验证码命令

命令格式:

SETRANDOMNO

随机生成验证码

示例:

[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>：<$RANDOMNO>

[@@CheckNo]
#If
CheckRandomNo
#Act
SendMsg 5 [提示]:验证码输入正确.
Close
#ElseAct
SendMsg 5 [提示]:验证码输入错误.
Close

相关链接: CHECKRANDOMNO


行会地图传送

Help > 执行命令 >
行会地图传送

命令格式:

GUILDMAPMOVE 地图代码 X坐标 Y坐标

行会成员集体传送到指定地图

示例:

[@main]

#if

#act

GUILDMAPMOVE 0150 12 12

sendmsg 6 你使用风雷召唤令把行会成员全部召唤到沙巴克皇宫了


创建行会命令

Help > 执行命令 >
创建行会命令

命令格式:

ADDGUILD 行会名字

新建一个行会

示例:

[@main]

#if

#act

ADDGUILD 风雨阁

sendmsg 6 成功创建风雨阁行会


特修全身装备

Help > 执行命令 >
特修全身装备

命令格式:

REPAIRALL

特殊修理全身装备

示例:

[@main]

#if

#act

REPAIRALL

sendmsg 6 你全身的装备都已经修理好了


设置人物下线是否自动安全区挂机

Help > 执行命令 >
设置人物下线是否自动安全区挂机

命令格式:

SETOFFLINEPLAY 开关(ON/OFF)

设置人物安全区下线开启脱机功能

示例:

[@main]
#IF
CHECKLEVELEX > 0
#ACT
SETOFFLINEPLAY ON
SENDMSG 7 你现在已经开启下线安全区自动脱机功能！

[@Login]
#IF
CHECKLEVELEX > 0
#ACT
SETOFFLINEPLAY OFF
SENDMSG 7 你现在没有开启下线安全区自动脱机功能！


调整英雄职业

Help > 执行命令 >
调整英雄职业

命令格式:

CHANGEHEROJOB 职业(Warrior战士, Wizard法师 ,Taoist道士)

调整英雄的职业

示例:

[@main]

#if

#act

CHANGEHEROJOB Wizard

sendmsg 6 你的英雄已经转职成法师了


删除英雄所有技能

Help > 执行命令 >
删除英雄所有技能

命令格式:

CLEARHEROSKILL

删除英雄的所有技能

示例:

[@main]

#if

#act

CLEARHEROSKILL

sendmsg 6 你英雄的所有技能已经被清空


给玩家附加临时属性

Help > 执行命令 >
给玩家附加临时属性

命令格式:

CHANGEHUMABILITY 属性类别 操作符(+-= ) 点数(1-65535) 时间(秒, 为0时在线一直有效 ) 是否百分比(0或空否1是)

给玩家附加临时属性

属性类别:

0防御下限 1防御上限 2魔御下限 3魔御上限 4攻击力下限 5攻击力上限 6魔法下限 7魔法上限 8道术下限 9道术上限

10MAXHP 11MAXMP 12内功减伤 13HP恢复 14MP恢复 15中毒恢复 16毒物躲避 17魔法躲避 18准确 19敏捷 20幸运 21内功增伤

示例:

[@main]

#if

#act

CHANGEHUMABILITY 4 + 100 600

sendmsg 6 你的攻击力下限增加100点, 持续600秒

配套变量：

<$ABILITYADDPOINT0>~<$ABILITYADDPOINT21> //附加点数
<$ABILITYADDTIME0>~<$ABILITYADDTIME21> //附加时间(秒)


离线挂机,自动打怪功能

Help > 执行命令 >
离线挂机,自动打怪功能

命令格式:

OFFLINEPLAY 时长(分钟)

开启离线挂机自动打怪功能

玩家需学会主动攻击技能,否则不会自动打怪

示例:

[@main]

#if

#act

OFFLINEPLAY 100

sendmsg 6 你已开启离线挂机功能,持续100分钟


加入会员时间

Help > 执行命令 >
加入会员时间

命令格式:

ADDUSERDATE 文本.txt

加入会员时间

DELUSERDATE 文本.txt

删除人物会员时间

示例:

[@main]

#if

#act

ADDUSERDATE ..\QuestDiary\会员文本.txt

#if

#act

DELUSERDATE ..\QuestDiary\会员文本.txt

相关链接: 检测角色会员时间


设置玩家穿人穿怪

Help > 执行命令 >
设置玩家穿人穿怪

命令格式:

THROUGHHUM 模式(0穿人穿怪, 1穿怪, 2穿人, -1恢复) 时间(秒)

设置玩家穿人穿怪模式

示例:

[@main]

#if

#act

THROUGHHUM 1 100

sendmsg 6 你已获得穿怪模式,持续100秒,尽情的升级吧


回城命令

Help > 执行命令 >
回城命令

命令格式:

GOHOME

将玩家传送到最后去过的安全区

[@main]

#if

#act

GOHOME

sendmsg 6 已经将你传送回城


自定义变量排序

Help > 执行命令 >
自定义变量排序

命令格式:

SORTHUMVARTOLISTEX 变量名 自定义变量文件路径 排序模式(0升序,1降序) 排序后保存路径 保存类型(0或空只保存玩家名, 1保存玩家名和数值)

排序玩家自定义变量

示例:

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试1.txt 0 ..\QuestDiary\测试2.txt 0

降序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试1.txt 1 ..\QuestDiary\测试2.txt 1

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


设置人物属性翻倍

Help > 执行命令 >
设置人物属性翻倍

命令格式:

STATUSRATE 类别 倍率 时间(秒)

设置人物属性倍数

类别:

0 防御

1 魔御

2 攻击力

3 魔法力

4 道术

5 气血

6 魔力值

示例:

[@main]

#if

#act

STATUSRATE 0 2 60

sendmsg 6 你的防御力翻倍,持续60秒


解毒命令

Help > 执行命令 >
解毒命令

命令格式:

DETOXIFCATION

解除人物红绿毒

示例:

[@main]

#if

#act

DETOXIFCATION

sendmsg 6 已经把你身上的毒解掉了,继续浪吧


播放人物动画特效

Help > 执行命令 >
播放人物动画特效

命令格式:

PLAYEFFECT WIL序号 开始编号 播放数量 循环次数 播放速度 偏移X 便宜Y 绘制模式(0普通,1特效)

以玩家为绘制点绘制人物动画特效, 效果会随着人物移动

WIL序号调用的是M2里 选项 --> 客户端管理 --> 物品自定义相关 --> 特效文件

示例:

[@main]

#if

#act

PLAYEFFECT 0 1210 20 2 200 0 0 0

sendmsg 6 绘制一个人物特效

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


替换文本指定字符串

Help > 执行命令 >
替换文本指定字符串

命令格式:

REPLACESTRINGINLIST ..\个人变量.txt 原字符串 新字符串 分隔符

(默认: |，分隔符可以作为标识，防止出错。类似: 哈哈、哈哈1、哈哈a)

替换文本内指定字符串

示例:

文本内容:

张三|1988

张三丰|1888

李四|2002

[@main]

#if

#act

REPLACESTRINGINLIST ..\QuestDiary\测试文本.txt 张三 张五 |

结果如下:

张五|1988

张三丰|1888

李四|2002

张三丰|1888 不会被替换


设置人物负面状态

Help > 执行命令 >
设置人物负面状态

命令格式:

MAKEPOSION 类型(0-7 , 12) 时长(秒) 威力(可留空)

给目标设置一个负面状态

类型:

0 中毒(绿色)：HP逐渐减少 (需填写威力值)
1 损伤(红色)：防御力降低，装备破损速度加快
2 冰冻(蓝色)：不可移动，不可施法
3 眩晕(黄色)：无法施法并受到1.2倍的伤害
4 减速(紫红)：减少敌方的移动速度和攻击速度，可以正常施法和普通攻击
5 石化(灰色)：不可移动，不可施法
6 禁锢(紫色)：不可移动，可以施法
7 防御崩坏：双防能力归零
12 蛛网缠绕：只能走动，不可跑动

示例:

[@main]

#if

#act

MAKEPOSION 5 10 10

sendmsg 6 你被施加一个石化状态,持续10秒

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


创建目录命令

Help > 执行命令 >
创建目录命令

命令格式:

FORCEDIRECTORIES 目录路径

创建指定目录, 不区分绝对或者相对路径

示例:

[@main]

#if

#act

FORCEDIRECTORIES ..\QuestDiary\测试

sendmsg 6 成功在QuestDiary目录下创建一个名为"测试"的文件夹


创建文本文件命令

Help > 执行命令 >
创建文本文件命令

命令格式:

CREATEFILE 文本文件路径

创建一个文本文件, 不区分绝对或相对路径

示例:

[@main]

#if

#act

CREATEFILE ..\QuestDiary\测试文本.txt

sendmsg 6 在QuestDiary目录下创建一个名为"测试文本"的txt文件


在指定文本插入字符串

Help > 执行命令 >
在指定文本插入字符串

命令格式:

INSERTLINELIST 文本路径 插入内容 指定行(0-65535)

在指定文本的指定行插入一段字符串

示例:

[@main]

#if

#act

INSERTLINELIST ..\QuestDiary\测试.txt 今天天气不错 4

sendmsg 6 在测试文本的第4行插入一段话"今天天气不错"


获取文本多行内容到变量

Help > 执行命令 >
获取文本多行内容到变量

命令格式:

GETLINELIST 文本路径 起始保存变量 起始行号(0-65535) 读取行数

从文本中读取多行数据到变量中, 保存的变量序号会根据读取行数而增加

示例:

[@main]

#if

#act

GETLINELIST ..\QuestDiary\测试文本.txt S10 20 5

sendmsg 6 读取的内容分别为<$STR(S10)>，<$STR(S11)>，<$STR(S12)>，<$STR(S13)>，<$STR(S14)>


过滤全服信息提示

Help > 执行命令 >
过滤全服信息提示

命令格式:

FILTERGLOBALMSG 类别(1所有消息提示, 2爆物品提示)

过滤全局消息提示, 该设置在人物小退后还原

示例:

[@main]

#if

#act

FILTERGLOBALMSG 2

sendmsg 6 你过滤了物品掉落提示


获取字符串所在文本中的行数

Help > 执行命令 >
获取字符串所在文本中的行数

命令格式:

GETSTRINGPOS 文本.txt 字符串

获取字符串在指定文本中所处的行数, 返回的行数信息保存在N0变量中

如果不存在则返回9999999 7个9

示例:

文本内容:

张三

李四

王五

周六

[@main]

#if

#act

GETSTRINGPOS ..\QuestDiary\测试文本.txt 李四

sendmsg 6 返回的N0变量的值应为1,因为是从0开始计数


读取文本内容到变量

Help > 执行命令 >
读取文本内容到变量

命令格式:

GETLISTSTRING 文本.txt 行数(0-65535) 变量1 变量2(可忽略)

读取指定行内容保存到指定变量

说明: 变量2可以不需要,当读取变量2时文本单行的内容必须是以下格式:
人物1:10
人物2:20
中间可以用":" 或者"|" 号

示例:
[@main]
#IF
#ACT
GETLISTSTRING ..\QuestDiary\测试.txt 5 A10 N10


一键回收命令

Help > 执行命令 >
一键回收命令

命令格式:

TAKEBAGITEM 物品名字(多个物品名用"|"隔开) 回收数量 回收给元宝 给金币 给游戏点 给经验 实际回收数量保存变量 是否给聚灵珠经验(0不给,1给) 极品是否回收(0或空回收,1不回收)

一键回收背包物品命令

示例:

[@main]

#if

#act

TAKEBAGITEM 木剑|布衣(男)|布衣(女)|六角戒指 46 1 10 10 100 N1 1

sendmsg 6 回收<$STR(N1)>件装备,每件装备给1个元宝10个金币10游戏点100点经验,并且聚灵珠也增长经验

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


给字符串增加空格

Help > 执行命令 >
给字符串增加空格

命令格式:

SETSTRINGBLANK 变量 长度(1-255) 模式(0前,1后)

给字符串增加空格,常见于NPC排版操作

模式: 0在字符串前面加空格, 1在字符串后面加空格

注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

示例:

[@main]

#if

#act

SETSTRINGBLANK S5 20 1


获取装备附加属性

Help > 执行命令 >
获取装备附加属性

命令格式:

GETITEMADDVALUE 装备位置(-1-34) 属性位置(0-30) 保存变量

获取装备附加属性保存到指定变量中, -1为OK框

示例:

[@main]

#if

#act

GETITEMADDVALUE 1 0 N8

sendmsg 6 你武器的附加攻击属性值为<$STR(N8)>

具体属性位置请参考: 属性位置


修改装备附加属性

Help > 执行命令 >
修改装备附加属性

命令格式:

CHANGEITEMADDVALUE 装备位置(-1-34) 属性位置(0-30) 操作符(+-=) 数值

修改指定位置装备的附加属性, -1为OK框

示例:

[@main]

#if

#act

CHANGEITEMADDVALUE 1 0 + 10

sendmsg 6 你武器的攻击属性额外增加10点

具体属性位置请参考: 属性位置


自动行走到指定坐标

Help > 执行命令 >
自动行走到指定坐标

命令格式:

GOTONOW X坐标 Y坐标 范围(可为空)

自动移动到当前地图指定坐标

示例:

[@main]

#if

ISONMAP

#act

GOTONOW 330 330 5

SENDMSG 6 自动行走到土城安全区330 330范围5以内


循环执行命令

Help > 执行命令 >
循环执行命令

命令格式:

LOOPGOTO 执行@段落 循环次数(1-65535)

循环指定指定段落的命令

ENDLOOP

停止循环命令

示例一:

[@main]

#if

#act

MOV N88 0

LOOPGOTO @测试 99

SENDMSG 6 循环99次后N88的值为99

[@测试]

#act

INC N88 1

示例二:

[@main]

#if

#act

MOV N88 0

LOOPGOTO @测试 999

SENDMSG 6 在N88等于5的时候就停止循环,所以执行完整段命令后N88的结果是50

[@测试]

#if

EQUAL N88 50

#ACT

ENDLOOP

#ELSEACT

INC N88 1


百分比计算命令

Help > 执行命令 >
百分比计算命令

命令格式:

CALCPERCENT 值 百分比(1-100) 结果保存变量 模式(0或空百分比, 1千分比, 2万分比)

百分比计算命令

示例:

[@main]

#if

#act

CALCPERCENT 500 10 N88

sendmsg 500的百分之10是<$STR(N88)>

#if

#act

CALCPERCENT 500 10 N88 1

sendmsg 500的千分之10是<$STR(N88)>

#if

#act

CALCPERCENT 5000 10 N88 2

sendmsg 500的万分之10是<$STR(N88)>


获取背包物品数量

Help > 执行命令 >
获取背包物品数量

命令格式:

GETBAGITEMCOUNT 物品名或IDX 保存变量 区分改名(0否1是)

获取背包指定物品的数量

示例:

[@main]

#if

#act

GETBAGITEMCOUNT 木剑 N88 0

sendmsg 6 你背包的木剑一共有<$STR(N88)>个,包括改名的


批量初始化变量

Help > 执行命令 >
批量初始化变量

命令格式:

SETVARS 变量 数量 值

批量初始化变量的值

示例:

[@main]

#if

#act

SETVARS T1 5 未领取

sendmsg 6 定义完成,现在T1-T5的值都是"未领取"


分割字符串

Help > 执行命令 >
分割字符串

命令格式:

EXTRACTSTRING 分隔符 待分割字符串 变量1 变量2 变量3 变量4 变量5 变量6 变量7

TEXTSPLIT 分隔符 待分割字符串 保存变量

将一个字符串按照指定分隔符进行分割, 分割结果分别保存到指定变量中

EXTRACTSTRING 的变量2~变量7可为空,按需使用

TEXTSPLIT 的保存变量只需要指定第一个即可,后面的会按照分割数量递增变量序号

示例一:

[@main]

#if

#act

MOV S1 今天*天气*真*好

EXTRACTSTRING * <$STR(S1)> S10 S11 S12 S13

SENDMSG 6 分割结果,S10值为"今天",S11值为"天气",S12值为"真",S13值为"好"

示例二:

[@main]

#if

#act

MOV S1 今天*天气*真*好

TEXTSPLIT * <$STR(S1)> S10

SENDMSG 6 分割结果,S10值为"今天",S11值为"天气",S12值为"真",S13值为"好"


设置游戏窗口标题

Help > 执行命令 >
设置游戏窗口标题

命令格式:

SENDCLIENTTITLEMSG 标题内容

设置游戏窗口的标题内容

示例:

[@main]

#if

#act

SENDCLIENTTITLEMSG 这是一个测试标题内容

sendmsg 6 你的游戏窗口标题已更改


时间戳

Help > 执行命令 >
时间戳

命令格式:

UNIXTOSTR UTC时间 保存变量

将UTC十位格式时间转成北京时间年月日格式保存到变量

<$UTCNOW> 为UTC十位格式时间变量

示例:

[@main]

#if

#act

UNIXTOSTR <$UTCNOW> S1

sendmsg 6 当前背景时间为<$STR(S1)>


数学表达式计算命令

Help > 执行命令 >
数学表达式计算命令

命令格式:

FORMULATION 表达式 结果保存变量

将一串数学表达式计算出结果保存到变量

注意: 被除数不能为0, 否则脚本执行错误

示例:

[@main]

#if

#act

FORMULATION 1/(3-3)*5+6 N1

sendmsg 6 计算结果为<$STR(N1)>


脱下指定位置装备

Help > 执行命令 >
脱下指定位置装备

命令格式:

TAKEOFF 装备位置(0-34)

将指定位置的装备脱下放进背包

示例:

[@main]

#if

#act

TAKEOFF 1

sendmsg 6 已经把你的武器取下来了

相关链接:装备位置


GOTOLABEL触发

Help > 执行命令 >
GOTOLABEL触发

命令格式:

GOTOLABEL 模式(0,1,2) 触发标签(QF内) 检测范围(为0不检测) 是否包括自己(0或空不包括,1包括)

指定模式触发字段

模式:

模式=0 小组成员触发
模式=1 行会成员触发
模式=2 当前地图的人物触发

示例:

[@main]

#if

#act

GOTOLABEL 1 @行会集合 10 1

sendmsg 6 所有在你范围10以内的本行会成员都会触发QF中的[@行会集合]段落,包括你自己


指定人物触发字段

Help > 执行命令 >
指定人物触发字段

命令格式:

HCALL 玩家名字 触发字段(QM中的字段)

指定玩家触发QM中的指定字段

示例:

[@main]

#if

#act

HCALL RED引擎 @测试触发

sendmsg 6 玩家RED引擎将触发QM中的[@测试触发]段落


调整玩家宝宝等级

Help > 执行命令 >
调整玩家宝宝等级

命令格式:

CHANGESLAVELEVEL 宝宝名字(*为所有) 操作符(+-=) 等级(1-7)

调整玩家宝宝的等级

示例:

[@main]

#if

#act

CHANGESLAVELEVEL 骷髅 = 7

sendmsg 6 你的骷髅宝宝等级被调整为7级

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


将怪物移动到新地图坐标

Help > 执行命令 >
将怪物移动到新地图坐标

命令格式:

MOVEMAPMONTOPOS 怪物名(*或all不匹配怪物名) 老地图名 老坐标X 老坐标Y 范围 新地图名 新坐标X 新坐标Y 范围

将指定范围的怪物移动到其他地图指定范围中

示例:

[@main]

#if

#act

MOVEMAPMONTOPOS 稻草人 SELF <$X> <$Y> 10 3 330 330 10

sendmsg 6 将自己周围10范围内的稻草人移动到土城安全区330 330范围10以内


调整人物杀怪爆率

Help > 执行命令 >
调整人物杀怪爆率

命令格式:

MONDROPRATE 操作符(+-=) 数值

调整人物杀怪的怪物爆率

初始爆率默认100, 爆率为0时就什么都不爆了

对应显示变量：<$MONDROPRATE>

示例:

[@main]

#if

#act

MONDROPRATE = 200

sendmsg 6 你的杀怪暴率翻倍


复活人物

Help > 执行命令 >
复活人物

命令格式:

REALIVE

复活玩家

示例:

[@main]

#if

#act

REALIVE

sendmsg 6 你已复活


修改怪物属性命令

Help > 执行命令 >
修改怪物属性命令

命令格式:

修改怪物的属性: CHANGEMONABILITY 地图(SELF为当前地图) 怪物名(ALL或*为不判断名字) 属性类别 操作符(+-=) 数值 是否百分比(0否1是) 时效(秒,为0时不检测时间) 坐标X|坐标Y|范围

刷新怪物属性命令: RECALCMONABILITY 地图(SELF为当前地图) 怪物名(ALL或*为不判断名字) 坐标X 坐标Y 范围

当坐标和范围为空时则为整个地图

修改完属性必须加上刷新怪物属性命令,否则修改无效

属性类别:

0防御下限 1防御上限 2魔御下限 3魔御上限 4攻击力下限 5攻击力上限 6魔法下限 7魔法上限 8道术下限 9道术上限

10MAXHP 11MAXMP 12攻击间隔 13移动间隔 14HP

示例:

[@main]

#if

#act

CHANGEMONABILITY SELF 白野猪 10 + 100 0 60 330|330|10

RECALCMONABILITY SELF 白野猪 330 330 10

sendmsg 6 当前地图330 330范围10以内的白野猪的气血上限增加100点,持续60秒

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


远程打开可视化仓库命令

Help > 执行命令 >
远程打开可视化仓库命令

命令格式:

OPENSTORAGEVIEW

打开可视化仓库命令

示例:

[@main]

#if

#act

OPENSTORAGEVIEW

sendmsg 6 可视化仓库已打开

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


变量传递命令

Help > 执行命令 >
变量传递命令

命令格式:

将值传给别人: SetHumVar 玩家名字 对方的变量 要传过去的值

获取别人的值: GetHumVar 玩家名字 对方的变量 自己要保存的变量

变量传递,把指定值传递到对方变量中,或者获取对方指定变量的值保存到自己的变量中

示例:

[@main]
你要把你的防御力数值传给别人,让他知道你的防御力是多少吗\
请确保对方在线\
<请输入对方名字/@@InPutString1> \
对方名字：<$STR(S1)> \

你想知道对方防御力是多少吗,并且不让他知道\
请确保对方在线\
<请输入对方名字/@@InPutString3> \
对方名字：<$STR(S3)>
对方防御力：<$STR(S4)>\

;传递
[@InPutString1]
#IF
#ACT
SetHumVar S1 S2 <$MAXAC>
;S1为对方名字
SENDMSG 6 成功把你的防御力数值传递给对方的S2变量，对方已知道你的防御力多少

;获取
[@InPutString3]
#IF
#ACT
GetHumVar S3 <$MAXAC> S4
;S3 为对方名字 <$MAXAC>对方防御力
;S4 你的变量
SENDMSG 6 你已成功取得对方防御力为<$STR(S4)>


获取物品原始各项数据库字段值参数

Help > 执行命令 >
获取物品原始各项数据库字段值参数

命令格式:

根据物品名来获取指定字段参数: GetDBItemFieldValue 物品名 字段名 保存的变量

根据物品IDX来获取指定字段参数: GetDBIdxItemFieldValue IDX 字段名 保存的变量

通过已知的物品名字或者IDX获取该物品在数据库指定字段的值

示例:

[@main]

#if

#ACT

GetDBItemFieldValue 屠龙 idx N1

GetDBItemFieldValue 屠龙 stdmode N2

sendmsg 6 屠龙的idx ：<$STR(N1)> ,类型stdmode:<$STR(N2)>


倒计时提示消息(快捷栏上方)

Help > 执行命令 >
倒计时提示消息(快捷栏上方)

命令格式:

SendDelayMsg 信息内容 倒计时时间(秒) 颜色(0-255) 触发字段(QF) 换地图是否删除(0否1是)

快捷栏上方的倒计时提示消息

%s 代表玩家名字

%t代表倒计时时间

示例:

[@main]

#if

#act

SendDelayMsg 敌军还有%t秒到达战场,请做好准备! 30 253 @战斗 1

QF中内容:

[@战斗]

#if

#act

sendmsg 6 抄起家伙干他一炮!

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


添加所有行会攻城

Help > 执行命令 >
添加所有行会攻城

命令格式:

ADDATTACKSABUKALL 城堡号

将所有行会加入攻城列表

示例:

[@main]

#if

#act

ADDATTACKSABUKALL 0

sendmsg 6 今晚8点所有行会同时攻城


使用脚本命令创建NPC

Help > 执行命令 >
使用脚本命令创建NPC

命令格式:

CREATENPC NPC名字 地图代码 坐标X(-1为随机坐标) 坐标Y(-1为随机坐标) 外观 调用脚本 脚本是否带地图代码(0是1否)

最后一个参数为0时, 调用的脚本名字要带地图代码, 如 传送员-3

最后一个参数为1时,调用的脚本名字不需要带地图代码, 如 传送员 这样可以多个不同地图调用同一个脚本文件

使用脚本命令创建NPC, M2重载NPC或重启后NPC消失

示例:

[@main]

#if

#act

CREATENPC 测试传送员 3 330 330 8 传送员-3 0 ;调用脚本带地图代码

CREATENPC 测试传送员 3 330 330 8 传送员 0 ;调用脚本不带地图代码


删除NPC命令

Help > 执行命令 >
删除NPC命令

命令格式:

DELNPC NPC名字 指定地图(可留空)

删除指定名字的NPC, 指定地图参数为空时删除所有地图该名字的NPC

示例:

[@main]

#if

#act

DELNPC 传送员 3

sendmsg 6 删除地图3的传送员NPC

DELNPC 传送员

sendmsg 6 删除所有地图中的传送员NPC


修改物品名字(新)

Help > 执行命令 >
修改物品名字(新)

命令格式:

CHANGEITEMNAME 位置(-1~34) 字符串

修改物品的名字

示例:

[@main]

#if

#act

CHANGEITEMNAME 1 牛逼的武器

sendmsg 6 你的武器已经改名为牛逼的武器了

相关变量:

<$G_DRESS> | 身上衣服改名后的名称
<$G_WEAPON> | 身上武器改名后的名称
<$G_RIGHTHAND> | 蜡烛改名后的名称
<$G_HELMET> | 头盔改名后的名称
<$G_HELMETEX> | 斗笠改名后的名称
<$G_NECKLACE> | 项链改名后的名称
<$G_ARMRING_R> | 手镯右改名后的名称
<$G_ARMRING_L> | 手镯左改名后的名称
<$G_RING_R> | 戒指右改名后的名称
<$G_RING_L> | 戒指左改名后的名称
<$G_BELT> | 腰带改名后的名称
<$G_BOOTS> | 鞋子改名后的名称
<$G_CHARM> | 宝石改名后的名称
<$G_BUJUK> | 符改名后的名称
<$G_DRUM> | 军鼓改名后的名称
<$G_HORSE> | 马牌改名后的名称
<$G_FASHION> | 时装改名后的名称


修改物品名颜色

Help > 执行命令 >
修改物品名颜色

命令格式:

CHANGEITEMNAMECOLOR 装备位置(-1~34) 颜色代码(0~255)

修改物品名的颜色

示例:

[@main]

#if

#act

CHANGEITEMNAMECOLOR 1 253

sendmsg 6 你的武器名已经变成骚骚的紫色,好耀眼


获取一组不同的随机数

Help > 执行命令 >
获取一组不同的随机数

命令格式:

GETMULTIRANDOMNUMBER 最小值 最大值 获取数量(最大50个) 保存的变量(不输入括号的变量，非自定义变量，如:N1) 实际获取数量

获取一组不同的随机数

示范：

[@Main]
#IF
#ACT
GetMultiRandomNumber 100 1000 10 N1 M1
SENDMSG 6 获取10个不一样的随机数，范围在100到1000之间，保存在N1~N10变量里，实际获取到随机数的数量为:<$STR(M1)>
SENDMSG 6 N1=<$STR(N1)>
SENDMSG 6 N2=<$STR(N2)>
SENDMSG 6 N3=<$STR(N3)>
SENDMSG 6 N4=<$STR(N4)>
SENDMSG 6 N5=<$STR(N5)>
SENDMSG 6 N6=<$STR(N6)>
SENDMSG 6 N7=<$STR(N7)>
SENDMSG 6 N8=<$STR(N8)>
SENDMSG 6 N9=<$STR(N9)>
SENDMSG 6 N10=<$STR(N10)>


获取一组不同的字符

Help > 执行命令 >
获取一组不同的字符

命令格式:

GETMULTIRANDOMTEXT 文本路径 获取数量(最大50个) 保存变量(不输入括号的变量，非自定义变量，如:S1) 实际获取数量

从指定文件中获取一组不同的字符串

示例:

[@Main]
#IF
#ACT
GETMULTIRANDOMTEXT ..\QuestDiary\测试.txt 10 S1 N1
SENDMSG 6 在“测试.txt”文件里，随机获取10个不相同的字符，保存在变量S1~S10里面，实际获取到字符数量为:<$STR(N1)>
SENDMSG 6 S1=<$STR(S1)>
SENDMSG 6 S2=<$STR(S2)>
SENDMSG 6 S3=<$STR(S3)>
SENDMSG 6 S4=<$STR(S4)>
SENDMSG 6 S5=<$STR(S5)>
SENDMSG 6 S6=<$STR(S6)>
SENDMSG 6 S7=<$STR(S7)>
SENDMSG 6 S8=<$STR(S8)>
SENDMSG 6 S9=<$STR(S9)>
SENDMSG 6 S10=<$STR(S10)>

;如果文本中只有9行字符,S10则为空,实际获取字符数量为:9


获取文件里文本总行数

Help > 执行命令 >
获取文件里文本总行数

命令格式:

GETTEXTLINECOUNT 文本路径 保存变量

获取指定文本内容的总行数

示例:

[@main]

#if

#act

GETTEXTLINECOUNT ..\QuestDiary\测试文本.txt N88

sendmsg 6 测试文本的内容总行数为<$STR(N88)>行


挂机命令

Help > 执行命令 >
挂机命令

命令格式:

开始挂机: STARTAUTOPLAYGAME

停止挂机: STOPAUTOPLAYGAME

使用脚本命令控制玩家挂机

示例:

[@main]

#if

#act

STARTAUTOPLAYGAME

sendmsg 6 挂机开始

[@main]

#if

#act

STOPAUTOPLAYGAME

sendmsg 6 挂机结束

相关触发: 开始挂机触发 [@StartAutoOnline] 和 停止挂机触发 [@StopAutoOnline]


增加角色隐藏元素属性

Help > 执行命令 >
增加角色隐藏元素属性

命令格式:

ADDHUMNEWVALUE 类型(0-8) 操作符(+-=) 数值(0~255) 时间(秒,0~65535,为0或空时在线一直有效)

增加角色元素属性, 只在属性面板内显示

元素类型:

0 暴击几率

1 目标暴率

2 防爆几率

3 忽视防御

4 增加伤害

5 伤害反射

6 物伤减少

7 法伤减少

8 经验吸收

示例:

[@main]

#if

#act

AddHumNewValue 0 + 20

sendmsg 6 你的暴击几率增加20%,在线一直有效


获取装备名字

Help > 执行命令 >
获取装备名字

命令格式:

GETUSERITEMNAME 装备位置 保存变量 是否改名(0获取改名后的名字 1获取数据库名字)

获取指定位置装备的名字

保存变量 只保存到S变量, 该参数只需要填写编号即可

示例:

[@main]

#if

#act

GETUSERITEMNAME 1 5 0

sendmsg 6 你武器改名后的名字为<$str(S5)>


获取物品属性值

Help > 执行命令 >
获取物品属性值

命令格式:

GETITEMFIELDVALUE 装备位置(装备位置 ) 属性名字 保存变量

属性名字:

MAKEINDEX 装备唯一idx

WINDEX 数据库里的idx

NAME_G 改名后的名字

DURA 当前持久

MAXDURA 当前最大持久

JPAC 极品防御属性

JPMAC 极品魔御属性

JPDC 极品攻击属性

JPMC 极品魔法属性

JPSC 极品道术属性

示例:

[@main]

#if

#act

GETITEMFIELDVALUE 1 MAKEINDEX N18

sendmsg 6 你手里武器的makeindex值为<$STR(N18)>


刷新人物属性

Help > 执行命令 >
刷新人物属性

命令格式:

RECALCABILITYS

刷新人物属性数据, 用于部分直接修改已穿戴装备人物属性刷新


设置技能威力和防御

命令格式:

SetSkillPower 技能ID 操作符(+-=) 对人物伤害%(-32768~32767) 对人物伤害值(-32768~32767) 对怪物伤害%(-32768~32767)

对怪物伤害值(-32768~32767) 技能防御%(-32768~32767) 技能防御值(-32768~32767) 时间(1~65535, 0在线一直有效)

设置技能威力和防御

示例:

[@main]

#if

#act

SetSkillPower 66 = 100 0 100 0 0 0 0

SENDMSG 6 你的开天斩技能对人物伤害增加为原来的2倍(增加100%)，对怪物伤害为原来的2倍(增加100%)


宝宝锁定目标开关

命令格式:

SLAVELOCK (0关1开)

设置宝宝是否受英雄切换目标快捷键控制

示例:

[@main]

#if

#act

SLAVELOCK 1

sendmsg 6 现在你的宝宝会和你的英雄一样锁定目标了


获取地图角色数量

命令格式:

GetMapHumCount 地图代码 类型(0所有, 1玩家, 假人) 保存变量

GetMapHumanCount 地图代码 类型(0所有, 1玩家, 假人) 保存变量

获取指定地图里角色数量

示例:

[@main]

#if

#act

GetMapHumCount 3 0 N88

sendmsg 6 地图3中所有角色的数量为<$STR(N88)>


召唤分身命令

命令格式:

RECALLSELF 时间(秒1-65535)

召唤分身命令

示例:

[@main]

#if

#act

RECALLSELF 180

sendmsg 6 成功召唤分身, 分身存在180秒


获取地图角色命令

命令格式:

GetMapHumCount 地图代码(self为当前地图) 类型(0所有, 1玩家, 2假人) 保存变量

获取指定地图所有角色数量

示例:

[@main]

#if

#act

GetMapHumCount 3 2 N88

sendmsg 6 现在土城有<$STR(N88)>个假人


倒计时格式转换

命令格式:

COUNTDOWN UTC时间 保存变量

将一个数值转化成倒计时格式 12:24:59

示例:

[@main]

#if

#act

MOV N18 <$UTCNOW>

INC N18 20

COUNTDOWN <$STR(N18)> S14

sendmsg 6 倒计时<$STR(S14)>


大背包扩展命令

命令格式:

CHANGEBAGCOUNT 操作符(+-=) 数量

给人物增加背包格子数量, 修改后的背包格子数量不能低于46 ,也不能大于126

相关变量<$BAGMAXCOUNT>玩家背包格子数量,双击未解锁图标触发QF文件中的 @UnLockBag

示例:

[@UnLockBag]

#if

small <$BAGMAXCOUNT> 126

#act

CHANGEBAGCOUNT + 1

sendmsg 6 你的背包格子数量增加1


仓库扩展页数命令

命令格式:

SETSTORAGEOPEN 分页(2,3) 状态(0关1开)

该命令仅适用于可视化仓库模式

相关变量<$STORAGEPAGE> 已开启页数,点击未开启分页触发QF文件中的 @StorageOpenFail编号

示例:

[@StorageOpenFail2]

#if

equal <$STORAGEPAGE> 1

#act

SETSTORAGEOPEN 2 1

sendmsg 6 由于你的仓库页数只有1页,本次为你激活第2页仓库


修改包宝宝属性命令

命令格式:

CHANGESLAVEABILITYEX 属性类型 操作符(+-=) 数值 值类型(0数值1百分比) 时效(秒) 宝宝名字(留空为所有宝宝)

刷新宝宝属性命令: RECALCSLAVEABILITY 宝宝名字(留空为所有宝宝)

修改完属性必须加上刷新宝宝属性命令,否则修改无效

属性类别:

0防御下限 1防御上限 2魔御下限 3魔御上限 4攻击力下限 5攻击力上限 6魔法下限 7魔法上限 8道术下限 9道术上限

10MAXHP 11MAXMP 12攻击间隔 13移动间隔 14HP

示例:

[@main]

#if

#act

CHANGESLAVEABILITYEX 10 + 100 0 60

RECALCSLAVEABILITY

sendmsg 6 你所有宝宝的气血上限增加100点,持续60秒


增加伤害附加效果命令

格式: RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6....参数12

说明：
RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6.....参数12
参数1 X坐标
参数2 Y坐标
参数3 范围
参数4 伤害值
参数5 附加效果 附加效果0=无，1=击退，2=冰冻，3=石化，4=吸血，5=吸蓝,6真实伤害,7蛛网效果,8红毒,9绿毒,10眩晕,11减速,12禁锢,13防御崩坏14最大hp百分比真实伤害,15当前hp百分比真实伤害

参数6 附加属性值 分别对应参数5= 1;击退距离 、2;冻结时间 、3;麻痹时间、4;吸血值、5;吸蓝值、6;真实伤害值（真实伤害无视防御不无视护身）、7;蛛网时间、8;红毒时间、9;绿毒时间、10;眩晕时间、
11;减速时间、12;禁锢时间、13;防御崩坏时间、14;MAXHP百分比伤害值、15;HP百分比真实伤害值
参数7 是否检查效果抗性（0: 直接设置状态; 1：检查后设置状态)
参数8 目标(0或空:所有目标; 1:仅人物; 2:仅怪物)
参数9 WIL序号
参数10 开始图片
参数11 播放张数
参数12 播放速度
参数13 是否透明绘制(0或空，1)
参数14 是否物理属性攻击(0或空，1 物理属性则目标以防御来抵御伤害，0或者空目标则以魔御来抵御伤害)

例
RangeHarm 333 333 8 100 1 5 0 0
当前地图 坐标 333 333 范围8之内所有可以攻击的目标都受到100点伤害 并且被击退5格
所有参数都支持变量 伤害和普通伤害一样 需要考虑目标的防御

该命令造成的伤害不会触发@ATTACK @MAGICATTACK 字段


屏幕播放动画命令

命令格式

SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人)

在自己屏幕上播放一个动画

示例:

[@main]

#ACT

SCREENEFFECT 100 100 0 1210 10 5 150 1 0

sendmsg 6 在自己屏幕上播放一个动画,循环播放5次后停止


在地图上播放魔法效果

命令格式:

MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0普通 1特效)

在地图指定坐标上播放一个动画, 像火墙那种播放模式

DELMAPEFFECT 地图 X Y

删除指定地图坐标用MAPEFFECT命令增加的特效

[@main]

#ACT

MAPEFFECT 3 333 333 0 0 10 1 300 1


修改游戏速度命令

命令格式:

CHANGESPEED 速度类型(1移动速度,2攻击和魔法速度) 速度值 持续时间(秒,为0或空时在线有效)

移动速度暂时修改无效, 速度值就相当于武器上加的攻击速度值-127 ~ 127

示例:

[@main]

#if

#act

CHANGESPEED 2 5

sendmsg 6 攻击速度增加5点,在线一直有效!


设置装备特效命令

命令格式:

SETITEMEFFECT 装备位置 特效编号(M2选项- 客户端设置- 特效编辑, 为0时取消通过SETITEMEFFECT命令设置的特效)

给装备设置一个特效

示例:

[@main]

#if

#act

SETITEMEFFECT 1 1

sendmsg 6 你的武器被套上特效了,好牛逼好耀眼!


获取宝宝信息命令

GETSLAVEBASEDATA 宝宝编号(1~n) 获取名字保存变量 获取等级保存变量

示例:

[@MAIN]

#IF

CHECKSLAVECOUNT > 1

#ACT

GETSLAVEBASEDATA 2 S5 S6

SENDMSG 6 你第二个宝宝的名字为<$STR(S5)>,等级为<$STR(S6)>

#ELSEACT

MESSAGEBOX 你只有一个宝宝


释放技能命令

RELEASEMAGIC 技能ID 技能等级 技能目标(1目标, 2 自己) 有动作

RELEASEMAGICEX 技能ID 技能等级 技能目标(1目标, 2 自己) 无动作

暂不支持释放劈砍动作技能

脚本释放技能命令,一般用在攻击触发和魔法攻击触发下,有目标的情况下


引擎启动后触发

Help > 功能触发 >
引擎启动后触发

触发字段:

@STARTUP

引擎启动完成后触发且只触发一次, 用于初始化一些游戏设置

写在QManage中


怪物掉落物品触发

Help > 功能触发 >
怪物掉落物品触发

触发字段:

@M2DropItem

杀怪掉落装备时触发, 在M2列表信息- 物品规则里,勾选了"怪物掉落触发"才有效

写在QFunction-0中

相关变量:

<$DROPITEMINDEX> 掉落的物品IDX

<$DROPITEMNAME> 掉落的物品名字

<$DROPITEMSTDMODE> 掉落的物品类别

<$DROPITEMMAKEINDEX> 掉落的物品唯一制造ID


拾取触发

Help > 功能触发 >
拾取触发

触发字段:

@PickUpItemX (X为物品IDX)

@PickUpItemEx (不区分IDX)

@PickUpItem 该字段需要在物品规则勾选 拾取触发 的物品才会生效

@HeroPickUpItem (英雄拾取触发)

玩家拾取物品触发, 两种模式 按需使用

写在QFunction-0中

拾取触发支持所有修改和检测装备属性命令, 装备位置为P

相关变量:

<$CURRTEMNAME> | 当前操作指向物品名称
<$CURRTEMMAKEINDEX> | 当前操作指向物品唯一生产编号
<$G_CURRTEMNAME> | 当前操作指向物品改名名称
<$CURRTEMSTDMODE> | 当前操作指向物品DB字段StdMode值
<$CURRTEMSHAPE> | 当前操作指向物品DB字段Shape值
<$CURRTEMANICOUNT> | 当前操作指向物品DB字段AniCount值
<$CURRTEMDURA> | 当前操作指向物品剩余持久值
<$CURRTEMINDEX> | 当前操作指向物品DB字段Idx值
<$CURRTEMDURAMAX> | 当前操作指向物品DB库中持久最大字段值
<$CURRTEMAC> | 当前操作指向物品DB库中防御下限字段值
<$CURRTEMMAXAC> | 当前操作指向物品DB库中防御上限字段值
<$CURRTEMMAC> | 当前操作指向物品DB库中魔御下限字段值
<$CURRTEMMAXMAC> | 当前操作指向物品DB库中魔御上限字段值
<$CURRTEMDC> | 当前操作指向物品DB库中攻击下限字段值
<$CURRTEMMAXDC> | 当前操作指向物品DB库中攻击上限字段值
<$CURRTEMMC> | 当前操作指向物品DB库中魔法下限字段值
<$CURRTEMMAXMC> | 当前操作指向物品DB库中魔法上限字段值
<$CURRTEMSC> | 当前操作指向物品DB库中道术下限字段值
<$CURRTEMMAXSC> | 当前操作指向物品DB库中道术上限字段值
<$CURRTEMSMITE> | 当前操作指向物品DB库中暴击字段值
<$CURRTEMLOOKS> | 当前操作指向物品DB库中Looks值字段值

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


获取杀怪经验触发

Help > 功能触发 >
获取杀怪经验触发

触发字段:

@GetExp

玩家杀怪获得经验时触发

写在QFunction-0中

相关变量:

<$GetExp> 最后一个杀怪获得的经验值


内功升级触发

Help > 功能触发 >
内功升级触发

触发字段:

@IPLevelUp

@HeroIPLevelUp

玩家内功等级提升触发

写在QFunction-0中


镖车受到攻击触发

Help > 功能触发 >
镖车受到攻击触发

触发字段:

@EscortUnderFire

押镖功能专用触发

写在QMapEvent-0中


攻击触发和被攻击触发

Help > 功能触发 >
攻击触发和被攻击触发

触发字段:

;主动攻击触发
[@Attack]
//(物理攻击触发)
[@MagicAttack]
//(魔法攻击触发)
[@HeroAttack]
//(英雄物理攻击触发)
[@HeroMagicAttack]
//(英雄魔法攻击触发)

;被攻击触发
[@Struck]
//(被物理攻击触发)
[@MagicStruck]
//(被魔法攻击触发)
[@HeroStruck]
//(英雄被物理攻击触发)
[@HeroMagicStruck]
//(英雄被魔法攻击触发)

几个常量：
<$CURRRTARGETNAME> 当前攻击(被攻击)目标名称
<$CURRRTARGETMAXHP> 当前攻击(被攻击)目标的最大血量
<$CURRRTARGETHP> 当前攻击(被攻击)目标受攻击时剩余的血量
<$CURRRUSEMAGICID> 攻击(被攻击)目标使用的魔法ID

[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@MagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================物理攻击触发==========================
[@Struck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@Attack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

QFunction-0

;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾
;======================英雄魔法攻击触发==========================
[@HeroMagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@HeroMagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================英雄物理攻击触发==========================
[@HeroStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@HeroAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


更改称号触发

Help > 功能触发 >
更改称号触发

触发字段:

玩家带上称号触发: @TitleChanged_X (X为称号的Shape值)

英雄带上称号触发: @HeroTitleChanged_X (X为称号的Shape值)

玩家取下称号触发: @Untitled_X (X为称号的Shape值)

英雄取下称号触发: @HeroUntitled_X (X为称号的Shape值)

更换称号时触发


瞬移前后触发

Help > 功能触发 >
瞬移前后触发

触发字段:

@OnEnvirChanging 瞬移前触发

@OnEnvirChanged 瞬移后触发

此触发用于随机,回城,瞬移时有效

写在QMapEvent-0中


进入安全区触发

Help > 功能触发 >
进入安全区触发

触发字段:

进入安全区触发: @EnterSafeArea

@HeroEnterSafeArea

离开安全区触发: @LeaveSafeArea

@HeroLeaveSafeArea

进出安全区触发

写在QFunction-0中


登陆触发

Help > 功能触发 >
登陆触发

触发字段:

@Login

@HeroLogin

人物或英雄登陆触发,常用于初始化一些人物变量

写在QManage中


双击物品触发

Help > 功能触发 >
双击物品触发

触发字段:

@StdModeFuncX (X为物品的Anicount值)

背包里双击物品触发, 类别为31的物品可用

写在QFunction-0中


死亡触发

Help > 功能触发 >
死亡触发

触发字段:

@PlayDie

玩家死亡触发

写在QFunction-0中


挖卧龙怪触发

Help > 功能触发 >
挖卧龙怪触发

触发字段:

@GetButchItemXXX (XXX为卧龙怪名字)

格式：

[@GetButchItem卧龙庄主]
#IF
#ACT
SENDMSG 1 宝藏守护者:%s在卧龙庄主身上挖到了宝贝！如果你想也得到宝贝请前去卧龙山庄杀守护者然后挖取其身上携带的装备。

写在QFunction-0中


杀怪杀人触发

Help > 功能触发 >
杀怪杀人触发

触发字段:

@KillPlayMonX (X为地图参数中 KillFUNC(X) 对应)

@KillPlayX (X为地图参数中 KillFUNC(X) 对应)

杀人和杀怪触发

写在QMapEvent-0中


穿戴触发和脱下触发

Help > 功能触发 >
穿戴触发和脱下触发

触发字段:

穿戴触发: @TakeOnX

@HeroTakeOnX

脱下触发: @TakeOffX

@HeroTakeOffX

X对应的是装备位置, 具体装备位置参考: 装备位置

写在QFunction-0中


升级触发

Help > 功能触发 >
升级触发

触发字段:

@PlayLevelUp

@HeroLevelUp

人物或英雄升级触发

写在QFunction-0中


挖宝触发

Help > 功能触发 >
挖宝触发

触发字段:

@DigItem

挖宝功能专用触发,挖到宝物后触发

写在QFunction中


自定义命令触发

Help > 功能触发 >
自定义命令触发

触发字段:

@UserCmdX (X为列表信息 - 其他功能列表 - 自定义命令列表 中的编号)

聊天框输入自定义命令后回车触发

写在QFunction中


摆摊触发

Help > 功能触发 >
摆摊触发

触发字段:

摆摊触发 @StoreOpened

收摊触发 @StoreClosed

写在QFunction中

脚本范例：

[@StoreOpened]
#IF
CHECKINMAPRANGE 3 349 334 10
#Act
SENDMSG 0 号外号外，<$USERNAME>收集了很多破铜烂铁摆了个摊，不知道能不能卖个天价？ 251 0
Break
#ElseAct
;必须要加一个延迟跳转，否则玩家客户端还会显示自己在摆摊
DELAYGOTO 1 @停止摆摊
Break

[@停止摆摊]
#IF
CheckLevelEx > 0
#Act
CANCELDOSTALL 1
Messagebox 摆摊失败：请移步到坐标349.334为中心的10个坐标范围内；
Break

[@StoreClosed]
#IF
CheckLevelEx > 0
#Act
Messagebox 你收起了你的摊位
Break


释放技能触发

Help > 功能触发 >
释放技能触发

触发字段:

释放技能前自身触发: @MagSelfFuncX (X为技能ID)

释放技能前目标触发: @MagTagFuncX (X为技能ID)

释放技能后自身触发: @MagSelfFuncExX (X为技能ID)

释放技能后目标触发: @MagTagFuncExX (X为技能ID)写在QFunction中

示例:

[@MagSelfFunc248]
#If
#SAY
欢迎使用自定意魔法功能--可以用此功能开发出更多的随身NPC会员功能等等！
#ACT
break

[@MagTagFunc248]
#If
#SAY
你被XX人打中了！他用了GM的必杀技能.把你赶回土城了
#ACT
MAPMOVE 3 333 333
break

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


攻城战结束触发

Help > 功能触发 >
攻城战结束触发

触发字段:

@WallWarStopFunc

沙巴克攻城结束时触发

写在QFunction中


退出游戏触发

Help > 功能触发 >
退出游戏触发

触发字段:

大退触发 @OnLogout_OffLinePlaying

小退触发 @OnLogout_SoftClosing

人物退出游戏触发

写在QFunction中

人物必须在安全区才会触发


占领沙巴克触发

Help > 功能触发 >
占领沙巴克触发

触发字段:

占领沙巴克触发: @GetCastle

丢失沙巴克触发: @LostCastle

写在QF里


加入和退出行会触发

Help > 功能触发 >
加入和退出行会触发

触发字段:

加入行会触发: @JoinGuild

退出行会触发: @ExitGuild

写在QF里


加入和退出小组触发

Help > 功能触发 >
加入和退出小组触发

触发字段:

加入小组触发: @JoinGroup

退出小组触发: @ExitGroup

写在QF里


自动出师触发

Help > 功能触发 >
自动出师触发

触发字段:

师父触发: @UnMasterEnd

徒弟触发: @UnMasterEnd1

写在QF中

[@UnMasterEnd]
#IF
#ACT
SENDMSG 6 提示：师傅触发！

[@UnMasterEnd1]
#IF
#ACT
SENDMSG 6 提示：徒弟触发！


挂机触发

Help > 功能触发 >
挂机触发

触发字段:

开始挂机触发: @StartAutoOnline

停止挂机触发: @StopAutoOnline

写在QFunction中

示例:

[@StartAutoOnline]

#if

#act

sendmsg 6 开始挂机!

[@StopAutoOnline]

#if

#act

sendmsg 6 停止挂机!


切换地图触发

Help > 功能触发 >
切换地图触发

触发字段:

@EnterMap

切换地图触发

写在QF里


走路触发

Help > 功能触发 >
走路触发

触发字段

@Walk

走路触发

写在QF里


跑步触发

Help > 功能触发 >
跑步触发

触发字段

@Run

跑步触发

写在QF中


升级前触发

@PlayBeginLevelUp

@HeroBeginLevelUp

写在QF里

中断升级命令 StopLevelUp

示例:

[@PlayBeginLevelUp]

#if

checklevelex > 99

#act

StopLevelUp

sendmsg 6 你的等级已经大于99级,所以本次升级取消


武器被诅咒前触发

@BeginCurse

@HeroBeginCurse

写在QF里

终止诅咒命令 STOPCURSE

示例:

[@BeginCurse]

#if

checklevelex < 35

#act

STOPCURSE

sendmsg 6 由于你等级小于35级,所以不对你的武器进行诅咒


复活触发

@Revival

该触发仅在复活戒指或套装复活功能下有效 复活剩余时间变量：<$RevivalTime>

写在QF文件中


宝宝攻击触发

宝宝攻击触发相关:

[@SlaveMagicStruck]
#ACT
SENDMSG 6 你的宝宝被魔法攻击了
BREAK

[@SlaveMagicAttack]
#ACT
SENDMSG 6 你的宝宝魔法攻击了目标
BREAK

[@SlaveStruck]
#ACT
SENDMSG 6 你的宝宝被物理攻击了
BREAK

[@SlaveAttack]
#ACT
SENDMSG 6 你的宝宝物理攻击目标
BREAK

增加变量<$CurSlaveName>，仅用于宝宝攻击和受击触发中

[@SlaveAttack]
#ACT
SendMsg 5 当前攻击宝宝名为<$CurSlaveName>

[@SlaveMagicAttack]
#IF
EQUAL <$CurSlaveName> 蜈蚣
#ACT
SENDMSG 6 你的蜈蚣宝宝在攻击目标

[@SlaveStruck]
#ACT
SendMsg 5 当前挨揍宝宝名为<$CurSlaveName>

[@SlaveMagicStruck]
#IF
EQUAL <$CurSlaveName> 蜈蚣
#ACT
SENDMSG 6 你的蜈蚣宝宝在被揍


物品代码表

Help > 数据库相关 >
物品代码表

物品代码表

物品代码(Stdmode) | 物品类型 | 相关说明
0 | 药品 | （MAC2=时间,Dc=+攻击,Sc=+道术,Mc=+魔法,Ac2=+速度,Ac=+HP,Mac=+MP）
1 | 食物 |
2 | 特殊 | 传送石、聚灵珠、祝福罐、书页包、修复神水、死亡记录卷等
3 | 卷类 |
4 | 技能书 |
5 | 武器 | 物品Anicount字段设置数字188，将代表武器带有 倚天技能
6 | 武器 | （Ac2=准,Mac=诅咒,Mac2=攻击速度-,Source=神圣,Ac=幸运）
7 | 补充 | 气血石、幻魔石、魔血石、千里传音等
10 | 衣服(男) | 物品Anicount字段设置数字0-27，将代表不同外观的翅膀
11 | 衣服(女) | 物品Anicount字段设置数字0-27，将代表不同外观的翅膀
15 | 头盔 |
16 | 斗笠、面巾 | 物品Anicount字段设置数字4、6、7，将代表不同外观的斗笠
17 | 军鼓 |
18 | 马牌 | 只增加属性,无坐骑效果
19 | 项链 | （Ac2=魔法躲避,Mac=诅咒,Mac2=幸运）
20 | 项链 | （Ac2=准,Mac2=敏）
21 | 项链 | （Ac=速度+,Ac2= HP恢复,Mac=速度-,Mac2=MP 恢复）
22 | 戒指 |
23 | 戒指 | （Ac=速度+,Ac2=毒物躲避,Mac=速度-,Mac2=中毒恢复）
24 | 手镯 | （Ac2=准确,Mac2=敏捷）
25 | 符、毒药 |
26 | 手镯 |
27 | 腰带 |
28 | 鞋子 | 物品Anicount字段设置数字，将代表可以增加负重
29 | 宝石 |
30 | 照明物 | 物品数据内Source字段为1时不随时间掉持久，为0随时间掉持久
31 | 捆装物品 |
40 | 肉类 | 鸡肉、肉
41 | 任务 |
42 | 制作原料 | 该类物品可补充火龙之心持久
43 | 矿石 |
44 | 行会相关 | 沃玛号角、祖玛头像、勋章之心
45 | 特殊 | 骰子、筹码
46 | 宝箱、钥匙 | 物品Shape字段设置对应数字，将代表可以开启对应的宝箱。 宝箱设置
47 | 金钱 |
48 | 盾牌 | 读取shield.wzl,变量<$shield> 600张一组,不分男女
66,67 | 时装衣服 |
68,69 | 时装武器 |
75,76,77 | 时装项链 |
78 | 时装头盔 |
79,80 | 时装手镯 |
81,82 | 时装戒指 |
83 | 时装勋章 |
84,85 | 时装腰带 |
86,87 | 时装靴子 |
88,89 | 时装宝石 |
96 | 填充物 | 火龙之心填充物

物品特殊属性设置:
武器 蜡烛 类型物品 使用物品数据库字段 AniCount
首饰 头盔 类型物品 使用物品数据库字段 Shape

属性代码 | 属性功能 | 功能介绍
111 | 隐身 | 人物进入隐身状态，普通怪物看不到人物，破隐身的怪物可以看到人物
112 | 传送 | 人物可以使用命令在传送到指定座标上(@UserMove)
113 | 麻痹 | 人物物理攻击时可以将对方麻痹
114 | 复活 | 人物具备复活功能，人物在死亡时起作用，生效一次掉一个持久
115 | 火焰 |
116 | 治愈 |
117,170 | 不掉物品 | 人物死亡时不会掉任何物品，包括背包里的及身上戴的
118 | 护身 | 人物在被攻击时，先降MP，MP为0时才降HP
119 | 超负载 | 人物可以戴上超过自己负重的物品
120 | 技巧 | 人物在练技能时，得到双倍的练习点
121 | 探测 | 可以查找指定人物当前位置
122 | 记忆戒指 |
124 | 记忆手镯 |
125 | 记忆头盔 |
126 | 祈祷手镯 |
127 | 祈祷项链 |
128 | 祈祷戒指 |
129 | 祈祷头盔 |
130 | 神秘戒指 |
131 | 神秘腰带 |
132 | 神秘头盔 |
133 | 魔血戒指 |
134 | 魔血手镯 |
135 | 魔血项链 |
136 | 虹魔戒指 |
137 | 虹魔戒指 |
138 | 虹魔项链 |
139 | 防麻 | 防麻痹功能，可以使被攻击方的麻痹功能失效(不防怪物麻痹）
140 | 无敌(未完全) |
141 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，如果物品持久太小，所得经验将比正常还低
142 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，如果物品持久太小，所得攻击力将比正常还低
143 | 防护身 |
144 | 防复活 |
145 | 行会召唤 |
150 | 麻痹护身 |
151 | 麻痹火球 |
152 | 麻痹防御 |
153 | 麻痹负载 |
154 | 护身火焰 |
155 | 护身防御 |
156 | 护身负载 |
157 | 传送麻痹 |
158 | 传送护身 |
159 | 传送探测 |
160 | 传送复活 |
161 | 复活麻痹 |
162 | 护身复活 |
163 | 防麻痹带记忆功能 | 防止人物麻痹以及可以使用记忆戒指式的传送功能
164 | 防毒带记忆功能 | 防止人物被怪物或其他人物的毒(例如道术的红绿毒、触龙神的绿毒).同时可以使用记忆戒指式的传送功能
165 | 破护身与复活 | 可以破除护身与复活的效果
166 | 防麻破复活属性 | 防止人物麻痹以及可以破坏对方复活属性
167 | 防麻破护身属性 | 防止人物麻痹以及可以破坏对方护身属性
171 | 不掉背包物品 |
172 | 不掉身上装备 |
182 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，不受物品持久太小影响
183 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，不受物品持久太小影响
184 | 物防提升 | 指定倍数(倍数为持久除以 10000)，不受物品持久太小影响，隐藏属性为减少物理伤害的百分比。
185 | 魔御提升 | 指定倍数(倍数为持久除以 10000)，不受物品持久太小影响，隐藏属性为减少魔法伤害的百分比。
188 | 倚天辟地 | 武器带有倚天辟地技能效果
189 | 魔道麻痹 | 带有魔道麻痹效果
190 | 虎威套装 | Shape=190，Reserved=吸血点数，穿齐六件，吸血效果的大幅度提升
191 | 必杀套装 | Shape=191，Reserved=内伤等级
192 | 五岳独尊技能 | （武器可通过鉴定的特殊技能；也可以直接赋予Anicount=192，将获得3级技能）
193 | 召唤巨魔技能 | （传奇装备套装、传奇神剑可获得此技能）
194 | 神龙附体 | （武器可通过鉴定的特殊技能；也可以直接赋予Anicount=194，将获得技能）
Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


DB数据库各字段详解

Help > 数据库相关 >
DB数据库各字段详解

StdItems.DB 代码表解释

代码(StdItems) | 代码名称 | 相关说明
0 | IDx | 装备的序号，不能出现重复序号，引擎物品规则控制将以装备的IDx为准
1 | NAME | 装备名称，连击引擎支持20个字节，其它版本的引擎只支持14个字节
2 | Stdmode | 物品类型 查看相关设置
3 | Weight | 装备或物品的重量
4 | Anicount | 物品特殊属性设置
5 | Source | 是+强度(负数+神圣) 物品Stdmode等于16的装备Source=1 代表是面巾
6 | Reserved | 是隐藏属性:"8"代表人死后会消失
7 | Looks | 显示装备物品栏里样子和在装备栏里的样子
8 | DuraMax | 装备持久度，这里的变量中"1000"表示1个持久度,那么"40000"就表示40个持久度了
9 | Ac | 查看相关设置
10 | Ac2 | 查看相关设置
11 | Mac | 查看相关设置
12 | Mac2 | 查看相关设置
13 | Dc | 查看相关设置
14 | Dc2 | 查看相关设置
15 | Mc | 查看相关设置
16 | Mc2 | 查看相关设置
17 | Sc | 查看相关设置
18 | Sc2 | 查看相关设置
19 | Need | 限制种类
20 | NeedLevel | 需要等级
21 | Price | 价格
22 | Stock | 是否为库存品，卧龙名将身上所穿装备，该值越大越难挖
23 | UniqueItem | 装备恢复内力值的百分比
24 | Overlap | 1或2 表示可以重叠 OverLap=1 重量=重叠数量*单物品重量/10 OverLap=2 重量=重叠数量*单物品重量
25 | ItemType | 是对市场物品进行分类
26 | ItemSet |
27 | Smite | 暴击
28 | DropRate | PK目标爆率
29 | IgnDef | 忽视目标防御
30 | DamAdd | 增加伤害
31 | DamReb | 伤害反射
32 | DcRedu | 物理伤害减少
33 | McRedu | 魔法伤害减少
34 | ExpAdd | 经验吸收增加
35 | Bind | 装备绑定设置，Bind=0 拾取，穿戴装备都不绑定，Bind=1 拾取后绑定，Bind=2 装备后绑定，Bind=3 拾取后绑定 + 装备后绑定
36 | Shine | 设置1-6之间的数字，首饰(1-4之间的数字代表发光)、武器(1-6之间的数字代表发光)、新衣服(1-2之间的数字代表主宰以上内观翅膀效果)
37 | Reference | 装备附加说明

Magic.DB 代码表解释

代码(Magic) | 代码名称 | 相关说明
0 | MagID | 技能的魔法ID
1 | MagName | 技能的名称
2 | EffectType | 使用技能时角色的动作效果
3 | Effect | 技能产生的动画效果
4 | Spell | 每次需要消耗的魔法值
5 | Power | 基本威力
6 | MaxPower | 最大威力
7 | Defspell | 升级后增加的每次耗用魔法值
8 | DefMaxPower | 升级后增加的最大威力
9 | Job | 职业（0=战士，1=法师，2=道士）
10 | NeedL1 | 1级技能所需达到等级（可设置技能到15级，需要补丁支持）
11 | L1Train | 1级技能修炼所需经验（可设置技能到15级，需要补丁支持）
12 | NeedL2 | 2级技能所需达到等级（可设置技能到15级，需要补丁支持）
13 | L2Train | 3级技能修炼所需经验（可设置技能到15级，需要补丁支持）
14 | NeedL3 | 3级技能所需达到等级（可设置技能到15级，需要补丁支持）
15 | L3Train | 3级技能修炼所需经验（可设置技能到15级，需要补丁支持）
16 | MaxTrainLv | 技能最高只能修炼几层，如果设置为3，那么技能只能修炼到3级
17 | Delay | 技能延迟时间
18 | Descr | 备注

Monster.DB 代码表解释

代码(Monster) | 代码名称 | 相关说明
0 | Name | 怪物名称
1 | Race | 行动模式及死亡时的效果代码
2 | Racelmg | 攻击模式代码
3 | Appr | 怪物外观代码
4 | Lvl | 怪物等级
5 | Undead | 不死系 0-否 1-是
6 | CoolEye | 怪物的视线范围，并和等级有关(远距离发现目标，cooleye 设置的数字太高的话，可破隐身戒指效果)
7 | HP | 怪物的生命值
8 | MP | 怪物的魔法值，注：如果该处数字大于0，那么引擎自动判断怪物被伤害最大为设置的数字。
9 | AC | 怪物的防御力
10 | MAC | 怪物的魔法防御力
11 | DC | 怪物的攻击力
12 | DCMax | 怪物的最大攻击力
13 | MC | 怪物的魔法攻击力
14 | SC | 怪物的道术攻击力
15 | SPEED | 速度
16 | HIT | 攻击命中率
17 | WALK_SPD | 行走速度间隔
18 | WALKSTEP | 行走步伐
19 | WalkWait | 行走等待时间
20 | ATTACR-SPD | 攻击速度间隔
21 | Exp | 杀死怪物后得到的经验值
22 | ExploreItem | 怪物死亡后是否支持探索(0=否，1=是)
23 | InLevel | 怪物内功等级，等级越高，怪物自身属性会逐渐获得提升
24 | IPExp | 杀死怪物后得到的内功经验值，人物必须学习了内功，否则无法获得内功经验


物品所需条件设置

Help > 数据库相关 >
物品所需条件设置

使用物品所需条件设置:

物品数据库字段:（字段包括二个参数的需要用字段计算器算出具体数字）

Need | NeedLevel
0 | 需要指定等级以上才可以戴上
1 | 需要指定攻击力以上才可以戴上
10 | 需要指定职业及指定等级以上才可以戴上
11 | 需要指定职业及指定攻击力以上才可以戴上
12 | 需要指定职业及指定魔法力以上才可以戴上
13 | 需要指定职业及指定道术以上才可以戴上
2 | 需要指定魔法力以上才可以戴上
3 | 需要指定道术以上才可以戴上
4 | 需要指定转生等级以上才可以戴上
40 | 需要指定转生等级及指定等级以上才可以戴上
41 | 需要指定转生等级及指定攻击力以上才可以戴上
42 | 需要指定转生等级及指定魔法力以上才可以戴上
43 | 需要指定转生等级及指定道术以上才可以戴上
44 | 需要指定转生等级及指定声望点以上才可以戴上
5 | 需要指定声望点以上才可以戴上
6 | 加入了行会的人才可以戴上
60 | 行会掌门才可以戴上
7 | 沙城成员才可以戴上
70 | 沙城城主才可以戴上
8 | 会员才可以戴上
81 | 指定类型会员，及大于或等于指定会员等级，字段设置
82 | 指定或大于类型会员，及大于或等于指定会员等级 字段设置
14 | 固定等级(必须为指定等级配戴)
50 | 所需等级&声望
51 | 所需攻击&声望
52 | 所需魔法&声望
53 | 所需精神力&声望

注意事项：普通老的物品数据库的Need及NeedLevel字段，不支持超过65535数字，

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


三大技能

Help > 数据库相关 > 示例DB > 魔法数据DB >
三大技能

MagicDB:

3个体验技能，技能参数见[游戏参数->魔法设置->高级技能]：

80;冰霜群雨;2;125;12;20;50;30;30;60;1;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;3;600;;
81;十步一杀;4;126;12;30;70;30;40;80;0;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;3;600;;
82;死亡之眼;2;127;12;20;50;30;30;60;2;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;3;600;;


合击技能

Help > 数据库相关 > 示例DB > 魔法数据DB >
合击技能

MagicDB:

60;破魂斩;0;60;15;10;15;7;10;15;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;30;英雄;
61;劈星斩;2;61;30;15;25;7;8;15;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;30;英雄;
62;雷霆一击;2;62;30;25;35;7;8;15;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;30;英雄;
63;噬魂沼泽;1;63;25;8;8;1;8;15;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;45;英雄;
64;末日审判;2;64;40;15;15;10;12;15;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;45;英雄;
65;火龙气焰;2;65;40;30;45;6;10;10;99;43;10;46;20;49;40;52;80;55;160;58;320;61;640;64;1280;67;2560;70;5120;73;10240;76;20480;79;40960;82;81920;85;163840;3;45;英雄;

StdItemsDB：

136;破魂斩;4;3;1;60;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
137;劈星斩;4;3;1;61;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
138;雷霆一击;4;3;1;62;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
139;噬魂沼泽;4;3;1;63;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
140;末日审判;4;3;1;64;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
141;火龙气焰;4;3;1;65;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;


连击技能

Help > 数据库相关 > 示例DB > 魔法数据DB >
连击技能

MagicDB:

100;追心刺;0;100;15;10;30;4;0;0;0;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;;
101;三绝杀;0;101;0;6;20;2;0;0;0;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;;
102;断岳斩;0;102;0;8;25;6;0;0;0;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;;
103;横扫千军;0;103;0;8;28;7;0;0;0;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;;
104;凤舞祭;8;104;8;20;40;6;10;20;1;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;;
105;惊雷爆;8;105;8;30;50;6;15;22;1;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;;
106;冰天雪地;2;106;8;18;45;10;9;18;1;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;;
107;双龙破;8;107;8;15;30;6;8;16;1;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;;
108;虎啸诀;8;108;8;15;30;6;8;18;2;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;;
109;八卦掌;8;109;8;18;42;6;10;23;2;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;;
110;三焰咒;8;110;8;30;55;6;15;30;2;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;;
111;万剑归宗;8;111;8;25;45;6;10;20;2;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;;

100;英雄追心刺;0;100;15;10;30;4;0;0;0;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;英雄;
101;英雄三绝杀;0;101;0;6;20;2;0;0;0;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;英雄;
102;英雄断岳斩;0;102;0;8;25;6;0;0;0;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;英雄;
103;英雄横扫千军;0;103;0;8;28;7;0;0;0;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;英雄;
104;英雄凤舞祭;8;104;8;20;40;6;10;20;1;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;英雄;
105;英雄惊雷爆;8;105;8;30;50;6;15;22;1;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;英雄;
106;英雄冰天雪地;2;106;8;18;45;10;9;18;1;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;英雄;
107;英雄双龙破;8;107;8;15;30;6;8;16;1;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;英雄;
108;英雄虎啸诀;8;108;8;15;30;6;8;18;2;15;50;15;100;15;200;15;400;15;800;15;1600;15;3200;15;6400;15;12800;15;25600;15;51200;15;102400;15;204800;15;409600;15;819200;3;0;英雄;
109;英雄八卦掌;8;109;8;18;42;6;10;23;2;33;50;33;100;33;200;33;400;33;800;33;1600;33;3200;33;6400;33;12800;33;25600;33;51200;33;102400;33;204800;33;409600;33;819200;3;0;英雄;
110;英雄三焰咒;8;110;8;30;55;6;15;30;2;52;50;52;100;52;200;52;400;52;800;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;3;0;英雄;
111;英雄万剑归宗;8;111;8;25;45;6;10;20;2;75;50;75;100;75;200;75;400;75;800;75;1600;75;3200;75;6400;75;12800;75;25600;75;51200;75;102400;75;204800;75;409600;75;819200;3;0;英雄;

StdItemsDB：

1312;三绝杀;4;0;1;0;0;0;0;45;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;0;0;12;0;;
1313;双龙破;4;1;1;0;0;0;0;45;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1314;虎啸诀;4;2;1;0;0;0;0;45;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1315;追心刺;4;0;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1316;凤舞祭;4;1;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1317;八卦掌;4;2;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1318;断岳斩;4;0;1;0;0;0;0;49;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1319;惊雷爆;4;1;1;0;0;0;0;49;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1320;三焰咒;4;2;1;0;0;0;0;49;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1321;横扫千军;4;0;1;0;0;0;0;51;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1322;冰天雪地;4;1;1;0;0;0;0;51;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;
1323;万剑归宗;4;2;1;0;0;0;0;51;0;0;0;0;0;0;0;0;0;0;0;0;3409;5;0;0;12;0;;


神龙附体

Help > 数据库相关 > 示例DB > 魔法数据DB >
神龙附体

MagicDB:

77;神龙附体;3;120;45;0;0;8;0;0;99;50;50;51;100;52;200;53;400;54;800;55;800;56;800;57;800;59;800;60;800;60;800;60;800;60;800;60;800;62;1000;3;100;;

77;英雄神龙附体;3;120;45;0;0;8;0;0;99;50;50;51;100;52;200;53;400;54;800;55;800;56;800;57;800;59;800;60;800;60;800;60;800;60;800;60;800;62;1000;3;100;英雄;

StdItem.DB：

16;神龙附体;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;

17;英雄神龙附体;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;


神秘解读

Help > 数据库相关 > 示例DB > 魔法数据DB >
神秘解读

MagicDB:

67;神秘解读;0;123;0;0;0;0;0;0;99;1;500;1;1200;1;1900;1;2600;1;3300;1;4000;1;4700;1;5400;1;6100;1;6800;1;7500;1;8200;1;8900;1;9600;1;10300;15;0;;


唯我独尊

Help > 数据库相关 > 示例DB > 魔法数据DB >
唯我独尊

MagicDB:

68;唯我独尊;0;122;1000;0;0;50;0;0;99;200;50;220;100;240;100;250;100;255;100;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;0;0;;
68;英雄唯我独尊;0;122;1000;0;0;50;0;0;99;200;50;220;100;240;100;250;100;255;100;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;0;0;英雄;

StdItem.DB:

1250;唯我独尊;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
1251;英雄唯我独尊;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;

图示：

内功200级可学习，冷却时间为5分钟技能释放时需要消耗至少1000内力值（Magic.DB调节），
在技能效果的持续时间内，每秒钟则会消耗250点内力值。使用技能不会增加技能点。


五岳独尊

Help > 数据库相关 > 示例DB > 魔法数据DB >
五岳独尊

MagicDB:

78;五岳独尊;0;122;1000;0;0;50;0;0;99;200;50;220;100;240;100;250;100;255;100;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;3;0;;
78;英雄五岳独尊;0;122;1000;0;0;50;0;0;99;200;50;220;100;240;100;250;100;255;100;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;255;0;0;英雄;

StdItem.DB:

1250;五岳独尊;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
1251;英雄五岳独尊;4;99;1;1;0;0;0;200;0;0;0;0;0;0;0;0;0;0;0;0;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;

图示：

内功200级可学习，冷却时间为5分钟技能释放时需要消耗至少1000内力值（Magic.DB调节），
在技能效果的持续时间内，每秒钟则会消耗250点内力值。使用技能不会增加技能点。


新增技能

Help > 数据库相关 > 示例DB > 魔法数据DB >
新增技能

MagicDB:

34;解毒术;2;26;16;0;0;0;0;0;2;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;40;;
36;火焰冰;1;1;4;8;8;1;2;2;0;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;60;;
37;群体雷电术;7;9;20;14;25;6;10;12;1;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;100;;
38;群体施毒术;9;46;12;10;10;30;4;4;2;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;40;;
39;彻地钉;2;1;4;8;8;1;2;2;0;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;20;;
40;双龙斩;0;44;40;0;0;3;0;0;0;43;50;44;100;45;200;74;400;78;800;82;1600;86;3200;90;6400;94;12800;98;25600;102;51200;106;102400;110;204800;114;409600;118;819200;3;60;;
43;雷霆剑法;0;38;0;0;0;10;0;0;0;48;50;49;100;50;200;76;400;80;800;84;1600;88;3200;92;6400;96;12800;100;25600;104;51200;108;102400;112;204800;116;409600;120;819200;3;0;;
41;狮子吼;4;43;8;1;1;0;0;0;0;38;50;41;100;44;200;47;400;50;800;53;1600;56;3200;59;6400;62;12800;65;25600;68;51200;71;102400;74;204800;77;409600;80;819200;3;30;;
42;龙影剑法;0;0;0;0;0;3;0;0;0;44;50;45;100;46;200;75;400;79;800;83;1600;87;3200;91;6400;95;12800;99;25600;103;51200;107;102400;111;204800;115;409600;119;819200;3;0;;
56;逐日剑法;0;53;0;0;0;7;0;0;0;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;0;;
57;噬血术;2;48;5;5;10;20;5;5;2;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;60;;
58;流星火雨;2;51;12;10;15;20;20;20;1;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;60;;
66;开天斩;0;23;0;0;0;8;0;0;0;34;50;36;100;40;200;44;400;48;800;52;1600;57;3200;62;6400;68;12800;74;25600;81;51200;89;102400;97;204800;106;409600;116;819200;3;0;;
70;心灵召唤;10;42;14;10;0;5;0;0;99;18;50;20;100;22;200;24;400;26;800;28;1600;30;3200;32;6400;34;12800;36;25600;38;51200;40;102400;42;204800;44;409600;46;819200;3;50;;
71;擒龙手;2;26;3;3;3;3;0;0;0;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;60;;
72;大挪移;10;42;3;3;3;3;0;0;99;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;60;;
75;护体神盾;1;0;10;0;0;0;0;0;99;34;50;36;100;38;200;40;400;42;800;44;1600;46;3200;48;6400;50;12800;52;25600;54;51200;56;102400;58;204800;60;409600;62;819200;3;0;;
76;美杜莎之瞳;2;47;15;1;1;8;10;12;1;50;50;51;100;52;200;53;400;54;800;55;800;56;800;57;800;59;800;60;800;60;800;60;800;60;800;60;800;62;1000;3;500;;
112;转风火轮;2;112;8;22;60;6;30;60;1;80;10;80;20;80;50;45;100;27;200;29;1600;31;3200;34;6400;37;12800;40;25600;44;51200;48;102400;52;204800;57;409600;62;819200;5;0;;
113;断空斩;0;24;0;8;25;6;0;0;0;52;10;52;20;52;50;52;100;52;200;52;1600;52;3200;52;6400;52;12800;52;25600;52;51200;52;102400;52;204800;52;409600;52;819200;5;0;;

34;英雄解毒术;2;26;16;0;0;0;0;0;2;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;40;英雄;
36;英雄火焰冰;1;1;4;8;8;1;2;2;1;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;60;英雄;
37;英雄群体雷电;7;9;20;14;25;6;10;12;1;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;100;英雄;
38;英雄群体施毒;9;46;12;10;10;30;4;4;2;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;40;英雄;
39;英雄彻地钉;2;1;4;8;8;1;2;2;0;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;20;英雄;
40;英雄双龙斩;0;44;40;0;0;3;0;0;0;43;50;44;100;45;200;74;400;78;800;82;1600;86;3200;90;6400;94;12800;98;25600;102;51200;106;102400;110;204800;114;409600;118;819200;3;60;英雄;
43;英雄雷霆剑法;0;38;0;0;0;10;0;0;0;48;50;49;100;50;200;76;400;80;800;84;1600;88;3200;92;6400;96;12800;100;25600;104;51200;108;102400;112;204800;116;409600;120;819200;3;0;英雄;
55;英雄召唤月灵;4;41;32;0;0;8;0;0;2;45;10;47;10;48;10;49;20;50;40;51;80;52;160;53;320;54;640;55;1280;56;2560;57;5120;58;10240;59;20480;60;40960;3;50;英雄;
56;英雄逐日剑法;0;53;0;0;0;7;0;0;0;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;0;英雄;
57;英雄噬血术;2;48;5;5;10;20;5;5;2;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;60;英雄;
58;英雄流星火雨;2;51;12;20;25;10;10;20;1;47;10;50;20;53;40;57;80;61;160;65;320;69;640;73;1280;77;2560;81;5120;85;10240;89;20480;93;40960;97;81920;101;163840;3;60;英雄;
66;英雄开天斩;0;23;0;0;0;8;0;0;0;45;10;47;10;48;10;49;20;50;40;51;80;52;160;53;320;54;640;55;1280;56;2560;57;5120;58;10240;59;20480;60;40960;3;0;英雄;
71;英雄擒龙手;2;26;3;3;3;3;0;0;0;42;50;44;100;46;200;48;400;50;800;52;1600;54;3200;56;6400;58;12800;60;25600;62;51200;64;102400;66;204800;68;409600;70;819200;3;60;英雄;
74;英雄分身术;1;0;7;0;0;0;0;0;1;45;10;47;10;48;10;49;20;50;40;51;80;52;160;53;320;54;640;55;1280;56;2560;57;5120;58;10240;59;20480;60;40960;3;0;英雄;
75;英雄护体神盾;1;0;10;0;0;0;0;0;99;34;20;36;40;38;80;40;160;42;320;44;640;46;1280;48;2560;50;5120;52;10240;54;20480;56;40960;58;81920;60;163840;62;327680;3;0;英雄

StdItemsDB：（部分技能没加上物品DB，请自行按需要增加）

130;解毒术;4;2;1;0;0;0;0;46;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
125;大挪移;4;99;1;0;0;0;0;42;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
128;火焰冰;4;1;1;0;0;0;0;46;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
142;双龙斩;4;0;1;0;0;0;0;43;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
146;噬血术;4;2;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
144;逐日剑法;4;0;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
145;流星火雨;4;1;1;0;0;0;0;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
134;龙影剑法;4;0;1;0;0;0;0;63;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
135;护体神盾;4;99;1;0;0;0;0;34;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
124;心灵召唤;4;2;1;0;0;0;0;18;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
143;雷霆剑法;4;0;1;0;0;0;0;48;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
129;群体雷电术;4;1;1;0;0;0;0;46;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
131;群体施毒术;4;2;1;0;0;0;0;46;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;

185;英雄召唤月灵;4;2;1;0;0;0;1144;45;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
186;英雄分身术;4;1;1;0;0;0;1144;45;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
187;英雄护体神盾;4;99;1;0;0;0;1144;34;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
66;英雄开天斩;4;0;0;0;0;0;1144;45;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
189;英雄双龙斩;4;0;1;0;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
190;英雄逐日剑法;4;0;1;0;0;0;1144;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
191;英雄流星火雨;4;1;1;0;0;0;1144;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
192;英雄噬血术;4;2;1;0;0;0;1144;47;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;
193;英雄雷霆剑法;4;0;1;0;0;0;1144;48;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;0;0;12;0;0;0;0;0;0;0;0;0;0;0;;

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


血魄一击

Help > 数据库相关 > 示例DB > 魔法数据DB >
血魄一击

Magic.DB

115;血魂一击(战);0;115;0;0;0;0;0;0;0;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;500;;
116;血魂一击(法);2;116;0;30;70;0;40;80;1;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;600;;
117;血魂一击(道);2;117;0;30;70;0;40;80;2;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;600;;
115;英雄血魂(战);0;115;0;0;0;0;0;0;0;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;600;英雄;
116;英雄血魂(法);2;116;0;30;70;0;40;80;1;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;600;英雄;
117;英雄血魂(道);2;117;0;30;70;0;40;80;2;100;100;101;200;102;500;103;800;104;1000;105;1600;106;3200;107;6400;108;12800;109;25600;110;51200;111;102400;112;204800;113;409600;114;819200;15;600;英雄;


倚天辟地

Help > 数据库相关 > 示例DB > 魔法数据DB >
倚天辟地

MagicDB:

114;倚天辟地;0;55;0;10;20;0;12;25;99;60;100;60;200;60;300;60;400;60;500;60;700;60;800;60;900;60;1000;60;1200;60;1400;60;1600;60;1800;60;2000;60;2500;3;0;;
114;英雄倚天辟地;0;55;0;10;20;0;12;25;99;60;100;60;200;60;300;60;400;60;500;60;700;60;800;60;900;60;1000;60;1200;60;1400;60;1600;60;1800;60;2000;60;2500;3;0;英雄;


英雄技能

Help > 数据库相关 > 示例DB > 魔法数据DB >
英雄技能

功能：
英雄技能书前面加英雄，如：英雄刺杀剑术，Magic.db 的descr=英雄

示例：

魔法DB库DB：

1;英雄火球术;1;1;4;8;8;1;2;2;1;7;10;11;50;16;100;60;英雄;
2;英雄治愈术;2;2;7;14;20;0;0;0;2;7;10;11;50;16;100;40;英雄;
3;英雄基本剑术;0;0;0;0;0;0;0;0;0;7;10;11;50;16;100;0;英雄;
4;英雄精神战法;0;0;0;0;0;0;0;0;2;9;10;13;50;19;100;0;英雄;
5;英雄大火球;1;3;3;6;6;5;10;10;1;19;10;23;50;25;100;60;英雄;
6;英雄施毒术;2;4;4;0;0;0;0;0;2;14;10;17;50;20;100;40;英雄;
7;英雄攻杀剑术;0;5;0;0;0;0;0;0;0;19;10;22;50;24;100;0;英雄;
8;英雄抗拒火环;4;6;8;1;1;0;0;0;1;12;10;15;50;19;100;30;英雄;
9;英雄地狱火;5;7;10;14;14;10;6;6;1;16;10;21;50;26;100;60;英雄;
10;英雄疾光电影;6;8;25;12;12;20;12;12;1;26;10;29;50;32;100;100;英雄;
11;英雄雷电术;7;9;12;14;28;6;10;10;1;17;10;20;50;23;100;100;英雄;
12;英雄刺杀剑术;0;13;0;0;0;0;0;0;0;25;10;27;50;29;100;0;英雄;
13;英雄灵魂火符;8;10;5;15;28;2;10;10;2;18;10;21;50;24;100;60;英雄;
14;英雄幽灵盾;9;11;15;0;0;0;0;0;2;22;10;24;50;26;100;40;英雄;
15;英雄神圣战术;9;12;15;0;0;0;0;0;2;25;10;27;50;29;100;40;英雄;
16;英雄困魔咒;10;14;10;0;0;5;0;0;2;28;10;30;50;32;100;50;英雄;
17;英雄召唤骷髅;4;15;16;0;0;8;0;0;2;19;10;23;50;26;100;50;英雄;
18;英雄隐身术;4;16;5;0;0;0;0;0;2;20;10;23;50;26;100;50;英雄;
19;英雄集体隐身;8;17;10;0;0;0;0;0;2;21;10;25;50;29;100;50;英雄;
20;英雄诱惑之光;2;18;3;3;3;3;0;0;1;13;10;18;50;24;100;60;英雄;
21;英雄瞬息移动;4;19;10;0;0;8;0;0;1;19;10;22;50;25;100;50;英雄;
22;英雄火墙;4;20;20;3;3;25;3;3;1;24;10;29;50;33;100;120;英雄;
23;英雄爆裂火焰;2;21;15;8;8;10;6;6;1;22;10;27;50;31;100;60;英雄;
24;英雄地狱雷光;4;22;35;10;30;20;10;30;1;30;10;32;50;34;100;60;英雄;
25;英雄半月弯刀;0;23;0;0;0;3;0;0;0;28;10;31;50;34;100;0;英雄;
26;英雄烈火剑法;0;24;0;0;0;7;0;0;0;35;10;37;50;40;100;0;英雄;
27;英雄野蛮冲撞;0;25;15;0;0;0;0;0;0;30;10;34;50;39;100;0;英雄;
28;英雄心灵启示;2;26;16;0;0;0;0;0;2;26;10;30;50;35;100;40;英雄;
29;英雄群疗术;2;27;12;10;10;25;4;4;2;33;10;35;50;38;100;40;英雄;
30;英雄召唤神兽;4;28;16;0;0;24;0;0;2;35;10;37;50;40;100;120;英雄;
31;英雄魔法盾;4;29;20;0;0;30;0;0;1;31;10;34;50;38;100;0;英雄;
32;英雄圣言术;2;30;50;0;0;40;0;0;1;32;10;35;50;39;100;120;英雄;
33;英雄冰咆哮;2;31;12;12;12;30;12;12;1;35;10;37;50;40;100;60;英雄;
34;英雄解毒术;2;26;16;0;0;0;0;0;2;42;500;44;1000;46;2000;40;英雄;
36;英雄火焰冰;1;1;4;8;8;1;2;2;0;42;500;44;1000;46;2000;60;英雄;
37;英雄群雷术;7;9;20;14;25;6;10;12;1;42;500;44;1000;46;2000;100;英雄;
38;英雄群毒术;9;46;12;10;10;30;4;4;2;42;500;44;1000;46;2000;40;英雄;
39;英雄彻地钉;1;1;4;8;8;1;2;2;0;42;500;44;1000;46;2000;20;英雄;
40;英雄双龙斩;0;44;40;0;0;3;0;0;0;42;500;44;1000;46;2000;60;英雄;
41;英雄狮子吼;4;43;8;1;1;0;0;0;0;42;500;44;1000;46;2000;30;英雄;
44;英雄寒冰掌;1;39;3;10;10;5;10;10;1;42;500;44;1000;46;2000;60;英雄;
45;英雄灭天火;2;34;16;42;60;30;24;24;1;42;500;44;1000;46;2000;60;英雄;
47;英雄火龙气焰;2;45;35;10;30;20;10;30;1;42;500;44;1000;46;2000;60;英雄;
48;英雄气功波;4;36;8;1;1;0;0;0;2;42;500;44;1000;46;2000;30;英雄;
49;英雄净化术;2;40;4;4;0;0;0;0;2;42;500;44;1000;46;2000;40;英雄;
50;英雄无极真气;4;35;8;1;1;0;0;0;2;42;500;44;1000;46;2000;30;英雄;
51;英雄飓风破;2;47;12;12;12;30;14;14;2;42;500;44;1000;46;2000;30;英雄;
52;英雄诅咒术;9;46;15;0;0;0;0;0;2;42;500;44;1000;46;2000;30;英雄;
53;英雄血咒;2;48;4;4;0;0;0;0;2;42;500;44;1000;46;2000;30;英雄;
54;英雄骷髅咒;2;49;4;4;0;0;0;0;2;42;500;44;1000;46;2000;30;英雄;
71;英雄擒龙手;2;26;3;3;3;3;0;0;0;42;500;44;1000;46;2000;60;英雄;


宝箱DB

Help > 数据库相关 > 示例DB > 物品数据DB >
宝箱DB

功能：
增加开宝箱功能，在Envir目录添加BoxItem.txt，
格式见附件BoxItem.txt，
文件菜单可以重新加载BoxItem.txt

使用说明：
双点打开箱子 然后把钥匙放到箱子孔上即可！不需要脚本支持！

示例：

数据DB

物品数据库：
999;黄金宝箱;46;6;1;0;0;0;1192;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1000;赤金宝箱;46;5;1;0;0;0;1105;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1001;白银宝箱;46;4;1;0;0;0;1104;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1002;紫铜宝箱;46;3;1;0;0;0;1103;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1003;檀木宝箱;46;2;1;0;0;0;1102;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1004;黄金钥匙;46;16;1;0;0;0;1191;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1005;赤金钥匙;46;15;1;0;0;0;1184;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1006;白银钥匙;46;14;1;0;0;0;1183;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1007;紫铜钥匙;46;13;1;0;0;0;1182;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;
1008;木箱钥匙;46;12;1;0;0;0;1181;1;0;0;0;0;0;0;0;0;0;0;0;0;10000;5;

BoxItem.txt

[檀木宝箱]
;物品名称 数量 获取几率(1-255,数字越大几率越小),引擎将自动计算,按照几率安排中间一格的物品
经验 2000 1
经验 200000 5
声望 5 10
声望 15 20
金刚石 10 30
金刚石 20 40
天尊头盔 1 150
天尊项链 1 150
天尊手镯 1 99
天尊戒指 1 99
圣战头盔 1 99
圣战项链 1 150
圣战戒指 1 150
圣战手镯 1 99
法神头盔 1 150
法神项链 1 150
法神戒指 1 99
法神手镯 1 99

[紫铜宝箱]
经验 2000 1
经验 200000 5
声望 5 10
声望 15 20
金刚石 10 30
金刚石 20 40
天尊头盔 1 150
天尊项链 1 150
天尊手镯 1 99
天尊戒指 1 99
圣战头盔 1 99
圣战项链 1 150
圣战戒指 1 150
圣战手镯 1 99
法神头盔 1 150
法神项链 1 150
法神戒指 1 99
法神手镯 1 99

[白银宝箱]
经验 2000 1
经验 200000 5
声望 5 10
声望 15 20
金刚石 10 30
金刚石 20 40
天尊头盔 1 150
天尊项链 1 150
天尊手镯 1 99
天尊戒指 1 99
圣战头盔 1 99
圣战项链 1 150
圣战戒指 1 150
圣战手镯 1 99
法神头盔 1 150
法神项链 1 150
法神戒指 1 99
法神手镯 1 99

[赤金宝箱]
经验 2000 1
经验 200000 5
声望 5 10
声望 15 20
金刚石 10 30
金刚石 20 40
天尊头盔 1 150
天尊项链 1 150
天尊手镯 1 99
天尊戒指 1 99
圣战头盔 1 99
圣战项链 1 150
圣战戒指 1 150
圣战手镯 1 99
法神头盔 1 150
法神项链 1 150
法神戒指 1 99
法神手镯 1 99

[黄金宝箱]
经验 2000 1
经验 200000 5
声望 5 10
声望 15 20
金刚石 10 30
金刚石 20 40
天尊头盔 1 150
天尊项链 1 150
天尊手镯 1 99
天尊戒指 1 99
圣战头盔 1 99
圣战项链 1 150
圣战戒指 1 150
圣战手镯 1 99
法神头盔 1 150
法神项链 1 150
法神戒指 1 99
法神手镯 1 99


元气恢复物品DB

Help > 数据库相关 > 示例DB > 物品数据DB >
元气恢复物品DB

功能：
增加元气物品DB 既人物HP和MP中间那条黄色气血 此物品为补偿中间黄色气血

示例：

元气大还丹;0;3;1;0;0;0;1224;1;250;0;0;0;0;0;0;0;0;0;0;0;50000;5;


聚灵珠DB

Help > 数据库相关 > 示例DB > 物品数据DB >
聚灵珠DB

功能：

增加聚灵珠物品，STDMODE=2，SHAPE=10

Stdmode=2，Shape= 10的物品(聚灵珠)，Anicount<>0并且Source=0时，产生出的物品为满持久，否则持久=0

DuraMAX =聚灵珠累计经验设置，万位计算

聚灵珠聚满经验后，使用Need字段条件来释放经验，聚灵珠DB Need字段 0不限制 1:金币模式 2:元宝模式 3:金刚石模式 4:灵符模式，5:低于指定等级才能使用 6:到达指定等级及以上才能使用

NeedLevel字段为限制货币数量或指定等级

示例：

35;聚灵珠(小);2;10;1;1;0;0;820;20;0;0;0;0;0;0;0;0;0;0;1;50000;100;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
36;聚灵珠(中);2;10;1;1;0;0;820;150;0;0;0;0;0;0;0;0;0;0;2;50000;8;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
37;聚灵珠(大);2;10;1;1;0;0;820;300;0;0;0;0;0;0;0;0;0;0;2;50000;15;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
38;英雄聚灵珠(小);2;10;1;1;0;0;1589;20;0;0;0;0;0;0;0;0;0;0;1;50000;100;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
39;英雄聚灵珠(中);2;10;1;1;0;0;1589;150;0;0;0;0;0;0;0;0;0;0;2;50000;8;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
40;英雄聚灵珠(大);2;10;1;1;0;0;1589;300;0;0;0;0;0;0;0;0;0;0;2;50000;15;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
41;超级聚灵珠(小);2;10;1;0;0;0;820;100;0;0;0;0;0;0;0;0;0;0;1;50000;5;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
42;超级聚灵珠(中);2;10;1;0;0;0;820;800;0;0;0;0;0;0;0;0;0;0;1;50000;5;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
43;超级聚灵珠(大);2;10;1;0;0;0;820;5000;0;0;0;0;0;0;0;0;0;0;1;50000;10;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;

功能：

增加内功聚灵珠物品，STDMODE=2，SHAPE=11

Stdmode=2，Shape= 11的物品(内功聚灵珠)，Anicount<>0并且Source=0时，产生出的物品为满持久，否则持久=0

DuraMAX =聚灵珠累计经验设置，万位计算

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


灵气神水DB

Help > 数据库相关 > 示例DB > 物品数据DB >
灵气神水DB

功能：

灵媒物品的灵气补充物品，放在包袱内双击即可补充。

示例：

物品DB库DB：

12;灵气神水;2;3;1;0;0;0;17;10000;0;0;0;0;0;0;0;0;0;0;0;1;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;


魔血石DB

Help > 数据库相关 > 示例DB > 物品数据DB >
魔血石DB

功能：

增加气血石，魔血石功能

示例：

DB格式：

494;气血石(小);7;1;1;1;0;0;990;4000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
495;幻魔石(小);7;2;1;2;0;0;994;6000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
496;气血石(中);7;1;1;1;0;0;991;9000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
497;幻魔石(中);7;2;1;2;0;0;995;14000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
498;气血石(大);7;1;1;1;0;0;992;20000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
499;幻魔石(大);7;2;1;2;0;0;996;32000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
500;魔血石(大);7;3;1;3;0;0;1026;20000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;


内功金针DB

Help > 数据库相关 > 示例DB > 物品数据DB >
内功金针DB

示例：

1238;舒经活络丸;41;9;1;100;0;0;1754;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1239;幸运符;41;30;1;0;0;0;1720;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1240;一级幸运符;41;31;1;0;0;0;1721;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1241;二级幸运符;41;32;1;0;0;0;1722;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1242;三级幸运符;41;33;1;0;0;0;1723;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1243;四级幸运符;41;34;1;0;0;0;1724;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1244;金针碎片;41;0;1;0;0;0;1730;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1245;金针;41;10;1;0;0;0;1731;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1246;一级金针;41;11;1;0;0;0;1732;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1247;二级金针;41;12;1;0;0;0;1733;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1248;三级金针;41;13;1;0;0;0;1734;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1249;四级金针;41;14;1;0;0;0;1735;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;
1250;五级金针;41;15;1;0;0;0;1736;1;0;0;0;0;0;0;0;0;0;0;1;90;5000;5;0;2;14;0;0;0;0;0;0;0;0;0;0;0;;


千里传音DB

Help > 数据库相关 > 示例DB > 物品数据DB >
千里传音DB

功能：

千里传音佩带于四格宝石位置在游戏里实用@传+要要说的话

示例：

物品库如下：
503;千里传音(大);7;0;1;0;0;0;1000;20000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
504;千里传音;7;0;1;0;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;11;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;


宝宝强化卷DB

Help > 数据库相关 > 示例DB > 物品数据DB >
宝宝强化卷DB

功能：

强化召唤卷，使用后宝宝可以立即达到Anicuont设置的数字等级，默认是7级

示例：

59;强化召唤卷;2;1;1;7;0;0;998;5000;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;


随机石DB

Help > 数据库相关 > 示例DB > 物品数据DB >
随机石DB

功能：

随机传送石实现和传送卷一样的效果，可以使用50次。

示例：

物品库如下：

47;随机传送石;2;2;0;0;0;0;1025;50000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;


回城石DB

Help > 数据库相关 > 示例DB > 物品数据DB >
回城石DB

功能：

回城石,和回城卷一样的功能, 可多次使用

Reserved字段控制回城点的随机范围, 为0时不随机

示例：

593;回城石;2;1;1;0;0;5;402;50000;0;0;0;0;0;0;0;0;0;0;0;0;455;5;0;;;;;;;;;;;;;;;;;;;

这个5就代表回到坐标点周围5格范围内


计次触发物品

Help > 数据库相关 > 示例DB > 物品数据DB >
计次触发物品

说明:

物品Stdmode为 2 ,shape字段为0

Anicount=XXX 数字 将触发 QFunction-0.txt 对应[@STDMODEFUNCXXX]

使用一次减一次持久, 持久在DURAMAX处控制

示例:

594;计次触发物品;2;0;1;222;0;0;402;50000;0;0;0;0;0;0;0;0;0;0;0;0;455;5;0;;;;;;;;;;;;;;;;;;;


修复神水

Help > 数据库相关 > 示例DB > 物品数据DB >
修复神水

功能：

修复神水可以按持久点修复下面的举列是100点持久点

示例：

物品库如下：

44;修复神水;2;9;1;0;0;0;120;10000;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;


烟花DB及设置

Help > 数据库相关 > 示例DB > 物品数据DB >
烟花DB及设置

功能：
烟花效果设置

示例：

物品DB库DB：

691;一心一意;31;1;1;12;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
692;心心相印;31;1;1;13;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
693;飞火流星;31;1;1;14;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
694;浪漫星雨;31;1;1;15;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
706;绮梦幻想;31;1;1;16;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
707;长空火舞;31;1;1;17;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;
737;如雾似梦;31;1;1;18;0;0;1016;0;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;

QFunction-0.txt段如下：

[@StdModeFunc12]
#IF
#ACT
Gmexecute showeffect 78
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc13]
#IF
#ACT
Gmexecute showeffect 79
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc14]
#IF
#ACT
Gmexecute showeffect 80
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc15]
#IF
#ACT
Gmexecute showeffect 81
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc16]
#IF
#ACT
Gmexecute showeffect 82
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc17]
#IF
#ACT
Gmexecute showeffect 83
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc18]
#IF
#ACT
Gmexecute showeffect 84
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。


祝福油罐

Help > 数据库相关 > 示例DB > 物品数据DB >
祝福油罐

功能：

增加储存灌类物品：STDMODE=2，SOURCE不为0，储存的数量持久/1000，
双击后减少一点持久，并给予UnbindList.txt中定义的SOURCE编号物品，
储存方式：储存灌装备到毒符位置，将UnbindList.txt中定义的SOURCE编号物品拖到毒符位置。

示例：

比如

1115;祝福罐;2;0;1;46;110;0;1174;50000;0;0;0;0;0;0;0;0;0;0;0;5000;1;0;0;0;10;0;双击1次释放1瓶祝福油;

注意上面红色部分的110

对应UnbindList.txt文本里

110 祝福油

储存灌装备到毒符位置 可以把祝福油 直接拖到储存罐内


火龙之心

火龙之心 和 补充物DB

517;火龙之心;25;9;1;0;0;0;4220;50000;0;0;0;0;0;0;0;0;0;0;0;1;3409;5;0;10;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
579;火龙之心填充物;96;0;5;0;0;0;255;20;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;255;0;0;0;0;0;0;0;0;0;0;0;0;;

合击必备物品


药品相关

药品相关设置:

解包设置: MirServer\Mir200\Envir\UnbindList.txt 内容

;;解开打包文件
100 金创药(小量)
101 魔法药(小量)
102 金创药(中量)
103 魔法药(中量)
104 强效金创药
105 强效魔法药
106 地牢逃脱卷
107 随机传送卷
108 回城卷
109 行会回城卷
110 强效太阳水
111 万年雪霜
112 疗伤药
113 一心一意
114 心心相印
115 飞火流星
116 浪漫星雨
117 绮梦幻想
118 长空火舞
119 如雾似梦
120 祝福油
121 大太阳水

药品DB:

499;强效金创药;0;0;3;104;0;0;260;20;90;0;0;0;0;0;0;0;0;0;0;0;550;5;0;0;0;0;0;255;0;0;0;0;0;0;0;0;0;0;0;0;0;
498;超级金创药;31;104;20;1;0;0;313;0;0;0;0;0;0;0;0;0;0;0;0;0;3400;5;0;0;0;0;0;255;0;0;0;0;0;0;0;0;0;0;0;0;0;

563;大太阳水;0;1;1;121;0;0;312;1000;80;0;100;0;0;0;0;0;0;0;0;0;2000;5;0;0;0;0;0;255;0;0;0;0;0;0;0;0;0;0;0;0;0;
564;太阳水包;31;121;20;3;0;0;313;0;0;0;0;0;0;0;0;0;0;0;0;0;3400;5;0;0;0;0;0;255;0;0;0;0;0;0;0;0;0;0;0;0;0;

药包的Shape104字段值和药品的Anicount104字段值对应

药包的Anicount值为1时是普通HP药包, 为2时是普通MP药包, 为3时是特殊药品药包

药品的Shape值为0时是普通药品, 为1时是特殊药品

设置药品数据时务必按照以上参数设置,否则PC端保护功能会出现异常


必杀首饰

Help > 数据库相关 > 示例DB > 装备DB >
必杀首饰

StdItems.DB：

10;必杀战盔;15;191;1;0;0;2;2272;10000;6;6;5;5;2;8;0;0;0;0;0;50;50000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
11;必杀道盔;15;191;1;0;0;2;2272;10000;6;6;5;5;0;0;0;0;2;8;0;50;50000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
12;必杀魔盔;15;191;1;0;0;2;2272;10000;6;6;5;5;0;0;2;8;0;0;0;50;50000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
13;必杀战戒;22;191;2;0;0;1;2270;8000;0;0;0;3;1;14;0;0;0;0;0;50;50000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
14;必杀道戒;22;191;2;0;0;1;2270;8000;0;0;0;3;0;0;0;0;1;13;0;50;50000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
15;必杀魔戒;22;191;2;0;0;1;2270;8000;0;0;0;3;0;0;3;13;0;0;0;50;50000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
16;必杀战靴;28;191;1;0;0;2;2274;10000;6;6;5;5;2;8;0;0;0;0;0;50;50000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
17;必杀魔靴;28;191;1;0;0;2;2274;10000;6;6;5;5;0;0;2;8;0;0;0;50;50000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
18;必杀道靴;28;191;1;0;0;2;2274;10000;6;6;5;5;0;0;0;0;2;8;0;50;50000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
19;必杀项链(战);19;191;3;0;0;2;2273;8000;0;0;0;2;3;8;0;0;0;0;0;50;50000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
20;必杀项链(道);19;191;3;0;0;2;2273;6000;0;0;0;2;0;0;0;0;3;8;0;50;50000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
21;必杀项链(法);19;191;3;0;0;2;2273;7000;0;0;0;2;0;0;3;8;0;0;0;50;50000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
22;必杀护腕(战);26;191;2;0;0;1;2271;8000;0;3;0;0;2;10;0;0;0;0;0;50;50000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
23;必杀护腕(道);24;191;2;0;0;1;2271;7000;0;0;0;2;0;0;0;0;4;10;0;50;50000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
24;必杀护腕(法);26;191;2;0;0;1;2271;6000;0;3;0;3;0;0;2;10;0;0;0;50;50000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
25;必杀腰带(战);27;191;1;0;0;2;2275;8000;6;6;5;5;2;8;0;0;0;0;0;50;50000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;
26;必杀腰带(道);27;191;1;0;0;2;2275;8000;6;6;5;5;0;0;0;0;2;8;0;50;50000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;
27;必杀腰带(法);27;191;1;0;0;2;2275;8000;6;6;5;5;0;0;2;8;0;0;0;50;50000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;
28;必杀面巾(战);16;0;1;0;1;0;1712;8000;3;3;3;3;1;4;0;0;0;0;0;60;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;
29;必杀面巾(法);16;0;1;0;1;0;1712;8000;3;3;3;3;0;0;1;4;0;0;0;60;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;
30;必杀面巾(道);16;0;1;0;1;0;1712;8000;3;3;3;3;0;0;0;0;1;4;0;60;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;
31;必杀斗笠(战);16;0;1;7;0;0;2081;30000;3;3;3;3;1;4;0;0;0;0;0;45;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;
32;必杀斗笠(法);16;0;1;7;0;0;2081;30000;3;3;3;3;0;0;1;4;0;0;0;45;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;
33;必杀斗笠(道);16;0;1;7;0;0;2081;30000;3;3;3;3;0;0;0;0;1;4;0;45;50000;50;0;0;15;0;0;1;0;0;0;0;0;0;0;0;;


传奇首饰

Help > 数据库相关 > 示例DB > 装备DB >
传奇首饰

StdItems.DB：

1216;传奇神甲(男);10;57;40;33;10;50;2540;60000;9;28;9;28;14;16;15;18;15;18;0;60;1500000;5000000;0;0;9;0;0;0;0;0;0;0;0;0;0;2;;
1217;传奇神甲(女);11;57;40;34;10;50;2542;60000;9;28;9;28;14;16;15;18;15;18;0;60;1500000;5000000;0;0;9;0;0;0;0;0;0;0;0;0;0;2;;
1218;传奇神剑;5;80;80;193;0;0;2523;60000;7;2;0;0;30;72;31;35;32;34;0;100;250000;200000;0;0;1;0;15;0;0;0;0;0;0;0;0;4;;
1219;传奇之冠;15;193;1;0;0;0;2515;10000;0;9;2;8;9;15;9;15;9;15;0;60;35000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;3;;
1220;传奇项链;19;193;1;0;0;0;2512;8000;0;0;0;4;10;14;10;14;10;14;0;60;35000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;3;;
1221;传奇护腕;26;193;1;0;0;0;2511;10000;0;2;0;2;12;16;12;16;12;16;0;60;35000;50000;0;0;4;0;0;0;0;0;0;0;0;0;0;3;;
1222;传奇之戒;22;193;2;0;0;0;2510;7000;0;2;0;0;15;22;15;22;15;22;0;60;35000;50000;0;0;3;0;0;0;0;0;0;0;0;0;0;3;;
1223;传奇勋章;30;193;1;0;1;0;2516;50000;0;0;0;0;18;20;18;20;18;20;0;50;1000000;150000;0;0;5;0;0;0;0;0;0;0;0;0;0;3;;
1224;传奇腰带;27;193;1;0;0;0;2514;10000;0;9;2;8;9;15;9;15;9;15;0;60;35000;50000;0;0;7;0;0;0;0;0;0;0;0;0;0;3;;
1225;传奇之靴;28;193;1;10;0;0;2513;10000;0;9;2;8;9;15;9;15;9;15;0;60;35000;50000;0;0;8;0;0;0;0;0;0;0;0;0;0;3;;
1226;传奇斗笠;16;193;1;9;0;0;2522;30000;3;3;6;9;6;9;6;9;0;0;0;45;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;3;;
1227;传奇面巾;16;193;1;0;1;0;2517;30000;3;3;6;9;6;9;6;9;0;0;0;45;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;3;;
1228;传奇魔杖;6;82;30;193;0;0;2525;60000;7;2;0;0;30;72;31;35;32;34;0;100;250000;200000;0;0;1;0;15;0;0;0;0;0;0;0;0;6;;
1228;传奇宝扇;5;81;30;193;0;0;2524;60000;7;2;0;0;30;72;31;35;32;34;0;100;250000;200000;0;0;1;0;15;0;0;0;0;0;0;0;0;5;;


传奇之刃

Help > 数据库相关 > 示例DB > 装备DB >
传奇之刃

图例：

StdItems.DB：

13;传奇战刃;5;70;70;194;0;0;2180;65000;0;2;0;0;12;80;0;0;0;0;0;120;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
14;传奇魔刃;5;70;25;194;0;0;2180;65000;0;2;0;0;12;30;12;38;0;0;0;120;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;
15;传奇道刃;5;70;40;194;0;0;2180;65000;0;2;0;0;12;37;0;0;12;37;0;120;5000;5000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;;


斗笠,蒙面面巾

Help > 数据库相关 > 示例DB > 装备DB >
斗笠,蒙面面巾

StdItems.DB：

472;斗笠11号;16;0;1;4;0;0;14k;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
473;斗笠12号;16;0;1;4;0;0;14k;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
474;斗笠13号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
475;斗笠14号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
476;斗笠15号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
477;斗笠23号;16;0;1;4;0;0;14k;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
478;斗笠24号;16;0;1;4;0;0;14k;6000;0;1;0;0;0;0;0;1;0;0;0;44;10000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
479;斗笠25号;16;0;1;4;0;0;14k;6000;0;1;0;0;0;0;0;0;0;1;0;44;10000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
480;斗笠31号;16;0;1;4;0;0;14k;6000;0;1;0;1;0;0;0;0;0;0;0;44;15000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
481;斗笠32号;16;0;1;4;0;0;14k;6000;1;1;0;1;0;0;0;0;0;0;0;44;15000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
482;斗笠33号;16;0;1;4;0;0;14k;6000;0;1;0;1;0;1;0;0;0;0;0;44;15000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
483;斗笠34号;16;0;1;4;0;0;14k;6000;0;1;0;1;0;0;0;1;0;0;0;44;15000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
484;斗笠35号;16;0;1;4;0;0;14k;6000;0;1;0;1;0;0;0;0;0;1;0;44;15000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
485;斗笠41号;16;0;1;4;0;0;14k;6000;0;2;0;0;0;0;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
486;斗笠42号;16;0;1;4;0;0;14k;6000;0;0;0;2;0;0;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
487;斗笠43号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;2;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
488;斗笠44号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;2;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
489;斗笠45号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;0;0;2;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
490;斗笠51号;16;0;1;4;0;0;14k;6000;0;3;0;0;0;0;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
491;斗笠52号;16;0;1;4;0;0;14k;6000;0;0;0;3;0;0;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
492;斗笠53号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;3;0;0;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
493;斗笠54号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;3;0;0;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;
494;斗笠55号;16;0;1;4;0;0;14k;6000;0;0;0;0;0;0;0;0;0;3;0;44;20000;5;0;0;15;0;0;0;0;0;0;0;0;0;0;0;;

502;蒙面方巾(战);16;0;1;0;1;0;1678;8000;0;0;0;0;0;1;0;0;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
503;蒙面方巾(法);16;0;1;0;1;0;1678;8000;0;0;0;0;0;0;0;1;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
504;蒙面方巾(道);16;0;1;0;1;0;1678;8000;0;0;0;0;0;0;0;0;0;1;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
505;蒙面黑巾(战);16;0;1;0;1;0;1678;8000;0;2;0;2;0;2;0;0;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
506;蒙面黑巾(法);16;0;1;0;1;0;1678;8000;0;2;0;2;0;0;0;2;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
507;蒙面黑巾(道);16;0;1;0;1;0;1678;8000;0;2;0;2;0;0;0;0;0;2;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
508;蒙面青巾(战);16;0;1;0;1;0;1713;8000;0;2;0;2;0;3;0;0;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
509;蒙面青巾(法);16;0;1;0;1;0;1713;8000;0;2;0;2;0;0;0;3;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
510;蒙面青巾(道);16;0;1;0;1;0;1713;8000;0;2;0;2;0;0;0;0;0;3;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
511;蒙面赤巾(战);16;0;1;0;1;0;1711;8000;0;3;0;3;1;3;0;0;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
512;蒙面赤巾(法);16;0;1;0;1;0;1711;8000;0;3;0;3;0;0;1;3;0;0;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;
513;蒙面赤巾(道);16;0;1;0;1;0;1711;8000;0;3;0;3;0;0;0;0;1;3;0;55;50000;50;0;0;15;0;0;0;0;0;0;0;0;0;0;;


虎威首饰

Help > 数据库相关 > 示例DB > 装备DB >
虎威首饰

StdItems.DB：

10;虎威战盔;15;190;20;0;0;4;2133;10000;6;7;5;6;0;10;0;0;0;0;0;54;35000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
11;虎威魔盔;15;190;20;0;0;4;2133;7000;6;7;5;6;0;0;0;10;0;0;0;54;35000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
12;虎威道盔;15;190;20;0;0;4;2133;7000;6;7;5;6;0;0;0;0;0;10;0;54;35000;50000;0;0;6;0;0;0;0;0;0;0;0;0;0;;
13;虎威战戒;22;190;2;0;0;2;2131;7000;0;0;0;4;2;15;0;0;0;0;0;54;35000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
14;虎威魔戒;22;190;2;0;0;2;2131;7000;0;0;0;4;0;0;2;15;0;0;0;54;35000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
15;虎威道戒;22;190;2;0;0;2;2131;7000;0;0;0;4;0;0;0;0;2;15;0;54;35000;15000;2;0;3;0;0;0;0;0;0;0;0;0;0;;
16;虎威战靴;28;190;2;0;0;1;2134;7000;6;7;5;6;0;10;0;0;0;0;0;54;35000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
17;虎威魔靴;28;190;2;0;0;1;2134;7000;6;7;5;6;0;0;0;10;0;0;0;54;35000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
18;虎威道靴;28;190;2;0;0;1;2134;7000;6;7;5;6;0;0;0;0;0;10;0;54;35000;20000;0;0;8;0;0;0;0;0;0;0;0;0;0;;
19;虎威项链(战);19;190;1;0;0;5;2132;6000;0;0;0;1;4;9;0;0;0;0;0;54;3000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
20;虎威项链(法);19;190;1;0;0;5;2132;6000;0;0;0;1;0;0;4;9;0;0;0;54;3000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
21;虎威项链(道);19;190;1;0;0;5;2132;6000;0;0;0;1;0;0;0;0;4;9;0;54;3000;50000;0;0;2;0;0;0;0;0;0;0;0;0;0;;
22;虎威护腕(战);26;190;2;0;0;2;2130;7000;0;4;0;4;3;11;0;0;0;0;0;54;35000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
23;虎威护腕(法);26;190;2;0;0;2;2130;7000;0;4;0;4;0;0;3;11;0;0;0;54;35000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
24;虎威护腕(道);24;190;2;0;0;2;2130;7000;0;0;0;2;0;0;5;11;0;0;0;54;35000;15000;0;0;4;0;0;0;0;0;0;0;0;0;0;;
25;虎威腰带(战);27;190;2;0;0;1;2135;7000;6;7;5;6;0;10;0;0;0;0;0;54;35000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;
26;虎威腰带(法);27;190;2;0;0;1;2135;7000;6;7;5;6;0;0;0;10;0;0;0;54;35000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;
27;虎威腰带(道);27;190;2;0;0;1;2135;7000;6;7;5;6;0;0;0;0;0;10;0;54;35000;20000;0;0;7;0;0;0;0;0;0;0;0;0;0;;


黄金武器

Help > 数据库相关 > 示例DB > 装备DB >
黄金武器

内观：

DB示例：（传奇中没有黄金屠龙这个武器，所以属性请自行设置）

10;黄金屠龙;5;69;99;0;0;0;1787;33000;0;0;0;0;10;45;0;0;0;0;0;34;160000;2000;0;0;1;0;0;0;0;0;0;0;0;0;0;;
11;黄金裁决;5;63;80;0;-5;0;1687;32000;0;0;0;0;0;50;0;0;0;0;0;60;250000;200000;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
12;紫金嗜魂法杖;5;64;26;0;-5;0;1780;10000;0;0;0;0;7;30;4;27;0;0;0;60;250000;200000;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;
13;赤金逍遥扇;5;65;45;0;-5;0;1781;30000;0;0;0;0;8;35;0;0;3;23;0;60;250000;200000;0;0;1;0;0;0;0;0;0;0;0;0;0;0;;


战鼓,马牌,时装

Help > 数据库相关 > 示例DB > 装备DB >
战鼓,马牌,时装

军鼓 升级属性位置 14 脚本显示装备名字变量$DRUM
马牌 升级属性位置 15 脚本显示装备名字变量$HORSE
时装 升级属性位置 16 脚本显示装备名字变量$FASHION

时装在人物的界面上有个选择 显示时装 时装和普通衣服一样升级属性 衣服和时装的属性同时存在

关于时装如何制作： 随便复制一件衣服的DB 把 StdMode段 10改12 11改13即可 一件新时装就做好了

StdItems.DB

以下DB示例：

4;时装(男);12;1;1;0;0;0;2420;5000;0;2;0;1;0;0;0;0;0;0;0;1;400;100;0;0;0;0;0;0;0;0;0;0;0;0;3;2;0;0;;

5;时装(女);13;1;1;0;0;0;2421;5000;0;2;0;1;0;0;0;0;0;0;0;1;400;100;0;0;0;0;0;0;0;0;0;0;0;0;2;2;0;0;;

StdItems.DB

以下DB示例：

1283;鼓;17;0;0;0;0;0;3472;10000;5;6;5;6;3;4;3;4;3;4;0;1;10000;1000;0;0;0;0;0;0;0;0;0;0;0;0;0;5;100;100;;

关于马牌 并无实际效果 只有属性 加成

1284;马牌;18;0;0;0;0;0;392;10000;5;6;5;6;3;4;3;4;3;4;0;1;10000;0;0;0;0;0;0;0;0;0;0;0;0;0;0;5;50;50;;


冰眼巨魔DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
冰眼巨魔DB

功能：

增加传奇套召唤出的巨魔，怪物部分细节DB，请自行修改

温顺的冰眼巨魔;126;39;267;99;0;40;8000;0;50;50;30;100;100;0;10;32;900;1;1;1200;0;0;0;0;
降伏的冰眼巨魔;126;39;268;99;0;40;9000;0;60;60;40;120;200;0;20;46;850;1;1;1100;0;0;0;0;
追随的冰眼巨魔;126;39;256;99;0;60;10000;0;70;70;50;150;300;0;30;52;800;1;1;1000;0;0;0;0;


释放技能的怪物

Help > 数据库相关 > 示例DB > 怪物数据DB >
释放技能的怪物

功能：
      新增怪物类型 让怪物也会技能！ 其他的技能正在一点点做上去！

介绍：
      当怪物Race值为207时.则会使用火墙攻击(条型火墙).当Race值为209时.则会使用火墙攻击(方型火墙).屏幕内随机传送人.推人效果.放出随从.随从在 !Setup.exe [Name]节 BloodMonSlaveX 编辑

北海神龟;209;40;271;254;1;100;75000;32000;0;220;240;240;260;0;0;150;40;230;1;0;600; 会使用火墙攻击(条型火墙)

北海神龟1;207;40;271;254;1;100;75000;32000;0;220;240;240;260;0;0;150;40;230;1;0;600; 会使用火墙攻击(方型火墙).屏幕内随机传送人.推人效果.放出随从

[Names]
HealSkill=治愈术
FireBallSkill=火球术
ClothsMan=超级金创药
ClothsWoman=布衣(女)
WoodenSword=超级魔法药
Candle=蜡烛
BasicDrug=金创药(小量)
GoldStone=金矿
SilverStone=银矿
SteelStone=铁矿
CopperStone=铜矿
BlackStone=黑铁矿石
Zuma1=祖玛卫士
Zuma2=祖玛雕像
Zuma3=祖玛弓箭手
Zuma4=楔蛾
Bee='蝙蝠'
Spider='爆裂蜘蛛'
WomaHorn=沃玛号角
ZumaPiece=祖玛头像
Dogz1=御卫
Dogz=神兽
BoneFamm=变异骷髅
GameGold=元宝
BoneFamm0=
BoneFamm1=
BoneFamm2=
BoneFamm3=
BoneFamm4=
BoneFamm5=
BoneFamm6=
BoneFamm7=
BoneFamm8=
BoneFamm9=
Dogz0=白虎至尊
Dogz1=神兽
Dogz2=
Dogz3=
Dogz4=
Dogz5=
Dogz6=
Dogz7=
Dogz8=
Dogz9=
GamePoint=泡点
Body=随身护卫
PayMentPointName=秒卡点
BloodMonSlave1=炎魔1
BloodMonSlave2=炎魔2
BloodMonSlave3=炎魔3


狐月山怪物DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
狐月山怪物DB

Monster.DB：

黑狐;162;113;320;60;0;80;4800;0;60;40;70;100;30;0;40;50;800;1;0;1250;10000;;;;
//战，刺杀
赤狐;163;114;321;90;0;80;2800;0;40;70;60;110;40;0;40;50;600;1;0;1350;10000;;;;
//法，吸MP，有几率群攻
素狐;164;115;322;90;0;80;3800;0;30;50;40;80;40;0;35;50;600;1;0;1350;10000;;;;
//道，诅咒，有几率召唤狐月黄蛙，狐月褐蛙
弓箭大师;169;45;323;90;0;40;1700;0;45;55;45;85;0;0;5;15;900;1;0;1200;11900;0;0;0;
//远程攻击
九尾魂石;167;117;324;70;0;90;2000;0;50;75;35;75;0;0;15;35;900;1;0;1500;10000;;;;
//推拉人，无敌
狐月电眼;165;118;325;80;0;100;3000;0;50;75;35;75;0;0;15;35;900;1;0;1500;10000;;;;
//攻击无效，野蛮才能杀
狐月风眼;166;119;326;80;0;100;3000;0;50;75;45;95;0;0;15;35;900;1;0;1500;10000;;;;
//攻击无效，野蛮才能杀
狐月天珠;168;120;327;120;0;100;20000;0;60;98;60;120;0;0;15;35;900;1;0;1500;10000;;;;
//BOSS，诅咒，麻痹，5种外观状态，死亡后狐月系列怪物将随之死亡
狐月黄蛙;169;57;328;60;10;30;2000;0;0;0;40;60;0;0;5;15;500;1;0;1500;16300;0;0;0;
//远程攻击
狐月褐蛙;169;58;329;60;10;30;2000;0;0;0;40;60;0;0;5;15;500;1;0;1500;16300;0;0;0;
//远程攻击


雷炎洞怪物DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
雷炎洞怪物DB

功能：

增加雷炎洞新怪和新怪魔法同时更新几个老BOSS的攻击效果 具体如下：

示例：

虹魔教主（旧）;81;62;182;99;1;1;5000;0;15;20;50;80;0;0;20;30;500;1;0;1200;50000;
//普通和发狂模式
虹魔教主（新）;122;62;182;99;1;1;5000;0;15;20;50;80;0;0;20;30;500;1;0;1200;50000;
//普通和发狂模式
牛魔王（新）;122;71;207;99;1;1;3600;0;20;24;45;80;0;0;20;30;600;1;0;1200;40000;
//远近2种攻击模式，远攻为3X3群体魔法
魔龙阴石;136;75;216;99;1;1;5000;0;15;20;50;80;0;0;20;30;500;1;0;1200;50000;
//提升周围非人物物理攻击力
魔龙阳石;136;77;217;99;1;1;5000;0;15;20;50;80;0;0;20;30;500;1;0;1200;50000;
//提升周围非人物物理防御力
魔龙教主（旧）;81;78;218;99;1;100;12000;0;15;15;120;150;0;0;20;15;500;1;0;500;80000;
//MC=攻击力，1X1群体攻击，全屏概率麻痹
魔龙教主（新）;137;78;218;99;1;100;12000;0;15;15;120;150;0;0;20;15;500;1;0;500;80000;
//MC=攻击力，1X1群体攻击，全屏概率麻痹
火龙神;138;83;800;99;1;100;5000;10;50;40;100;150;50;50;30;30;800;1;0;1000;655350;
//MC=攻击力，2X2群体攻击
全屏雷电攻击
火龙雕像1;139;84;802;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
火龙雕像2;139;84;803;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
火龙雕像3;139;84;804;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
火龙雕像4;139;87;805;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
火龙雕像5;139;87;806;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
火龙雕像6;139;87;807;10;1;100;3000;10;25;20;70;100;50;50;10;10;1500;1;0;3000;655350;
//MC=攻击力，2X2群体攻击
狂热火蜥蜴;150;102;220;60;1;1000;5500;12000;0;35;45;80;100;0;0;24;600;900;1;800;20000;
//会拖回敌人进行攻击，一定几率中毒效果
恶魔蜘蛛;144;105;223;60;1;1000;1800;4000;0;40;45;60;70;0;0;24;600;700;1;800;8000;
圣殿卫士;143;104;221;60;1;1000;5000;3500;0;40;50;60;70;0;0;24;600;700;1;800;8000;
//远近攻击，远攻为红色雷电(MC)
巨镰蜘蛛;81;19;230;60;1;1000;5000;3000;0;15;24;38;55;0;0;24;600;750;1;800;15000;
白玉老虎;153;103;222;60;1;1000;1800;10000;0;20;35;60;70;0;0;24;600;780;1;800;10000;
绿魔蜘蛛;81;19;232;60;1;1000;1800;4000;0;24;35;60;70;0;0;24;600;750;1;800;9000;
铁翼巨蛾;81;19;235;60;1;1000;1800;4000;0;25;38;60;70;0;0;24;600;750;1;800;9000;
黑牙蜘蛛;81;19;236;60;0;1000;1000;500;0;13;22;20;40;0;0;22;600;800;1;800;15000;
雷炎蛛王;125;111;237;60;1;1000;10000;20000;0;40;45;280;300;0;0;35;600;700;1;800;8000;
//普攻带绿毒，蜘蛛网带麻痹攻击
蓝背蜘蛛;81;19;238;60;1;1000;1800;4000;0;30;45;60;70;0;0;24;600;700;1;800;8000;
剧毒骷髅;81;19;239;60;1;1000;1800;4000;0;50;36;60;70;0;0;24;600;700;1;800;8000;
圣殿黄龙;81;19;233;60;1;1000;10000;20000;0;50;36;280;300;0;0;24;600;700;1;800;8000;
圣殿护卫;143;104;234;60;1;1000;10000;20000;0;55;36;280;300;0;0;24;600;700;1;800;8000;
金杖蜘蛛;145;106;231;60;1;1000;10000;20000;0;24;36;280;300;0;0;24;600;700;1;800;8000;

雷炎洞小地图：
hl001 303
hl002 304

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


强化宝宝DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
强化宝宝DB

功能：

增加强化变异骷髅、强化神兽

变异骷髅示例：

变异骷髅1;100;91;700;20;1;0;300;0;30;20;50;50;0;0;5;10;600;2;0;1200;2240;0;0;448;
变异骷髅2;100;92;701;30;1;0;300;0;35;25;55;55;0;0;5;10;600;2;0;1200;3360;0;0;672;
变异骷髅3;100;93;702;40;1;0;300;0;45;30;65;65;0;0;5;10;600;2;0;1200;3920;0;0;784;

变异神兽示例：

神兽5;113;94;703;32;1;0;300;0;30;6;4;15;0;0;20;30;600;2;0;1000;2100;0;0;420;
神兽51;114;95;704;32;1;100;600;0;60;20;45;50;150;150;10;300;600;2;0;1000;4200;0;0;840;
神兽6;113;94;705;32;1;0;300;0;30;6;4;15;0;0;20;30;600;2;0;1000;2100;0;0;420;
神兽61;114;95;706;32;1;100;600;0;60;25;55;60;150;150;10;300;600;2;0;1000;4200;0;0;840;
神兽7;113;94;707;32;1;0;300;0;30;6;4;15;0;0;20;30;600;2;0;1000;2100;0;0;420;
神兽71;114;95;708;32;1;100;600;0;60;30;65;70;150;150;10;300;600;2;0;1000;4200;0;0;840;


卧龙人形怪

Help > 数据库相关 > 示例DB > 怪物数据DB >
卧龙人形怪

功能：

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：

RACE=60//普通人形怪

战士;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

注意：如果觉得怪物速度太慢！可以自己调节怪物的攻击速度。走动速度。防御等等！！！！

功能：

RACE=61 //卧龙人形怪

战士;61;19;0;255;0;100;5000;0;10;10;0;0;0;0;88;45;450;1;0;450;5000;
法师;61;19;0;255;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;
道士;61;19;0;255;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;

增加三职业英雄怪：RACE=61，制作卧龙山庄
功能基于RACE=60人型怪基础上，
增加：
支持英雄所有普通技能
支持使用三英雄新技能，护体神盾，四级技能等

挖卧龙守将物品需要灵符设置在[英雄设置]调节，挖到的物品暴率文件在MonItems目录下的：守将名字.txt（等同其他怪）

示例：

MonUseItems 目录配置文件增加：
[Info]
;Butch=0表示暴出物品，Butch=1表示用挖才能得到物品，挖到的物品设置在MonItems目录，等同其他怪
Butch=1
;BodyLeathery=尸体坚韧度，数字越大，表示要挖更久的时间才进入获取物品函数(是否获得物品取决于MonItems目录下此怪的暴率文件)。
BodyLeathery=200

MonUseItems文件夹下：

战士.TXT

设置内容如下：

[INFO]
;是不是掉装备,1=掉,0=不掉
DROPUSEITEM=0
Butch=1
BodyLeathery=10
;职业
JOB=0
;性别
GENDER=0
;头发
HAIR=3
;使用魔法
USESKILL=基本剑术,攻杀剑术,刺杀剑术,野蛮冲撞,烈火剑法,英雄开天斩,
DropUseItemRate=1
UseAllSkillByJob=1

;开启首饰盒
UseJewelry=1

;开启神佑盒
UseGod=1

[USEITEMS]
;衣服
USEITEMS0=凤天魔甲
;武器
USEITEMS1=开天
;照明物
USEITEMS2=银星勋章(战)
;项链
USEITEMS3=星王项链(战)
;头盔
USEITEMS4=星王战盔
;左手镯
USEITEMS5=星王护腕(战)
;右手镯
USEITEMS6=星王护腕(战)
;左戒指
USEITEMS7=星王战戒
;右戒指
USEITEMS8=星王战戒
;物品
USEITEMS9=护身符(大)
;腰带
USEITEMS10=星王腰带(战)
;鞋子
USEITEMS11=星王战靴
;宝石
USEITEMS12=魔血石(大)
;斗笠
USEITEMS13=
;军鼓
USEITEMS14=
;马牌
USEITEMS15=
;盾牌
USEITEMS16=
;时装衣服
USEITEMS17=
;时装武器
USEITEMS18=
;时装项链
USEITEMS19=
;时装头盔
USEITEMS20=
;时装左手
USEITEMS21=
;时装右手
USEITEMS22=
;时装左戒
USEITEMS23=
;时装右戒
USEITEMS24=
;时装勋章
USEITEMS25=
;时装腰带
USEITEMS26=
;时装靴子
USEITEMS27=
;时装宝石
USEITEMS28=
;首饰1
USEITEMS29=
;首饰2
USEITEMS30=
;首饰3
USEITEMS31=
;首饰4
USEITEMS32=
;首饰5
USEITEMS33=
;首饰6
USEITEMS34=
;神佑1
USEITEMS35=
;神佑2
USEITEMS36=
;神佑3
USEITEMS37=
;神佑4
USEITEMS38=
;神佑5
USEITEMS39=
;神佑6
USEITEMS40=
;神佑7
USEITEMS41=
;神佑8
USEITEMS42=
;神佑9
USEITEMS43=
;神佑10
USEITEMS44=
;神佑11
USEITEMS45=
;神佑12
USEITEMS46=

在以上基础上增加：
可挖物品 = 卧龙守将身上穿戴物品 + MonItems目录下此怪的暴率文件物品
可挖物品 几率控制在StdItem.DB中的Stock设置(Stock数字越大，获取物品几率越小)
例：
装备类物品可以不写在MonItems目录下的暴率文件中，暴率文件用来写上一些非穿戴装备类的物品
注意：
------------------------------------------------------------------------------
只要是卧龙守将类，将受StdItem.DB中的Stock控制几率，
对于暴率文件：
有两重几率控制，所以暴率文件中最好修改为百分之百得到，再到StdItem.DB
设置Stock的值，这样比较好控制物品的暴率
对于身上物品：
只受StdItem.DB设置Stock的值控制几率。

示例：

比如：我给卧龙守将 穿了一把血饮

我物品库设置血饮的Stock值为5000

162;血饮;5;22;12;0;0;0;53;200000;0;5;0;13;6;16;3;5;0;0;2;40000;5000;27;

那么玩家要从这怪身上挖到血饮的几率就是5000分之一

MonItems目录下的怪 暴率 建议只做一些宝石。书。之类的暴率这样方便控制几率！

Copyright ? 2019. All rights reserved. (To change the copyright info, just edit it in template.)


雪域怪物DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
雪域怪物DB

功能：

增加对MON25.WIL、MON27.WIL、MON28.WIL支持，怪物部分细节DB，请自行修改

示例：

灵魂收割者;122;25;240;80;1;100;32000;0;150;140;580;680;300;0;15;24;300;1;0;600;800000;1;0;200000;
蓝影刀客;122;26;241;80;1;100;32000;0;150;140;580;680;300;0;15;24;300;1;0;600;800000;1;0;200000;
雪域战将;126;27;250;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域侍卫;126;28;251;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域寒冰魔;126;29;252;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域灭天魔;126;29;253;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域五毒魔;126;29;254;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域天将;126;38;255;99;1;1;8000;0;11;11;55;55;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域魔王;126;39;256;99;1;1;65000;0;160;150;550;580;800;0;20;30;800;1;0;800;500000;0;0;0;
雪域野人;81;44;258;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域羊人;81;27;259;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域冰甲虫;81;27;260;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域冰狼;81;27;261;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域力士;121;46;262;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域卫士;122;51;263;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;
雪域毛人;81;16;265;99;1;1;1111;0;11;11;11;11;0;0;5;30;800;1;0;1200;500000;0;0;0;


月灵DB

Help > 数据库相关 > 示例DB > 怪物数据DB >
月灵DB

怪物库表：monster.DB
Name Racw Racelmg Appr Lv1 Undead CooiEye HP MP AC MAC DC DCMAX MC SC SPEED HIT WALK_SPD walkstep WalkWait attack_spd exp
月灵 99 56 172 80 0 100 3000 0 40 40 50 70 0 0 20 50 500 1 0 1200 0
月灵;99;56;172;80;0;100;3000;0;40;40;50;70;0;0;20;50;500;1;0;1200;0;


[@main]
宝物之间有一定的灵犀存在，鉴宝师可以帮你分辨你的宝物到底是\
不是灵媒，如果是灵媒，你可以把它放在灵媒探索位，对，就是界\
面左下角那个框，用快截键<COLOR=clRed CTRL+X>就可以探寻宝物的存在。\
<购买铲子/@购买铲子>  <如何寻宝/@如何寻宝>\
<如何挖宝/@如何挖宝>  <关于灵媒/@关于灵媒>\
<回收除魔灵媒/@回收除魔灵媒>\

[@回收除魔灵媒]
你要是除魔灵媒太多，可以交给我，我免费回收。\
<COLOR=clRed 点击下面的按钮将回收包裹中所有的除魔灵媒，请确认。>\
<回收包裹中的所有除魔灵媒/@回收>\

[@回收]
你确定要回收掉<COLOR=clRed 包裹中所有的除魔灵媒吗？>\ \
<确定/@确定>\

[@确定]
#IF
CHECKITEM 除魔灵媒 1
#ACT
TAKE 除魔灵媒 999
close
#ELSESAY
您的背包中没有除魔灵媒啊！\ \

[@关于灵媒]
通过鉴宝师的鉴定，任何宝物都有可能成为灵媒。每个灵媒都有自\
己的品质，品质越高的灵媒，越有可能寻找到好的宝物，使用最好\
的灵媒甚至可以挖到天龙装备和神戒！不过每次挖到一件宝物，灵\
媒的品质都会有所降低。每次使用灵媒会扣除灵媒一定的灵气值，\
灵媒的灵气值可以使用灵气神水来补充，灵气神水可以在商城购买\
得到。\
<返回/@MAIN>\

[@如何挖宝]
只有用我特制的新手铲、铁铲、金刚铲、乌金铲才能挖掘到宝物，\
用的铲子越好，挖掘范围则越大，挖掘速度也越快。\ \
<购买铲子/@购买铲子>\
<返回/@MAIN>\

[@如何寻宝]
    要想寻找宝物，首先你必须有一个宝物灵媒，任何可鉴定的物\
品都可能是宝物灵媒，你要去鉴定师那里进行鉴定，如果你的某件\
装备被鉴定为宝物灵媒，你可以把它放在灵媒探索位，放好之后，\
按下<COLOR=clRed CTRL+X>快截键就可以使用灵媒了。\
    在某些地图，例如<COLOR=clRed 祖玛七层大厅、雷炎二层、宫殿迷宫、霸者>\
<COLOR=clRed 大厅、连接通道、石墓七层、尸魔洞三层、骨魔洞五层、沃玛寺庙>\
<COLOR=clRed 、行会遗迹地图>等都有大量宝物的存在，在这些地图中，灵媒更容\
易感应到宝物的存在。在以上地图中，当你使用灵媒的时候，灵媒\
<下一页/@下一页>   <返回/@MAIN>\

[@下一页]
会给你指示宝物所在的方位，当你离很近的时候，灵媒会给你指示\
宝物所在的范围，你离宝物越近，灵媒给你的提示也会不同，你需\
要<COLOR=clRed 细心琢磨>，快速掌握挖宝的诀窍哦！\
<上一页/@如何寻宝>   <返回/@MAIN>\

[@购买铲子]
只有用我特制的新手铲、铁铲、金刚铲、乌金铲才能挖掘到宝物，\
用的铲子越好，挖掘范围则越大，挖掘速度也越快。\
<使用5000金币购买新手铲/@新手铲>\
<使用1元宝购买铁铲/@铁铲>\
<使用10元宝购买金刚铲/@金刚铲>\
<使用50元宝购买乌金铲/@乌金铲>\
<返回/@MAIN>\

[@乌金铲]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
GIVE 乌金铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@金刚铲]
#IF
CHECKGAMEGOLD > 9
#ACT
GAMEGOLD - 10
GIVE 金刚铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@铁铲]
#IF
CHECKGAMEGOLD > 0
#ACT
GAMEGOLD - 1
GIVE 铁铲 1
close
#ELSESAY
[失败]：您的元宝不足\ \
<返回/@购买铲子>\

[@新手铲]
#IF
CHECKGOLD 5000
#ACT
TAKE 金币 5000
GIVE 新手铲 1
close
#ELSESAY
购买新手铲需要5000金币，你没有足够的金币。\ \
<返回/@购买铲子>\


[@main]
你别看我满头苍髯，想当年，咱也是英姿飒爽，一剑光寒玛法动、\
万军之中自往来，现在毕竟年纪大了，我自从追随庄主走南闯北以\
来，对玛法大陆上的各种珍奇古玩产生了浓厚的兴趣。但愿我能帮\
到你。给我一件装备我可以帮你鉴定它是否还具有更大的潜能，另\
外，带有神秘属性的装备，也可以在我这里进行解读和激活；你还\
可以在我这里用羊皮卷制作神秘卷轴来卖钱。\
<鉴定宝物/@鉴定宝物>  <关于神秘属性/@神秘属性>  <关于卷轴碎片/@卷轴碎片>  <宝物品评/@宝物品评>\
<宝物任务：鉴定师成长之路/@宝物任务>\

[@宝物任务]
欢迎来到风云变幻的玛法大陆，开始您的勇士征程，在您征战\
玛法大陆的同时，我们还为您开启了神秘的宝物宝藏等待着您\
的探索。\ \
<初入师门/@初入师门>  <我有其它事情找你/@main>\

[@初入师门]
想要入门学习我的宝物鉴定绝学必须要接受我的考验。\ \
<接受考验/@接受考验>\
<我再考虑考虑/@EXIT>

[@接受考验]
自行修改。\ \

[@宝物品评]
通过对宝物各项属性的评价，我可以帮你品评一下你的宝物得分和\
星级，宝物得分越高，星级越高，经过我品评的装备可以拿到\
收藏家那里去进行展示，让玛法大陆的勇士们都对你的神兵利器\
顶礼膜拜。\ \
<品评宝物/@品评宝物>\ \
<返回/@main>\

[@品评宝物]
未开放。\ \
<返回/@main>\

[@卷轴碎片]
使用卷轴碎片，可以兑换鉴定卷轴。\
要获得卷轴碎片，你可以拿你不用的闲置装备跟我换，星王以上的装\
备都可以换成卷轴碎片，<COLOR=clRed 越好的装备换得的卷轴碎片就越多。>\
当然，有些装备看上去级别比较低，但品质却是很高，如果你能给我\
这样的装备，我会给你<COLOR=clRed 非常多的卷轴碎片。>\
兑换一级卷轴需要<COLOR=clRed 5>个卷轴碎片，兑换二级卷轴需要<COLOR=clRed 10>个卷轴碎片，\
兑换三级卷轴需要<COLOR=clRed 30>个卷轴碎片。\
<使用装备换取卷轴碎片/@@ExchangeBook>      <参加活动获得卷轴碎片/@活动卷轴碎片>\
<使用卷轴碎片兑换鉴定卷轴/@碎片换卷轴>  <返回/@main>\

[@碎片换卷轴]
请问你要兑换哪种鉴定卷轴？一级卷轴需要5颗卷轴碎片，二级卷轴\
需要10颗卷轴碎片，三级卷轴需要30颗卷轴碎片。注：所有兑换的精\
鉴卷轴都是绑定的。\ \
<兑换一级卷轴/@一级卷轴>\
<兑换二级卷轴/@二级卷轴>\
<兑换三级卷轴/@三级卷轴>\
<返回/@卷轴碎片>\

[@三级卷轴]
#IF
CHECKITEM 卷轴碎片 30
#ACT
TAKE 卷轴碎片 30
GIVE 三级鉴定卷轴 1
CLOSE
#ELSESAY
兑换需要30个卷轴碎片，你没有足够的碎片。\ \
<返回/@碎片换卷轴>

[@二级卷轴]
#IF
CHECKITEM 卷轴碎片 10
#ACT
TAKE 卷轴碎片 10
GIVE 二级鉴定卷轴 1
CLOSE
#ELSESAY
兑换需要10个卷轴碎片，你没有足够的碎片。\ \
<返回/@碎片换卷轴>

[@一级卷轴]
#IF
CHECKITEM 卷轴碎片 5
#ACT
TAKE 卷轴碎片 5
GIVE 一级鉴定卷轴 1
CLOSE
#ELSESAY
兑换需要5个卷轴碎片，你没有足够的碎片。\ \
<返回/@碎片换卷轴>

[@活动卷轴碎片]
请问你要使用什么东西兑换卷轴碎片，卷轴碎片可以合成各级鉴定\
卷轴。\ \
<用一个珍珑碎片兑换15个卷轴碎片/@一珍珑兑换>\
<用六个珍珑碎片兑换100个卷轴碎片/@六珍珑兑换>\
<返回/@卷轴碎片>\

[@六珍珑兑换]
#IF
CHECKITEM 珍珑碎片 6
#ACT
TAKE 珍珑碎片 6
GIVE 卷轴碎片 100
CLOSE
#ELSESAY
你的背包中没有足够的珍珑碎片，无法兑换。\ \
<返回/@活动卷轴碎片>

[@一珍珑兑换]
#IF
CHECKITEM 珍珑碎片 1
#ACT
TAKE 珍珑碎片 1
GIVE 卷轴碎片 15
CLOSE
#ELSESAY
你的背包中没有珍珑碎片，无法兑换。\ \
<返回/@活动卷轴碎片>

[@神秘属性]
有些鉴定出来的宝物带有神秘属性，并不是我不能解读这些神秘的\
功能，因为解读宝物的属性需要大量的经验和历史知道，我也不是\
万能的，需要通过阅读更多的神秘卷轴来帮你揭密神秘属性。\
<制作与解读/@@SecretProperty>\
<关于神秘卷轴/@神秘卷轴>\
<返回/@main>\

[@神秘卷轴]
神秘卷轴是由玛法勇士们根据自己的阅历和经验写成的鉴宝经验总\
结，根据每个人神秘解读的技能等级和熟练度，卷轴也会对应一定\
的熟练度和等级，等级越高熟练度越高的卷轴，解读神秘属性成功\
的概率就越高。\
<返回/@神秘属性>\

[@鉴定宝物]
鉴宝是一门技术，更是一门艺术。宝物和普通装备的区别，在于细微\
之间，有人说靠眼力，我觉得，应该是靠心去感受。\
<COLOR=clRed 高级鉴定有机会将你正在鉴定的装备鉴定为主宰装备，届时你正在鉴>\
<COLOR=clRed 定的装备将消失，如果你不想将某件装备鉴定为主宰装备，你可以使>\
<COLOR=clRed 用普通鉴定。>\
<鉴定宝物/@@TreasureIdentify>          <宝物的用途/@宝物的用途>\
<如何获得鉴定卷轴/@鉴定卷轴>  <关于高级鉴定/@高级鉴定>\

[@高级鉴定]
我这里共有两种鉴定方式，一个是普通鉴定，一个是高级鉴定，两种\
方式使用的鉴定卷轴和卷轴碎片是一样的，唯一的不同是，使用高级\
鉴定方式，将有概率将你正在鉴定的装备替换为对应的古董装备，古\
董装备属性非常高，只有非常幸运的勇士才能鉴定得到。\
<COLOR=clRed 当然，如果你不想要自己的装备变成主宰装备，你可以使用普通鉴定>\
<COLOR=clRed 方式鉴定。>\
<查看主宰装备属性/@主宰属性>\
<返回/@鉴定宝物>\

[@主宰属性]
主宰神甲(男) 防御20-26 魔御15-22 攻击10-14 魔法10-16 道术10-16\
主宰神甲(女) 防御20-26 魔御15-22 攻击10-14 魔法10-16 道术10-16\
主宰神剑 幸运+7 攻击10-70 魔法10-33 道术12-32\
         暴击等级+15 准确+2\
主宰项链 攻击5-13 魔法5-13 道术5-13 幸运+2\
主宰护腕 防御0-2 魔御0-2 攻击5-15 魔法5-15 道术5-15\
主宰之戒 防御0-2 攻击5-21 魔法5-21 道术5-21\
主宰之冠 防御6-8 魔御6-8 攻击2-14 魔法2-14 道术2-14\
<下一页/@下一页> <返回/@鉴定宝物>\

[@下一页]
主宰腰带 防御6-8 魔御6-8 攻击2-14 魔法2-14 道术2-14\
主宰之靴 防御6-8 魔御6-8 攻击2-14 魔法2-14 道术2-14\
主宰斗笠 防御3-3 魔御3-3 攻击4-8 魔法4-8 道术4-8\
主宰面巾 防御3-3 魔御3-3 攻击4-8 魔法4-8 道术4-8\
主宰勋章 攻击15-18 魔法15-18 道术15-18\ \ \ \
<上一页/@主宰属性> <返回/@鉴定宝物>\

[@鉴定卷轴]
在日常的活动中可以获得卷轴碎片，卷轴碎片可以在我这里合成各级\
鉴定卷轴。可以获得的卷轴碎片的活动包括：\
(活动介绍自己写)\

[@宝物的用途]
宝物带有非常强大的附加属性，高级宝物最高可以附加<COLOR=clRed 攻魔道>\
<COLOR=clRed 上限+10>的属性，有些甚至带有<COLOR=clRed 护身特技、八卦护身特技、>\
<COLOR=clRed 战意麻痹特技，麻痹特技，魔道麻痹特技、探测特技、传送特技>\
等超强属性！\
若同时穿戴带有同类属性特技的宝物和神戒，优先计算神戒的属性。\
例如，同时穿戴麻痹戒指和带有战意麻痹特技的装备，则优先按照\
麻痹戒指的特效麻痹对手。\ \
<返回/@鉴定宝物>


设置玩家当前模式

Help > 执行命令 >
设置玩家当前模式

命令格式:

CHANGEMODE 模式(1管理模式, 2无敌模式 3,隐身模式) 开关(0关/1开)

设置玩家当前模式

示例:

[@main]

#if

#act

CHANGEMODE 2 1

sendmsg 6 已为你开启无敌模式